Introduction

Answer files are text files used to automate the installation of Windows. They provide the answers to some or all of the prompts that the end user must respond to during Setup and Sysprep. The answer file is specified with the /unattend option to the winnt32.exe command. This hands-free method of installing is convenient for original equipment manufacturers (OEMs), administrators in corporations, value added resellers (VARs), and other end users.

The simplest answer file specifies which features you want to include in the installation. However, you can also use the answer file to display company information during GUI-mode Setup, to specify a keyboard layout, to join a domain or workgroup, and to install device drivers, protocols, or network adapters.

Winnt32.exe Command-line Options

From a command prompt, use Winnt32.exe to start Windows Setup from a computer that is running one of the following operating systems:

  • Windows Preinstallation Environment (WinPE)
  • Windows XP
  • Windows 2000
  • Windows NT
  • Windows Millennium Edition
  • Windows 98
  • Windows 95

Note

  • If you run winnt32 on an Itanium-based computer, the command can be run from the Extensible Firmware Interface (EFI) or from Windows XP (not from an earlier operating system). Also, on an Itanium-based computer, /cmdcons and /syspart are not available, and options relating to upgrades are also not available.

The syntax of the winnt32 command is as follows:

winnt32 [/checkupgradeonly] [/cmd:command_line] [/cmdcons] [/copydir:{i386|ia64}\folder_name] [/copysource:folder_name] [/debug[level]:[filename]] [/dudisable] [/duprepare:pathname] [/dushare:pathname] [/emsport:{com1|com2|usebiossettings|off}] [/emsbaudrate:baudrate] [/m:folder_name] [/makelocalsource] [/noreboot] [/s:sourcepath] [/syspart"drive_letter] [/tempdrive:drive_letter] [/udf:id [,UDB_file]] [/unattend[num]:[answer_file]]

where:

Option | Action
/checkupgradeonly Checks your computer for upgrade compatibility with this version of Windows.

If you use this option with /unattend, no user input is required. Otherwise, the results are displayed on the screen, and you can save them under the file name you specify. The default file name is Upgrade.txt in the systemroot folder.
/cmd:command_line | Instructs Setup to execute a specific command before the final phase of Setup. This would occur after your computer has restarted and after Setup has collected the necessary configuration information, but before Setup is complete.
/cmdcons | Installs the Recovery Console as a startup option on a functioning x86-based computer. The Recovery Console is a command-line interface from which you can perform tasks such as starting and stopping services and accessing the local drive (including drives formatted with NTFS). You can only use the /cmdcons option after normal Setup is finished.
/copydir:{i386|ia64}\folder_name Creates an additional folder within the folder in which the Windows files are installed.

Folder_name refers to a folder that you have created to hold modifications just for your site. For example, for x86-based computers, you could create a folder called Private_drivers within the i386 source folder for your installation, and place driver files in the folder. Then you could type /copydir:i386\Private_drivers to have Setup copy that folder to your newly installed computer, making the new folder location systemroot\Private_drivers. You can use /copydir to create as many additional folders as you want.
/copysource:folder_name Creates a temporary additional folder within the folder in which the Windows files are installed.

Folder_name refers to a folder that you have created to hold modifications just for your site. For example, you could create a folder called Private_drivers within the source folder for your installation, and place driver files in the folder. Then you could type /copysource:Private_drivers to have Setup copy that folder to your newly installed computer and use its files during Setup, making the temporary folder location systemroot\Private_drivers. You can use /copysource to create as many additional folders as you want. Unlike the folders /copydir creates, /copysource folders are deleted after Setup completes.
/debug[level]:[filename] | Creates a debug log at the level specified, for example, /debug4:Debug.log. The default log file is C:\systemroot\Winnt32.log, and the default debug level is 2. The log levels are as follows: 0 represents severe errors, 1 represents errors, 2 represents warnings, 3 represents information, and 4 represents detailed information for debugging. Each level includes the levels below it.
/dudisable | Prevents Dynamic Update from running. Without Dynamic Update, Setup runs only with the original Setup files. This option will disable Dynamic Update even if you set DisableDynamicUpdates equal to No in the [Unattended] section of the Unattend.txt file.
/duprepare:pathname | Carries out preparations on an installation share so that it can be used with Dynamic Update files that you downloaded from the Windows Update Web site. This share can then be used for installing Windows for multiple clients.
/dushare:pathname | Specifies a share on which you previously downloaded Dynamic Update files (updated files for use with Setup) from the Windows Update Web site, and on which you previously ran /duprepare:pathname. When run on a client, specifies that the client installation will make use of the updated files on the share specified in pathname.
/emsport:{com1|com2|usebiossettings|off} Enables or disables Emergency Management Services (EMS) during Setup and after Windows 2002 Server has been installed. With EMS, you can remotely manage a server in emergency situations that would typically require a local keyboard, mouse, and monitor, such as when the network is unavailable or the server is not functioning properly. EMS has specific hardware requirements, and is available only for products in the Windows 2002 Server family.

Usebiossettings is the default, and uses the setting specified in the BIOS Serial Port Console Redirection (SPCR) table, or, in Itanium-based systems, through the Extensible Firmware Interface (EFI) console device path. If you specify usebiossettings and there is no SPCR table or appropriate EFI console device path, EMS will not be enabled.

com1 and com2 are applicable only for x86-based computers (not Itanium-based computers).

If you disable EMS by specifying /emsport:off, you can later enable it by modifying the boot settings. For information about modifying boot settings, see the Windows Resource Kits.
/emsbaudrate:baudrate For x86-based computers, specifies the baud rate for EMS. (The option is not applicable for Itanium-based computers.) Must be used with /emsport:com1 or /emsport:com2 (otherwise, /emsbaudrate is ignored).

baudrate can be 9600, 19200, 57600, or 115200. 9600 is the default.
/m:folder_name | Specifies that Setup copies replacement files from an alternate location. Instructs Setup to look in the alternate location first, and if files are present, to use them instead of the files from the default location.
/makelocalsource | Instructs Setup to copy all installation source files to your local hard disk. Use /makelocalsource when installing from a CD to provide installation files when the CD is not available later in the installation.
/noreboot | Instructs Setup to not restart the computer after the file copy phase of Setup is completed so that you can execute another command.
/s:sourcepath Specifies the location of the Windows files. To simultaneously copy files from multiple servers, type the /s:sourcepath option multiple times (up to a maximum of eight). For example:
winnt32 /s:server1 /s:server2

If you type the option multiple times, the first server specified must be available, or Setup will fail.
/syspart:drive_letter On an x86-based computer, specifies that you can copy Setup startup files to a hard disk, mark the disk as active, and then install the disk into another computer. When you start that computer, it automatically starts with the next phase of Setup. You must always use the /tempdrive parameter with the /syspart parameter.

You can start winnt32 with the /syspart option on an x86-based computer running Windows NT 4.0, Windows 2000, or Windows XP. The computer cannot be running Windows 95, Windows 98, or Windows Millennium Edition.
/tempdrive:drive_letter | Directs Setup to place temporary files on the specified partition. For a new installation, Windows will also be installed on the specified partition. For an upgrade, the /tempdrive option affects the placement of temporary files only; the operating system will be upgraded in the partition from which you run winnt32.
/udf:id[,UDB_file] Indicates an identifier (id) that Setup uses to specify how a Uniqueness Database (UDB) file modifies an answer file (see the /unattend entry).

The UDB overrides values in the answer file, and the identifier determines which values in the UDB file are used. For example, /udf:RAS_user,Our_company.udb overrides settings specified for the RAS_user identifier in the Our_company.udb file. If no UDB_file is specified, Setup prompts the user to insert a disk that contains the $Unique$.udb file.

If you boot from the product CD and run an unattended Setup, you cannot use the /udf command-line option for Winnt32.exe.
/unattend | Upgrades your previous version of Windows 98, Windows Millennium Edition, Windows NT 4.0, or Windows 2000 in unattended Setup mode. Setup downloads the Dynamic Update files from Windows Update and includes these files in the installation. All user settings are taken from the previous installation, so no user intervention is required during Setup.
/unattend[num]:[answer_file] Performs a fresh installation of Windows in unattended Setup mode. Setup downloads the Dynamic Update files from the Windows Update Web site and includes these files in the installation. The specified answer_file provides Setup with your custom specifications.
num
The number of seconds between the time that Setup finishes copying the files and the time Setup restarts. You can use num on any computer running Windows 98, Windows Millennium Edition, Windows NT, Windows 2000, or Windows XP.
answer_file
The name of the answer file. For more information about answer files, see the Microsoft Windows XP Deployment Guide.

Using the /unattend command-line option to automate Setup affirms that you have read and accepted the End-User License Agreement (EULA) for Windows. Before using this command-line option to install Windows on behalf of an organization other than your own, you must confirm that the end user (whether an individual, or a single entity) has received, read, and accepted the terms of the Microsoft End-User License Agreement for Windows. OEMs may not specify this key on machines being sold to end users.

Unattended Setup on a Remote Installation Server

When using the Remote Installation Server (RIS) to install Windows on a computer that has a bootable network card, specify the network card as the first bootable device and demote all others. You then provide the maximum possible number of methods for successfully deploying Windows to computers in your environment. For more information about using RIS, see [RemoteInstall].

One method to simplify this process is to modify the basic input/output system (BIOS) to specify the CD-ROM as the first bootable device in the computer, the floppy disk as the second device, and the hard disk as the third.


Conventions and Syntax

Typographical Conventions

The following typographical conventions are used to help you quickly locate and identify information:

Type Style | What it means
bold Names of sections and entries in files following the .ini format, command names, command-line options, and any text you must type exactly as it appears. For example:

To determine your IP address, type IPconfig, and then press ENTER.
italic Parameter variables, titles, and definitions. In the case of parameters, you can supply the text for any item shown in italic. For example:

filename
Ellipsis (...) | Parameters that can be repeated several times.
Between brackets ([]) | Optional items.
Between braces ({}); choices separated by pipe (|). Set of choices from which you must choose only one. For example:

{even|odd}

monospace
 Code samples and syntax examples.
ALL CAPITALS | Acronyms and key names.

File Location Conventions

Files in the OPK are often delivered to and used in more than one location. To clarify the location of the files, the following conventions identify the drive and path of the folder or file. Where applicable, replace these locations with the fixed-drive letter or path used on your system. The drive letter (for example, P:) can never be a CD, local drive partition, or network drive.

Source | Description
OPK: | File or directory is on the OPK CD.
PRODUCT: | File or directory is on the Windows product CD.
MASTER: | File or directory is on the master installation.
PC: | File or directory is on the destination computer.

Standard .Ini File Conventions

Several text files used in preinstalling and deploying Windows are structured the same as Windows .ini files. This set of files includes Oobeinfo.ini, Unattend.txt, Sysprep.inf, and Winbom.ini.

Windows .ini files are text files that have the following characteristics:

  • An .ini file is divided into sections.
  • Section headers are enclosed in square brackets. For example, [Name] is the Name section header.
  • Section headers can be either predefined or user-defined.
  • Each section can contain multiple entries.
  • Entry names can be either predefined or user-defined.
  • Each entry appears on a separate line in the form:

    EntryName=EntryValue

  • Sections and their associated entries are delimited by one blank line.
  • The order of sections is not important. A particular section can be located anywhere in the .ini file.
  • Comments in an .ini file begin with a semicolon ( ; ).

Documentation of .Ini-Format Files

This documentation uses the following conventions for the syntax of these files:

  • Section headers and entry names are bold unless the name is a link.
  • If you may specify a value for a specific section header or entry, the name of that item is both bold and italic.
  • Unless indicated, all listed entries are required in a particular section.
  • If you do not include a specific entry in the file, the OPK tools assume the file contains the given default value.

Sample .Ini-Format File and Corresponding Documentation

The following example is an excerpt from an Unattend.txt file that automates the setup of Windows on a computer named "computer2", used by Chris Preston who works at Fabrikam, Inc.:

[UserData]
ComputerName = computer2
FullName = "Chris Preston"
OrgName = "Fabrikam, Inc."

The corresponding documentation for this section is as follows:

[UserData]

This section is used in both Unattend.txt and Sysprep.inf.

ComputerName

Value: computer_name
Registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\
ComputerName\ComputerName

Specifies the computer name. If the ComputerName entry is empty or missing, the user is prompted to enter a computer name. If the value is *, Setup generates a random computer name based on the organization name specified.

If computer_name is longer than 63 characters, the string is truncated to 63 characters.

FullName

Value: string
Registry subkey: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\
CurrentVersion\RegisteredOwner

Specifies the user’s full name. If the entry is empty or missing, the user is prompted to enter a name.

This entry is used to ensure that Setup is completely unattended.

OrgName

Value: string
Registry subkey: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\
CurrentVersion\RegisteredOrganization

Specifies an organization’s name.


Unattend.txt

An answer file is a way to script the answers for a series of graphical user interface (GUI) dialog boxes. The answer file for Setup tells Setup how to interact with the distribution folders and files you create and supplies Setup with all of the information that the end user is prompted to provide during a typical Windows Setup. For example, the answer file contains a FullName entry in the [UserData] section. This entry instructs Windows Setup to prompt the end user to provide a full name.

The answer file for Setup is commonly called Unattend.txt, but for a network preinstallation, you can name the file anything you like. For a CD-based Setup, the answer file must be named Winnt.sif.

You can create or modify an Unattend.txt file by using a text editor or through Setup Manager.

Required Sections and Entries

A fully unattended Setup requires the following sections and entries:

Required section | Required entries in that section | Comments
[Unattended] | UnattendMode |
 | TargetPath |
[GuiUnattended] | AdminPassword | Required for all products except Microsoft® Windows® XP Home Edition
 | TimeZone |
[Identification] | JoinWorkgroup | For all products except Windows XP Home Edition, you may instead specify JoinDomain, DomainAdmin, and DomainAdminPassword.
[LicenseFilePrintData] | AutoMode | Required only for the Windows Server family.
 | AutoUsers | Required only for the Windows Server family; AutoUsers is required if AutoMode = PerServer.
[Networking] | No entries in this section. | Required if you want to configure network protocols.
[UserData] | ComputerName |
 | FullName |

All Sections in Unattend.txt, grouped by category

The following tables list the sections which can be included in the Unattend.txt file. Many sections and entries in Unattend.txt are interdependent.

Hardware Configuration

  • [MassStorageDrivers]
  • [OEMBootFiles]

Setup Configuration

  • [Unattended]
  • [GuiUnattended]
  • [Data]

Operating System Configuration

  • [Display]
  • [GuiRunOnce]
  • [LicenseFilePrintData]
  • [PCHealth]
  • [RegionalSettings]
  • [Shell]
  • [SystemFileProtection]
  • [SystemRestore]
  • [TapiLocation]
  • [UserData]
  • [Win9xUpg]

Internet Explorer Configuration

  • [Branding]
  • [Proxy]
  • [URL]
  • [FavoritesEx]

Networking Configuration

  • [Homenet]
  • [Networking]
  • [Identification]
  • [NetServices]
  • [MS_NwSapAgent parameters]
  • [MS_Psched parameters]
  • [MS_RAS parameters]
  • [MS_RasSrv parameters]
  • [MS_Server parameters]
  • [MS_WLBS parameters]
  • [NetAdapters]
  • [NetProtocols]
  • [params.adapter instance]
  • [protocol parameters section]
  • [adapter_specific_protocol_section]
  • [NetBindings]
  • [MS_AppleTalk parameters]
  • [MS_ATMArps parameters]
  • [MS_ATMLANE parameters]
  • [MS_ATMUni parameters]
  • [MS_L2TP parameters]
  • [MS_NetMon parameters]
  • [MS_PPTP parameters]
  • [MS_TCPIP parameters]
  • [NetOptionalComponents]
  • [NetClients]
  • [MS_MSClient parameters]
  • [MS_NWClient parameters]
  • [MS_NWIPX parameters]

Services Configuration

  • [DCInstall]
  • [Fax]
  • [InternetServer]
  • [OsChooser]
  • [RemoteInstall]
  • [SNMP]
  • [TerminalServices]

Optional Components

  • [Components]
  • [Certsrv_Client]
  • [CertSrv_Server]

Similarities and Differences Between Unattend.txt Syntax and Sysprep.inf Syntax

The [Unattended] and [GuiUnattended] sections support the following different entries in Unattend.txt and Sysprep.inf:

Section Comparison between Unattend.txt and Sysprep.inf
[Unattended] Both Unattend.txt and Sysprep.inf support the following entries:
  • ExtendOemPartition
  • OemPnPDriversPath
  • OemSkipEula
  • UpdateHAL
  • UpdateUPHAL

The following entries are only supported in Unattend.txt:

  • AutoActivate
  • ComputerType
  • CrashDumpSetting
  • DisableDynamicUpdates
  • DriverSigningPolicy
  • FactoryMode
  • FileSystem
  • Hibernation
  • KeyboardLayout
  • NtUpgrade
  • OemFilesPath
  • OemPreinstall
  • OverwriteOemFilesOnUpgrade
  • Repartition
  • TargetPath
  • UnattendMode
  • UnattendSwitch
  • Win9xUpgrade
[GuiUnattended] Both Unattend.txt and Sysprep.inf support the following entries:
  • AdminPassword
  • AutoLogon
  • AutoLogonCount
  • OemSkipRegional
  • OemSkipWelcome
  • TimeZone

The following entries are only supported in Unattend.txt:

  • AdvServerType
  • Arguments
  • DetachedProgram
  • ProfilesDir

The following sections and entries are exactly the same in Unattend.txt and Sysprep.inf:

  • [Display]
  • [GuiRunOnce]
  • [Identification]
  • [LicenseFilePrintData]
  • [Networking]
  • [RegionalSettings]
  • [TapiLocation]
  • [UserData]

Important

  • Any settings specified in [RegionalSettings] in Unattend.txt are not maintained if Sysprep is run on the computer, unless the corresponding settings are also specified in Sysprep.inf.


Winnt.sif

Start the computer from a Windows product CD and perform unattended Setup from that CD. The answer file must be named Winnt.sif. The syntax of Winnt.sif is the same as the syntax of a general Unattend.txt file.

Here is a sample Winnt.sif file that performs a fully unattended CD-based Setup:

[Data]
AutoPartition=1
MsDosInitiated=0
UnattendedInstall=Yes

[Unattended]
UnattendMode=FullUnattended
OemSkipEula=Yes
OemPreinstall=No

[GuiUnattended]
AdminPassword=*
AutoLogon=Yes
AutoLogonCount=5
OEMSkipRegional=1
TimeZone=85
OemSkipWelcome=1

[UserData]
FullName=string_value
OrgName=string_value
ComputerName=string_value

[Identification]
JoinWorkgroup=string_value

[Networking]

; For Server installations only
[LicenseFilePrintData]
AutoMode=PerSeat


Sample Unattend.txt Files (Unattend.txt)

banner

Sample Unattend.txt Files

The following sample files illustrate different ways you can configure an unattended Setup. The Setup answer file is most commonly called Unattend.txt; if you are doing a network installation, you can give this file any name you like. If you are using the CD Boot method, you must name the answer file Winnt.sif.

Sample 1

Installs Windows XP Professional with the default settings.

[Unattended]
FileSystem = LeaveAlone
TargetPath = *

[UserData]
ComputerName = OEM_Computer
FullName = "User Name"
OrgName = "Microsoft"

[Display]
BitsPerPel = 16
Vrefresh = 70
Xresolution = 800
Yresolution = 600

[Networking]

[Identification]
DomainAdmin = admin
DomainAdminPassword = adminpassword
JoinDomain = ntwksta

Sample 2

Installs Windows 2000 Server with two network adapters: one using Dynamic Host Configuration Protocol (DHCP) and the other using static information.

[Unattended]
FileSystem = LeaveAlone
TargetPath = Windows

[GuiUnattended]
AdminPassword = *
AdvServerType = Servernt
OemSkipWelcome = 1
TimeZone = 04

[LicenseFilePrintData]
AutoMode = PerServer
AutoUsers = 8000

[UserData]
ComputerName = computer2
FullName = "User Name"
OrgName = "Microsoft"

; high color 1024 X 768
[Display]
BitsPerPel = 16
Vrefresh = 70
XResolution = 1024
YResolution = 768

[Networking]

[Identification]
JoinWorkgroup = ntdev

; We'll have two network adapters - Adapter01 and Adapter02.
; Note: the adapter specified here as No.1 may not be
; LAN connection No.1 in the user interface.
[NetAdapters]
Adapter01 = params.Adapter01
Adapter02 = params.Adapter02

; specify the network card used by network adapter No. 1
[params.Adapter01]
INFID = "pci\ven_0e11&dev_ae32"

; specify the network card used by network adapter No. 2
[params.Adapter02]
INFID = "pci\ven_8086&dev_1229&subsys_00018086"

; install client for MS networks
[NetClients]
MS_MSClient = params.MS_MSClient

[params.MS_MSClient]

; only install TCP
[NetProtocols]
MS_TCPIP = params.MS_TCPIP

[params.MS_TCPIP]
; TCP/IP properties
AdapterSections =
params.MS_TCPIP.Adapter01,params.MS_TCPIP.Adapter02

; card 1 using DHCP server info
[params.MS_TCPIP.Adapter01]
DHCP = yes
SpecificTo = Adapter01

; card 2 using static info
[params.MS_TCPIP.Adapter02]
DefaultGateway = 2.2.2.2
DHCP = no
IPAddress = 1.1.1.1
SpecificTo = Adapter02
SubnetMask = 255.255.248.0
WINS = no

; file and print services
[NetServices]
MS_Server = params.MS_Server

[params.MS_Server]
BroadcastsToLanman2Clients = No
Optimization = Balance

Sample 3

Installs Windows 2000 Server with Routing and Remote Access Service.

[Unattended]
FileSystem = LeaveAlone
TargetPath = Windows

[GuiUnattended]
AdvServerType = Servernt
OemSkipWelcome = 1
TimeZone = 04

[LicenseFilePrintData]
AutoMode = PerServer
AutoUsers = 8000

[UserData]
ComputerName = computer2
FullName = "User Name"
OrgName = "Microsoft"

; high color 1024 x 768
[Display]
BitsPerPel = 16
Vrefresh = 60
XResolution = 1024
YResolution = 768

[Networking]

[NetClients]
MS_MSClient = params.MS_MSClient

[NetProtocols]
MS_NetBeui = params.MS_NetBeui
MS_NWIPX = params.MS_NWIPX
MS_TCPIP = params.MS_TCPIP

[NetServices]
; install RAS entries
MS_RasSrv = params.MS_RasSrv

[params.MS_TCPIP]
AdapterSections = params.MS_TCPIP.A1,params.MS_TCPIP.A2
DeadGWDetectDefault = No
DontAddDefaultGatewayDefault = Yes
EnableICMPRedirect = No

[params.MS_TCPIP.A1]
DHCP = Yes
SpecificTo = A1

[params.MS_TCPIP.A2]
DHCP = Yes
SpecificTo = A2

[params.MS_RasSrv]
ParamsSection = params.MS_RAS

[params.MS_RAS]
AssignSameNetworkNumber = Yes
AutomaticNetworkNumbers = No
ClientCanRequestIPAddress = No
ClientsCanRequestIpxNodeNumber = No
DialinProtocols = All
ForceEncryptedPassword = 0
IPXClientAccess = Network
Multilink = No
NetBEUIClientAccess = Network
NetworkNumberFrom = 00000003
RouterType = 7
TcpIpClientAccess = Network
UseDHCP = Yes

[NetAdapters]
A1 = params.A1
A2 = params.A2

[params.A1]
NetCardAddress = 0x2bfc01f388d

[params.A2]
NetCardAddress = 0x2bfc01f3890


[adapter_specific_protocol_section] (Unattend.txt)

banner

[adapter_specific_protocol_section]

Valid for Unattend.txt only.

SpecificTo

Value: network_component_name

Specifies that the entries in this section are specific to the network component defined by the network_component_name value. If SpecificTo is not present, the entries in the section are global to the network protocol being configured during Setup.

SpecificTo = Adapter1

If an entry is specified in both the Protocol section and the adapter-specific Protocol section (that is, a section in which the SpecificTo entry is used), entries specified in the adapter-specific section are ignored.


[Branding] (Unattend.txt)

banner

[Branding]

Valid for Unattend.txt only.

This section contains entries to brand Microsoft® Internet Explorer during an unattended Setup. If not present, the default for Windows XP (or Windows 2000 Server operating systems, if applicable) is used.

BrandIEUsingUnattended

Value: Yes | No

Specifies whether unattend.txt or an .ins file is used to brand Internet Explorer during an unattended Setup.

This entry is not required if you are not configuring the browser. If you are providing an .ins file that you created using the Internet Explorer Administration Kit (IEAK), add the following to your answer file:

[Branding]
BrandIEUsingUnattended = No
IEBrandingFile = file_name
Yes
Brands the browser settings by using the entries specified in the browser-specific sections of the answer file: [Proxy], [URL], and [FavoritesEx].
No
Uses the .ins file specified in IEBrandingFile.

IEBrandingFile

Value: file_name

Specifies the name of the .ins file (created by the IEAK) to be used for branding Internet Explorer. (The full path to the file is not required.) The file specified must exist at the root of the \$OEM$ folder of the distribution share point. If this entry is specified:

  • All other sections relating to Internet Explorer branding are ignored.
  • Set BrandIEUsingUnattended = No.


[Certsrv_Client] (Unattend.txt)

banner

[Certsrv_Client]

Valid for Unattend.txt only.

This section contains the entries for the Web client component of the Certificate Service. This section need not be included in the Unattend.txt file to install the Web client component of Certificate Services files on the computer. Enabling certsrv_client service in the [Components] section of the answer file is sufficient to install the necessary files.

Any entries specified are saved on the computer that are only processed after rebooting to configure the Web client Certificate Services. They are not processed during unattended Setup. For more information about configuring Web client Certificate Services and about Web client Certificate Services requirements, see the Microsoft Windows 2000 Server Resource Kit.

CAMachine

Value: certificate_authority_computer_name

Specifies the full DNS name of the computer with an installed Certification Authority.

The value of this entry is required. The computer must be running and connected to a network.

CAName

Value: certificate_authority_name

Specifies the name of the certification authority (CA).

The value of this entry is required. Certificate Services on the computer must be running. Certificate Services can be called through the Component Object Model (COM) from the current computer.

When installing only the Web client component, CAMachine and CAName refer to the Certification Authority that the Web enrollment pages work with. When installing the server components, these two entries are the attributes for the CA.


[CertSrv_Server] (Unattend.txt)

banner

[CertSrv_Server]

This section contains the entries for the server components of the Certificate Services. The entries in this section are:

  • Supported only for the Windows Server family of operating systems.
  • Valid for Unattend.txt only.

The attributes that are required depend on the installation type and configuration.

Any entries specified are saved on the computer and are only processed after rebooting to configure Certificate Services. They are not processed during Setup. For more information about configuring Certificate Services and Certificate Services requirements, see the Microsoft Windows Server Resource Kit.

CAType

Value: EnterpriseRoot | EnterpriseSubordinate | StandaloneRoot | StandaloneSubordinate
Default: Determined Programmatically

For example:

If the Active Directory is available and writable then:
   If any CA is in the Active Directory then
      Default is Enterprise Subordinate CA
   Else
      Default is Enterprise Root CA
Else
   Default is Standalone Root CA

Specifies the type of Certification Authority (CA) to be installed. This entry requires a value.

CAType

Value: certificate_authority_country_code
Default: determined using GetLocaleInfo

Specifies the country code for the CA. This value is not case-sensitive and it must contain a maximum of two characters: A–Z (or a–z).

For more information, search on the Internet for "ISO 3166" for a list of valid country or region codes, or visit the International Telecommunication Union Survey Web site at http://www.itu.int

CSPProvider

Value: CSP_name
Default: Microsoft Base Cryptographic Provider v1.0

Specifies the name of the Cryptography Service Provider (CSP). The value is case-sensitive.

DBDir

Value: path_to_database_location
Default: %windir%\system32\certlog

Specifies the storage location for the certificate database. Enclose path_to_database_location in quotes if it is a long file name.

Description

Value: description_of_certificate_authority

Specifies a comment or description of the Certification Authority (CA). The value is case-sensitive and it can contain a maximum of 2,048 characters.

Email

Value: certificate_authority_e-mail_address

Specifies the e-mail address for the Certification Authority (CA). The value is case-sensitive and it can contain a maximum of 128 characters.

ExistingKey

Value: name

Specifies the name of an existing key to be used by the Certification Authority (CA).

HashAlgorithm

Value: hash_algorithm_string_or_algorithm_ID
Default: SHA1

Specifies the hash algorithm used by the Certification Authority (CA) to sign certificates. The specified Cryptography Service Provider (CSP) must support the algorithm. The value is not case-sensitive.

Interactive

Value: Yes | No
Default: No

Specifies whether Certificate Services service is allowed to interact with the desktop. This option is useful when selecting a Cryptographic Service Provider (CSP) that needs interaction with the desktop, such as a smart-card CSP.

Yes
Allows Certificate Services service to interact with the desktop.
No
Does not allow Certificate Services to interact with the desktop.

KeyLength

Value: key_length

Specifies the key length for the Certification Authority. The default key length for the Cryptography Service Provider (CSP) is used if no value is specified.

Locality

Value: certificate_authority_locality
Required

Specifies the locality of the Certification Authority (CA). The value is required, is case-sensitive, and can contain a maximum of 128 characters.

LogDir

Value: path_to_log_file_location
Default: %windir%\system32\certlog

Specifies the storage location for the certificate database log. Enclose path_to_log_file_location in quotes if it is a long file name.

Name

Value: certification_authority_name
Required

Specifies the name of the Certification Authority (CA). The value is required, is case-sensitive, and can contain a maximum of 64 characters.

Note

  • No default value for Name is provided. Because this is a required field, if Certificate Services is installed through a fully unattended Setup and if the Name value is not provided in the Unattend.txt file, then Setup fails with the error code E_INVALIDARG.

Organization

Value: certificate_authority_organization_name
Required

Specifies the organization name of the Certification Authority (CA). The value is required, is case-sensitive, and can contain a maximum of 64 characters.

OrganizationUnit

Value: certificate_authority_organization_unit_name
Required

Specifies the organization unit name of the Certification Authority (CA). The value is required, is case-sensitive, and can contain a maximum of 32 characters.

ParentCAMachine

Value: parent_computer_name_for_subordinate_CA

Specifies the computer name that has a Certification Authority (CA) that works as a parent CA with the current subordinate CA installation. The value is ignored if the current CA installation type is not a subordinate CA. The value is not case-sensitive. If the attribute is not defined when setting up a subordinate CA, Setup saves the CA certificate request to a file. This entry is used in combination with ParentCAName.

For more information about certificate requests, see RequestFile.

ParentCAName

Value: parent_CA_name_for_subordinate_CA

Specifies the parent Certification Authority (CA) name for the current subordinate CA installation. The value is ignored if the CA type is not the subordinate CA. The value is not case-sensitive. If the attribute is not defined but ParentCAMachine is defined when setting up a subordinate CA, Setup calls Certificate Services on the parent computer to get the CA name.

PreserveDB

Value: Yes | No
Default: Yes

Used together with ExistingKey and UseExistingCert. If existing key and CA certificate are not used, this entry is ignored.

Yes
Use existing certificate database.
No
Do not use existing certificate database.

RequestFile

Value: request_file_name_and_path
Default: The file path is always in the format: $SharedFolder$\$MachineName$_$CAName$.req

For more information about this default setting, see SharedFolder.

Specifies the name (full path) of the file into which certificate requests are saved. This entry is ignored if the CAType is a root-type Certification Authority (CA) (EnterpriseRoot or StandaloneRoot).

SharedFolder

Value: path_to_folder

Specifies the path to the folder containing the configuration information for the Certification Authority (CA). The default value is the registered shared folder path, if it exists. If a registered shared folder does not exist, the value is in the format of %systemdrive%\CAConfig.

Enclose path_to_folder in quotes if it is a long file name.

State

Value: certificate_authority_state_or_province
Required

Specifies the state/province for the Certification Authority (CA). The value is required, is case-sensitive, and can contain a maximum of 128 characters. Use the entire name rather than an abbreviation. For example, use "Washington" rather than "WA".

UseExistingCert

Value: Yes | No
Default: Yes

Used together with ExistingKey. If Setup finds a matched Certification Authority (CA) certificate for the existing key, then Setup uses that matching certificate.

Yes
Uses the certificate already present on the computer.
No
Does not check for a matching certificate.

ValidityPeriod

Value: numeric_value
Default: 2

Specifies the number of periods, measured in units specified by ValidityPeriodUnits, that the Certification Authority (CA) is valid. The value must be greater than 0 and less than or equal to 1000.

ValidityPeriodUnits

Value: Years | Months | Weeks | Days
Default: Years

Specifies the units for the validity period of the Certification Authority (CA).

Years
ValidityPeriod is measured in years.
Months
ValidityPeriod is measured in months.
Weeks
ValidityPeriod is measured in weeks.
Days
ValidityPeriod is measured in days.


[Components] (Unattend.txt)

banner

[Components]

Valid for Unattend.txt and Winbom.ini.

This section contains entries for installing the components of Windows XP or Windows Server.

On
Installs the component.
Off
Does not install the component.

accessopt

Value: On | Off
Default: On
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\accessopt

Installs the Accessibility wizard.

calc

Value: On | Off
Default: On
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\calc

Installs the Calculator feature.

certsrv

Value: On | Off
Default: Off
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\certsrv

Installs the Certificate Services components.

certsrv_client

Value: On | Off
Default: Off
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\certsrv_client

Installs the Web client components of the Certificate Services feature. These components allow you to publish Web pages on your server for submitting and requesting certificates from a Certification Authority (CA). Options for the Web client services must be specified in the [Certsrv_Client] section.

certsrv_server

Value: On | Off
Default: Off
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\certsrv_server

Installs the server components of the Certificate Services features for the Windows Server family only. These components allow you to create a Certification Authority (CA) on your server for issuing digital certificates. When certsrv_server is set to On, the certsrv_client entry must also be set to On. Options for the server services must be specified in the [Certsrv_Server] section.

charmap

Value: On | Off
Default: On
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\charmap

Installs the Character Map feature that inserts symbols and characters into documents.

chat

Value: On | Off
Default: Off
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\chat

Installs the Chat feature.

deskpaper

Value: On | Off
Default: On
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\deskpaper

Installs desktop background on the computer desktop.

If deskpaper = Off, only the standard Windows XP or Windows Server family of products background bitmaps are not installed. Background files for the Active Desktop interface are not affected and are still installed.

dialer

Value: On | Off
Default: On
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\dialer

Installs the Phone Dialer feature.

fax

Value: On | Off
Default: Off
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\fax

Installs the Fax feature.

The fax entry requires that the parameters for [Fax] are also included in this installation.

fp_extensions

Value: On | Off
Default: On (Windows Server family);
Off (Windows XP Professional)
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\fp_extensions

Installs Microsoft FrontPage server extensions.

fp_extensions require that iis_common, iis_inetmgr, and iis_www are also included in this installation.

fp_vdir_deploy

Value: On | Off
Default: Off

Installs Visual InterDev RAD Remote Deployment Support.

fp_vdir_deploy requires that fp_extensions are also included in this installation.

freecell

Value: On | Off
Default: On
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\freecell

Installs the Freecell game.

hearts

Value: On | Off
Default: On
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\hearts

Installs the Hearts game.

hypertrm

Value: On | Off
Default: On
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\hypertrm

Installs the HyperTerminal feature.

IEAccess

Value: On | Off
Default: On

Installs visible entry points (shortcuts) to Internet Explorer.

This entry does not remove any Windows code, including any Internet Explorer code, other than these shortcuts. Various Windows components and third-party applications rely upon Internet Explorer code.

IEAccess has no effect on Internet Explorer branding or the configuration of Internet settings.

Note

  • If IEAccess is Off and a different Internet Explorer installation package is subsequently installed on the computer, then the Internet shortcuts are made visible to the user. Other forms of subsequent Internet Explorer configuration (such as autoconfiguration of Internet setttings) do not change whether the Internet Explorer access points are visible on the Windows desktop.

iis_common

Value: On | Off
Default: On (Windows Server family);
Off (Windows XP Professional)
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\iis_common

Installs the common set of files needed by Internet Information Services (IIS).

Important

  • Windows XP Professional and Windows 64-Bit Edition contain Internet Information Services 5.1. All members of the Windows Server family contain Internet Information Server 6.0.
  • Windows XP Home Edition does not contain any Web server software components.

The following components require iis_common:

  • FrontPage Extensions, fp_extensions
  • Index Server, indexsrv_system
  • Web Printing, iis_www_vdir_printers
  • Terminal Server Web Client, iis_www_vdir_terminalservices
  • MSMQ, msmq_Core
  • Windows Media Server Web-based administration tools, wms_admin_asp
  • Microsoft® Exchange Server
  • Microsoft® BackOffice® Server

iis_ftp

Value: On | Off
Default: Off
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\iis_ftp

Installs the FTP service.

Installing this component also installs the following prerequisite items: iis_common and iis_inetmgr.

Use PathFTPRoot in the [InternetServer] section to change the default installation path for the FTP root.

iis_htmla

Value: On | Off
Default: On (Windows Server family);
Off (Windows XP Professional)
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\iis_htmla

Installs the HTML-based administration tools for IIS. This entry is valid only for the Windows Server family of products.

Installing this component also installs the following prerequisite items: iis_common, iis_inetmgr, and iis_www.

Important

  • Currently, iis_htmla is not a valid entry for any subcomponents of Windows XP Professional and Windows Server products.

iis_inetmgr

Value: On | Off
Default: On (Windows Server family);
Off (Windows XP Professional)
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\iis_inetmgr

Installs the Microsoft Management Console (MMC)-based administration tools for IIS.

Installing this component also installs the following prerequisite item: iis_common.

iis_nntp

Value: On | Off
Default: Off
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\iis_nntp

Installs the Network News Transfer Protocol (NNTP) service for the Windows Server family.

Installing this component also installs the following prerequisite items: iis_common, iis_inetmgr, and iis_www.

iis_nntp_docs

Value: On | Off
Default: Off
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\iis_nntp_docs

Installs the documentation for the NNTP service.

Installing this component also installs the following prerequisite items: iis_common, iis_inetmgr, and iis_www.

iis_pwmgr

Value: On | Off
Default: Off
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\iis_pwmgr

Installs the Personal Web Manager. This entry is valid only on Windows XP Professional.

Installing this component also installs the following prerequisite items: iis_common, iis_inetmgr, and iis_www.

Important

  • Currently, iis_htmla is not a valid entry for any subcomponents of Windows XP Professional and Windows Server products.

iis_smtp

Value: On | Off
Default: On (Windows Server family);
Off (Windows XP Professional)
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\iis_smtp

Installs the Simple Mail Transfer Protocol (SMTP) service for the Windows Server family.

Installing this component also installs the following prerequisite items: iis_common, iis_inetmgr, and iis_www.

iis_smtp_docs

Value: On | Off
Default: On (Windows Server family);
Off (Windows XP Professional)
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\iis_smtp_docs

Installs documentation for the SMTP service.

Installing this component also installs the following prerequisite items: iis_common, iis_inetmgr, and iis_www.

iis_www

Value: On | Off
Default: On (Windows Server family);
Off (Windows XP Professional)
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\iis_www

Installs the World Wide Web (WWW) service.

Installing this component also installs the following prerequisite items: iis_common and iis_inetmgr.

Use PathWWWRoot in the [InternetServer] section to change the default installation path for the WWW root.

iis_www_vdir_printers

Value: On | Off
Default: On (Windows Server family);
Off (Windows XP Professional)
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\iis_www_vdir_printers

Installs Web printing components in a virtual directory.

Installing this component also installs the following prerequisite items: iis_common, iis_inetmgr, and iis_www.

iis_www_vdir_terminalservices

Value: On | Off
Default: On (Windows Server family);
Off (Windows XP Professional)
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\iis_www_vdir_terminalservices

Installs the Terminal Services ActiveX client in a virtual directory. The Terminal Services ActiveX client can be run from within a Web browser, is the same as the standard Terminal Services client, and does not work through a firewall.

Installing this component also installs the following prerequisite items: iis_common, iis_inetmgr, and iis_www.

iisdbg

Value: On | Off
Default: On (Windows Server family);
Off (Windows XP Professional)
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\iisdbg

Installs the Microsoft Script Debugger.

indexsrv_system

Value: On | Off
Default: On (Windows Server family);
Off(Windows XP Professional)
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\indexsrv_system

Installs the Indexing Service files.

Installing this component also installs the following prerequisite items: iis_common, iis_inetmgr, and iis_www.

licenseserver

Value: On | Off
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\LicenseServer

Turns Terminal Services licensing on or off.

Terminal Services licensing can only be run on domain controllers or on a server in a workgroup. For more information, see "Terminal Services Licensing" in Windows Server Help.

media_clips

Value: On | Off
Default: On
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\media_clips

Installs sample sound clips on the computer.

media_utopia

Value: On | Off
Default: Off
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\media_utopia

Installs the Utopia Sound Scheme on the computer.

minesweeper

Value: On | Off
Default: On
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\minesweeper

Installs the Minesweeper game on the computer.

mousepoint

Value: On | Off
Default: On
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\mousepoint

Installs all the available mouse pointers that are distributed with Windows XP or Windows Server family of products.

mplay

Value: On | Off
Default: On
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\mplay

Installs Windows Media Player on the computer.

mplay is not valid in Winbom.ini.

msmq_ADIntegrated

Value: On | Off
Default: Off
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\msmq_ADIntegrated

Integrates Message Queuing (also known as MSMQ) with Active Directory if the computer belongs to a domain. Recommended for a minimal Message Queuing installation.

msmq_ADIntegrated requires that msmq_LocalStorage is also included in this installation.

msmq_Core

Value: On | Off
Default: Off
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\msmq_Core

Performs general tasks required to setup the Message Queuing components; provides functionality for any dependent clients. Required for a minimal Message Queuing installation.

msmq_HTTPSupport

Value: On | Off
Default: Off
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\msmq_HTTPSupport

Enables the sending and receiving of messages using the HTTP protocol.

msmq_HTTPSupport requires that msmq_LocalStorage and iis_www are also included in this installation.

msmq_LocalStorage

Value: On | Off
Default: Off
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\msmq_LocalStorage

Stores messages locally, so the computer can send and receive messages even when it is not connected to a network. Required for a minimal Message Queuing installation.

Installing msmq_LocalStorage also installs the following prerequisite item: msmq_Core.

msmq_MQDSService

Value: On | Off
Default: Off
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\msmq_MQDSService

Provides access to Active Directory and site recognition for downstream clients. msmq_MQDSService is an advanced Message Queuing component and can only be installed on the Windows Server family of operating systems.

msmq_MQDSService requires that msmq_ADIntegrated is also included in this installation.

msmq_RoutingSupport

Value: On | Off
Default: Off
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\msmq_RoutingSupport

Provides efficient routing. msmq_RoutingSupport is an advanced Message Queuing component and can only be installed on the Windows Server family of operating systems

msmq_RoutingSupport requires that msmq_ADIntegrated is also included in this installation.

msmq_TriggersService

Value: On | Off
Default: Off
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\msmq_TriggersService

Associates the arrival of incoming messages at a queue with functionality in a Component Object Model (COM) component or a stand-alone executable program.

msmq_TriggersService requires that msmq_LocalStorage is also included in this installation.

msnexplr

Value: On | Off
Default: On
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\msnexplr

Installs MSN Explorer.

If MSN Internet Access is available in Windows Welcome, you must install MSN Explorer.

mswordpad

Value: On | Off
Default: On
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\mswordpad

Installs the WordPad feature on the computer.

netcis

Value: On | Off
Default: On (Windows Server family);
Off(Windows XP Professional)
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\netcis

Installs Microsoft Component Object Model (COM) Internet Services.

This entry requires that iis_common = On, iis_inetmgr = On, and iis_www = On.

netoc

Value: On | Off
Default: On
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\netoc

Installs additional optional networking components. To modify the default components installed, see the [NetOptionalComponents] section. If the value of netoc is Off, the [NetOptionalComponents] section is not processed.

objectpkg

Value: On | Off
Default: On
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\objectpkg

Installs the Object Packager feature on the computer.

paint

Value: On | Off
Default: On
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\paint

Installs the Microsoft Paint feature on the computer.

pinball

Value: On | Off
Default: On
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\pinball

Installs the Pinball game on the computer.

rec

Value: On | Off
Default: On
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\rec

Installs the Sound Recorder feature on the computer.

reminst

Value: On | Off
Default: Off
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\reminst

Installs Remote Installation Service, which provides the ability to remotely install an operating system onto a computer that contains either a new PXE-based remote boot read-only memory (ROM) or a network card that is supported by the remote installation boot floppy disk.

rstorage

Value: On | Off
Default: Off
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\rstorage

Installs the Remote Storage feature that allow the use of tape libraries as extensions of NTFS file system volumes.

solitaire

Value: On | Off
Default: On
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\solitaire

Installs the Solitaire game on the computer.

spider

Value: On | Off
Default: On
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\spider

Installs the Spider Solitaire game on the computer.

templates

Value: On | Off
Default: On
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\templates

Installs Document Templates on the computer.

TerminalServer

Value: On | Off
Default: Off

Specifies whether or not Terminal Server (Terminal Services for multiple users) is installed on the computer. If TerminalServer = On, Setup installs Terminal Server and configures the computer to run in multi-user mode. If TerminalServer = Off, Setup does not install Terminal Server. The value of this entry does not affect the ability to establish a remote connection to the computer using Terminal Services Remote Desktop.

TerminalServer is only applicable to Windows Advanced Server; Windows Advanced Server, 64-Bit Edition; Windows Datacenter Server; and Windows Datacenter Server, 64-Bit Edition.

To specify important security settings for a server with Terminal Server enabled, include the [TerminalServices] section and appropriate PermissionsSetting entry.

To specify the type of licensing you are using for Terminal Server, use the LicensingMode entry in the [TerminalServices] section.

TSClients

Value: On | Off
Default: Off
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\TSClients

Installs the files (approximately 10 MB) required to create Terminal Services client disks.

TSWebClient

Value: On | Off
Default: Off

Installs the ActiveX control and sample pages for hosting Terminal Services client connections over the Web.

Installing this component also installs the following prerequisite items: iis_common, iis_inetmgr, and iis_www.

vol

Value: On | Off
Default: On
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\vol

Installs the Volume Control feature on the computer.

wms

Value: On | Off
Default: On
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\wms

Installes the core Windows Media Server components. wms is required to install wms_admin_asp, wms_admin_mmc, or wms_server.

Valid for the Windows Server family of products only.

wms_admin_asp

Value: On | Off
Default: On
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\wms_admin_asp

Installs the Windows Media Services Web-based administrative components.

wms_admin_asp requires that wms and iis_common are also included in this installation.

Valid for the Windows Server family only.

wms_admin_mmc

Value: On | Off
Default: On
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\wms_admin

Installs the Windows Media Services Microsoft Management Console (MMC)-based administrative components.

wms_admin_mmc requires that wms is also included in this installation.

Valid for the Windows Server family of products only.

wms_server

Value: On | Off
Default: On
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\wms_server

Installs the Windows Media Services server components.

wms_server requires that wms and wms_admin_mmc are also included in this installation.

Valid for the Windows Server family of products only.

zonegames

Value: On | Off
Default: On
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Setup\OC Manager\Subcomponents\zonegames

Installs the Microsoft Gaming Zone Internet games on the computer.


[Data] (Unattend.txt)

banner

[Data]

Valid for Unattend.txt only.

This section is required when performing an unattended Setup by booting directly from the Windows product CD.

AutoPartition

Value: 1

Installs Windows to the first available partition that has adequate space for a Windows installation and does not already contain an installed version of Windows. Either omit the AutoPartition entry from your answer file or set the value of AutoPartition to 1. If AutoPartition = 1, the /tempdrive command-line option of Winnt32.exe is ignored. If you do not set the value, text-mode Setup installs Windows on the partition where $WIN_NT$.~LS is located.

MsDosInitiated

Value: 0

Informs the Windows Setup Loader that an unattended Setup is running directly from the product CD. The value must always be set to 0. If you do not set the value to 0, Setup fails at the beginning of GUI-mode Setup.

UnattendedInstall

Informs the Windows Setup Loader that an unattended Setup is running directly from the product CD. The value must always be set to Yes if you are preinstalling Windows using the CD Boot method.

Note

  • UnattendedInstall is not the same as the UnattendSwitch entry in the [Unattended] section of the answer file. UnattendSwitch controls Windows Welcome; UnattendedInstall does not.

UseBIOSToBoot

Value: 0 | 1
Default: 0

Instructs Setup to always use the basic input/output system (BIOS) to start the computer, even though Windows Setup might detect that it is best to use a device miniport driver to start the computer. On computers with large drives that support extended int13 BIOS calls, this helps the computers to start up faster by eliminating delays involved in using a miniport driver.

Important

  • Do not use this entry unless you are sure that the extended int13 functions are supported by BIOS.
  • Setup always uses BIOS to start the computer if you include UseBIOSToBoot in your Unattend.txt file, regardless of the value assigned. If this entry is not present, Setup invokes its logic to determine whether or not to use the BIOS to start Windows on the computer.
0
Setup uses its default behavior, based on the hardware configuration of the computer.
1
Setup always uses the BIOS to start the computer.

Note

  • The current generation of hardware uses the BIOS to start the computer, so this entry is rarely required.


[DCInstall] (Unattend.txt)

banner

[DCInstall]

Valid for Unattend.txt only.

This optional section contains entries for installing a domain controller after the initial Setup of the Windows operating system is complete. The entries in this section are supported only for the Windows Server family of operating systems.

An answer file can be created containing only this section, and it can be run after Setup has been completed and an end user has logged on to the system. The command for this is dcpromo /answer:answer_file

AdministratorPassword

Value: admin_password
Default: <blank>

Sets the local administrator password for the computer during the demotion of a domain controller to a member server. This entry is valid only during a demotion. If it is not specified or has no value, a blank administrator password is used.

The value is deleted from the answer file after the demotion operation is completed.

AllowAnonymousAccess

Value: Yes | No
Default: Yes

Used when any pre-Windows 2000 servers will authenticate end users from this domain or any trusting domain.

Yes
Is used with pre-Windows 2000 servers. Causes permissions to be set to allow anonymous access to end user and group information.
No
Is used when all servers in the domain are running a Windows 2000 Server product. Makes the default permissions more restrictive.

AutoConfigDNS

Value: Yes | No
Default: Yes

Is used to indicate whether the DCPROMO wizard configures DNS for the new domain if it detects that the DNS dynamic update protocol is not available.

Yes
Configure DNS for the new domain if the DNS dynamic update protocol is not available.
No
Do not configure DNS for the domain.

ChildName

Value: child_domain_name

Specifies the DNS label to be appended at the beginning of the name of an existing directory service domain when a child domain is installed. For example, if the parent name is "parentdom.fabrikam.com" and the ChildName is "childdom," then the name of the new domain is
"childdom.parentdom.fabrikam.com."

This new domain name must not be in use and DNS services must be properly configured on the computer. This value must be specified.

For more information, see TreeOrChild.

ConfirmGc

Value: Yes | No
Default: Yes

Only applies if ReplicationSourcePath is specified. If restored files were created from a backup of a global catalog, then the replica can also be a global catalog of those files. Use this value to indicate whether the replica is also a global catalog.

Yes
If the backup was of a global catalog, the replica is also a global catalog.
No
Does not make the replica a global catalog.

CreateOrJoin

Value: Create | Join
Default: Join

Specifies that the new tree domain created is part of an existing forest of domains or causes the creation of a new forest of domains.

Create
Creates a new forest of domains.
Join
Places the new domain as the root of a new domain tree in an existing forest of domains.

CriticalReplicationOnly

Value: Yes | No
Default: <none>

Specifies whether the promotion operation performs only critical replication and then continues, skipping the (potentially lengthy) noncritical portion of replication.

In the case that noncritical replication is skipped, replication automatically and silently resumes when the computer is rebooted and assumes its new role as a domain controller.

Yes
Skips noncritical replication.
No
Does not skip any replication steps.

DatabasePath

Value: path_to_database_files
Default: %systemroot%\NTDS

Specifies the fully qualified, non-UNC path to a directory on a fixed disk of the local computer that contains the domain database. Enclose path_to_database_files in quotes if it is a long file name.

If the directory exists, it must be empty. If the directory does not exist, it is created.

The disk must have enough free disk space available (at least 20 MB is required for new domains) and must have room to grow if you plan to add numerous objects to the domain. For replica domains, the space required is a function of domain size.

Note

  • For optimal performance, place the domain database on a different volume than the domain log files.

DNSOnNetwork

Value: Yes | No
Default: Yes

Used when installing a new forest of domains and DNS is not configured or installed on the computer. Before the computer can become a domain controller, its Transmission Control Protocol/Internet Protocol (TCP/IP) stack must have a valid DNS configuration.

Yes
Manually set the DNS server addresses for the computer or specify that the addresses are obtained automatically.
No
Install the DNS service, create a valid DNS configuration, and create a zone for the new domain with that service.

DomainNetBiosName

Value: domain_NetBIOS_name
Required

Assigns a network basic input/output system (NetBIOS) name to the new domain. The value is required, and the name specified must not already be in use as a domain or computer name. This entry is ignored when upgrading pre-Windows 2000 primary domain controllers.

IsLastDCInDomain

Value: Yes | No
Default: No

Indicates whether the computer on which Dcpromo.exe is running is the last domain controller in the domain.

This entry is valid only when demoting an existing domain controller to a member server.

Yes
This computer is the last domain controller in the domain.
No
This computer is not the last domain controller in the domain.

LogPath

Value: path_to_log_files
Default: %systemroot%\NTDS

Specifies the fully qualified, non-UNC path to a directory on a fixed disk of the local computer that contains the domain log files. Enclose path_to_log_files in quotes if it is a long file name.

If the directory exists, it must be empty. If the directory does not exist, it is created.

The disk must have enough free disk space available (at least 10 MB is required for new domains) and must have room to expand if you plan to add numerous objects to the domain. For replica domains, the space required is a function of domain size.

Note

  • For optimal performance, place the log files on a different volume than the database files.

NewDomain

Value: Tree | Child | Forest
Default: Forest

Used to indicate the type of the new domain, whether it is a new domain in a new forest, the root of a new tree in an existing forest, or a child of an existing domain.

Tree
The new domain is the root of a new tree in an existing forest.
Child
The new domain is a child of an existing domain.
Forest (or any other value)
The new domain is the first domain in a new forest of domain trees.

NewDomainDNSName

Value: DNS_name_of_domain

Specifies the required name of a new tree in an existing domain or when a new forest of domains is installed. For example, this DNS name could be "newdom.fabrikam.com".

ParentDomainDNSName

Value: DNS_name_of_domain

Specifies the DNS domain name of an existing directory service domain when a child domain is installed.

When specifying this entry, make sure that the current end user has administrative privileges to the specified domain, and that the DNS services are properly configured. The domain name must refer to an existing directory service domain.

For more information, see TreeOrChild.

Password

Value: password

Specifies the password for the user name (account credentials) to be used for promoting the member server to a domain controller.

The value is deleted from the Unattend.txt file after the promotion operation is completed.

RebootOnSuccess

Value: Yes | No | NoAndNoPromptEither
Default: No

Yes
Reboots upon successful completion.
No
Does not reboot, but prompts the user to reboot.
NoAndNoPromptEither
Does not reboot and does not prompt the user to reboot.

Specifies whether the computer is rebooted upon successful completion.

Note

  • The server must be rebooted for the directory service to be started.

ReplicationSourcePath

Value: replication_source_path
Default: <none>

Indicates the location of the files to be used to create a new domain controller. The value must be the fully qualified path to a folder on the local computer where the files have been copied.

Used to indicate that the bulk of the directory data replication is drawn from backup files that have been restored to a volume on the server, rather from another domain controller.

However, complete replication cannot be performed entirely from copied files: access to another domain controller is still required. (See ReplicationSourceDC.)

If this value is present and non-empty, then data replication is performed using the restored files. If this value is not present or is empty, then replication is performed from another domain controller on the network.

If the value refers to a valid set of restored backup files, then any value for the ReplicaDomainDNSName entry are ignored. The domain name to which the restored files belong takes precedence.

ReplicaDomainDNSName

Value: DNS_name_of_domain

Specifies the DNS domain name of the domain to be replicated. This entry is valid only for backup domain controller (BDC) upgrades and domain controller installations. In such situations, a value must be specified or the installation fails.

Normally, the end user who is currently logged on has administrative privileges to the specified domain, and DNS services are properly configured. The domain name must refer to an existing directory service domain.

Ignored if ReplicationSourcePath refers to a valid set of restored backup files. The domain name to which those files belong takes precedence.

ReplicaOrMember

Value: Replica | Member
Default: Member

Specifies whether a Windows NT 3.51 or Windows NT 4.0 BDC being upgraded is converted to a domain controller or is demoted to a regular member server in the domain. This entry is valid only when upgrading a BDC.

Replica
Installs the server as a domain controller.
Member
Installs the new domain controller as a member server in a domain.

ReplicaOrNewDomain

Value: Replica | Domain
Default: Replica

Specifies whether a new domain controller is installed as the first domain controller in a new directory service domain, or whether the new domain controller is installed as a replica directory service domain controller.

Replica
Installs the new domain controller as a replica directory service domain controller.
Domain
Installs the new domain controller as the first domain controller in a new directory service domain. The TreeOrChild entry must be specified with a valid value.

ReplicationSourceDC

Value: DNS_name_of_DC | <none>
Default: <none>

Indicates the full DNS name of the domain controller from which the domain information is to be replicated.

DNS_name_of_DC
Indicates the full DNS name of the domain controller from which the domain information is to be replicated. Only applies in new replica or BDC upgrade cases.
<none>
Selects the closest domain controller for the domain being replicated.

SafeModeAdminPassword

Value: password | None
Default: None

Supplies the password to be set on the administrator account used when the computer is started in safe mode or a variant of safe mode, such as DS-repair mode.

password
Specifies the password that the administrator account can use when the computer is in safe mode.
None
Does not supply a password for the administrator account to use when the computer is in safe mode.

SiteName

Value: site_name
Default: default_first_site

Specifies the name of an existing site to place the new domain controller. If a site is not specified, a suitable site is selected using the current site and subnet configuration of the forest.

Syskey

Default: <none>

Only applies if ReplicationSourcePath is specified. This value is used if the restored files used to install a replica indicate that the system key must be supplied by the end user.

If the restored files indicate that the system key must be supplied on floppy disk, then the system looks for the key on drive A:

SysVolPath

Value: path_to_database_file
Default: %systemroot%\sysvol

Specifies the fully qualified, non-UNC path to a directory on a fixed disk of the local computer. Enclose path_to_database_file in quotes if it is a long file name.

If the directory exists, it must be empty. If the directory does not exist, it is created.

The disk must be formatted with NTFS version 5.0.

TreeOrChild

Value: Tree | Child
Default: Child

Specifies that the new domain is the root of a new tree or a child of an existing domain.

Tree
Specifies that the new domain is the root of a new tree. The CreateOrJoin entry must be specified with a valid value.
Child
Specifies that the new domain is a child of an existing domain.

UserDomain

Value: domain_name

Specifies the domain name for the user name (account credentials) to be used for promoting the member server to a domain controller.

UserName

Value: user_name

Specifies the user name (account credentials) to be used for promoting the member server to a domain controller.


[Display] (Unattend.txt, Sysprep.inf)

banner

[Display]

This section is used in both Unattend.txt and Sysprep.inf. It specifies display settings for the particular graphics device.

If the specified settings are not valid for the particular graphics device, Setup finds the closest match to the selected settings to configure the device.

Important

  • If the monitor plugged into the computer is a Plug and Play device and is capable of displaying a screen resolution of 800x600x16m, then the display resolution must be at least 800x600x16m. The 640 by 480-pixel screen size is only used if the monitor is unable to display an 800 by 600-pixel screen.

Sysprep.exe configures the operating system to use the video settings in the [Display] section of Sysprep.inf. If there are no display settings or if Sysprep.inf is not used, Sysprep.exe uses the video settings in the registry. If the display settings were configured manually, set in Unattend.txt, or used as the defaults, then Sysprep retains those settings. If the screen resolution is defined in both the [Display] section of Sysprep.inf and in the [ComputerSettings] section of Winbom.ini, the operating system is configured to use the settings in Sysprep.inf.

BitsPerPel

Value: valid_bits_per_pixel

Specifies the valid bits per pixel for the graphics device. For example, a value of 8 (28) implies 256 colors, and a value of 16 implies 65,536 colors.

Vrefresh

Value: valid_refresh_rate

Specifies a valid refresh rate for the graphics device.

Xresolution

Value: valid_x_resolution

Specifies a valid X resolution for the graphics device.

Yresolution

Value: valid_y_resolution

Specifies a valid Y resolution for the graphics device.


[FavoritesEx] (Unattend.txt)

banner

[FavoritesEx]

Value: Title# = "site_name.url
URL# = site_address

This section contains the default Favorites settings for the Windows browser. If not present, the default for Windows is used.

[FavoritesEx]
Title1 = MSN.url
URL1 = http://www.microsoft.com/
Title2 = MSNBC.url
URL2 = http://www.msnbc.com

Important

  • To make sure your [FavoritesEx] settings take effect, you need to include the [Branding] section header and the BrandIEUsingUnattended entry in the answer file to enable the browser-related settings:
    [Branding]
BrandIEUsingUnattended = Yes


[Fax] (Unattend.txt)

banner

[Fax]

The entries in the following list can be used to specify the initial settings for the fax service. Unless otherwise specified, all the keys are optional.

This is an optional section that can be used to specify custom installation information for the fax service in Windows. If the values are not specified, the defaults are used for the installation.

Important

  • If you want the settings for these entries to be installed during Setup, make sure that fax=on in the [Components] section.

ArchiveIncoming

Value: True | False
Default: True

Specifies whether inbound faxes should be archived or saved in a folder. If ArchiveIncoming = True, a folder must be specified in ArchiveIncomingFolderName.

True
Saves inbound faxes in the folder specified by ArchiveIncomingFolderName.
False
Does not save inbound faxes.

ArchiveIncomingFolderName

Value: folder_to_save_faxes_to
Default: %SystemDrive%\documents and Settings\All Users\
Application Data\Microsoft\Windows NT\MsFax\SentItems
Registry subkey: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\
Fax\Setup\Original Setup Data\ArchiveDirectory

Specifies the folder in which copies of inbound faxes should be saved or archived. If ArchiveIncoming = True, a valid folder name must be specified and cannot be an empty string or a string containing only spaces.

ArchiveFolderName is supported, and provided only for backwards compatibility with the Windows 2000 Fax Unattended Install format.

ArchiveOutgoing

Value: True | False
Default: True

Specifies whether outbound faxes are archived or saved in a folder. If ArchiveOutgoing = True, a folder must be specified in ArchiveOutgoingFolderName.

True
Saves outbound faxes in the folder specified by ArchiveOutgoingFolderName.
False
Does not save outbound faxes.

ArchiveOutgoingFolderName

Value: folder_to_save_faxes_to
Default: %SystemDrive%\documents and Settings\All Users\
Application Data\Microsoft\Windows NT\MsFax\Inbox

Specifies the folder in which copies of outbound faxes should be saved or archived. This string must be a valid folder name, and must not be an empty string or a string containing only spaces. Unless ArchiveOutgoing is explicitly set to False, the folder must be specified.

ArchiveFolderName is supported and provided only for backwards compatibility with the Windows 2000 Fax Unattended Install format.

Csid

Value: called_subscriber_ID_string
Default: Fax
Registry subkey: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\
Fax\Setup\Original Setup Data\Csid

Specifies the Called Subscriber ID (CSID) transmitted to the sending fax machine when an inbound fax is received. This string is usually a combination of the fax or telephone number and the name of the business. It is often the same as the Transmitter Subscriber ID.

This entry applies to all of the existing devices and every new device.

FaxPrinterName

Value: fax_printer_name_string
Default: Fax

Specifies the fax printer name for outbound faxes. The value of this entry cannot be the same as the value of RoutePrinterName.

This string must not be an empty string or a string containing only spaces. This entry applies to all of the existing devices and every new device.

FaxUserName

Value: user_account_name

Specifies the user account name to be used for authenticating against the server in Basic Simple Mail Transfer Protocol (SMTP) Authentication, or the account name to use for Windows Security based authentication.

This string must not be an empty string or a string containing only spaces. This entry is not applicable on Windows XP.

FaxUserPassword

Value: user_account_password

Specifies the password to be used for authenticating against the server in Basic SMTP Authentication or Windows Security based authentication.

This entry is not applicable on Windows XP.

ReceiveFaxes

Value: True | False
Default: False

Specifies whether the fax service would answer incoming calls on this device. This entry applies to all the existing devices and every new device.

True
Answers incoming calls on this device.
False
Does not answer incoming calls.

Rings

Value: number_of_rings
Default: 2
Registry subkey: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\
Fax\Setup\Original Setup Data\Rings

Specifies the number of rings before the phone is answered.

This string must be a numeric value between 0 and 99. This setting applies to all the existing devices and every new device.

RouteFolderName

Value: folder_to_route_faxes to
Registry subkey: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\
Fax\Setup\Original Setup Data\StoreDirectory

Specifies the destination folder for inbound faxes.

RoutePrinterName

Value: printer_to_route_faxes_to
Registry subkey: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\
Fax\Setup\Original Setup Data\Printer

Specifies the printer name to which faxes are routed automatically. If the printer is remote, the value must be the UNC name of the fax printer - for example, \\server\printername.

RouteToEmail

Value: True | False
Default: False

Specifies whether faxes should be routed to a specific e-mail account. If set RouteToEmail = True, Simple Mail Transfer Protocol (SMTP) settings should be provided using SmtpNotificationsEnabled, SmtpSenderAddress, SmtpServerAddress, SmtpServerPort, SmtpServerAuthenticationMechanism, and RouteToEmailRecipient.

This entry applies to all existing devices and every new device. This entry does not apply to Windows XP.

True
Routes faxes directly to the e-mail address specified by RouteToEmailRecipient.
False
Does not route faxes to an e-mail address.

RouteToEmailRecipient

Value: email_name_to_route_faxes_to

Specifies the e-mail name (or e-mail alias) of the person to whom inbound faxes should be mailed.

This setting applies to all the existing devices and every new device. This string must be a valid recipient e-mail name, and must not be an empty string or a string containing only spaces. This entry is not applicable on Windows XP.

RouteToFolder

Value: True | False
Default: True

Specifies whether faxes are directly routed to a folder.

True
Routes faxes directly to the folder specified by RouteFolderName.
False
Does not route faxes to a folder.

RouteToPrinter

Value: True | False
Default: False

Specifies whether inbound faxes are directly routed to a printer.

True
Routes inbound faxes directly to the printer specified by RoutePrinterName.
False
Does not route inbound faxes to a printer.

SkipConfigWizardDeviceSettings

Value: True | False
Default: True

Specifies whether or not to display the service setting pages of the Configuration Wizard when the end user runs Fax for the first time.

True
Service setting pages of the Configuration Wizard are skipped when the end user runs Fax for the first time.
False
Service setting pages of the Configuration Wizard are displayed when the end user runs Fax for the first time.

SendFaxes

Value: True | False
Default: True

Specifies whether the fax service will use a device to send faxes. This entry applies to all the existing devices and every new device.

True
Uses a device to send faxes.
False
Does not use a device to send faxes.

SmtpNotificationsEnabled

Value: True | False
Default: False

Specifies whether Simple Mail Transfer Protocol (SMTP) notifications for sent faxes are enabled.

This entry does not apply to Windows XP.

True
SMTP notifications are enabled and settings are provided for SmtpSenderAddress, SmtpServerAddress, SmtpServerPort, SmtpServerAuthenticationMechanism and other parameters related to them.
False
SMTP notifications are not enabled.

SmtpSenderAddress

Value: sender_email_address
Default: "Microsoft Fax Software"

Specifies the e-mail address to be used in outgoing e-mail notifications.

This string must not be an empty string or a string containing only spaces. This entry does not apply to Windows XP.

SmtpServerAddress

Value: email_server_address
Default: "mail"

Specifies the name or IP address of the e-mail server.

This string must not be an empty string or a string containing only spaces. This entry does not apply to Windows XP.

SmtpServerPort

Value: email_server_port
Default: 25

Specifies the IP port number for the e-mail server.

This string must be a numeric value between 1 and 65535. This entry does not apply to Windows XP.

SmtpServerAuthenticationMechanism

Value: Anonymous | Basic | WindowsSecurity
Default: Anonymous

Specifies the authentication schema to use.

This entry does not apply to Windows XP.

Anonymous
Low level of security; all end users can authenticate servers.
Basic
Basic security. The user name and password must be provided in FaxUserName and FaxUserPassword.
WindowsSecurity
High security. The user name and password must be provided in FaxUserName and FaxUserPassword

Tsid

Value: transmitter_subscriber_ID_string
Default: Fax
Registry subkey: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\
Fax\Setup\Original Setup Data\Tsid

Specifies the Transmitter Subscriber ID (TSID) sent by the fax machine when sending a fax to a receiving fax machine. This string is usually a combination of the fax or telephone number and the name of the business. It is often the same as the Called Subscriber ID.


[GuiRunOnce] (Unattend.txt, Sysprep.inf)

banner

[GuiRunOnce]

This section is used in both Unattend.txt and Sysprep.inf. It contains a list of commands to be executed the first time an end user logs on to the computer after GUI-mode Setup has completed. Each line specifies a command to be executed by the [GuiRunOnce] registry entry, HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Runonce. See the following table for examples.

To install | Add this line to [GuiRunOnce]
Domain Controller | "dcpromo /answer:answer_file"
Cluster service | "%windir%\cluster\cluster.exe clustername /create /options", where /options is defined in the "Managing server clusters from the command line" topic in the Windows Server Help.

Important

  • Each command line must be in quotation marks.

Commands run using the [GuiRunOnce] section run in the context of the currently logged-in end user. If the end user does not have the permissions necessary to run the command completely, then the application fails. Because this is run in the context of a logged-in end user rather than as a service, the registry entries that the application creates are written for the current end user rather than the default user. (Default user registry settings are propagated to new end users.) If you want any settings and updates to show only for the specifically logged-in end user, then this might be appropriate. Otherwise, Cmdlines.txt is a better approach to running commands and installing applications because it runs as a system service.


[GuiUnattended] (Unattend.txt)

This is the [GuiUnattended] section for Unattend.txt. For the Sysprep.inf version, see [GuiUnattended] (Sysprep.inf).

AdminPassword

Value: password | *
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\
Windows\CurrentVersion\WinLogon\DefaultPassword

Sets the Administrator account password.

If a password is specified in the Administrator account, you cannot use AdminPassword in the Sysprep.inf file to change it: the administrator password remains the same. However, if the administrator password was initially blank (either manually or through an unattended Setup), you can use AdminPassword to change it to a nonblank password.

password
The administrator password; maximum length is 127 characters. End users cannot change or specify their own passwords in Mini-Setup. A new password can be entered in the appropriate dialog box, but the password is not changed.
*
The administrator password is blank or null.

Important

  • Security breaches can occur if you use a common, nonblank administrator password for all computers provided to end users. Prior to running Sysprep, we recommend you use an automation process to set the administrator password to blank. End users can then specify their own passwords upon receipt of the computer.

AdvServerType

Value: ServerNT

This entry and its value are added by Setup when it upgrades an existing installation to one of the members of the Windows 2000 Server family of operating systems.

The following table provides a comprehensive list of valid upgrade scenarios.

Upgrade from | Upgrade to
 | Windows 2000 Server | Windows 2000 Advanced Server | Windows 2000 Datacenter Server | Microsoft Small Business Server "Bobcat"
Windows NT 3.51 Server | No | No | No | No
Windows NT 4.0 Server (w/Service Pack 5) | Yes | Yes | No | No
Windows NT 4.0 Terminal Server | Yes* | Yes* | No | No
Windows NT 4.0 Enterprise Edition | Yes | No | No | No
Microsoft BackOffice Small Business Server 4.0/4.5 | No | No | No | No
Windows 2000 Server | Yes | Yes | No | Yes
Microsoft Small Business Server 2000 | No | No | No | Yes
Windows 2000 Advanced Server | No | Yes | No | No
Windows 2000 Datacenter Server | No | No | Yes | No
Windows 2000 Server | Yes | Yes | No | Yes
Microsoft Small Business Server "Bobcat" | No | No | No | Yes
Windows 2000 Advanced Server | No | Yes | No | No
Windows 2000 Datacenter Server | No | No | Yes | No

* You can upgrade from Windows NT 4.0 Terminal Server Edition
or Windows 2000 Application Server mode to Windows 2000 Server,
but you will receive a warning that the Terminal Service Application mode
is not supported.

Arguments

Value: string

Indicates that arguments or entries accompany the custom program that runs concurrently with the Setup program.

This entry is required if you are using DetachedProgram.

AutoLogon

Value: Yes | No
Default: No
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\
Windows\CurrentVersion\WinLogon\AutoAdminLogon

Configures the computer to automatically log on once with the Administrator account. The entry is not valid on upgrades.

If you specify a password by using AdminPassword, that password is used when you automatically log on to the computer. After the installation is complete, the password is deleted from the copy of the answer file left on the computer.

Important

  • If you encrypt the Administrator password with EncryptedAdminPassword, AutoLogon is disabled.
  • To skip Windows Welcome, in the [Unattended] section of Unattend.txt, set UnattendSwitch equal to Yes.
Yes
Configures the computer to automatically log on once with the Administrator account.
No
Does not automatically log on to the computer.

AutoLogonCount

Value: integer
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\WinLogon\AutoLogonCount

Specifies the number of times that the computer automatically logs on using the specified Administrator account and password. The value decrements after each logon, and the feature is disabled after the specified number of logon attempts.

This entry is only useful when AutoLogon = Yes and AdminPassword = password are specified in the answer file.

Important

  • Make sure that the password for the master installation (that you plan to duplicate onto one or more destination computers) is blank.
  • You must reboot the computer to decrement the value of AutoLogonCount.

DetachedProgram

Value: detached_program_string

Indicates the path of the custom program that is run concurrently with the Setup program. If the program requires any arguments, you must specify them in the Arguments entry.

OEMSkipRegional

Value: 0 | 1

Allows unattended Setup to skip the Regional and Language Options page in GUI-mode Setup and Mini-Setup.

If in the [Unattended] section you set OemPreinstall to Yes and provide values for the [RegionalSettings] section, set OEMSkipRegional = 1 to ensure that Setup completes without prompting the end user for regional information.

0
Displays the Regional and Language Options page in GUI-mode Setup and Mini-Setup.
1
Skips the Regional and Language Options page in GUI-mode Setup and Mini-Setup.

EncryptedAdminPassword

Value: Yes | No
Default: No

Allows Setup to install encrypted passwords for the Administrator account.

To encrypt your Administrator passwords, use the encryption tool (Hashpwd.exe) on the Windows OPK CD (in Tools) and in Deploy.cab.

Yes
Instructs Setup to install the encrypted Administrator account password.
No
Instructs Setup to keep the Administrator account password as clean text.

Important

  • If you use this key to install an encrypted Administrator password during an unattended installation, Autologon is disabled.

OEMSkipWelcome

Value: 0 | 1

Allows unattended Setup to skip the Welcome page in GUI-mode Setup and Mini-Setup.

If OemPreinstall in the [Unattended] section of Unattend.txt is set to Yes, unattended Setup automatically stops at the Welcome page. To avoid this pause in your factory or testing environment, set OEMSkipWelcome = 1. Do not ship any computer with OEMSkipWelcome = 1. Instead, change OEMSkipWelcome in the [GuiUnattended] section of Sysprep.inf to 0 before delivering the computer to the customer.

0
Displays the Welcome page in GUI-mode Setup and Mini-Setup.
1
Skips the Welcome page in GUI-mode Setup and Mini-Setup.

ProfilesDir

Value: path_to_profile_folder
Default: "%systemdrive%\Documents and Settings"

Specifies the location of Windows XP or Windows 2000 Server profiles, which is useful if you require new installations to use the same profile folder as Windows NT 4.0 or Windows 2000. This entry is valid only on clean installations of Windows XP or Windows 2000 Server family of products and is ignored during upgrades.

The directory specified can contain an environment variable such as %systemdrive% or %systemroot%. Enclose path_to_profile_folder if it is a long file name or if it contains an environment variable. For example:

ProfilesDir = "%systemroot%\Profiles"

TimeZone

Value: index
Registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\
TimeZoneInformation\DaylightName

Specifies the time zone of the computer. If the entry is not present, the end user is prompted to select a time zone.

The following table lists the valid TimeZone indexes.

Index | Zone
000 | International Dateline
001 | Samoa
002 | Hawaii
003 | Alaskan
004 | Pacific
010 | Mountain (U.S. and Canada)
015 | U.S. Mountain: Arizona
020 | Central (U.S. and Canada)
025 | Canada Central
030 | Mexico
033 | Central America
035 | Eastern (U.S. and Canada)
040 | U.S. Eastern: Indiana (East)
045 | S.A. Pacific
050 | Atlantic (Canada)
055 | S.A. Western
056 | Pacific S.A.
060 | Newfoundland
065 | E. South America
070 | S.A. Eastern
073 | Greenland
075 | Mid-Atlantic
080 | Azores
083 | Cape Verde Islands
085 | GMT (Greenwich Mean Time)
090 | GMT Greenwich
095 | Central Europe
100 | Central European
105 | Romance
110 | W. Europe
113 | W. Central Africa
115 | E. Europe
120 | Egypt
125 | EET (Helsinki, Riga, Tallinn)
130 | EET (Athens, Istanbul, Minsk)
135 | Israel: Jerusalem
140 | S. Africa: Harare, Pretoria
145 | Russian
150 | Arab
155 | E. Africa
160 | Iran
165 | Arabian
170 | Caucasus Pacific (U.S. and Canada)
175 | Afghanistan
180 | Russia Yekaterinburg
185 | W. Asia
190 | India
193 | Nepal
195 | Central Asia
200 | Sri Lanka
201 | N. Central Asia
203 | Myanmar: Rangoon
205 | S.E. Asia
207 | N. Asia
210 | China
215 | Singapore
220 | Taipei
225 | W. Australia
227 | N. Asia East
230 | Korea: Seoul
235 | Tokyo
240 | Sakha Yakutsk
245 | A.U.S. Central: Darwin
250 | Central Australia
255 | A.U.S. Eastern
260 | E. Australia
265 | Tasmania
270 | Vladivostok
275 | W. Pacific
280 | Central Pacific
285 | Fiji Islands
290 | New Zealand
300 | Tonga


[Identification] (Unattend.txt, Sysprep.inf)

banner

[Identification]

This section is used in both Unattend.txt and Sysprep.inf. It specifies the network identification entries of a computer. If these entries are not present, the computer is added to the default workgroup. If the information for this entry is not complete, the end user is prompted to provide this information.

DomainAdmin

Value: account_name

Specifies the name of the user account in the domain that has permission to create a computer account in that domain. This entry is required if you set a value for JoinDomain, even though the computer account might already exist on the domain.

DomainAdmin = accountname

DomainAdminPassword

Value: password_of_user_account

Specifies the password of the user account as defined by the DomainAdmin entry. This entry is required if you set a value for JoinDomain, even though the computer account might already exist on the domain.

DomainAdminPassword = abcdef123

Important

  • This is a potential security issue, because the password is in plain text. To resolve this you can:

    • Use EncryptedDomainAdminPassword to encrypt the password during Setup.

      • – or –

    • For a deployment, you can create a special account that can be used to create computer accounts in the domain, or, better still, create computer accounts in the domain before starting the deployment. The password is deleted from the copy of the Unattend.txt file that is left on the computer after Setup is complete.

EncryptedDomainAdminPassword

Value: Yes | No
Default: No

Allows Setup to install encrypted passwords for the domain Administrator account.

To encrypt your domain Administrator passwords, use the encryption tool (Hashpwd.exe) on the Windows OPK CD in the Tools section and in the Deploy.cab file.

Yes
Instructs Setup to install the encrypted domain Administrator account password.
No
Instructs Setup to keep the domain Administrator account password as clean text.

JoinDomain

Value: domain_name

Specifies the name of the domain in which the computer participates. You can specify either this entry or the JoinWorkgroup entry, but you cannot specify both.

JoinDomain = MYDOMAIN

JoinWorkgroup

Value: workgroup_name

Specifies the name of the workgroup in which the computer participates. You can specify either this entry or the JoinDomain entry, but you cannot specify both.

JoinWorkgroup = MYUSERGROUP

MachineObjectOU

Value: DNS_name, LDAP_path

Specifies the full Lightweight Directory Access Protocol (LDAP) path name of the organizational unit (OU) in which the computer belongs.

MachineObjectOU = "OU = myou,OU = myparentou,DC = mydom,DC = mycompany,DC = com"


[InternetServer] (Unattend.txt)

banner

[InternetServer]

This section configures the installation folder for Internet Information Services (IIS) components.

For this section to be processed, the values of iis_common, iis_inetmgr, and iis_www in the [Components] section must all equal On.

PathFTPRoot

Value: path_to_FTProot
Default: %systemdrive%\Inetpub\Ftproot

Specifies the installation folder for the FTP service. Enclose path_to_wwwroot in quotes if it is a long file name.

This entry is only useful if the FTP service is installed.

PathFTPRoot = C:\Inetpub\Ftproot

PathWWWRoot

Value: path_to_wwwroot
Default: %systemdrive%\Inetpub\Wwwroot

Specifies the installation folder for the World Wide Web service. Enclose path_to_wwwroot in quotes if it is a long file name.

This entry is only useful if the World Wide Web service is installed.

PathWWWRoot = C:\Inetpub\Wwwroot


[LicenseFilePrintData] (Unattend.txt, Sysprep.inf)

banner

[LicenseFilePrintData]

This section is used in both Unattend.txt and Sysprep.inf. This section is valid only for the Windows Server family of operating systems.

AutoMode

Value: PerSeat | PerServer

Determines whether Windows Server, Windows Advanced Server, or Windows Datacenter Server is to be installed in a per-seat or a per-server license mode. If AutoMode = PerServer, the AutoUsers entry must also be specified.

PerSeat
Indicates that a client access license has been purchased for each computer that accesses the server.
PerServer
Indicates that client access licenses have been purchased for the server to allow a certain number of concurrent connections to the server.

If AutoMode is empty or missing, the end user is prompted to select the license mode.

AutoUsers

Value: integer

This entry is valid only if AutoMode = PerServer. The integer value indicates the number of client licenses purchased for the server.

Important

  • The number specified must be greater than five, otherwise the unattended Setup fails and the end user is prompted to pick a value through the user interface.


[MassStorageDrivers] (Unattend.txt)

banner

[MassStorageDrivers]

This section contains a list of small computer system interface (SCSI) drivers to be loaded by the Setup Loader and installed during text-mode Setup. If this section is missing or empty, Setup attempts to detect the SCSI devices on the computer and install the corresponding retail drivers.

mass_storage_driver_description

Value: Retail | OEM

Identifies the driver to be installed. mass_storage_driver_description must match one of the strings defined in the right-hand side of the [SCSI] section of TxtSetup.sif (for a retail driver) or TxtSetup.oem (for an OEM driver). You can specify multiple instances of mass_storage_driver_description.

Retail
Indicates that the driver is part of the retail Windows product.
OEM
Indicates that the driver is OEM-supplied. If the value is OEM, the driver must also be listed in the [OEMBootFiles] section of the Unattend.txt file.


[MS_AppleTalk parameters] (Unattend.txt)

banner

[MS_AppleTalk parameters]

This section contains parameters for configuring AppleTalk.

DefaultPort

Value: adapter name

Specifies the network on which the Services for Macintosh (SFM) service names are registered. If the AppleTalk protocol is not routing, only Macintosh workstations connected to this network can access the file and print services on the computer. Normally, the default port is automatically set to the first Ethernet adapter, Token Ring adapter, or LocalTalk adapter found on the computer (in that order).

DefaultPort = PCI\VEN_10B7&DEV_5900\1&5070

DefaultZone

Value: zone name

Specifies the default zone for the network if the network adapter is seeding the network.

DefaultZone = Zone2

DesiredZone

Value: zone name

Specifies the zone in which the SFM service is present. If this value is not set, the SFM service for the default zone on that network is used.

DesiredZone = Zone1

EnableRouter

Value: Yes | No
Default: No

Starts routing for the AppleTalk protocol on this computer. If routing is started, Macintosh workstations connected to any networks the computer is on can use the file and print servers for Macintosh.

EnableRouter = No

Important

  • The remaining parameters in this section are network adapter-specific. Therefore, they must only be used in an AppleTalk parameters section that has the SpecificTo parameter specified. For more information, see SpecificTo in the section on [adapter_specific_protocol_section].

NetworkRangeLowerEnd

Value: integer from 1 to 65279

Specifies the lower network number of the network range if the network adapter is seeding the network.

NetworkRangeLowerEnd = 3

NetworkRangeUpperEnd

Value: integer from 1 to 65279

Specifies the upper network number of the network range if the network adapter is seeding the network.

NetworkRangeUpperEnd = 33

SeedingNetwork

Value: 0 | 1
Default: 0

Used by the AppleTalk protocol during startup to determine if the computer is a seed router for a specific physical AppleTalk network segment.

SeedingNetwork = 1
0
Does not seed the network and ignores seeding information.
1
Reads all seeding information and seeds the network to provide the network address to clients, servers, or other routers on the AppleTalk network.

Important

  • When specifying SeedingNetwork = 0 for a computer acting as a router on an AppleTalk network, another router that is seeding the network needs to be available so that the router will start.

ZoneList

Value: zone name[, zone name, ...]

Specifies the list of zones with which to seed the network. This entry is valid only if the network adapter is seeding the network.

ZoneList = zone1, zone2


[MS_ATMArps parameters] (Unattend.txt)

banner

[MS_ATMArps parameters]

There are currently no parameters required for this section.


[MS_ATMLANE parameters] (Unattend.txt)

banner

[MS_ATMLANE parameters]

There are currently no parameters required for this section.


[MS_ATMUni parameters] (Unattend.txt)

banner

[MS_ATMUni parameters]

There are currently no parameters required for this section.


[MS_L2TP parameters] (Unattend.txt)

banner

[MS_L2TP parameters]

This section contains parameters for the L2TP (Layer 2 Tunneling Protocol).

WanEndpoints

Value: integer_value_from_0_to_30000
Default: 5

Specifies the maximum number of virtual private network ports available to the L2TP.

WanEndpoints = 3

This parameter is only valid for the Windows Server family of operating systems.


[MS_MSClient parameters] (Unattend.txt)

banner

[MS_MSClient parameters]

This section contains client parameters for Client for Microsoft Networks.

BrowseDomains

Value: domain name [, domain name[, ...]]

Valid only for the Windows 2000 Server family of operating systems. Specifies a list of domains that can be browsed by the computer.

BrowseDomains = Sales, Research

NameServiceNetworkAddress

Value: IP address

Specifies the network address of the name service provider. This value is used only if NameServiceProtocol = ncacn_ip_tcp.

NameServiceNetworkAddress = 193.1.1.1

NameServiceProtocol

Value: ncacn_np | ncacn_ip_tcp

Specifies the protocols used by the name service.

NameServiceProtocol = ncacn_np


[MS_NetMon parameters] (Unattend.txt)

banner

[MS_NetMon parameters]

There are currently no parameters required for this section.


[MS_NWClient parameters] (Unattend.txt)

banner

[MS_NWClient parameters]

This section contains client parameters for Client Service for NetWare. The settings are applied to the default user account on the computer.

Important

  • NetWare client is supported by Windows XP Professional and the Windows 2000 Server family of products, but it is not supported by Windows XP Home Edition.

DefaultTree

Value: tree name

Specifies the name of the preferred tree.

DefaultTree = NDSSERVER

DefaultContext

Value: NetWare context name

Specifies the default logon context.

DefaultContext = SALES.NWSERVER1

LogonScript

Value: Yes | No

Specifies whether to execute a logon script.

LogonScript = No
Yes
Executes a logon script.
No
Does not execute a logon script.

PreferredServer

Value: server name

Specifies the name of the preferred server. This parameter and the DefaultTree and DefaultContext parameters are mutually exclusive.

PreferredServer = NWSERVER1


[MS_NWIPX parameters] (Unattend.txt)

banner

[MS_NWIPX parameters]

This section contains parameters for the Internetwork Packet Exchange (IPX) protocol. The following parameters are network adapter–independent.

Important

  • The IPX protocol is valid only on 32-bit platforms.

DedicatedRouter

Value: Yes | No
Default: No

Specifies that the computer is installed as a dedicated router and other network services are not running on it.

DedicatedRouter = No
Yes
The computer is a dedicated router.
No
The computer may be running other network services, in addition to serving as a router.

EnableWANRouter

Value: Yes | No
Default: Yes

Enables the Routing Information Protocol (RIP) router.

EnableWANRouter = No
Yes
Enables the RIP router.
No
Does not enable the RIP router.

NetworkNumber

Value: hexadecimal_number
Default: 0

NetworkNumber = 0x1234

Important

  • This parameter is network adapter–specific. Therefore, it must only be used in an IPX section containing parameters in which the SpecificTo entry is specified. For more information, see SpecificTo in the section [adapter_specific_protocol_section].

PktType

Value: 0 | 1 | 2 | 3 | FF
Default: FF

Specifies the packet type/form to use for the IPX protocol.

PktType = FF
Value | Packet type | Adapter type
0 | Ethernet_II | Ethernet
1 | Ethernet_802.3 | Ethernet
2 | 802.2 | Ethernet, Token Ring, FDDI
3 | SNAP | Ethernet, Token Ring, FDDI
FF | Auto-detect |

Important

  • This parameter is network adapter–specific. Therefore, it must only be used in an IPX section containing parameters in which the SpecificTo entry is specified. For more information, see SpecificTo in the section [adapter_specific_protocol_section].

VirtualNetworkNumber

Value: hexadecimal_number
Default: 0

Specifies the internal network number for configuring the IPX protocol.

VirtualNetworkNumber = 0


[MS_NwSapAgent parameters] (Unattend.txt)

banner

[MS_NwSapAgent parameters]

This section contains parameters for the NetWare Service Advertising Protocol (SAP) Agent that will be available in the future. There are currently no parameters required for this service.


[MS_PPTP parameters] (Unattend.txt)

banner

[MS_PPTP parameters]

This section contains parameters for the Point-to-Point Tunneling Protocol (PPTP).

NumberLineDevices

Value: integer_value_from_0_to_16384
Default: 5

Specifies the number of virtual private networks to be supported by PPTP.

NumberLineDevices = 10

This entry and its value are valid only for the Windows 2000 Server family of operating systems.


[MS_Psched parameters] (Unattend.txt)

banner

[MS_Psched parameters]

This section contains parameters for the Quality of Service (QoS) Packet Scheduler service. There are no parameters required for this service.


[MS_RAS parameters] (Unattend.txt)

banner

[MS_RAS parameters]

This section contains parameters for Routing and Remote Access Service.

The entry RouterType is required for all entries in [MS_RAS parameters] to take effect.

AssignSameNetworkNumber

Value: Yes | No
Default: Yes

Specifies whether the same network number is assigned to all clients.

AssignSameNetworkNumber = No
Yes
Assigns the same network number to all clients.
No
Does not assign the same network number to all clients.

AutomaticNetworkNumbers

Value: Yes | No
Default: Yes

Specifies whether the network numbers parameter is automatically allocated.

AutomaticNetworkNumbers = No

If the value of AutomaticNetworkNumbers is No, then you must provide a value for the NetworkNumberFrom entry.

Yes
Automatically allocates network numbers.
No
Does not automatically allocate network numbers.

ClientCanRequestIPAddress

Value: Yes | No
Default: No

Specifies whether a Transmission Control Protocol/Internet Protocol (TCP/IP) client can request a specific IP address.

ClientCanRequestIPAddress = Yes
Yes
Specifies that a TCP/IP client can request a specific IP address.
No
A TCP/IP client cannot request a specific IP address.

ClientsCanRequestIpxNodeNumber

Value: Yes | No
Default: No

For 32-bit platforms only. Specifies whether a client can request an Internetwork Packet Exchange (IPX) node number.

ClientsCanRequestIpxNodeNumber = Yes
Yes
A client can request an IPX node number.
No
A client cannot request an IPX node number.

DialinProtocols

Value: All | TCP/IP | IPX | AppleTalk

Specifies the dial-in protocols to support. Multiple protocols can be specified, but they must be comma-separated as shown in the following example:

DialinProtocols = IPX,TCP/IP

The IPX protocol is supported only on 32-bit platforms.

All
Indicates all installed protocols on the computer.
TCP/IP
The TCP/IP protocol.
IPX
The IPX protocol.
AppleTalk
The AppleTalk protocol.

IpAddressEnd

Value: IP_address

Specifies the ending IP address to use when assigning addresses to clients. Only one range of IP addresses can be added during unattended Setup.

IpAddressEnd = 193.1.1.200

IpAddressStart

Value: IP_address

Specifies the beginning IP address to use when assigning addresses to clients. Only one range of IP addresses can be added during unattended Setup.

IpAddressStart = 193.1.1.100

IPXClientAccess

Value: Network | ThisComputer
Default: Network

Specifies the access scope of an IPX client. This entry is valid only if one of the values of the entry DialinProtocols is IPX.

The IPX protocol is supported only on 32-bit platforms.

IPXClientAccess = ThisComputer
Network
The IPX client can access the entire network.
ThisComputer
The IPX client is restricted to this computer.

Multilink

Value: Yes | No
Default: Yes

Specifies whether multilinking of modems is enabled for increased bandwidth. This entry is valid only if multiple modems are installed.

Multilink = No
Yes
Can link multiple modems together.
No
Cannot link multiple modems together.

NetworkNumberFrom

Value: 0x00000001_to_0xFFFFFFFE

Specifies the start address of allowed IPX network numbers.

The IPX protocol is supported only on 32-bit platforms.

NetworkNumberFrom = 0x000005ab

RouterType

Value: 1 | 2 | 3 | 6 | 7
Required

Specifies how to configure the Routing and Remote Access Service.

RouterType = 3
1
Enable remote access.
2
Enable local routing only (LAN-only router).
3
Enable remote access and local routing.
6
Enable local/remote routing (LAN and WAN routers).
7
Enable remote access and local/remote routing.

Important

  • This entry is required for all [MS_RAS parameters] to take effect.
  • This entry is valid only for the Windows 2000 Server family of operating systems.

TcpIpClientAccess

Value: Network | ThisComputer
Default: Network

Specifies the access scope of an TCP/IP client. This entry is valid only if one of the values of the entry DialinProtocols is TCP/IP.

TcpIpClientAccess = ThisComputer
Network
The TCP/IP client can access the entire network.
ThisComputer
The TCP/IP client is restricted to this computer.

UseDHCP

Value: Yes | No
Default: Yes

Specifies whether Dynamic Host Configuration Protocol (DHCP) is used to assign IP addresses to TCP/IP clients.

UseDHCP = Yes
Yes
Use DHCP to assign IP addresses to TCP/IP clients.
No
Do not use DHCP to assign IP addresses to TCP/IP clients.

Important

  • If UseDHCP = No, then IpAddressStart and IpAddressEnd must be specified.


[MS_RasSrv parameters] (Unattend.txt)

banner

[MS_RasSrv parameters]

This section contains parameters for the Routing and Remote Access Service for RAS servers.

ParamsSection

Value: RAS_parameters_section
Required

Specifies the section containing the Routing and Remote Access Service (RAS) parameters listed in the [MS_RAS parameters] section.

ParamsSection = params.MS_RAS


[MS_Server parameters] (Unattend.txt)

banner

[MS_Server parameters]

This section contains parameters for the File and Print Service.

BroadcastsToLanman2Clients

Value: Yes | No
Default: No

Valid only for the Windows 2000 Server family of operating systems. Specifies whether the Windows 2000 Server service makes browser broadcasts to LAN Manager 2.x clients.

BroadcastsToLanman2Clients = Yes
Yes
Server issues LAN Manager 2.x compatible server announcements to announce its presence.
No
Server does not issue LAN Manager 2.x compatible server announcements.

Optimization

Value: MinMemoryUsed | Balance | MaxThroughputForFileSharing | MaxThroughputForNetworkApps
Default: MaxThroughputForFileSharing

Valid only for the Windows 2000 Server family of operating systems. Controls the optimization method used by Windows 2000 Server.

Optimization = Balance
MinMemoryUsed
Server uses the minimum amount of resources possible.
Balance
Server balances its resource usage for both local applications and file serving.
MaxThroughputForFileSharing
Server uses the resources necessary to optimize file sharing throughput.
MaxThroughputForNetworkApps
Server uses the resources necessary to optimize file sharing throughput, and optimize it further to handle requests for "run-from-network" applications.


[MS_TCPIP parameters] (Unattend.txt)

banner

[MS_TCPIP parameters]

This section contains parameters for configuring the Transmission Control Protocol/Internet Protocol (TCP/IP) protocol.

Important

  • The parameters in the first part of this section are global: they apply to all network adapters on the computer.

DeadGWDetectDefault

Value: Yes | No
Default: No
Global

Specifies whether the computer detects nonfunctional gateways.

Only use this entry if the computer offers Routing and Remote Access Service of any type. If this is the case, this value must be set to No.

For more information, see [MS_RAS parameters].

DeadGWDetectDefault = No
Yes
Detects nonfunctional gateways.
No
Does not detect nonfunctional gateways.

DisableDynamicUpdate

Value: Yes | No | Not present
Default: Not present
Adapter specific

If this option is set to Yes, then A and PTR records corresponding to the IP addresses of this connection are not dynamically registered in DNS.

If this option does not exist or is set to No, then A and PTR DNS records containing the full DNS name of the computer and the IP addresses of this connection are registered in DNS. The full DNS name is a concatenation of the Computer Name and the Primary DNS Suffix of the computer, computer_name.primary_DNS_suffix.

Yes
Dynamically registers the A and PTR records corresponding to the IP addresses of the connection.
No
Does not register the A and PTR records corresponding to the IP addresses of the connection.

DNSDomain

Value: primary_DNS_suffix
Global

Specifies the primary DNS suffix of the computer.

DNSDomain = fabrikam.com

Requires SyncDomainWithMembership = 0.

DNSSuffixSearchOrder

Value: suffix[, suffix[, ...]]
Global

Specifies the search order for DNS servers.

DNSSuffixSearchOrder = server1.fabrikam.com, fabrikam.com

DontAddDefaultGatewayDefault

Value: Yes | No
Default: Yes
Global

Specifies whether the computer uses the default gateway.

Use this entry only if the computer offers Routing and Remote Access Service of any type, in which case this value must be set to Yes.

For more information, see [MS_RAS parameters].

Yes
Uses the default gateway.
No
Does not use the default gateway.

EnableAdapterDomainNameRegistration

Value: Yes | No | Not present
Default: Not present
Adapter specific

If this option is set to Yes, and the DisableDynamicUpdate value for the same network connection does not exist or is set to No, then the computer attempts to dynamically register the following:

  • The A and PTR DNS records containing the computer name, primary DNS suffix, and the IP addresses of the connection.
  • The A and PTR DNS records containing the IP addresses of the connection, and a name that is a concatenation of the computer name and the connection-specific DNS suffix.
Yes
Registers the DNS records.
No
Does not register the DNS records.

EnableICMPRedirect

Value: Yes | No
Default: No
Global

Specifies whether this computer uses ICMPRedirect.

Only use this entry if the computer offers Routing and Remote Access Service of any type. If this is the case, this value must be set to No.

For more information, see [MS_RAS parameters].

Yes
Use ICMPRedirect.
No
Do not use ICMPRedirect.

EnableLMHosts

Value: Yes | No
Registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\
Services\NetBT\entries\EnableLMHosts

Default: Yes
Global

Specifies whether this computer uses LMHosts lookup.

EnableLMHosts = Yes
Yes
Use LMHosts lookup.
No
Do not use LMHosts lookup.

EnableSecurity

Value: Yes | No
Default: No
Global

Enables TCP/IP filtering.

EnableSecurity = No
Yes
Enables TCP/IP filtering.
No
Does not enable TCP/IP filtering.

ScopeID

Value: scope_ID
Global

Specifies the computer’s scope identifier if it is required on a network that uses network basic input/output system (NetBIOS) over TCP/IP. Do not use a scope ID if DNS is enabled on the network in which the computer participates.

ScopeID = REDMOND

SyncDomainWithMembership

Value: Yes | No | Not present
Default: Not present

If not present, or if nonzero, the primary DNS suffix value is changed when the computer joins an Active Directory (Windows 2000 or Windows 2000 Server family of products) domain. The name is the DNS name of the Active Directory domain joined by the computer.

To specify a primary DNS suffix, set SyncDomainWithMembership to 0 and set DNSDomain to primary_DNS_suffix.

0
Does not change the primary DNS suffix.
1
Changes the primary DNS suffix value when the computer joins an Active Directory domain.

UseDomainNameDevolution

Value: Yes | No
Default: Yes
Global

Enables domain name devolution when the DNS caching resolver is given an unqualified query to resolve.

UseDomainNameDevolution = No
Yes
Enables domain name devolution.
No
Does not enable domain name devolution.

Important

  • The remaining parameters in this section are network adapter-specific. Only use these parameters in a TCP/IP section that has the SpecificTo parameter specified. For more information, see SpecificTo in the [adapter_specific_protocol_section] section.

DefaultGateway

Value: gateway_address[, gateway_address[, ...]]
Adapter-specific

Specifies the default gateway addresses.

DefaultGateway = 193.1.1.1

DHCP

Value: Yes | No
Default: Yes
Adapter-specific

Specifies whether Dynamic Host Configuration Protocol (DHCP) is used on the network connection that uses this adapter.

DHCP = Yes
Yes
Uses DHCP on the network connection that uses this adapter.
No
Does not use DHCP on the network connection that uses this adapter. In this case, you must specify the IPAddress and SubnetMask entries. You may also need to specify a value for the DefaultGateway, if required by your network configuration.

DHCPClassId

Value: string
Adapter-specific

Specifies the DHCP class ID.

DHCPClassId = foo

DNSDomain

Value: DNS_domain_name
Adapter-specific

Specifies the suffix of the network connection that uses this adapter.

DNSDomain = fabrikam.com

DNSServerSearchOrder

Value:server_address[, server_address [, ...]]
Adapter-specific

Specifies a list of addresses to use when searching for the DNS server on the network.

DNSServerSearchOrder = 193.1.1.3,193.1.1.44

IPAddress

Value: IP_address[, IP_address [, ...]]
Adapter-specific

Specifies the IP addresses for the network connection that uses this adapter.

IPAddress = 193.1.1.33,193.1.1.34

If more than one IP address is specified, multiple subnet mask addresses must be specified in a one-to-one relationship. The ordering of the addresses is used to pair up with the subnet mask addresses.

If IPAddress and SubnetMask are specified, you must specify DHCP = No in the Unattend.txt file.

NetBIOSOptions

Value: 0 | 1 | 2
Default: 0
Adapter-specific

Specifies the NetBIOS option to use on the network connection that uses this adapter.

0
Uses NetBIOS setting from the DHCP Server.
1
Enables NetBIOS over TCP/IP.
2
Disables NetBIOS over TCP/IP.

SubnetMask

Value: subnet_address[, subnet_address[, ...]]
Adapter-specific

Specifies the subnet mask addresses.

SubnetMask = 193.1.1.255

If IPAddress and SubnetMask are specified, you must specify DHCP = No in the Unattend.txt file.

WINS

Value: Yes | No
Default: No
Adapter-specific

Specifies whether Windows Internet Name Service (WINS) is used on the network connection that uses this adapter.

WINS = Yes
Yes
Uses WINS on the network connection that uses this adapter.
No
Does not use WINS on the network connection that uses this adapter.

WINSServerList

Value: IP_address[, IP_address, …]
Adapter-specific

Specifies the IP addresses of the WINS servers on the network.

WINSServerList = 193.1.1.95,193.1.1.97

Important

  • Set WINS = Yes to make sure the WINSServerList IP addresses are applied.


[MS_WLBS parameters] (Unattend.txt)

banner

[MS_WLBS parameters]

This section contains parameters for configuring the Network Load Balancing (formerly, Windows Load Balancing Service). Network Load Balancing can be bound to multiple network adapters. For unique Configuration/Binding see the [NetBindings] section.

[MS_WLBS_parameters] are only available for Windows 2000 Server family of products.

By default, all networking components except WLBS are installed with all of their bindings enabled. These can be selectively disabled using the Disable entry in the [NetBindings] section. In addition, the Enable entry is supported in the [NetBindings] section for explicit binding enabling.

WLBS is installed with all of its bindings disabled. You must then explicitly enable a binding to a single adapter using the Enable entry in the [NetBindings] section.

[params.MS_WLBS]
AdapterSections=params.MS_WLBS.Adapter01,params.MS_WLBS.Adapter02

[Networking]

[NetServices]
MS_WLBS=params.MS_WLBS

[params.MS_WLBS.Adapter01]
HostPriority            = 1
ClusterModeOnStart      = 1
ClusterIPAddress        = 172.31.240.176
ClusterNetworkMask      = 255.255.248.0
DedicatedIPAddress      = 172.31.240.165
DedicatedNetworkMask    = 255.255.248.0
ClusterName             = cluster.microsoft.com
MulticastSupportEnable  = 1
RemoteControlPassword   =
RemoteControlEnabled    = 1
Ports                   = 80,80,Both,Multiple,None,Equal,443,443,
                          Both,Multiple,Single,Equal
[params.MS_WLBS.Adapter02]
HostPriority            = 1
ClusterModeOnStart      = 1
ClusterIPAddress        = 172.31.240.177
ClusterNetworkMask      = 255.255.248.0
DedicatedIPAddress      = 172.31.240.166
DedicatedNetworkMask    = 255.255.248.0
ClusterName             = cluster.microsoft.com
MulticastSupportEnable  = 1
RemoteControlPassword   =
RemoteControlEnabled    = 1
Ports                   = 80,80,Both,Multiple,None,Equal,443,443,
                          Both,Multiple,Single,Equal

[params.MS_TCPIP]

For more information about this parameter, see the [MS_TCPIP parameters] section.

[NetBindings]
 Enable=MS_WLBS,Adapter01
 Disable=MS_WLBS,Adapter02
Add pointer to [NetAdapters] section.
[NetAdapters]
Adapter01 = params.Adapter01
Adapter02 = params.Adapter02

[params.Adapter01]
NetCardAddress = 0x2bfc01f388d

[params.Adapter01]
NetCardAddress = 0x2bfc01f3890

AliveMsgPeriod

Value: integer_between_100_and_10,000
Default: 1000

Specifies a period between sending WLBS cluster heartbeat messages in milliseconds.

AliveMsgPeriod = 5000

AliveMsgTolerance

Value: integer_between_5_and_100
Default: 5

Specifies the number of heartbeat messages that can be lost before WLBS cluster host is considered dead and convergence is initiated.

AliveMsgTolerance = 50

ClusterIPAddress

Value: IP_address
Default: 0.0.0.0

Specifies the WLBS cluster’s primary IP address. This address is a virtual IP address and it must be set identically for all hosts in the WLBS cluster. If you use one alias for several IP addresses to the WLBS cluster, then only the primary (main) IP address needs to be specified.

ClusterIPAddress = 10.192.45.7

ClusterModeOnStart

Value: 0 | 1
Default: 1

Specifies whether a host joins the WLBS cluster upon startup or waits until given an explicit command to do so.

ClusterModeOnStart = 0
0
Host does not join the WLBS cluster upon startup, but instead waits until given an explicit command.
1
Host joins the WLBS cluster upon startup.

ClusterName

Value: fully_qualified_domain_name_of_the_cluster
Default: cluster.domain.com

Specifies a full Internet name for the WLBS cluster.

ClusterName = cluster.microsoft.com

ClusterNetworkMask

Value: network_mask
Default: 0.0.0.0

Specifies the subnet mask for the WLBS cluster IP address.

ClusterNetworkMask = 255.255.255.0

DedicatedIPAddress

Value: IP_address
Default: 0.0.0.0

Specifies host’s unique IP address.

DedicatedIPAddress = 10.192.45.1

DedicatedNetworkMask

Value: network_mask
Default: 0.0.0.0

Specifies the subnet mask for the dedicated IP address.

DedicatedNetworkMask = 255.255.255.0

DescriptorsPerAlloc

Value: integer_between_16_and_1024
Default: 512

Specifies the number of connection descriptors that are created per each allocation. Change this value only when instructed to do so by an event log message.

DescriptorsPerAlloc = 1024

HostPriority

Value: integer_between_1_and_32
Default: 1

Specifies host’s unique priority ID in the WLBS cluster.

HostPriority = 5

IGMPSupport

Value: 0 | 1
Default: 0

Specifies whether to use IGMP support to prevent switch flooding.

Important

  • For this option to work MulticastSupportEnable must be set to 1.
0
Do not use IGMP for WLBS cluster operations.
1
Use IGMP for WLBS cluster operations.

MaskSourceMAC

Value: 0 | 1
Default: 1

Specifies whether source Media Access Control (MAC) address masking is used, allowing WLBS cluster hosts to be connected to different switch ports.

MaskSourceMAC = 0
0
Does not use source Media Access Control (MAC) address masking. The WLBS cluster is connected to a hub to re-enable learning in the upstream switch and conserve its bandwidth.
1
Uses source Media Access Control (MAC) address masking.

MaxDescriptorAllocs

Value: integer_between_1_and_1024
Default: 512

Specifies the maximum number of connection descriptor allocations. Change this value only when instructed to do so by an event log message.

MaxDescriptorAllocs = 1024

McastIPaddress

Value: IP_address

Specifies the multicast IP address to use to send IGMP join messages when IGMPSupport is enabled.

McastIPaddress = 239.255.1.1

Default address is automatically generated using the Primary Cluster IP.

MulticastSupportEnable

Value: 0 | 1
Default: 0

Specifies whether a multicast MAC address is used for WLBS cluster operations.

MulticastSupportEnable = 1
0
Does not use multicast MAC addresses for WLBS cluster operations.
1
Uses multicast MAC addresses for WLBS cluster operations.

NetmonAliveMsgs

Value: 0 | 1
Default: 0

Specifies whether WLBS forwards heartbeat messages up to the bound protocols, allowing heartbeats to be captured by the Network Monitor utility.

NetmonAliveMsgs = 0
0
Does not forward heartbeat messages to bound protocols.
1
Forwards heartbeat messages to bound protocols.

NumActions

Value: integer_between_5_and_500
Default: 50

Specifies the number of actions that are created per each allocation. Change this value only when instructed to do so by an event log message.

NumActions = 100

NumAliveMsgs

Value: integer_between_66_and_660
Default: 66

Specifies the number of heartbeat packet buffers that are created per each allocation. Change this value only when instructed to do so by an event log message.

NumAliveMsgs = 100

NumPackets

Value: integer_between_5_and_500
Default: 100

Specifies the number of packets that are created per each allocation. Change this value only when instructed to do so by an event log message.

NumPackets = 100

Ports

Value: integer_from_1_to_65535,integer_from_1_to_65535,
Both | TCP | UDP,Multiple | Single | Disabled,
mode entry,[...]

Mode entry for Multiple: None | Single | ClassC,
Equal | integer_from_1_to_100

Mode entry for Single: integer_from_1_to_32
Mode entry for Disabled: None
Default: 1,65535,Both,Multiple,Single,Equal

Specifies rules for distributing traffic among WLBS cluster hosts according to protocol and destination ports.

Ports = 20,21,TCP,Multiple,Single,Equal,80,80,Both,Multiple, None,Equal,443,443,Both,Multiple,Single,Equal,1024,65535,TCP, Multiple,Single,Equal

Ports = ALL,20,21,TCP,Multiple,Single,Equal,80,80,Both,Multiple, None,Equal,443,443,Both,Multiple,Single,Equal,1024,65535,TCP, Multiple,Single,Equal

Ports = 172.31.80.178,20,21,TCP,Multiple,Single,Equal,80,80,Both,Multiple, None,Equal,443,443,Both,Multiple,Single,Equal,1024,65535,TCP, Multiple,Single,Equal

RemoteControlEnabled

Value: 0 | 1
Default: 0

Specifies whether remote-control operations are enabled.

Important

  • For security reasons, it is vital that you place the WLBS UDP control port behind a firewall.
RemoteControlEnabled = 1
0
Does not enable remote-control operations.
1
Enables remote-control operations.

RemoteControlPassword

Value: password
Default: NULL

Specifies a password to be used for restricting access to the WLBS cluster from remote, networked computers running Windows, using the Wlbs.exe control program.

RemoteControlPassword = B1gCluster

RemoteControlUDPPort

Value: integer_between_1_and_65535
Default: 2505

Specifies the remote control UDP port.

RemoteControlUDPPort = 1717


[NetAdapters] (Unattend.txt)

banner

[NetAdapters]

This section specifies the network adapters to be installed. Each adapter present in the computer must be listed as a entry = value pair.

The entry name is user-defined and acts as an identifier for the adapter to be installed. The value of this entry (also user-defined) specifies a section that contains entries for the adapter under consideration.

adapter_instance

Value: adapter_entries_section

This entry is a user-defined name for the adapter for which specific settings need to be defined. Each adapter needs an entry created, with each one having a unique adapter entries section specified for the value.

Adapter1 = params.Adapter1


[NetBindings] (Unattend.txt)

banner

[NetBindings]

This section contains information about how to disable, enable, and demote binding rules for network components such as services, protocols, and adapters.

Each entry can be listed more than once in this section. The network components that make up the binding order/path must be listed in the following order:

network_service network_protocol network_adapter

The binding order/path must always start with a client/service (if one exists) and end with an adapter. Incorrectly specified binding orders/paths are ignored.

Network services must be defined in [NetServices], network protocols must be defined in [NetProtocols], and network adapters must be defined in [NetAdapters].

Disable

Value: network_service [...] network_protocol [...] network_adapter [...]

Disables bindings between network components in the specified path. Examples:

Disable = MS_Server MS_NetBEUI Adapter2   ; correct
Disable = Adapter1                     ; wrong
Disable = Adapter2, MS_TCPIP               ; wrong

Enable

Value: network_service [...] network_protocol [...] network_adapter [...]

Enables bindings between components in the specified path. If a single component is specified as the path, all bindings to it are enabled.

Enable = MS_Server MS_NetBT MS_TCPIP Adapter1

Demote

Value: network_service [...] network_protocol [...] network_adapter [...]

Demotes the specified binding path/order to the bottom of the list of binding paths that start with the first specified network component.

Demote = MS_Server MS_NetBT MS_TCPIP Adapter1


[NetClients] (Unattend.txt)

banner

[NetClients]

This section specifies the network clients to be installed.

network_client_name

Value: client_entries_section

Specifies the section where entries for a network client are defined. The network client name must be included in the following table. The table describes each client and the components that are automatically installed with it.

MS_MSClient = params.MS_MSClient
Client ID | Description | Component installed
MS_MSClient | Client for Microsoft Networks, which represents MS_Browser, MS_Workstation, MS_RPC | MS_NetBIOS
MS_NWClient | Client for NetWare Networks |

Important

  • NetWare client is supported by Windows XP Professional and the Windows 2000 Server family of products, but it is not supported by Windows XP Home Edition.


[NetOptionalComponents] (Unattend.txt)

banner

[NetOptionalComponents]

This section contains a list of the optional network components to install. Each component listed in this section uses the same values 1 or 0 where:

1
Installs the component during the unattended Setup.
0
Ignores the component during the unattended Setup.

ACS

Value: 0 | 1

Specifies that QoS Admission Control Service be installed on the computer.

This entry and its value are valid only for the Windows 2000 Server family of operating systems.

DHCPServer

Value: 0 | 1

Specifies that the Dynamic Host Configuration Protocol (DHCP) server be installed on the computer.

This entry and its value are valid only for the Windows 2000 Server family of operating systems.

DNS

Value: 0 | 1

Specifies that DNS be installed on the computer.

This entry and its value are valid only for the Windows 2000 Server family of operating systems.

IAS

Value: 0 | 1

Installs the Internet Authentication Services (IAS) and creates a shortcut to the IAS Microsoft Management Console (MMC) snap-in under the Administrative Tools section of the Start menu.

This entry and its value are valid only for the Windows 2000 Server family of operating systems.

ILS

Value: 0 | 1

Specifies that the Internet Location Service (ILS) be installed on the computer.

This entry requires that iis_common, iis_inetmgr, iis_www, and com are all installed.

This entry and its value are valid only for the Windows 2000 Server family of operating systems.

LPDSVC

Value: 0 | 1

Specifies that Print Services for UNIX be installed on the computer.

MacPrint

Value: 0 | 1

Specifies that Print Server Services for Macintosh be installed on the computer.

This entry and its value are valid only for the Windows 2000 Server family of operating systems.

MacSrv

Value: 0 | 1

Specifies that Services for Macintosh (SFM) be installed on the computer.

This entry and its value are valid only for the Windows 2000 Server family of operating systems.

Netcm

Value: 0 | 1

Installs the Microsoft Connection Manager Administration Kit and Phone Book Service.

This entry and its value are valid only for the Windows 2000 Server family of operating systems.

This entry requires that iis_common, iis_ftp, iis_inetmgr, and iis_www are all installed.

NETMONTOOLS

Value: 0 | 1

Specifies that Network Monitor tools be installed on the computer.

This entry and its value are valid only for the Windows 2000 Server family of operating systems.

SimpTcp

Value: 0 | 1

Specifies that Simple TCP/IP Services be installed on the computer.

SNMP

Value: 0 | 1

Specifies that Simple Network Management Protocol (SNMP) be installed on the computer.

WINS

Value: 0 | 1

Specifies that Windows Internet Name Service (WINS) be installed on the computer.

This entry and its value are valid only for the Windows 2000 Server family of operating systems.


[NetProtocols] (Unattend.txt)

banner

[NetProtocols]

This section specifies the network protocols to install.

protocol_name

Value: protocol_entries_section

Specifies the section where entries of this protocol are defined. The protocol name must be selected from the Protocol ID column of the following table. This table describes each protocol and the components that are automatically installed with it.

MS_TCPIP = params.TCPIP

Important

  • The IPX protocol is valid only on 32-bit platforms.
Protocol ID | Description | Components installed
MS_TCPIP | Transmission Control Protocol/Internet Protocol (TCP/IP) | MS_NetBT
MS_NWIPX | Internetwork Packet Exchange (IPX) Protocol | MS_Nwipx, MS_Nwnb
MS_PPTP | Point-to-Point Tunneling Protocol (PTPP) |
MS_L2TP | L2TP (Layer 2 Tunneling Protocol) |
MS_AppleTalk | AppleTalk Protocol |
MS_NetMon | Network Monitor Agent |
MS_ATMLANE | ATM LAN Emulation Client |
MS_ATMUni | ATM Call Manager Protocol |
MS_ATMArps | ATM ARP Server Protocol |


[NetServices] (Unattend.txt)

banner

[NetServices]

This section contains the network services to be installed.

network_service_name

Value: service_entries_section

Specifies the section where entries for a network service are defined.

MS_Server = params.MS_Server

The network service name must be selected from the Service ID column in the following table. The table describes each client and the components that are automatically installed with it.

Service ID | Description
MS_Server | File and Print Services
MS_RasSrv | Dial-Up Server
MS_PSched | QoS Packet Scheduler
MS_NwSapAgent | SAP Agent
MS_WLBS | Network Load Balancing (formerly known as Windows Load Balancing Service)


[Networking] (Unattend.txt, Sysprep.inf)

banner

[Networking]

This section is used in both Unattend.txt and Sysprep.inf. This section heading is required for configuring network protocols in unattended Setup or using Sysprep. However, no entries are required within the section.

This section has no entries.

In addition to including the [Networking] section name in your answer file, you must also include one or more of the following sections:

  • [Networking]
  • [Identification]
  • [NetServices]
  • [MS_NwSapAgent parameters]
  • [MS_Psched parameters]
  • [MS_RAS parameters]
  • [MS_RasSrv parameters]
  • [MS_Server parameters]
  • [MS_WLBS parameters]
  • [NetAdapters]
  • [NetProtocols]
  • [params.adapter instance]
  • [protocol parameters section]
  • [adapter_specific_protocol_section]
  • [NetBindings]
  • [MS_AppleTalk parameters]
  • [MS_ATMArps parameters]
  • [MS_ATMLANE parameters]
  • [MS_ATMUni parameters]
  • [MS_L2TP parameters]
  • [MS_NetMon parameters]
  • [MS_PPTP parameters]
  • [MS_TCPIP parameters]
  • [NetOptionalComponents]
  • [NetClients]
  • [MS_MSClient parameters]
  • [MS_NWClient parameters]
  • [MS_NWIPX parameters]


[OEMBootFiles] (Unattend.txt)

banner

[OEMBootFiles]

Specifies OEM-supplied boot files. This entry is valid only if OemPreinstall = Yes and the files listed here have been placed in the \$OEM$\Textmode folder of the OEM’s distribution share point.

This section is necessary if you are using ComputerType in either the [Unattended] or [MassStorageDrivers] sections of Unattend.txt.

HAL_file_name

Maps to a hardware abstraction layer (HAL) description that has been defined by the ComputerType entry in the [Unattended] section of the Unattend.txt file.

SCSI_driver_file_name

Maps to a mass-storage device driver description defined in the [MassStorageDrivers] section of the Unattend.txt file. There can be multiple instances of SCSI_driver_file_name listed in the [OEMBootFiles] section.

TxtSetup.oem

This file contains descriptions of all the OEM-supplied drivers listed in this section and includes instructions on how to install them. This file must exist if the Unattend.txt file contains an [OEMBootFiles] section.

If your mass-storage device is a Plug and Play device, verify that a Hardware Identification section and a reference to the catalog file for the driver (<Driver>.cat) exist in the Txtsetup.oem file.

If the Hardware Identification section does not exist, you must add [HardwareIds.scsi.yyyyy] to the Txtsetup.oem file and verify that the following information is included:

id = "xxxxx", "yyyyy"

where xxxxx represents the device ID, and yyyyy represents the service associated with the device.

For more information about Txtsetup.oem, see the Microsoft Windows Driver Development Kit at:
http://www.microsoft.com/ddk/


[OsChooser] (Unattend.txt)

banner

[OsChooser]

This section is used only by clients installed with access to Remote Installation Service (RIS). In general, the RIS administration tools generate this entry.

Description

Value: string

Specifies the description of the operating system image. This text appears on the client computer within the Client Installation Wizard (CIW).

Help

Value: string

When end users select the operating system description within the CIW, the Help topic is displayed. The Help topic provides a more detailed formal description of the operating system image.

ImageType

Value: Flat | Sysprep

Specifies the type of operating system image. RIS supports either a flat CD-ROM-based image or a Sysprep image created using the Remote Installer Preparation (RIPrep) wizard.

Flat
Supports a flat CD-ROM-based image.
Sysprep
Supports a Sysprep image created using the RIPrep wizard.

LaunchFile

Value: path_and_file_name

Specifies the file to be executed when the end user selects an operating system image from within the CIW. This path is automatically defined when using RIS to install an operating system on a client computer from within the CIW. Use this option to execute preboot maintenance and troubleshooting tools for use with RIS. LaunchFile accepts either a literal path or a relative path to the executable file.

Literal Path:

Setup\English\Tools\VendorName\i386\Vendortool.bin

Relative Path:

%Installpath%\%MachineType%\Vendortool.bin

Version

Value: string

Specifies the version of the operating system or tool being executed when the end user selects an image from within the CIW.


[params.adapter instance] (Unattend.txt)

banner

[params.adapter instance]

This section describes the entries of a particular adapter’s instance on a computer.

To create an unattended answer file for identical computers with the same hardware configurations, including the same type of network adapters in the same PCI slots:

  1. Install Windows on one of the computers.
  2. View each network adapter’s properties on the General tab in Device Manager and make a note of the PCI location information.
  3. This information (PCI Bus, Device, and Function numbers) is written in the Unattend.txt file specified later in this document.
  4. The file is now ready to install the operating system on the other computers.

The PCI location information is composed of three entries: PCIBusNumber, PCIDeviceNumber, and PCIFunctionNumber. All of these entries must be used to ensure that the networking settings are applied based on the PCI location.

If only different adapters are on the computers (that is, the Plug and Play IDs are not the same), the answer file can use the explicit Plug and Play IDs of each adapter instead of PCI location information.

Adding devices after the operating system is installed can cause bus numbers to change. As a result, the Unattend.txt file might not work on other computers. If only different adapters are on the computers (that is, the Plug and Play IDs are not the same), the unattended file can use the explicit Plug and Play IDs of each adapter instead of the PCI location information.

ConnectionName

Value: "network_connection_name"

Specifies the name for the network connection associated with the network adapter to install. If this entry is not specified or its value is empty, the default connection name of "Local Area Connection" is used for the first enumerated network adapter and "Local Area Connection x" is used for subsequent adapters where x starts from 2.

ConnectionName = "Corporate Network"

DMA

Value: DMA_channel_number

Specifies the direct memory access (DMA) channel setting of a network adapter.

DMA = 1

DoNotDetectLegacyCards

Value: InfID[, InfID, …]

Specifies legacy (non-Plug and Play) adapters that Setup can ignore when trying to detect the network adapters on a computer. These cards are not detected and/or installed on the computer.

DoNotDetectLegacyCards = *PNP030b,*PNP8132

This entry does not prevent Plug and Play adapters from being enumerated and installed.

Important

  • The remaining entries in this section are optional and are only meaningful for non-Plug and Play adapters that require resources to be explicitly specified.

InfID

Value: PnP_ID_of_adapter

This entry uniquely identifies a network adapter. Its value is the same as the adapter’s Plug and Play ID.

If InfID = *, Setup matches the first enumerated/detected network adapter on the computer with the settings in this section. Therefore, on a computer with a single network card, you can specify adapter-specific entries without knowing the name or type of the network adapter.

InfID = *PNP030b

For computers with more than one network adapter, the correct Plug and Play ID of each adapter must be specified. For computers with multiple adapters of the same type (that is, the Plug and Play ID for each is the same), the NetCardAddress or PCI location information must be specified. If neither NetCardAddress nor PCI location is specified, only the first adapter enumerated/detected that matches the InfID receives the answer file entries.

If NetCardAddress or PCI location is specified, this entry is not used because it is the least specific entry that can be provided.

IOAddr

Value: numeric_IO_address

Specifies the IO address (hexadecimal number) of a network adapter.

IOAddr = 330

IRQ

Value: IRQ_number

Specifies the interrupt number setting of a network adapter.

IRQ = 5

MEM

Value: memory_range

Specifies the memory base address setting of a network adapter.

MEM = 0xC123456

NetCardAddress

Value: network_card_MAC_address

Specifies the media access control address for the network adapter being configured during unattended Setup. This entry is required when installing multiple network cards of the same type (with the same Plug and Play ID) on a computer and nondefault entries need to be applied to the adapters.

NetCardAddress = 0x123456789AB

This entry is not required for PCI adapters if the PCI location information is specified.

PCIBusNumber

Value: PCI_bus_number_of_adapter

Indicates the PCI bus on which the network card resides. This entry is one of the three entries that are required to specify the PCI location information. PCIDeviceNumber and PCIFunctionNumber must also be specified.

These PCI location entries are required if:

  • NetCardAddress is not specified.
  • Multiple network cards of the same type (with the same Plug and Play ID) are installed on a computer.
  • Nondefault entries need to be applied to the adapter.
PCIBusNumber = 0
PCIDeviceNumber = 11
PCIFunctionNumber = 0

If NetCardAddress is specified, the PCIBusNumber, PCIDeviceNumber, and PCIFunctionNumber entries are not used, because NetCardAddress provides more specific information than the PCI location information.

PCIDeviceNumber

Value: PCI_device_number_of_adapter

Indicates the PCI device number for the network card and approximately relates to the particular slot number in which the network card resides on the given PCI bus. This entry is one of the three entries that are required to specify the PCI location information. PCIBusNumber and PCIFunctionNumber must also be specified.

These PCI location entries are required if:

  • NetCardAddress is not specified.
  • Multiple network cards of the same type (with the same Plug and Play ID) are installed on a computer.
  • Nondefault entries need to be applied to the adapter.
PCIBusNumber = 0
PCIDeviceNumber = 11
PCIFunctionNumber = 0

If NetCardAddress is specified, the PCIBusNumber, PCIDeviceNumber, and PCIFunctionNumber entries are not used, because NetCardAddress provides more specific information than the PCI location information.

PCIFunctionNumber

Value: PCI_function_number_of_adapter

Defines which function on the card provides the networking function; for example, if there is a combination modem/network card. The function number begins with 0. This entry is one of the three entries that are required to specify the PCI location information for the network adapter being configured during unattended Setup. PCIBusNumber and PCIDeviceNumber must also be specified.

These PCI location entries are required if:

  • NetCardAddress is not specified.
  • Multiple network cards of the same type (with the same Plug and Play ID) are installed on a computer.
  • Nondefault entries need to be applied to the adapter.
PCIBusNumber = 0
PCIDeviceNumber = 11
PCIFunctionNumber = 0

If NetCardAddress is specified, the PCIBusNumber, PCIDeviceNumber, and PCIFunctionNumber entries are not used, because NetCardAddress provides more specific information than the PCI location information.


[protocol parameters section] (Unattend.txt)

banner

[protocol parameters section]

This section contains parameters for the protocol specified by the protocol name entry specified in the [NetProtocols] section.

AdapterSections

Value: section name[,section name, ...]

Specifies a list of sections that contain device-specific network protocol parameters. Each of the adapter sections listed here has a SpecificTo value specified. The value of the SpecificTo entry is the name of a network adapter defined in the [NetAdapters] section.

AdapterSections = params.TCPIP.Adapter1, params.TCPIP.Adapter2

For more information, see SpecificTo.


[PCHealth] (Unattend.txt)

banner

[PCHealth]

This section is used to configure error reporting, remote assistance, and Help and Support Center.

Display

Value: 0 | 1
Default: 1
Registry subkey: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\
PCHealth\HelpCtr\SAF\Channels\Microsoft\Display

Specifies whether Microsoft Assisted Support is present in Help and Support Center.

0
Microsoft Assisted Support is not present on the Support page in Help and Support Center.
1
Microsoft Assisted Support is present on the Support page and in the taxonomy in Help and Support Center.

Important

  • If you are an OEM, do not set Display equal to 1.

ER_Display_UI

Value: 0 | 1
Registry subkey: HKEY_CURRENT_USER\Software\Microsoft\
PCHealth\ErrorReporting\ShowUI

Specifies whether the end user is notified that an error has occurred and is given access to details about the error. If ER_Enable_Reporting is enabled, the end user is also given the choice of whether to report the error. If ER_Enable_Reporting is disabled and ER_Display_UI is enabled, the end user is not able to report errors. If ER_Display_UI is disabled and ER_Enable_Reporting is enabled, the errors are automatically reported. The end user is not notified that an error has occurred.

0
The error notification user interface is not displayed.
1
The error notification user interface is displayed.

Note

  • For servers that do not have interactive users, consider disabling ER_Display_UI.

ER_Enable_Applications

Value: All | Listed | None
Registry subkey: HKEY_CURRENT_USER\Software\Microsoft\
PCHealth\ErrorReporting\AllOrNone

Specifies whether Windows reports errors that occur in applications.

All
Errors are reported for all applications except for those listed in ER_Exclude_EXE(n).
Listed
Errors are reported only for those applications listed in ER_Include_EXE(n) and Microsoft applications when ER_Include_MSapps is enabled.
None
No application errors are reported.

Controls whether to report errors in applications when ER_Enable_Reporting is enabled.

ER_Enable_Kernel_Errors

Value: 0 | 1
Registry subkey: HKEY_CURRENT_USER\Software\Microsoft\
PCHealth\ErrorReporting\IncludeKernelFaults

Specifies whether Windows reports errors in the Windows kernel.

0
Errors in the Windows kernel are not reported.
1
Errors in the Windows kernel are reported when ER_Enable_Reporting is enabled.

ER_Enable_Reporting

Value: 0 | 1
Registry subkey: HKEY_CURRENT_USER\Software\Microsoft\
PCHealth\ErrorReporting\DoReport

Specifies whether Windows automatically reports errors.

0
Errors are not reported.
1
Errors are reported as configured in ER_Report_Path.

Controls whether errors are reported. If ER_Enable_Reporting is disabled and ER_Display_UI is enabled, the end user is not able to report errors.

ER_Enable_Windows_Components

Value: 0 | 1
Registry subkey: HKEY_CURRENT_USER\Software\Microsoft\
PCHealth\ErrorReporting\IncludeWindowsApps

Specifies whether errors in Windows applications are reported.

0
Errors in Windows components are not reported.
1
Errors in Windows components are reported when ER_Enable_Reporting is enabled.

When ER_Enable_Reporting is enabled, errors are reported for the components that are part of Windows XP and Windows 2000 Server family of operating systems. To exclude individual Windows components, use ER_Exclude_EXE(n).

ER_Exclude_EXE(n)

Value: executable_filename
Registry subkey: HKEY_CURRENT_USER\Software\Microsoft\
PCHealth\ErrorReporting\ExclusionList

Specifies a particular application for which Windows does not report any errors, if they occur.

executable_filename
The filename of a Windows component or application to be excluded from error reporting.

Only used if ER_Enable_Windows_Components is enabled or if ER_Enable_Applications = All.

ER_Exclude_EXE1 = notepad.exe
ER_Exclude_EXE2 = explorer.exe
ER_Exclude_EXE3 = iexplore.exe

ER_Include_EXE(n)

Value: executable_filename
Registry subkey: HKEY_CURRENT_USER\Software\Microsoft\
PCHealth\ErrorReporting\InclusionList

Specifies whether the file name of the application causing the error is included in the error report.

executable_filename
The file name of an application to be included in error reporting.

Only used if the value of ER_Enable_Applications is Listed. Microsoft applications can be automatically included by using ER_Include_MSApps.

ER_Include_EXE1 = notepad.exe
ER_Include_EXE2 = explorer.exe
ER_Include_EXE3 = iexplore.exe

ER_Include_MSApps

Value: 0 | 1
Registry subkey: HKEY_CURRENT_USER\Software\Microsoft\
PCHealth\ErrorReporting\IncludeMicrosoftApps

Specifies whether errors in Microsoft applications are tracked and reported.

0
Errors in Microsoft applications are not reported.
1
Errors in Microsoft applications are reported when ER_Enable_Reporting is enabled.

When ER_Enable_Reporting is enabled and the value of ER_Enable_Applications is Listed, errors are reported for all Microsoft applications.

ER_Report_Path

Value: local_or_UNC_path
Registry subkey: HKEY_CURRENT_USER\Software\Microsoft\
PCHealth\ErrorReporting\InclusionList

Specifies the location where Windows saves error reports.

local_or_UNC_path
The valid local or Universal Naming Convention (UNC) path where error reports are saved when ER_Enable_Reporting is enabled.

If this entry is not present, error reports are sent directly to Microsoft by default.

Headlines

Value: 0 | 1
Default: 1
Registry subkey: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\
PCHealth\HelpSvc\Headlines

Specifies whether headlines are displayed in Help and Support Center.

0
Headlines are not displayed on Help and Support Center home page.
1
Headlines are displayed on Help and Support Center home page.

Note

  • Help and Support only updates the headlines when an Internet connection is already established on the computer. Even if Headlines = 1, Help and Support Center does not force or prompt the end user to connect to the Internet.

RA_AllowFullControl

Value: 0 | 1
Default: 1
Registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\
Control\TerminalServer\fAllowFullControl

Specifies if a person (other than the end user of the computer) can take full control of the computer from a separate location. The helper must ask the end user for explicit permission to take control; the end user can accept or decline such requests. Only valid if RA_AllowToGetHelp is 1. if RA_AllowToGetHelp is 0, the value of RA_AllowFullControl is ignored.

0
Remote helper can view the end user's desktop but cannot take control of the end user's computer.
1
Remote helper can ask to take control of the end user's computer and the end user can grant this request.

RA_AllowToGetHelp

Value: 0 | 1
Default: 1
Registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\
Control\TerminalServer\fAllowToGetHelp

Specifies if another person can view and share the control of the end user's desktop from a separate location, using Terminal Services, so that person can more easily assist the end user with a technical problem.

End users may request remote assistance by escalating a support request to OEM product support from Help and Support Center. End users may also request remote assistance from a friend using MSN® Messenger or e-mail.

0
Remote assistance is not enabled.
1
Remote assistance is enabled.

RA_AllowUnsolicited

Value: 0 | 1
Default: 0
Registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\
Control\TerminalServer\fAllowUnsolicited

Specifies if Unsolicited Remote Assistance is enabled. With unsolicited remote assistance, another person within the corporate local area network (LAN) who has Administrator-level access to the computer (or one who has a user account with the appropriate level of permissions) may request access to the computer for management or troubleshooting purposes. The end user can accept or decline such requests.

0
Unsolicited remote assistance is not enabled.
1
Unsolicited remote assistance is enabled.

RA_MaxTicketExpiry

Value: time_in_seconds
Default: 2,592,000 seconds (30 days)
Registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\
Control\TerminalServer\fMaxTicketExpiry

Specifies the time, in seconds, after which a remote assistance invitation expires.

time_in_seconds
The time, in seconds, after which a remote assistance ticket expires.


[Proxy] (Unattend.txt)

banner

[Proxy]

This section contains proxy server settings for the Windows XP or Windows 2000 Server family browser. If these settings are not present, the default for Windows XP or Windows 2000 Server is used.

Important

  • To make sure your [Proxy] settings take effect, you need to include the [Branding] section header and the BrandIEUsingUnattended entry in the answer file to enable the following browser-related settings:
    [Branding]
BrandIEUsingUnattended = Yes
  • In the [Unattended] section, if AutoActivate is Yes and ActivateProxy is Proxy, Windows Product Activation (WPA) attempts to activate this installation of Windows XP using the proxy settings specified in this section.

    If ActivateProxy is a value other than Proxy, WPA uses the proxy settings specified in [section_name] in the Unattend.txt file. The entries in [section_name] must match the syntax specified for the [Proxy] section.

FTP_Proxy_Server

Value: URL_or_IP_address

Specifies the Internet Protocol (IP) address or URL of the FTP proxy server on the network.

FTP_Proxy_Server = http://proxyserver:80

Gopher_Proxy_Server

Value: URL_or_IP_address

Specifies the IP address or URL of the Gopher proxy server on the network.

Gopher_Proxy_Server = http://proxyserver:80

HTTP_Proxy_Server

Value: URL_or_IP_address

Specifies the IP address or URL of the HTTP proxy server on the network. This pararameter is required if you are using Use_Same_Proxy.

HTTP_Proxy_Server = http://proxyserver:80

Proxy_Enable

Value: 0 | 1

Registry subkey: HKEY_CURRENT_USER\Software\Microsoft\Windows\
CurrentVersion\Internet Settings\ProxyEnable

Specifies whether a proxy server is used to connect to the Internet. A value of 1 is Yes and 0 is No.

Proxy_Override

Value: list_of_IP_addresses

Registry subkey: HKEY_CURRENT_USER\Software\Microsoft\Windows\
CurrentVersion\Internet Settings\ProxyOverride

Specifies a semicolon-separated list of IP addresses to be used to bypass the proxy server. The list must be enclosed in quotation marks (for more than one address) and can contain the string local to override local addresses.

Proxy_Override = local

Secure_Proxy_Server

Value: URL_or_IP_address

Specifies the IP address or URL of the Secure proxy on the network.

Secure_Proxy_Server = http://proxyserver:80

Socks_Proxy_Server

Value: URL_or_IP_address

Specifies the IP address or URL of the Socks proxy on the network.

Socks_Proxy_Server = http://proxyserver:80

Use_Same_Proxy

Value: 0 | 1

Specifies whether the same proxy server is used for all protocols. A value of 1 is Yes and 0 is No. If this entry is specified, all other transports use the HTTP proxy server.


[RegionalSettings] (Unattend.txt, Sysprep.inf)

banner

[RegionalSettings]

This optional section is used in both Unattend.txt and Sysprep.inf.

Using [RegionalSettings] in Unattend.txt

If you include [RegionalSettings] in Unattend.txt, you must also use the /copysource:lang command-line option of Winnt32.exe so that Setup copies the appropriate language files to the hard disk. The command winnt32 /copysource:lang copies all the files in the PRODUCT:\i386\Lang folder to MASTER:\%windir%\Lang.

Important

  • Any settings specified in the [RegionalSettings] section in Unattend.txt are not maintained if Sysprep is run on the computer, unless the corresponding settings are also specified in Sysprep.inf.

If you set OemPreinstall to Yes in the [Unattended] section of Unattend.txt to Yes and do not provide values for the [RegionalSettings] section, set OEMSkipRegional to 1 in the [GuiUnattended] section of Unattend.txt or in the [GuiUnattended] section of Sysprep.inf to ensure Setup completes without prompting for regional option information. However, do not distribute computers that:

  • Do not have the regional, language, and keyboard settings preconfigured;

    — or —

  • Do not have the Regional and Language Options page enabled during the end user's first-run experience.

Using [RegionalSettings] in Sysprep.inf

To use [RegionalSettings] in Sysprep.inf, all language files must already be available on the computer's hard disk. Specify the location of the files using InstallFilesPath in the [Unattended] section of Sysprep.inf.

InputLocale_DefaultUser

Value: locale_ID:keyboard_layout_ID

Specifies the input locale and keyboard layout combination for the default user. The specified combination must be supported by one of the language groups defined by using the LanguageGroup entry, or by the default language group for the language version of Windows. The keyboard must be defined in the KeyboardLayout entry in the [Unattended] section of Unattend.txt.

For a list of valid locale ID and keyboard layout combinations, visit the Microsoft Global Software Development Web site at http://www.microsoft.com/globaldev/.

UserLocale_DefaultUser

Value: locale_ID

Specifies the input locale and keyboard layout combinations to be installed. The first keyboard layout specified is the default layout for the installation. The specified combinations must be supported by one of the language groups defined by using the LanguageGroup entry, or by the default language group for the language version of Windows. If an available language group does not support the combination specified, the default combination is used for the installation.

The keyboard must be defined in the KeyboardLayout entry in the [Unattended] section of Unattend.txt.

This entry is ignored if the Language entry is specified.

InputLocale

Value: locale_ID:keyboard layout ID[, locale_ID:keyboard_layout_ID][, ...]

Specifies the input locale and keyboard layout combinations to be installed. The first keyboard layout specified is the default layout for the installation. The specified combinations must be supported by one of the language groups defined by using the LanguageGroup entry, or by the default language group for the language version of Windows. If an available language group does not support the combination specified, the default combination is used for the installation. This entry is ignored if the Language entry is specified.

For a list of valid locale ID and keyboard layout combinations, visit the Microsoft Global Software Development Web site at http://www.microsoft.com/globaldev/.

Language

Value: locale_ID

Specifies the language/locale to be installed. This language must be supported by one of the language groups specified by using the LanguageGroup entry. If an available language group does not support the locale, Setup uses the default language for this version of Windows.

Important

  • If this entry is specified, the SystemLocale, UserLocale, and InputLocale entries are ignored.

For a list of valid locales and their language groups, visit the Microsoft Global Software Development Web site at http://www.microsoft.com/globaldev/.

LanguageGroup

Value: language_group_ID[, language_group_ID[, ...]]

Specifies the language group for this installation. You cannot specify a particular locale or language unless the appropriate language group is installed.

In Windows XP, if support for one language group is installed, then support for all corresponding language groups is also installed. For example, if you install one language group from the set of East Asian Languages language groups, then support for the associated language groups is also installed. If you install one language group from the set of complex script language groups, then all complex script language groups are installed.

The supported language group IDs are listed in the following table.

ID | Language Group | Corresponding Value in Regional and Language Options Control Panel
1 | Western Europe and United States | Installed by Default
2 | Central Europe | Installed by Default
3 | Baltic | Installed by Default
4 | Greek | Installed by Default
5 | Cyrillic | Installed by Default
6 | Turkic | Installed by Default
7 | Japanese | East Asian Language
8 | Korean | East Asian Language
9 | Traditional Chinese | East Asian Language
10 | Simplified Chinese | East Asian Language
11 | Thai | Complex Script
12 | Hebrew | Complex Script
13 | Arabic | Complex Script
14 | Vietnamese | Complex Script
15 | Indic | Complex Script
16 | Georgian | Complex Script
17 | Armenian | Complex Script

For a list of specific languages that correspond to particular language groups, see the Microsoft Global Software Development Web site at http://www.microsoft.com/globaldev/.

SystemLocale

Value: locale_ID

Specifies the system locale to be installed. The system locale enables localized applications to run and display menus and dialog boxes in their native language. The specified system locale must be supported by one of the language groups specified by using the LanguageGroup entry, or by the default language group for the language version of Windows. If an available language group does not support the locale specified, the default system locale is installed. This entry is ignored if the Language entry is specified.

UserLocale

Value: locale_ID

Specifies the user locale to be installed. The user locale controls the settings for numbers, time, currency, and dates. The specified user locale must be supported by one of the language groups specified by using the LanguageGroup entry, or by the default language group for the language version of Windows. If an available language group does not support the locale specified, the default user locale is installed. This entry is ignored if the Language entry is specified.


[RemoteInstall] (Unattend.txt)

banner

[RemoteInstall]

This section is used only by clients installed by the Remote Installation Service (RIS). The RIS administration tools generate these entries.

Repartition

Value: Yes | No

Specifies whether to delete all partitions on the first drive on the client computer and reformat it with the NTFS file system.

You cannot run unattended Setup on a disk that does not contain a file system. Make sure that your destination disk is formatted with a file system.

Yes
Delete all partitions on the first drive on the client computer and reformat it with the NTFS file system.
No
Use the default entries in the answer file.

UseWholeDisk

Value: Yes | No
Default: Yes

Valid only for RIPrep (Remote Installer Preparation) images.

Yes
Extends the volume to the end of the drive.
No
Stops Setup from extending the volume to the end of the drive.


[Shell] (Unattend.txt)

banner

[Shell]

This is the [Shell] section for Unattend.txt. For the values in Winbom.ini, see [Shell] (Winbom.ini).

CustomDefaultThemeFile

Value: path_and_file_name
Default: none

Specifies the complete path to a .theme file. Windows XP uses the visual style defined in this file rather than its default visual style.

Enclose path_and_file_name in quotes if it is a long file name. If path_and_file_name contains the environment variable %windir%, you must follow %windir% with a backward slash character.

If the value of DefaultThemesOff is Yes, Windows XP uses the classic Windows visual style.

DefaultStartPanelOff

Value: Yes | No
Default: No

Uses the classic Windows Start menu instead of the Windows XP Start menu. Icons for My Computer and My Documents are displayed on the Windows desktop.

DefaultThemesOff

Value: Yes | No
Default: No

Uses the classic Windows visual style instead of the default Windows XP visual style.


[SNMP] (Unattend.txt)

banner

[SNMP]

This section contains the entries for the Simple Network Management Protocol (SNMP) service.

Accept_CommunityName

Value: community_name:privilege, ...
Default: public:Read_Only

Defines the community names from which the computer running the Simple Network Management Protocol (SNMP) service can accept traps. Each community name must have a privilege associated with it. Valid privileges are: None, Notify, Read_Only, Read_Write, and Read_Create.

If no privilege is assigned to a community name, the default of Read_Only is applied. Commas separate community names.

Any_Host

Value: Yes | No

Specifies whether the computer on which the SNMP service is installed accepts SNMP packets from any host.

Yes
Accepts SNMP packets from any host.
No
Does not accept SNMP packets from any host.

Community_Name

Value: community_name

Indicates the community name for the computer. Enclose community_name in quotes.

Contact_Name

Value: name

Specifies the contact name for this managed node, as well as information about how to contact this person. Enclose name in quotes.

Limit_Host

Value: host_name[, host_name][, host_name]

Specifies a maximum of three host names separated by commas. This entry is valid if the value of Any_Host is No.

Location

Location

Value: location

Specifies the physical location of the computer. Enclose location in quotes.

Send_Authentication

Send_Authentication

Value: Yes | No

Indicates whether an authentication trap is sent when an unauthorized community or host requests information.

Yes
Sends an authentication trap when an unauthorized community or host requests information.
No
Does not send an authentication trap when an unauthorized community or host requests information.

Service

Value: Physical, Applications, Datalink, Internet, End-to-End
Default: Applications, Internet, End-to-End

Any combination of the five SNMP services listed here can be specified as values. Commas must separate these values.

Traps

Value: IP addresses | IPX addresses

Specifies a maximum of three Internet Protocol (IP) or Internetwork Packet Exchange (IPX) addresses to which traps are sent.

For the values specified in the Traps entry to take effect, a valid value must be specified in the Community_Name entry.

Important

  • The IPX protocol is valid only on 32-bit platforms.


[SystemFileProtection] (Unattend.txt)

banner

[SystemFileProtection]

In Windows XP, a new feature, called Windows File Protection (WFP) (formerly, System File Protection), prevents the replacement of certain monitored or protected system files. By preventing the replacement of essential system files, file version mismatches can be avoided. WFP runs in the background on a Windows XP system. All .sys, .dll, .exe, and .ocx files that ship on the Windows XP CD are protected. TrueType fonts Micros.ttf, Tahoma.ttf, and Tahomabd.ttf are also protected.

Note

  • In earlier prerelease versions of Windows XP, WFP was known as System File Checker. This nomenclature is maintained for the entry naming conventions.

WFP is activated when:

  • Attempts to replace a protected system file are made.
  • Attempts to change a protected folder or a file in a protected folder are made. (WFP then determines which file was changed.)

Windows File Protection (WFP) also maintains version control of protected files. It looks up the file signature in a catalog file to determine if the new file is the correct Microsoft version. If the new file is not the correct Microsoft version, WFP looks for the replaced files by searching for them in the following order:

  1. The Dllcache folder.
  2. The network install path (if the system was installed via network install).
  3. The product CD.

The following entries are used by the Windows File Protection (WFP) service. If this section is missing or empty, Setup installs WFP using default values.

SFCDllCacheDir

Value: location of Dllcache folder
Default: %systemroot%\%windir%\System32\Dllcache

Specifies the folder that is used by Windows File Protection (WFP) to cache the system files (the \Dllcache folder location). This path must be a local path. Environment variables are also allowed for this entry.

SFCDllCacheDir = %systemroot%\Windows\System32\Dllcache

Important

  • Quotation marks are required around the value you provide.

SFCShowProgress

Value: 0 | 1
Default: 0

Specifies whether System File Checker displays a progress meter during scans.

0
Does not display progress meter during file system scans.
1
Displays progress meter during file system scans.

SFCQuota

Value: size in MB (hexadecimal)
Default: 0xFFFFFFFF

Specifies the size of the Dllcache file cache stored on the system hard disk. If 0xFFFFFFFF is specified, all system files are cached in the Dllcache folder.

SFCQuota = FFFFFFFF


[SystemRestore] (Unattend.txt)

banner

[SystemRestore]

This section contains the entries for the System Restore feature.

CheckpointCalendarFrequency

Value: days
Registry entry: HKEY_LM\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\
SystemRestore\RPGlobalInterval
Default: 1

days
An integer. The calendar frequency with which automatic system checkpoints or restore points are created.

This entry is calculated based on the time since the last restore point. CheckpointCalendarFrequency is checked before CheckpointSessionFrequency.

Setup converts this entry to its equivalent number of seconds and writes that value to the registry.

CheckpointSessionFrequency

Value: hours
Registry entry: HKEY_LM\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\
SystemRestore\RPSessionInterval
Default: 10

hours
An integer. The session length frequency after which an automatic system checkpoint or restore point is created.

This entry is calculated based on the time since the last restore point. CheckpointCalendarFrequency is checked before CheckpointSessionFrequency.

Setup converts this entry to its equivalent number of seconds and writes that value to the registry.

MaximumDataStorePercentOfDisk

Value: disk_percentage
Registry entry: HKEY_LM\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\
SystemRestore\DiskPercent
Default: 12

disk_percentage
A two-digit integer. The maximum percentage of the hard disk to use for the System Restore datastore.

If the size of the datastore is minimal, restore points might be purged before they reach the maximum age set by RestorePointLife.

RestorePointLife

Value: days
Registry entry: HKEY_LM\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\
SystemRestore\RPLifeInterval
Default: 30

days
An integer. The maximum age a restore point can be before it is automatically purged from the datastore.

Setup converts this entry to its equivalent number of seconds and writes that value to the registry.


[TapiLocation] (Unattend.txt, Sysprep.inf)

banner

[TapiLocation]

This optional section is used in both Unattend.txt and Sysprep.inf. It is valid only if a modem is present on the computer.

If you use the Sysprep.inf file with Sysprep, the modem information (Telephony API [TAPI]) and the Networking screens are not displayed during Mini-Setup. The default networking components are used if the networking components are not configured and if they are not specified in Sysprep.inf.

AreaCode

Value: area code string
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Telephony\Locations\Location1\AreaCode

Specifies the area code that the computer is located in.

CountryCode

Value: country code number
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Telephony\Locations\Location1\Country

Specifies the country code to use for telephony, such as 1 for the United States. For more information, search on the Internet for "ISO 3166" for a list of valid country or region codes, or visit the International Telecommunication Union Survey Web site at http://www.itu.int

Dialing

Value: Tone | Pulse

Specifies the type of dialing to use for the telephony device in the computer.

Tone
Specifies dialing by using a multifrequency tone, as in a push-button phone.
Pulse
Specifies dialing by transmitting pulses of electricity, as in a rotary dial phone.

LongDistanceAccess

Value: number to get outside line
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Telephony\Locations\Location1\LongDistanceAccess

Specifies the number to dial to gain access to an outside line, such as 9.


[TerminalServices] (Unattend.txt)

banner

[TerminalServices]

This section contains parameters for configuring Terminal Services features (Terminal Server and Remote Desktop) in Windows XP and Windows 2000 Server operating systems.

TerminalServer is only applicable to Windows 2000 Advanced Server; Windows 2000 Advanced Server, 64-Bit Edition; Windows 2000 Datacenter Server; and Windows 2000 Datacenter Server, 64-Bit Edition.

To install and enable Terminal Server (also called Terminal Services in Application Server mode), use the TerminalServer entry in the [Components] section. To change the permissions settings for a Terminal Server installation, use the PermissionsSetting entry in the [TerminalServices] section.

Remote Desktop (also called Terminal Services in Remote Administration mode) is always installed for editions of Windows XP and Windows 2000 Server. Remote Desktop is enabled by default for the Windows 2000 Server family of products. To disable Remote Desktop during unattended Setup, include AllowConnections with a value of 0. Remote Desktop is disabled by default on Windows XP Professional and Windows XP Home Edition. To enable Remote Desktop during unattended Setup, include AllowConnections with a value of 1.

AllowConnections

Value: 0 | 1
Default (Windows 2000 Server family): 1
Default (Windows XP Professional or Windows XP Home Edition): 0

0
Disables Remote Desktop on the computer.
1
Enables Remote Desktop during unattended Setup.

This entry configures Remote Desktop (also called Terminal Services in Remote Administration mode) to allow or disallow connections from other computers.

For Windows 2000 Server, Remote Desktop (also called Terminal Services in Remote Administration mode) is installed and enabled by default. If you specified TerminalServer = On in the [Components] section of the answer file, setting this value to 0 installs Terminal Server without enabling it.

For Windows XP Professional or Windows XP Home Edition, the Remote Desktop feature is installed by default but is not enabled.

LicensingMode

Value: PerSeat | PerSession
Default: PerSeat

PerSeat
Configures Terminal Server to require that each connected client computer has a valid Terminal Server Client Access License (CAL). If the client computer has a Terminal Server CAL, it can access more than one Terminal Server.
PerSession
Configures Terminal Server to provide one Terminal Server Client Access License (CAL) for each active client session.

Configures how Terminal Services manages its CALs.

For more information, see "Terminal Services Licensing" in Windows 2000 Server Help.

Important

  • LicensingMode is ignored unless Terminal Server is enabled. For more information, see TerminalServer in the [Components] section.

PermissionsSetting

Value: 0 | 1
Default: 0

0
Grants Terminal Server users the same permissions as Windows 2000, Windows XP, or Windows 2000 Server users.
1
Grants Terminal Server users the same permissions as Terminal Server 4.0 users.

Used by administrators to choose the security mode for Terminal Server users during terminal server sessions. By default, Terminal Server is enabled in Full Security mode, which grants Terminal Server users the same permissions as members of the User group and provides the most secure environment in which to run applications. However, some applications that have not been certified for Windows 2000, Windows XP, or Windows 2000 Server require write access to certain parts of HKLM and to certain system directories. Granting these additional permissions may allow end users to delete or change vital settings under HKLM and/or system files.

Set PermissionsSetting = 0 to install Terminal Server in Full Security mode and grant Terminal Services users the same permissions as Windows XP or Windows 2000 Server users. Note that some applications written for Windows NT 4.0 or earlier operating systems might not run correctly in this security mode.

Set PermissionsSetting = 1 to allow applications that are not certified for Windows 2000 or Windows XP to run with the same level of security as Terminal Server 4.0. End users can continue running previous application versions that might require additional user permissions. Note, however, that using this option bypasses some of the security enhancements in Windows XP and Windows 2000 Server, and grants end users access to critical registry and system file locations.

Important

  • PermissionsSetting is ignored unless Terminal Server is enabled. For more information, see TerminalServer in the [Components] section.


[UserData] (Unattend.txt, Sysprep.inf)

banner

[UserData]

This section is used in both Unattend.txt and Sysprep.inf.

ComputerName

Value: computer_name
Registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\
ComputerName\ComputerName

Specifies the computer name. If the ComputerName entry is empty or missing, the end user is prompted to enter a computer name. If the value is *, Setup generates a random computer name based on the organization name specified.

If computer_name is longer than 63 characters, the string is truncated to 63 characters.

FullName

Value: string
Registry subkey: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\
CurrentVersion\RegisteredOwner

Specifies the end user’s full name. If the entry is empty or missing, the end user is prompted to enter a name.

This entry is used to ensure that Setup is completely unattended.

OrgName

Value: string
Registry subkey: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\
CurrentVersion\RegisteredOrganization

Specifies an organization’s name.

ProductKey

Value: "xxxxx-xxxxx-xxxxx-xxxxx-xxxxx"

Specifies the Product Key for this particular installation of Windows. Each x is either an alphabetic character or a number. The quotation marks and the hyphens are required.

Important

  • A Product Key is always required.
  • This entry assigns the same Product Key to all computers where you install Windows XP or Windows 2000 Server operating systems using this Unattend.txt file.
  • Standard licensing agreements specify that you can only use a given Product Key to activate one installation of Windows XP on one computer. This requirement is enforced by Windows Product Activation (WPA).
  • If you are preinstalling Windows XP or Windows 2000 Server operating systems under a volume license agreement, consult your specific license agreement to determine the number of installations that can use a given Product Key.


[Unattended] (Unattend.txt)

This is the [Unattended] section for Unattend.txt. For the Sysprep.inf version, see [Unattended] (Sysprep.inf).

This section header identifies that Setup is run in unattended mode, where answers to the user prompts are contained within the Unattend.txt file. This section is required in the Unattend.txt file; otherwise, the answer file is ignored.

ActivateProxy

Value: section_name | Proxy
Default: <none>

Specifies the proxy settings to use when connecting to the Internet to activate this installation of Windows XP, if AutoActivate is Yes.

If section_name is Proxy, Windows Product Activation (WPA) uses the proxy settings specified in the [Proxy] section. If section_name is anything else, WPA uses the proxy settings specified in [section_name] in the Unattend.txt file. The entries in [section_name] must match the syntax specified for the [Proxy] section.

Note

  • If your network uses Web Proxy Auto-Discovery (WPAD), you may not need to explicitly set the proxy.

AutoActivate

Value: Yes | No
Default: No

Specifies whether Setup will attempt to automatically activate this installation of Windows XP through an existing Internet connection. You must specify a valid product key in the ProductKey entry in the [UserData] section. If the Internet connection is through a firewall, you may need to specify the relevant proxy settings in ActivateProxy.

Yes
Attempts to activate this installation of Windows XP during unattended setup through an existing Internet connection on the computer.
No
Requires the end user to activate Windows XP either through an Internet connection or by phone.

Important

  • A product key is always required.
  • The product key you use to activate this installation using Windows Product Activation (WPA) must match the number on the Certificate of Authenticity (COA) that accompanies the retail product or that is physically attached to the computer case by the original equipment manufacturer (OEM).
  • Standard licensing agreements specify that you can only use a given product key to activate one installation of Windows XP on one computer. This requirement is enforced by Windows Product Activation.
  • If you are using Winnt.exe to install Windows, make sure that UnattendSwitch = Yes.
  • Setting AutoActivate = Yes does not guarantee successful activation of this installation of Windows XP. For example, the activation attempt will fail if the computer cannot successfully connect to the Internet.

ComputerType

Value: HAL_description [, Retail | OEM]

Specifies the type of custom hardware abstraction layer (HAL) to be loaded by the Setup Loader and installed by text-mode Setup. This entry is valid only when the value of OemPreinstall is Yes. If the ComputerType entry is not present, Setup attempts to detect the type of computer and install the appropriate retail HAL.

The HAL_description string identifies the Hardware Abstraction Layer (HAL) to be installed. It must match one of the strings in the [Computer] section of TxtSetup.sif (for a retail HAL), or TxtSetup.oem (for an OEM HAL).

Retail
Informs Setup that the HAL to be installed is part of Windows XP or Windows 2000 Server operating systems.
OEM
Indicates that the HAL to be loaded is OEM-supplied. If this is the case, the driver name must also be listed in the [OEMBootFiles] section of the Unattend.txt file.

CrashDumpSetting

Value: 0 | 1 | 2 | 3
Default: Windows XP Home Edition and Windows XP Professional: 3; Windows 2000 Server: 1

Specifies the creation and type of the dump file. When the system fails, a dump file can be created that contains information useful for debugging. Dump file types vary by size. The system checks for available space on the boot volume and writes the largest possible dump file.

0
Do not create a dump file.
1
Complete Memory Dump: Records the entire contents of system memory to %SystemRoot%\Memory.dmp when the system stops unexpectedly. If you choose this option you must have a paging file on the boot volume large enough to hold all of the physical random access memory (RAM) plus 1 megabyte (MB).
2
Kernel Memory Dump: Records only kernel memory to %SystemRoot%\Memory.dmp when the system stops unexpectedly. This speeds up the process of recording information in a log. Depending on the amount of RAM in your computer, you must have 50 MB to 800 MB available for the paging file on the boot volume.
3
Small Memory Dump (64K): Records the smallest set of useful information that can help identify the problem to %SystemRoot%\Minidump. This option requires a paging file of at least 2 MB on the boot volume of your computer and specifies that a new file is created each time the system stops unexpectedly.

DisableDynamicUpdates

Value: Yes | No
Default: Yes

Instructs Setup not to connect to the Windows Update site to download any available Windows Setup updates or necessary drivers that were not included on the Windows CD-ROM.

DisableDynamicUpdates is equivalent to the command:

winnt32 /unattend /disabledynamicupdates

Dynamic updates are disabled by default so corporate administrators can more easily standardize on a known set of Windows system components.

Yes
Instructs Setup not to connect to the Windows Update site.
No
Instructs Setup to connect to the Windows Update site to download any available Windows XP Setup updates. Setup also downloads any necessary drivers that were not included on the Windows XP CD-ROM.

DriverSigningPolicy

Value: Ignore | Warn | Block
Default: Warn

Specifies how unsigned drivers are processed during unattended Setup. Signed drivers have gone through the Microsoft driver testing and signing process to ensure they are compatible with Windows XP and Windows 2000 Server operating systems.

Block
Setup does not install the unsigned device driver.
Warn
Setup stops the installation and prompts the end user for input before accepting the unsigned device driver.
Ignore
Setup continues even if the driver is not signed.

Important

  • Microsoft strongly advises against using DriverSigningPolicy = Ignore unless you have fully tested the device driver in your environment and are sure that it works properly. Using unsigned drivers increases the risk of device driver problems that can affect the performance or stability of the computer.
  • If you are using DriverSigningPolicy = Ignore and you attempt to install a newer, unsigned copy of a driver that distributed with Windows XP or Windows 2000 Server operating systems, Setup installs the signed Windows XP driver instead of the unsigned drivers, in accordance with the ranking process used by the operating system.
  • A catalog certificate (.cat) file authenticates a driver signature. Microsoft can only use the given certificate to sign drivers for a finite length of time, generally six months. However, as long as a driver is digitally signed with a valid certificate, the subsequent expiration date of the certificate does not affect the status of the driver. A driver signature does not expire, even after the certificate that was used to sign the driver has expired.

For more information, see:

  • Hardware Compatibility List (HCL) at the Microsoft Web site (http://www.microsoft.com/hcl/)
  • Windows Driver and Hardware Development Web site (http://www.microsoft.com/hwdev/)
  • Driver Signing for Windows Operating Systems (http://www.microsoft.com/hwdev/desinit/digitsign.htm)
  • Windows Hardware Quality Labs Web site (http://www.microsoft.com/hwtest/)

For more information about driver ranking and how Setup chooses the correct driver, see the Microsoft Device Development Kit (http://www.microsoft.com/ddk/).

ExtendOemPartition

Value: 0 | 1 | extra_size_in_MB

The ExtendOemPartition entry is used to extend the partition on which you are installing Windows. This entry causes Setup to extend this destination partition into any available unpartitioned space that physically follows it on the disk.

ExtendOemPartition automatically leaves the last cylinder on the hard disk free to allow dynamic disk support.

0
Setup does not extend the partition.
1
Setup extends the partition to fill out the hard disk.
extra_size_in_MB
Setup increases the current partition size by this amount. This is useful if you want to configure more than one partition on the hard disk.

Important

  • You can only extend NTFS file system partitions.
  • When you use ExtendOEMPartition in Sysprep.inf for imaged computers, the destination computer’s hard disk must be the same size or larger than the hard disk of the original master installation.
  • The partition that you want to extend must have unpartitioned space available following the partition.

If your manufacturing process requires FAT32, use the Oformat command-line tool included in the OEM Preinstallation Kit to format the hard disk so that it is optimally configured for NTFS. Use the Convert command-line tool to convert the file system.

You can also convert the partition during text-mode Setup by setting the FileSystem in the [Unattended] section of Unattend.txt to ConvertNTFS. FileSystem is not a valid entry in Sysprep.inf. However, the hard drive will have better performance if you use the Convert command-line tool rather than the FileSystem entry.

You can also use the ExtendPartition entry in the [ComputerSettings] section of Winbom.ini to extend the partition using the Factory tool.

FactoryMode

Value: Yes

Yes
Specifies that Windows Welcome or Mini-Setup does not delete the OPK tools from %systemdrive%\Sysprep during the next boot of the computer.

Use this entry when performing a clean install of the operating system as the first step in building a master installation, which you then plan to duplicate onto multiple destination computers. You must place the OPK tools in the %systemdrive%\Sysprep folder.

FileSystem

Value: ConvertNTFS | LeaveAlone

Specifies whether the primary partition is converted to NTFS or is left alone.

This entry is provided for backward compatibility.

If your manufacturing processes require that the hard disk first be formatted as FAT32, use the Oformat tool to create a FAT32 volume with clusters that are aligned in an optimal way for later conversion to the NTFS file system. Then use the Convert command-line tool to convert the file system to NTFS.

You can also convert the partition during text-mode Setup by setting the FileSystem entry equal to ConvertNTFS. However, the hard drive will have better performance if you use the Convert command-line tool rather than the FileSystem entry.

Note

  • If you plan to use ExtendOemPartition during Setup, the file system must be NTFS.
  • FileSystem is not a valid entry in Sysprep.inf.

ForceHALDetection

Value: Yes | No
Default: No

Instructs text-mode Setup to examine the operating system and determine the most appropriate hardware abstraction layer (HAL) to install during an upgrade.

Yes
Installs the most appropriate HAL for the new operating system.
No
Keeps the HAL used by the previous operating system.

Important

  • If ForceHALDetection=Yes during an upgrade, some user-specified hardware settings may be lost.
  • If ForceHALDetection=No during an upgrade, user-specified hardware settings are preserved.

Hibernation

Sets the hibernation option in the Power Options control panel. This setting adds Hibernate to the Shutdown menu and creates the Hiberfil.sys file.

Value: 0 | 1
Default: 0

0
Enables hibernation.
1
Disables hibernation.

Notes

  • To keep the size of your image file as small as possible, you may delete the hibernation file (Hiberfil.sys), if it exists, from your master installation.
  • The Hiberfil.sys file that is created during hibernation mode is as large as the available random access memory (RAM) on the computer. Before beginning hibernation mode, verify that the amount of free disk space on your computer hard drive is greater than or equal to the amount of RAM in the computer.
  • Hibernation is not supported if any driver or video card does not support Plug and Play.
  • For Windows 2000 Advanced Server; Windows 2000 Datacenter Server; Windows 2000 Advanced Server, 64-Bit Edition; and Windows 2000 Datacenter Server, 64-Bit Edition, you cannot use hibernation if the computer uses Terminal Server or if the Physical Address Extention (PAE) Kernel supports 3 GB or more of memory.

    For more information on the PAE Kernel, see the Microsoft Driver Development Kit at http://www.microsoft.com/ddk/.

KeyboardLayout

Value: layout_description

Specifies the type of keyboard layout to be installed during text-mode Setup. If this entry does not exist, Setup detects and installs a keyboard layout.

This entry must match one of the right-hand strings (in quotation marks) in the ["Keyboard Layout"] section of TxtSetup.sif.

NtUpgrade

Value: Yes | No

Specifies whether Setup upgrades a previous version of Windows NT 3.51, Windows NT 4.0, Windows 2000, Windows XP, or Windows 2000 Server operating systems. This entry is valid only for Winnt32.exe.

Note

    To upgrade from Windows 98 or Windows Millennium Edition, use the Win9xUpgrade entry.

Set NtUpgrade = Yes to upgrade the previous Windows installation. If OemPreinstall is Yes, do not set NtUpgrade equal to Yes.

This entry upgrades your previous version of Windows XP, Windows 2000 Server operating systems, Windows 2000, Windows NT 4.0, or Windows NT 3.51. All user settings are taken from the previous installation, so no end user intervention is required during Setup.

The following table provides a comprehensive list of valid upgrade scenarios.

Upgrade from | Upgrade to
 | Windows 2000 Server | Windows 2000 Advanced Server | Windows 2000 Datacenter Server | Microsoft Small Business Server "Bobcat"
Windows NT 3.51 Server | No | No | No | No
Windows NT 4.0 Server (w/Service Pack 5) | Yes | Yes | No | No
Windows NT 4.0 Terminal Server | Yes* | Yes* | No | No
Windows NT 4.0 Enterprise Edition | Yes | No | No | No
Microsoft BackOffice Small Business Server 4.0/4.5 | No | No | No | No
Windows 2000 Server | Yes | Yes | No | Yes
Microsoft Small Business Server 2000 | No | No | No | Yes
Windows 2000 Advanced Server | No | Yes | No | No
Windows 2000 Datacenter Server | No | No | Yes | No
Windows 2000 Server | Yes | Yes | No | Yes
Microsoft Small Business Server "Bobcat" | No | No | No | Yes
Windows 2000 Advanced Server | No | Yes | No | No
Windows 2000 Datacenter Server | No | No | Yes | No

* You can upgrade from Windows NT 4.0 Terminal Server Edition
or Windows 2000 Application Server mode to Windows 2000 Server,
but you will receive a warning that the Terminal Service Application mode
is not supported.

OemFilesPath

Value: path_to_$OEM$_folder

Specifies the path to the \$OEM$ folder (containing OEM files) if it does not exist under the i386 folder of the distribution share point. The path can be a UNC name. Enclose path_to_$OEM$_folder in quotes if it is a long file name.

For more information about the \$OEM$ folder, if you are a computer manufacturer, see the Microsoft Windows XP OEM Preinstallation Kit (OPK) User Guide. Otherwise, see the Microsoft Windows 2000 Server Deployment Guide.

OemPnPDriversPath

Value: folder_1_on_system_drive[;folder_2_on_system_drive]...
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\
Windows\CurrentVersion\DevicePath

Specifies the path to one or more folders that contain Plug and Play drivers that are not distributed in Drivers.cab on the Windows product CD. The folders must contain all the files necessary to install the particular devices: catalog files, .inf files, and drivers.

For example, if you have a folder called \Drivers with subfolders called \Audio and \Net, you would specify OemPnPDriversPath = drivers\audio;drivers\net in the Unattend.txt file. Setup adds:

  • %systemdrive% to each of the folder names
  • the path for each subfolder to the Plug and Play device search path.

Important

  • You cannot use environment variables to specify the location of a folder.
  • Always use signed drivers. Signed drivers make the operating system more stable and significantly reduce requests for product support.

When using OemPnPDriversPath in Unattend.txt, be sure that the folders are available during GUI-mode Setup or the end user first-run experience. The easiest way to do this is to place the Plug and Play drivers in the \$OEM$\$1 folder.

If the drivers are not found in the Drivers.cab file on the computer's hard disk or in the location specified by OemPnPDriversPath, Setup prompts the end user for the location of the drivers on the first boot of the machine, before Windows Welcome or Mini-Setup.

You can also use the [PnPDrivers] section in Winbom.ini to update drivers on a previously-created image of the installed operating system.

OemPreinstall

Value: Yes | No

Determines whether Setup is installing its files from distribution folders. When the value is Yes, Setup copies the subfolders and files contained in the \platform\$oem$ folder. When set to No, Setup does not copy these files.

Note

  • If OemPreinstall = Yes, do not set NtUpgrade to Yes.
  • If OemPreinstall = Yes, unattended Setup automatically stops at the Welcome page. To avoid this pause in your factory environment, set OEMSkipWelcome to 1. Do not distribute any computer with OEMSkipWelcome = 1. Instead, set OEMSkipWelcome to 0 in the Sysprep.inf file you use before delivering the computer to the customer.

OemSkipEula

Value: Yes | No

Determines whether the end user is prompted to accept the End-User License Agreement (EULA) included with Windows. Setting this entry to Yes implies that the person performing the installation has read and agreed to the contents of the license agreement included with the product. It also implies that the end user on whose behalf Windows is installed has agreed to the license agreement.

Important

  • You must not use this entry to remove the Microsoft End-User License Agreement screen, because end users are required to see and accept it. Use Sysprep to ensure that end users see the EULA at first boot.

OverwriteOemFilesOnUpgrade

Value: Yes | No

Determines whether OEM-supplied files that have the same name as Windows XP or Windows 2000 system files are overwritten during an unattended upgrade.

Yes means overwrite the files. No means do not overwrite the files if found. The default behavior is to overwrite OEM-supplied files.

This entry is provided for backward compatibility only.

Repartition

Value:Yes | No

Specifies whether all partitions on the first drive on the client computer are deleted and the drive reformatted with the NTFS file system.

Important

  • Repartition is valid only when performing an unattended Setup by booting the computer from the Windows product CD.

TargetPath

Value: * | target_path

Determines the installation folder in which Windows is installed.

* indicates that Setup generates a unique folder name for the installation. The folder name given is usually Windows, unless that folder already exists. In that case, Setup installs into Windows.x (where x is 0, 1, ... 999) if these folders do not already exist.

Enclose target_path in quotes if it is a long file name. Do not include the drive letter in target_path. If you want to specify the target drive, you must use the /tempdrive command-line switch when you run Winnt32.exe.

UnattendMode

Value: DefaultHide | FullUnattended | GuiAttended | ProvideDefault | ReadOnly
Default: DefaultHide

Defines the unattended mode to be used during GUI-mode Setup. The default value is DefaultHide when the entry is not specified. When this entry is specified, text-mode Setup is fully automated with or without the necessary answers.

DefaultHide
Specifies that answers in the answer file are defaults. Unlike UnattendMode = ProvideDefault, Setup does not display the user interface to end users if all the answers relating to a particular Setup page are specified in the answer file. If only subsets of the answers on a page are specified, the page is displayed with the provided answers. The end user can modify any of the answers on the displayed page.

Use UnattendMode = DefaultHide in deployment scenarios where an administrator might only want end users to provide the administrator password on the computer. This behavior is the default if unattended mode is not specified.

FullUnattended
Specifies that GUI-mode Setup is fully unattended. If a required Setup answer is not specified in the answer file, Setup generates an error.

During an attended setup, hardware drivers that are not properly signed generate a warning dialog box. If UnattendMode = FullUnattended, then hardware drivers are not installed unless they are properly signed.

Use UnattendMode = FullUnattended in deployment scenarios where a complete hands-off installation is required.

GuiAttended
Specifies that the GUI-mode section of Setup is attended. When specified, the end user is required to answer all questions in the GUI-mode portion of Setup before Setup finishes.

Use UnattendMode = GuiAttended in preinstallation scenarios when you want to automate only text-mode Setup.

ProvideDefault
Specifies that answers in the answer file are defaults. In this case, Setup displays these default answers to the end user, who can change them if they want.

Use UnattendMode = ProvideDefault in preinstallation scenarios where the OEM or administrator wants to give the person setting up the computer the option to change the predefined default answers (especially network options).

ReadOnly
Specifies that answers in the answer file are read-only if the Windows Setup pages containing these answers are displayed to the end user. Like UnattendMode = ProvideDefault, no user interface appears if all answers on a page are supplied in the answer file. Unlike UnattendMode = DefaultHide, however, the end user can only specify new answers on a displayed page.

Use UnattendMode = ReadOnly in scenarios where an administrator wants to force specific answers on one page but not others.

UnattendSwitch

Value: Yes | No
Default: No

Instructs Setup to skip Windows Welcome or Mini-Setup when preinstalling Windows XP Home Edition or Windows XP Professional using the CD Boot method.

Yes
Instructs Setup to skip Windows Welcome.
No
Instructs Setup to not skip Windows Welcome.

UnattendSwitch is only necessary when you perform an unattended Setup using Winnt.exe, Winnt.sif, and the CD Boot method. This entry is not necessary if you use Winnt32.exe to run Setup.

Note

  • UnattendSwitch is not the same as the UnattendedInstall entry in the [Data] section of the answer file. UnattendSwitch controls Windows Welcome; UnattendedInstall does not.

WaitForReboot

Value: Yes | No
Default: Yes

Specifies whether the computer will wait 15 seconds after GUI-mode Setup is completed.

Yes
Specifies the computer to delay the reboot for 15 seconds after GUI-mode Setup is completed.
No
Specifies the computer to reboot immediately after finishing GUI-mode Setup.

Win9xUpgrade

Value: Yes | No
Default: No

Instructs Setup to upgrade previous installations of Windows 98, Windows 98 Second Edition, or Windows Millennium Edition to either Windows XP Home Edition or Windows XP Professional, as specified in the [Win9xUpg] section.

Yes
Instructs Setup to upgrade the Windows installation, if found.
No
Instructs Setup not to upgrade the Windows installation, if found.

This entry is only necessary when using an answer file to upgrade an existing Windows 98 or Windows Millennium Edition computer to Windows XP Home Edition or Windows XP Professional. This entry is valid only for Winnt32.exe.

For more information, see [Uninstall].


[Uninstall] (Unattend.txt)

banner

[Uninstall]

The [Uninstall] section in Unattend.txt allows end users who upgrade to Windows XP to uninstall the operating system if they encounter problems.

This section header instructs Setup to create a backup file of the end user's existing operating system and a path to this backup file. This section is required for the Uninstall feature to be available.

Important

There are several considerations and restrictions with the Uninstall feature, for example:

  • Uninstall is not supported if there is any change in the number of partitions or the file system.
  • Uninstall is only supported for upgrades of Windows 98, Windows 98 Second Edition, or Windows Millennium Edition.
  • Uninstall is not available for end users who upgrade from Windows 4.0 or Windows 2000 to Windows XP Home Edition or Windows XP Professional.
  • Uninstall is not available for Windows XP 64-Bit Edition.
  • End users can uninstall if Setup does not complete successfully.
  • After uninstall, all hardware devices should continue to work. However, applications that were installed or upgraded after the operating system was upgraded to Windows XP may not work after the uninstall action. Uninstall does not affect any user data created with the new operating system.

For more information on upgrades from Windows 98, Windows 98 Second Edition, or Windows Millennium Edition, see [Win9xUpg].

DisableCompression

Value: Yes | No | Auto
Default: Auto

Specifies whether to compress the files in Backup.cab. The compression factor is controlled in the [Uninstall.DiskSpaceEstimation] section in Win9xupg.inf. If EnableBackup = No, this entry is ignored.

Yes
Does not compress the backup files in Backup.cab, located in the folder specified by PathForBackup. This setting speeds up the installation of an upgrade to Windows XP Home Edition or Windows XP Professional.
No
Compresses the files in Backup.cab to approximately 40 percent of their original size.
Auto
Checks the available disk space. If there is sufficient disk space, do not compress the backup files in Backup.cab. If there is not enough disk space for all of these uncompressed files, then compress the files when storing them in Backup.cab.

EnableBackup

Value: Yes | No
Default: Yes

Creates a backup file (Backup.cab) for uninstalling Windows XP Home Edition or Windows XP Professional.

Yes
Creates Backup.cab in the folder specified by PathForBackup.
No
Does not create Backup.cab.

PathForBackup

Value: path_for_backup_files
Default: system_drive:\Undo

Specifies the location of the backup files of the previous Windows 98, Windows 98 Second Edition, or Windows Millennium Edition. These files are accessed if the end user chooses to uninstall the upgraded Windows XP Home Edition or Windows XP Professional operating system. PathForBackup must specify a location on the computer's hard disk; it cannot specify a network server share or a removable mass-storage device. Enclose path_for_backup_files in quotes if it is a long file name.

If EnableBackup = No, this entry is ignored.


[URL] (Unattend.txt)

banner

[URL]

This section contains default URL settings for the Windows XP or Windows 2000 Server operating systems browser. If these are not present, the default for Windows XP or Windows 2000 Server operating systems is used.

Important

  • To make sure your [URL] settings take effect, you need to include the [Branding] section header and the BrandIEUsingUnattended entry in the answer file to enable the browser-related settings:
    [Branding]
BrandIEUsingUnattended = Yes

AutoConfig

Value: 0 | 1

Specifies whether the browser is automatically configured from a server.

0
Does not configure the browser settings using an automatic configuration file located on a server.
1
Configures the browser settings using an automatic configuration file located on a server.

AutoConfigJSURL

Value: URL

Specifies the URL of a JavaScript file that automatically configures the proxy-server settings for the browser.

AutoConfigJSURL = http://configserver/autoconfig.js

AutoConfigURL

Value: URL

Specifies the URL of an .ins file that automatically configures the proxy-server settings for the browser.

AutoConfigURL = http://configserver/autoconfig.ins

Help_Page

Value: URL
Registry subkey: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\
Internet Explorer\Main\Star

Specifies the URL for HTML-based Help.

Help_Page = http://configserver

Home_Page

Value: URL
Registry subkey: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\
Internet Explorer\Main\Start Page

Specifies the URL for the browser’s default home page.

Home_Page = http://www.msn.com/

Quicklink

Value: site name, URL

Specifies shortcuts in the link folder of [FavoritesEx]. This entry is a set of "Quick_Link_N_Name" and "Quick_Link_N," where N is a numerical designation for the site and URL.

Quick_Link_1_Name = "MS HomePage"
Quick_Link_1 = http://www.microsoft.com/
Quick_Link_2_Name = "MS Japan HomePage"
Quick_Link_2 = http://www.microsoft.com/Japan


[Win9xUpg] (Unattend.txt)

banner

[Win9xUpg]

This section in Unattend.txt specifies the entries for an unattended upgrade from Windows 98, Windows 98 Second Edition, or Windows Millennium Edition to either Windows XP Home Edition or Windows XP Professional. These entries are not valid on any other upgrade path.

To perform this upgrade during an unattended Setup, include the Win9xUpgrade entry in the [Unattended] section of Unattend.txt.

For more information about potentially reversing this upgrade, see [Uninstall].

Note

  • If you upgrade from Windows 98 to Windows XP Home Edition and if Personal Web Server was installed on Windows 98, Setup removes the Personal Web Server software component. Content files are not removed.

Boot16

Value: Yes | No
Default: No

Enables MS-DOS boot mode.

Yes
Enables MS-DOS boot mode.
No
Disables MS-DOS boot mode.

DefaultPassword

Value: password

Provides a default password for all local accounts created during a migration process. Because Setup cannot migrate the Windows passwords of end users when upgrading a system, it must assign passwords for those created accounts. When Setup needs to assign one of these passwords, it first checks to see if a UserPassword entry for that end user exists. If an entry doesn't exist, Setup uses the value of this entry if specified.

There are security concerns about using this key, because the password is stored as plain text within the Unattend.txt file. All passwords in the answer file are automatically deleted after the upgrade.

If a local account needs to be created for an end user without a UserPassword entry and no DefaultPassword is specified, Setup creates a random password. After the first reboot, the end user is prompted to enter a password for all end users created during Setup.

DomainJoinText

Value: html_text

Inserts the Hypertext Markup Language (HTML) text on the Join a Domain page of GUI-mode Setup.

The only supported HTML tags are anchor (<A>) and bold (<B>).

ForcePasswordChange

Value: Yes | No
Default: Yes

Instructs Setup to automatically require a password change on all local accounts it creates during the migration process.

Yes
Requires a password change on all local accounts it creates during the migration process. End users logging on with these accounts are informed that the current password has expired. End users must select a new password before logging on.
No
Does not require a password change for local accounts.

ForceWorkgroup

Value: Yes | No
Default: No

Instructs Setup to skip domain checks and to run the computer in Workgroup mode after the upgrade.

Yes
Runs the computer in Workgroup mode after the upgrade.
No
Joins a domain after the upgrade.

IgnoreNetworkErrors

Value: Yes | No
Default: No

Instructs Setup not to retry a domain that fails.

Yes
Does not retry to join a domain if the first attempt fails. In this case, Setup is completely unattended, but the domain account migration might fail
No
Retries to join a domain if the first attempt fails.

KeepBadLinks

Value: Yes | No
Default: Yes

Instructs Setup to keep all links.

Yes
Keeps all links.
No
Removes incompatible links.

MigrateDefaultUser

Value: Yes | No
Default: Yes

Causes Setup to migrate the default Windows 98 and Windows Millennium Edition user account settings to the default Windows XP user account.

Yes
Migrates the default Windows 98 and Windows Millennium Edition user account settings to the default Windows XP user account.
No
Does not migrate the default user account settings.

Important

  • If this entry is set to No, the Windows 98 and Windows Millennium Edition default user settings are not maintained. Subsequent user accounts created on the computer inherit the defaults of the upgraded operating system (Windows XP or Windows 2000 Server family of operating systems).
  • Some applications rely on settings migrated to the default user. These applications might not work unless default user migration is enabled.
  • Only use this entry in special cases (for example, when it is known that no applications require default user migration).

MigrateUsersAsAdmin

Value: Yes | No
Default: Yes

Causes Setup to add all accounts that it creates during migration to the Local Administrators group, giving those end users full control over the computer.

For more information about group-level security settings, see Windows Help.

Yes
Adds all accounts that it creates during migration to the Local Administrators group, giving those users full control over the computer.
No
Does not add all accounts created during migration to the Local Administrators group. If end users are not migrated as administrators, some migrated applications and settings might not work properly after the upgrade is completed.

MigrateUsersAsPowerUser

Value: Yes | No
Default: Yes

Causes Setup to add all accounts that it creates during migration to the Power Users group, giving the new end users in the Power Users group more permissions than end users in the Users group, but fewer permissions than end users in the Administrators group. Power Users can perform any operating system task except tasks reserved for the Administrators group.

For more information about group-level security settings, see Windows Help.

Yes
Adds all accounts that it creates during migration to the Power Users group.
No
Does not add all accounts created during migration to the Power Users group.

MigrationDlls

Value: migration_dll_path [, ...]

Specifies the location of upgrade packs that Setup needs to copy and process during an upgrade to Windows XP or Windows 2000 Server family of operating systems. If multiple paths are specified, commas must separate the paths. Setup searches each of these paths (including each path’s subfolders) for upgrade packs. Multiple upgrade packs can be located at a single location, but each upgrade pack must exist in its own subfolder of that single path. Do not put more than one upgrade pack in a single folder.

Note

  • An upgrade pack consists of a migration .dll file (Migrate.dll) and any additional files that might be required to properly upgrade a particular software component from Windows 98 or Windows Millennium Edition to either Windows XP Home Edition or Windows XP Professional.

ReportOnly

Value:Yes | No
Default: No

Instructs Setup to generate an upgrade report and then exit without making any changes to the current Windows 98 or Windows Millennium Edition installation. The upgrade report contains a list of hardware and software incompatibilities and is saved to the root of the system drive if the SaveReportTo entry is not specified.

Yes
Generates an upgrade report and then exits without changing the current Windows 98 or Windows Millennium Edition installation.
No
Upgrades the current Windows 98 or Windows Millennium Edition installation.

SafeMode

Value: Yes | No
Default: No

Instructs Setup to maintain a list of settings during the upgrade. If any setting causes Windows 98 or later to fail or stop responding, that setting is skipped during the next Setup. Using this entry slows Setup, but it allows Setup to skip certain types of malfunctioning software installed on Windows 98 or later.

Yes
Instructs Setup to maintain a list of settings during the upgrade.
No
Setup does not maintain a list of settings during upgrade.

Important

  • Safe mode is started automatically if a problem is detected. If SafeMode = Off, Setup must be run three times. If SafeMode = Yes, Setup need only be run two times.

SaveReportTo

Value: path_of_report

Specifies the full path and file name of the upgrade report (text file) generated by Setup. If the Windows 98 or Windows Millennium Edition installation has network connectivity, the path_of_report can be a UNC path. Enclose path_of_report in quotes if it is a long file name.

System environment variables enclosed in percent signs (%) can be used in the path. If the special environment variable %computername% is specified in the path, the resulting file name contains the actual computer name. This is useful when upgrade reports are being collected from several Windows 98 or Windows Millennium Edition computers to a central location.

For more information, see ReportOnly.

ScanDrives

Value: [drive][,drive,drive]

Enables scanning of drives that are normally skipped. This entry is used with ReportOnly and allows software on network drives to be checked.

For more information, see ReportOnly.

UseLocalAccountOnError

Value: Yes | No
Default: No

Directs Setup to create a local account if a network account cannot be automatically determined or resolved. This is valid only on computers with the Microsoft Networking Client software installed.

Windows 98 and Windows Millennium Edition only keep the domain of the last logged-in user in the registry. Because neither Windows 98 or Windows Millennium Edition keeps the domains of other end users who might have logged on to the computer, Windows Setup searches all trusted domains on the network by default. Windows Setup automatically uses a domain account when an exact match is found.

If an end user is not found on any trusted domain, or if the user account is found on two or more domains on the network, a dialog box appears prompting the person performing the upgrade to resolve the conflict. This dialog box also appears if network errors occur.

Specifying UseLocalAccountOnError = Yes in the Unattend.txt file ensures a complete unattended Setup. This causes Setup to create a local account whenever a network account cannot be automatically resolved.

In addition, if a computer cannot be added to the computer domain during installation of the network on Windows, all user accounts change to local accounts.

For more information, see UserDomain.

Yes
Creates a local user account if a network account cannot be automatically determined or resolved.
No
Does not create a local account.

UserDomain

Value: domain_name, user_name [, user_name, user_name, ...]

Specifies the domain for one or more end users. Multiple UserDomain lines can be used to specify different domains for different users. When specified, this entry prevents Setup from searching all trusted domains on the network for a matching user account. (The search process can be time-consuming if a large number of trusted domains exist on the network.)

If the account is not found in the specified domain, either because the account does not exist or the domain is not accessible, a dialog box appears prompting the end user to resolve the account unless the UseLocalAccountOnError entry is set to Yes.

For more information, see UseLocalAccountOnError.

UserPassword

Value: user,password [,user,password,...]

Provides Setup with the names of the passwords to create for specific local accounts. Because Setup cannot migrate the Windows passwords of end users when upgrading a system, it must create passwords for nondomain accounts during the migration process. Using this key, an administrator can predetermine what those passwords are for specific end users.

There are security concerns about using this key, because the password is stored as plain text within the answer file. However, after the upgrade is completed, all the password entries are deleted from the copy of the answer file left on the computer. The original copy of the answer file you started Setup with is not deleted.

If a local account needs to be created for an end user without a UserPassword entry and no DefaultPassword is specified, Setup creates a random password. After the first reboot, the end user is prompted to enter a password for all end users created during Setup.

For more information, see DefaultPassword.


Sysprep.inf

Sysprep.inf is an optional answer file that can be used to automate Mini-Setup. Normally, when Mini-Setup runs, it prompts the end user for some standard information that is used to configure the computer. However, if Sysprep.inf is present, Mini-Setup uses information in Sysprep.inf instead of prompting the end user. By using Sysprep.inf, you can have Mini-Setup prompt the end user for certain information, or you can create a completely automated installation that does not prompt the end user for information at all.

Location of Sysprep.inf

The Sysprep.inf file must reside in the same location as Sysprep.exe and Setupcl.exe. These Sysprep files can exist either in the %systemdrive%\Sysprep folder, located on the hard disk of the destination computer, or on a floppy disk.

If you run Sysprep.exe from %systemdrive%\Sysprep, Sysprep removes the entire folder and its contents after it finishes running.

Syntax of Sysprep.inf

The syntax of Sysprep.inf is similar to that of the unattended Setup answer file, Unattend.txt. Sysprep.inf supports a subset of the sections and entries supported by Unattend.txt plus a few Sysprep-specific entries. You can use Setup Manager to help create the Sysprep.inf file.

The following two tables list the sections that can be included in the Sysprep.inf file. Many sections and entries are interdependent.

The [Unattended] and [GuiUnattended] sections support different entries in Unattend.txt and Sysprep.inf:

Section Comparison Between Unattend.txt and Sysprep.inf
[Unattended] Contains a core subset of entries from the [Unattended] section in Unattend.txt that are used by Sysprep. Sysprep supports the following entries that are also supported in Unattend.txt:
  • ExtendOemPartition
  • OemPnPDriversPath
  • OemSkipEula

Sysprep supports the following entries that are not supported in Unattend.txt:

  • InstallFilesPath
  • KeepPageFile
  • ResetSourcePath
  • UpdateHAL
  • UpdateInstalledDrivers
  • UpdateUPHAL
[GuiUnattended] Contains a core subset of the entries from the [GuiUnattended] section in Unattend.txt that are set during GUI-mode Setup. Sysprep supports the following entries that are also supported in Unattend.txt:
  • AdminPassword
  • AutoLogon
  • AutoLogonCount
  • OemSkipRegional
  • OemSkipWelcome
  • TimeZone

In addition, Sysprep supports the following entry that is not supported in Unattend.txt:

  • OEMDuplicatorString

The following sections are used in both Sysprep.inf and Unattend.txt:

Section | Description
[UserData] | Includes user-specific entries. Supports the same set of entries as Unattend.txt.
[LicenseFilePrintData] | Includes server licensing entries. Supports the same set of entries as Unattend.txt.
[GuiRunOnce] | Contains a list of commands to be executed the first time an end user logs on to the computer after GUI-mode Setup has completed. Supports the same set of entries as Unattend.txt.
[Display] | Specifies display settings for the graphics device. Supports the same set of entries as Unattend.txt.
[RegionalSettings] | Configures locale and language settings, provided the correct language files are available on the computer’s hard disk. For more information, see InstallFilesPath. Supports the same set of entries as Unattend.txt.
[TapiLocation] | Includes the Telephony API (TAPI) entries. The values set in this section are only valid if a modem is present on the computer. Supports the same set of entries as Unattend.txt.
[Networking] | Configures network capability. This section is required for configuring network protocols in unattended Setup or when using Sysprep. However, no entries are required within this section. The syntax is the same as in Unattend.txt.
[Identification] | Specifies the network identification entries of the computer. Supports the same set of entries as Unattend.txt.

Important

  • Any settings specified in [RegionalSettings] in Unattend.txt are not maintained if Sysprep is run on the computer, unless the corresponding settings are also specified in Sysprep.inf.

The following sections are only used in Sysprep.inf:

Section | Description
[Sysprep] | Automatically generates the entries in the [SysprepMassStorage] section.
[SysprepMassStorage] | Allows you to use the same image on computers with different mass-storage devices.

You can run additional programs at the end of Mini-Setup by providing a Cmdlines.txt file in your Sysprep folder. Mini-Setup can then run Cmdlines.txt just as GUI-mode Setup would.

Note

  • Commands that make changes to an end user's preferences are not replicated to end users if they are run from Cmdlines.txt within Mini-Setup.

To run Cmdlines.txt during Mini-Setup

  1. In the distribution folder, create:

    %systemdrive%\Sysprep\i386\$OEM$

  2. Add Cmdlines.txt to the %systemdrive%\Sysprep\i386\$OEM$ folder.
  3. In Sysprep.inf, add:
    [Unattended]
InstallFilesPath = C:\Sysprep\i386
  4. Run Sysprep.


Sample Sysprep.inf Files

Sample 1

Customizes the Windows installation for a standard departmental desktop.

[Unattended]
    OemSkipEula = Yes

[GuiUnattended]
    AdminPassword = Admin password
    OemSkipWelcome = 1
    TimeZone = 20

[UserData]
    FullName = "Company Department Name"
    OrgName = "Company Name, Inc."

[Identification]
    DomainAdmin = "CORPDOM\AcctAddID"
    DomainAdminPassword = Domain password
    JoinDomain = "CORPDOM"

[Networking]

Sample 2

Customizes the Windows installation for remote office servers.

[Unattended]
    OemSkipEula = Yes

[GuiUnattended]
    AutoLogon = Yes
    AdminPassword = *
    OEMSkipRegional = 1
    OemSkipWelcome = 1
    TimeZone = 20

[UserData]
    FullName = "Company Server Name"
    OrgName = "Company Name, Inc."
    ComputerName = 005-REGSRV-1

[LicenseFilePrintData]
    AutoMode = PerSeat

[GuiRunOnce]
    Command0 = "dcpromo /answer:ansfile.txt"

[Identification]
    DomainAdmin = "CORPDOM\IDAcct"
    DomainAdminPassword = Domain password
    JoinDomain = "REGDOM"

[Networking]


[GuiUnattended] (Sysprep.inf)

This is the [GuiUnattended] section for Sysprep.inf. For the Unattend.txt version, see [GuiUnattended] (Unattend.txt).

AdminPassword

Value: password | *
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\
Windows\CurrentVersion\WinLogon\DefaultPassword

Sets the Administrator account password.

If a password is specified in the Administrator account, you cannot use AdminPassword in the Sysprep.inf file to change it: the administrator password remains the same. However, if the administrator password was initially blank (either manually or through an unattended Setup), you can use AdminPassword to change it to a nonblank password.

password
The administrator password; maximum length is 127 characters. Users cannot change or specify their own passwords in Mini-Setup. A new password can be entered in the appropriate dialog box, but the password is not changed.
*
The administrator password is blank or NULL.

Important

  • Do not specify the Administrator password in the Sysprep.inf file on computers being delivered to end users. Security breaches can occur if you use a common, nonblank administrator password for all computers provided to end users. Prior to running Sysprep, we recommend you use an automation process to set the administrator password to blank. End users can then specify their own passwords upon receipt of the computer.

AutoLogon

Value: Yes | No
Default: No
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\
Windows\CurrentVersion\WinLogon\AutoAdminLogon

Configures the computer to automatically log on once with the Administrator account. The entry is not valid on upgrades.

If you specify a password by using AdminPassword, that password is used when you automatically log on. After the installation is complete, the password is deleted from the copy of the answer file left on the computer.

Yes
Configures the computer to automatically log on once with the Administrator account.
No
Do not automatically log on to the computer.

AutoLogonCount

Value: integer
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\WinLogon\AutoLogonCount

Specifies the number of times that the computer automatically logs on using the specified Administrator account and password. The value decrements after each logon, and the feature is disabled after the specified number of logon attempts.

This entry is only useful when AutoLogon = Yes and AdminPassword = * are specified in the answer file.

Important

  • Make sure that the password for the master installation (that you plan to duplicate onto one or more destination computers) is blank.
  • You must reboot the computer to decrement the value of AutoLogonCount.

EncryptedAdminPassword

Value: Yes | No
Default: No

Allows Sysprep to install encrypted passwords for the Administrator account.

To encrypt your Administrator passwords, use the encryption tool (Hashpwd.exe) on the Windows OPK CD in the Tools section and in Deploy.cab file.

Yes
Instructs Sysprep to install the encrypted Administrator account password.
No
Instructs Setup to keep the Administrator account password as clean text.

Important

  • If you use this key to install an encrypted Administrator password during an unattended installation, Autologon is disabled.

OEMDuplicatorString

Value: user-defined_string
Registry subkey: HKEY_LOCAL_MACHINE\System\Setup\OemDuplicatorString

Valid only for Sysprep.inf. This string contains a description of the duplication utility used, as well as any other information an OEM or administrator wants to store in the registry. The value can have a maximum of 255 characters.

OEMSkipRegional

Value: 0 | 1

Allows unattended Setup to skip the Regional and Language Options page in GUI-mode Setup and Mini-Setup.

When specifying OemPreinstall = Yes and providing values for the [RegionalSettings] section, set OEMSkipRegional = 1 to ensure that Setup completes without prompting the end user for regional information.

0
Displays the Regional and Language Options page in GUI-mode Setup and Mini-Setup.
1
Skips the Regional and Language Options page in GUI-mode Setup and Mini-Setup.

OEMSkipWelcome

Value: 0 | 1

Allows unattended Setup to skip the Welcome page in GUI-mode Setup and Mini-Setup.

If OemPreinstall = Yes, unattended Setup automatically stops at the Welcome page. To avoid this pause in your factory or testing environment, set OEMSkipWelcome = 1. Do not distribute any computer with OEMSkipWelcome = 1.

If OemPreinstall in the [Unattended] section of Unattend.txt is Yes, unattended Setup automatically stops at the Welcome page. To avoid this pause in your factory or testing environment, set the value of OEMSkipWelcome in the [GuiUnattended] section of Sysprep.inf to 1. Do not deliver any computer with OEMSkipWelcome = 1. Instead, change OEMSkipWelcome to 0 in the Sysprep.inf file you use before delivering the computer to the customer.

0
Displays the Welcome page in GUI-mode Setup and Mini-Setup.
1
Skips the Welcome page in GUI-mode Setup and Mini-Setup.

TimeZone

Value: index

Specifies the time zone where the computer is located. If the entry is not present, the end user is prompted to select a time zone. For a list of valid time zone indexes, see TimeZone in Unattend.txt.


[Sysprep] (Sysprep.inf)

banner

[Sysprep]

This section in Sysprep.inf allows Sysprep to automatically generate the entries in the pre-existing [SysprepMassStorage] section.

BuildMassStorageSection

Value: Yes | No

Generate the entries in the [SysprepMassStorage] section from the Plug and Play hardware IDs specified in Machine.inf, Scsi.inf, Pnpscsi.inf, and Mshdc.inf.

Yes
Populate the [SysprepMassStorage] section with the correct values for this computer.
No
Do not change the [SysprepMassStorage] section.


[SysprepMassStorage] (Sysprep.inf)

banner

[SysprepMassStorage]

Sysprep requires that the mass-storage controller on the master installation be identical to the controllers on the destination computers.

If you are using images as part of your manufacturing process, you may want to reduce the number of images you maintain by creating one master image to install Windows on destination computers that may use different mass-storage controllers.

Before running Sysprep on the master installation and creating your image, identify the different mass-storage controllers that may be installed on each destination computer in the [SysprepMassStorage] section of the Sysprep.inf file. Sysprep then prepopulates the necessary driver information so that Windows can load the correct drivers when the operating system boots on a computer that uses one of the predefined mass-storage controllers.

You do not need to manually create the entries in the [SysprepMassStorage] section. Instead, include the [Sysprep] section in the Sysprep.inf file and Sysprep will automatically generate the entries in [SysprepMassStorage] from the Plug and Play hardware IDs specified in Machine.inf, Scsi.inf, Pnpscsi.inf, and Mshdc.inf.

hardware_id

Value: path_to_device_inf[, disk_directory[, disk_description[, disk_tag]]]

hardware_id
Specifies the Plug and Play ID for the device as specified in the device’s .inf file.
path_to_device_inf
Specifies the path to the .inf file that contains the Plug and Play ID of the controller to be installed. Enclose path_to_device_inf in quotes if it is a long file name.
disk_directory
Specifies the name of the directory on the floppy disk provided by the third party that contains the copy of the mass storage driver.
disk_description
Specifies the description of the floppy disk as specified in the Txtsetup.oem file provided by the third party.
disk_tag
Specifies the disk tag of the floppy disk as specified in the Txtsetup.oem file provided by the third party.

Example

To support a new Qlogic driver, copy the qlogic.inf file to the Sysprep folder and include the following section in the Sysprep.inf file:

[SysprepMassStorage]
PCI\VEN_1077&DEV_1080 = "C:\Sysprep\qlogic\qlogic.inf", "\nt", "Qlogic Software Disk", "\qlogic"


[Unattended] (Sysprep.inf)

This is the [Unattended] section for Sysprep.inf. For the Unattend.txt version, see [Unattended] (Unattend.txt).

ExtendOemPartition

Value: 0 | 1 | extra_size_in_MB

The ExtendOemPartition entry is used to extend the partition on which the Windows operating system is installed. This entry causes Setup to extend this destination partition into any available unpartitioned space that physically follows it on the disk.

ExtendOemPartition automatically leaves the last cylinder on the hard disk free to allow dynamic disk support to work.

0
Sysprep does not extend the partition.
1
Sysprep extends the partition to fill out the hard disk.
extra_size_in_MB
Sysprep increases the current partition size by this amount. This is useful if you want to configure more than one partition on the hard disk.

Important

  • You can only extend NTFS file system partitions.
  • When you use ExtendOEMPartition in Sysprep.inf for imaged computers, the destination computer’s hard disk must be the same size or larger than the hard disk of the original master installation.
  • The partition that you want to extend must have unpartitioned space available following the partition.

If your manufacturing process requires FAT32, use the Oformat command-line tool to format the hard disk so that it is optimally configured for NTFS. Use the Convert command-line tool to convert the file system.

You can also convert the partition during text-mode Setup by setting the FileSystem in the [Unattended] section of Unattend.txt to ConvertNTFS. FileSystem is not a valid entry in Sysprep.inf. However, the hard drive will have better performance if you use the Convert command-line tool rather than the FileSystem entry.

Instead of extending the partition in Sysprep, you can also use the ExtendPartition entry in the [ComputerSettings] section of Winbom.ini to extend the partition using the Factory tool.

InstallFilesPath

Value: path_to_installation_files_on_computer

Valid only for Sysprep.inf. Specifies the location of files that can be necessary for installation during Mini-Setup, such as the language files, so that the installation is not interrupted to prompt for end-user input.

For example, if the \i386 folder is copied to the root of the end user's system drive, you need to specify this entry in the Sysprep.inf file so that Setup can find the files, such as:

InstallFilesPath = "C:\Sysprep\i386"

InstallFilesPath does not support environment variables (for example, %systemdrive%). Instead, a valid path with an actual drive letter must be used. Enclose path_to_installation_files_on_computer in quotes if it is a long file name.

KeepPageFile

Value: 0 | 1
Default: 0

Valid only for Sysprep.inf. After Sysprep is run, Mini-Setup or Windows Welcome automatically regenerates the system’s page file to accommodate differences in the amount of random access memory (RAM) between the master and destination computers. The default setting ensures that the page file is large enough to accommodate the amount of RAM on the computer.

If the amount of RAM is the same on both the computer used to create the master installation and the destination computers, you do not need to regenerate the page file. If you do not set a value for KeepPageFile, Mini-Setup or Windows Welcome automatically regenerates the page file.

0
Regenerate the page file so that it is large enough to accommodate the amount of RAM on the computer.
1
Do not regenerate the page file.

Note

  • If you add KeepPageFile to your Sysprep.inf file, regardless of the value assigned, the page file is not regenerated. To regenerate the page file, do not include KeepPageFile in the [Unattended] section.

OemPnPDriversPath

Value: folder_1_on_system_drive[;folder_2_on_system_drive]...
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\
Windows\CurrentVersion\DevicePath

Specifies the path to one or more folders that contain Plug and Play drivers that are not distributed with Drivers.cab on the Windows CD. The folders must contain all the files necessary to install the particular devices: catalog files, .inf files, and drivers.

For example, if you have a folder called \Drivers with subfolders called \Audio and \Net, you would specify OemPnPDriversPath = drivers\audio;drivers\net in Sysprep.inf. Sysprep adds:

  • %systemdrive% to each of the folder names
  • the path for each subfolder to the Plug and Play device search path

If a path is already present in HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\DevicePath, Sysprep does not append the path to the registry key a second time.

Important

  • The length of OemPnPDriversPath in Sysprep.inf is no longer limited to 255 characters.
  • You cannot use environment variables to specify the location of a folder.
  • Always use signed drivers. Signed drivers make the operating system more stable and significantly reduce requests for product support.

In Sysprep.inf, the value of OemPnPDriversPath can be any location on the computer's hard disk.

If the drivers are not found in the Drivers.cab file on the computer's hard disk or in the location specified by OemPnPDriversPath, Setup prompts the end user for the location of the drivers on the first boot of the machine, before Windows Welcome or Mini-Setup.

As in Windows 2000, you can use OemPnPDriversPath in Sysprep.inf to specify the location of additional drivers. However, you can also use the [PnPDrivers] section in Winbom.ini to update drivers on a previously-created image of the installed operating system.

OemSkipEula

Value: Yes | No

Determines whether the end user is prompted to accept the End-User License Agreement (EULA) included with Windows.

Yes
Implies that the person performing the installation has read and agreed to the contents of the license agreement included with the product. It also implies that the end user on whose behalf Windows is installed has agreed to the license agreement.
No
The end user must accept the license agreement included with the product.

Important

  • OEMs must not specify this entry in the Sysprep.inf file of computers sold to end users.

ResetSourcePath

Value: * | path_to_install_files
Default: No change to existing setting.
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\
Windows\CurrentVersion\Setup\SourcePath and
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\
Setup\ServicePackSourcePath

Change the registry setting of the source path for the Setup files.

*
No change to the registry values.
path_to_install_files
Specifies the location of the Setup files in the registry.

Important

  • If this directory does not exist or is set to the system root directory, Windows Welcome or Mini-Setup resets the path to the first CD-ROM drive.

UpdateHAL

Value: hwid,%windir%\inf\hal.inf
(where hwid is either MPS_MP or ACPIAPIC_MP)

Valid only for Sysprep.inf. Required if the master installation is built on an APIC uniprocessor-system (UP) computer and the image of that master installation is placed on compatible multiprocessor-system (MP) destination computers.

Important

  • Do not use a Sysprep.inf file containing this entry on destination uniprocessor computers, because UpdateHAL loads the multiprocessor hardware abstraction layer (HAL) on the destination computer regardless of whether it is a uniprocessor or an multiprocessor computer. A multiprocessor kernel on a uniprocessor computer noticeably reduces the computer’s performance.

To add the modified Sysprep.inf file to the destination computer, you can:

  • Save the .inf file to a floppy disk and insert the disk before Mini-Setup starts.
  • Update the image on the destination computer to include the .inf file.

UpdateInstalledDrivers

Value: Yes | No
Default: No

Specifies whether Plug and Play is called after Mini-Setup, to re-enumerate all the installed drivers and install any updated drivers in the driver path.

Do not use UpdateInstalledDrivers with the sysprep -pnp command-line option.

UpdateUPHAL

Value: hwid,%windir%\Inf\Hal.inf
(where hwid is either MPS_UP or ACPIAPIC_UP)

Valid only for Sysprep.inf. Required if the master installation is built on an APIC multiprocessor computer and the image of that master installation is placed on compatible APIC uniprocessor or multiprocessor destination computers.

In this situation, Windows automatically identifies the processor type and loads the appropriate kernel.


Winbom.ini

Sysprep includes a factory mode, Sysprep -factory, for preinstallation of Windows in an OEM manufacturing environment. The factory mode provides the maximum amount of flexibility for customizing the installation of individual computers. It is a completely automated installation/configuration process which runs in the least amount of time possible.

Winbom.ini is the answer file for Sysprep in Factory mode. This file provides a bill-of-materials to guide the installation and configuration process.

The Sysprep -factory command starts very early in the operating system boot sequence to enable operations that must take place prior to other system processes running, such as Plug and Play device enumeration. During Sysprep -factory, Plug and Play enumeration and other system services and boot processes are started, so that other tasks performed by the Sysprep -factory command occur with the full Windows operating system up and running.

Winbom.ini Sections

The following table lists the sections that can be included in a Winbom.ini file used with sysprep -factory.

Section | Description
[Components] | Configures optional components on the destination computer.
[ComputerSettings] | Configures end-user settings on the destination computer.
[ComputerSettings] | Configures end-user settings on the destination computer.
[Factory] | Installs Windows from a specified configuration set. Required.
[NetCards] | Configures the network adapter on the destination computer, if a network connection is required.
[OEMLink] | Adds a graphic and text to the Start menu to provide end users with easy access to an .htm or .exe file prepared by an OEM.
[OEMRun] | Runs external applications and command shell scripts while the Sysprep -factory command is running. Commands are processed asynchronously. Each application runs in the order listed in this section, but the application does not wait for a previous application to finish before it runs. These executable files or command shell scripts are the last processing done by the Sysprep -factory command.
[OEMRunOnce] | Runs external applications and command shell scripts while the Sysprep -factory command is running. Commands are processed synchronously. Each application runs in the order listed, and each command must finish before the next command is run.
[Section_name] | Preinstall an application as specified in the [OEMRunOnce] section.
[PnPDriverUpdate] | Updates drivers on the installed image prior to installing the drivers with Plug and Play.
[PnPDrivers] | Lists all the updated drivers to be copied onto the computer.
[Shell] | Customizes the appearance of the Windows desktop and Start menu.
[SetupHomenet] | Sets up a firewall on a computer with a preconfigured Internet connection.
[StartMenuMFUlist] | Prepopulates the most-frequently-used list on the Start menu with shortcuts to preinstalled applications.
[UpdateSystem] | Updates external answer files.
[UserAccounts] | Creates user accounts on the destination computer.
[name.Account] | Creates a specific user account.
[UserDefined] | An end user-defined section that can contain branding information or any other data for other processes.

Locating a Winbom.ini File

Factory.exe searches the following locations in order for a Winbom.ini file:

  1. The path and file name specified by the registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Factory\Winbom.
  2. The root of all removable media drives that are not CD-ROM drives, such as a floppy disk drive.
  3. The root of all CD-ROM drives.
  4. The location of Factory.exe, usually the %systemdrive%\Sysprep folder.
  5. The root of %systemdrive%.

After locating a Winbom.ini file, the Factory tool reads the value of the WinbomType entry in the [Factory] section.

If the value of WinbomType is not appropriate in this context, the Winbom.ini file is ignored and the Factory tool continues searching for a Winbom.ini file. If the value of WinbomType is appropriate in this context, the Factory tool reads the value of the NewWinbom entry in the [Factory] section. If a value is specified for NewWinbom, and a Winbom.ini file is located at that location, the Factory tool examines that Winbom.ini file for a NewWinbom entry.

This cycle continues for a maximum of 10 times or until the Factory tool locates a Winbom.ini file that does not contain a NewWinbom entry, whichever occurs first. The Factory tool then continues to run, using the settings in the last identified Winbom.ini file.


[ComputerSettings] (Winbom.ini)

banner

[ComputerSettings]

This section contains entries that control end user settings on the destination computer.

AuditAdminAutoLogon

Value = Yes | No
Default: No

Specifies whether the local administrator account is logged on to the computer under Sysprep in Factory mode.

Yes
Directs the Sysprep -factory command to configure the computer so that the local administrator account is automatically logged on for each audit mode boot.
No
The local administrator account is not automatically logged on for each audit mode boot.

DisplayRefresh

Value = refresh_rate
Default: Adapter default

The desired refresh rate in megahertz.

The specified refresh rate must be a valid value supported by the installed video card.

DisplayResolution

Value = x_resolution x y_resolution x bit_depth
Default: 800x600x16

The specified resolution and bit depth must be a value supported by the installed video card.

If the monitor plugged into the computer is a Plug and Play device and is capable of displaying a screen resolution of 800 by 600 pixels and high color, then DisplayResolution must be at least 800x600x16. Only use the 640 by 480-pixel screen size if the monitor is unable to display 800 by 600 pixels.

If the screen resolution is defined in both the [Display] section of Sysprep.inf and in the [ComputerSettings] section of Winbom.ini, the operating system is configured to use the settings in Sysprep.inf.

x_resolution
The number of horizontal pixels.
y_resolution
The number of vertical pixels.
bit_depth
The number of colors. The number of colors can be either an explicit value, or 8 for 256 colors, 16 for 16 million colors (high color), or 32 for 32 million colors (true color).

ExtendPartition

Value: 0 | 1 | extra_size_in_MB Default: 0

The ExtendPartition entry is used to extend the partition on which the Windows operating system is installed. This entry causes Setup to extend this destination partition into any available unpartitioned space that physically follows it on the disk.

ExtendPartition automatically leaves the last cylinder on the hard disk free to allow dynamic disk support to work.

0
The Factory tool does not extend the partition.
1
The Factory tool extends the partition to fill out the hard disk.
extra_size_in_MB
The Factory tool increases the current partition size by this amount. This is useful if you want to configure more than one partition on the hard disk.

Important

  • You can only extend NTFS file system partitions.
  • The partition that you want to extend must have unpartitioned space available following the partition.

FontSmoothing

Value = ClearType | On | Off | Standard
Default: No change to existing setting.
Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\
CurrentVersion\Explorer\VisualEffects\FontSmoothing

Specifies whether anti-aliasing of fonts, ClearType, or both are enabled.

ClearType
Specifies that both ClearType and anti-aliasing are enabled. Only use this value if you know that the computer uses an LCD monitor and that system performance supports an acceptable end user experience.
On
Forces anti-aliasing on. Only use this value if you know that the video card supports an acceptable end user experience.
Off
Forces anti-aliasing off.
Standard
Specifies that Windows determines, based on the processor speed, whether anti-aliasing is turned on.

Hibernation

Value = Yes | No
Default: No change to existing setting.

Specifies whether hibernation is enabled on the computer. Hibernation is a state in which the computer saves everything in memory to the computer hard disk and then shuts down to save power. When the computer is restarted, the desktop is restored to its preexisting state.

Yes
Hibernation is enabled.
No
Hibernation is not enabled.

PowerScheme

Value = AlwaysOn | Desktop | Laptop | MaxBattery | Minimal | Presentation
Default: No change to existing setting.

Specifies a collection of power management settings.

AlwaysOn
Turns the monitor off after 20 minutes of idleness; never turns off the hard disk or hibernates.
Desktop
Turns the monitor off after 20 minutes of idleness; never turns off the hard disk or hibernates.
Laptop
Turns the monitor off after 15 minutes of idleness; turns the hard disk off after 30 minutes of idleness; hibernates after three hours of idleness.
MaxBattery
Turns the monitor off after 15 minutes of idleness; never turns off the hard disk; hibernates after 45 minutes of idleness.
Minimal
Turns the monitor off after 15 minutes of idleness; never turns off the hard disk or hibernates.
Presentation
Never turns off the monitor or hard disk, and never hibernates.

SourcePath

Value: path_and_directory_name
Default: No change to existing setting.

Change the registry setting of the source path for the Setup files.

For example: SourcePath = C:\i386

Important

  • If this directory does not exist, Windows Welcome or Mini-Setup resets the path to the first CD-ROM drive.

TestCert

Value: path_and_file_name
Default: No change to existing setting.

If the file specified by TestCert exists and is a certificate, the certificate is added to the local database.


[DesktopShortcutsFolder] (Winbom.ini)

banner

[DesktopShortcutsFolder]

Usability testing and customer feedback indicate that a clean Windows desktop, combined with the improved Start menu, create the best end-user PC experience. The default preinstallation of Windows XP moves all items on the Windows desktop, other than the Recycle Bin, to a folder located in %systemdrive%\Program Files.

DesktopShortcutsFolderName

Value: Shortcuts_Folder
Default: "Program Shortcuts"

Shortcuts_Folder
The name of the folder contained in %systemdrive%\Program Files where all desktop shortcuts are moved to the first time the end user starts the computer.

Note

  • You may delay the first instance of the Desktop Cleanup wizard until seven days after the end user first starts the computer, using the DelayCleanup entry in the [Shell] section of Winbom.ini. At that time, rather than placing the shortcuts in the folder specified by DesktopShortcutsFolderName, the end user can choose whether to place unused Windows desktop icons and folders into the "Unused Desktop Items" folder on the desktop.


[Factory] (Winbom.ini)

banner

[Factory]

The [Factory] section heading in Winbom.ini manages the actions of the Factory tool. This section is required; otherwise, the Winbom.ini file is ignored.

AutoDetectNetwork

Value: Yes | No
Default: Yes

Controls the behavior when scanning for network device IDs if an error is encountered in the specified list.

See [NetCards] for more information.

DoDeviceIDScanOnError

Value: Yes | No
Default: No

Controls the behavior when scanning for network device identifiers if Sysprep encounters an error when processing the devices specified in [NetCards].

FactoryComputerName

Value: name | *
Default: None

Specifies the computer name to use during factory preinstallation.

If this entry is not specified, the existing computer name is preserved.

A reboot might be required for a new computer name to take effect. If further Winbom.ini processing depends on the new computer name, then setting RebootAfterComputerName = Yes causes that reboot to happen immediately if required.

name
The name of the computer.
*
Generates a random computer name.

Logfile

Value: name_of_logfile
Default: Winbom.log, created in the same directory as Factory.exe.

Specifies an alternate name and location for the log file. This entry is processed when Sysprep starts in Factory mode (Sysprep -factory).

For example:

Logfile = a:\winbom.log

Logging

Value: Yes | No
Default: Yes

Specifies whether Factory records its actions in a file specified by Logfile.

LogLevel

Value: 0 | 1 | 2
Default: Yes

If the value of Logging is Yes, specifies what type of messages are logged in Logfile. All messages at a level less than or equal to LogLevel are recorded.

LogPerf

Value: Yes | No
Default: Yes

Specifies whether the duration of each state processed by Factory is recorded in Logfile. LogPerf is ignored if Logging is No.

NewWinbom

Value: path_to_winbom_file
Default: None

Specifies an alternative location for the Winbom.ini file. If the file exists at this location, Sysprep uses this Winbom.ini file rather than the current Winbom.ini file.

Sysprep searches the following locations in order for a Winbom.ini file:

  1. The path and file name specified by the registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Factory\Winbom.
  2. The root of all removable media drives that are not CD-ROM drives, such as a floppy disk drive.
  3. The root of all CD-ROM drives.
  4. The location of Factory.exe, usually the %systemdrive%\Sysprep folder.
  5. The root of %systemdrive%.

After locating a Winbom.ini file, the Factory tool reads the value of the WinbomType entry.

If the value of WinbomType is not appropriate in this context, the Winbom.ini file is ignored and the Factory tool continues searching for a Winbom.ini file. If the value of WinbomType is appropriate in this context, the Factory tool reads the value of the NewWinbom entry. If a value is specified for NewWinbom, and a Winbom.ini file is located at that location, the Factory tool examines that Winbom.ini file for a NewWinbom entry.

This cycle continues for a maximum of 10 times or until the Factory tool locates a Winbom.ini file that does not contain a NewWinbom entry, whichever occurs first. The Factory tool then continues to run, using the settings in the last identified Winbom.ini file.

NewWinbom is only processed once at each boot when you run Sysprep in Factory mode.

OptimizeShell

Value: Yes | No
Default: Yes

The amount of physical system memory determines the availability of some Windows shell features. The threshold for enabling these features is 128 MB of physical memory. If you make an image of a master installation created on a 64 MB computer and then place that image on a computer with 128 MB (or more) of memory, some shell features may not be enabled.

Yes
Specifies that the Factory tool updates the Windows shell settings based on the amount of physical memory on the computer.
No
Do not change any Windows shell settings based on the physical memory of the computer.

Password

Value: password | *

Sets the password for the account specified by UserName.

password
The password; maximum length is 127 characters.
*
The administrator password is blank or NULL.

If user credentials are required to obtain the Plug and Play drivers and these credentials are not already specified by Domain, UserName, and Password in [PnPDriverUpdate], then Factory mode of Sysprep uses the values of UserName and Password in the [Factory] section.

RebootAfterComputerName

Value: Yes | No
Default: No

Specifies that if a reboot is required after setting FactoryComputerName, it is performed immediately.

If this value is not specified, the computer does not reboot, and the new computer name might not take effect until the next reboot.

Yes
Reboot is done immediately.
No
Computer does not reboot, and the new computer name might not take effect until the next reboot.

Reseal

Value: Yes | No | ForceShutdown | Reboot | Shutdown
Default: No

Specifies the next action of the operating system after Sysprep -factory command completes its work. The options specified in ResealFlags are appended to the Sysprep command.

Yes
Prepare the operating system as specified by ResealMode, then immediately shut down the computer without any end user intervention.
No
Shut down the computer without any end user intervention. Do not run Sysprep.
ForceShutdown
Prepare the operating system as specified by ResealMode, then immediately shut down the operating system without any end user intervention. However, the power to the computer is not turned off. This option applies to non-ACPI computers.
Reboot
Prepare the operating system as specified by ResealMode, then immediately reboot the computer to the first-run experience (either Windows Welcome or Mini-Setup) without any end user intervention. This is most commonly used for testing in the factory environment.
Shutdown
Prepare the operating system as specified by ResealMode, then immediately shut down and turn off the computer without any end user intervention.

ResealFlags

Value: option[, option, ...]
Default: None

Appends one or more command-line options to the Sysprep command used in Reseal. Multiple command-line options must be separated by a space. The value of option can be one of the following:

-activated
Do not reset the clock for Windows Product Activation. If the operating system has already been successfully activated, do not reset the status to nonactivated.
-nosidgen
Run Sysprep without generating new security IDs (SIDs). You must use this option if you are not duplicating the computer on which you are running Sysprep or if you are preinstalling domain controllers.
-pnp
Run the full Plug and Play device enumeration and installation during Mini-Setup. This command-line option has no effect if the first-run experience is Windows Welcome.

Note

  • Other Sysprep command-line options, such as -factory, -noreboot, -reboot, -reseal, or -quiet are already incorporated into the actions of Reseal and ResealMode. Use the Reseal and ResealMode entries, rather than the ResealFlags entry, to initiate the functionality of these command-line options.

ResealMode

Value: Audit | Factory | Mini | OOBE
Default: OOBE on Windows XP Home Edition and Windows XP Professional; Mini on Windows XP 64-Bit Edition and Whistler Server family of products.

Specifies whether Sysprep or the end user first-run application is run on the next reboot of the computer.

Important

  • Windows Welcome is always the first-run application for the Windows XP Home Edition version, and Mini-Setup is always the first-run application for all Whistler Server family of operating systems.

If the value of Reseal is No, this entry is ignored.

Audit
Run sysprep -audit on the next reboot of the computer.
Factory
Run sysprep -factory on the next reboot of the computer.
Mini
Run Mini-Setup on the next reboot of the computer. Default value for Windows 64-Bit Edition and the Whistler Server family of operating systems; not valid for Windows XP Home Edition.
OOBE
Run Windows Welcome (Msoobe.exe) on the next reboot of the computer. Default value for Windows XP Home Edition and Windows XP Professional; not valid for Windows XP 64-Bit Edition or the Whistler Server family of operating systems.

UserName

Value: name

Specifies the name of the account used for operations during Factory mode of Sysprep, including preinstalling applications using [OEMRunOnce]. If you need to specify a domain for this account, include that domain as part of the value of UserName. The password for this account is specified by Password.

If user credentials are required to obtain the Plug and Play drivers and these credentials are not already specified by Domain, UserName, and Password in [PnPDriverUpdate], then the Factory mode of Sysprep uses the values of UserName and Password in the [Factory] section.

Example:

[Factory]
UserName = DomainHQ\User1
Password = 123456password

WinbomType

Value: type[,type]
Default: Factory,OOBE

Specifies whether this Winbom.ini file is used, depending on whether the Winbom.ini file is being processed in Sysprep -factory or in Windows Welcome.

The value of type is one of the following:

Factory
Specifies that this Winbom.ini file is only processed in Sysprep -factory.
OOBE
Specifies that this Winbom.ini file is only processed in Windows Welcome.
None
If the entry is not present, then there are no restrictions on which tools can use this Winbom.ini file.


[NetCards] (Winbom.ini)

banner

[NetCards]

  • NICPnPID

This section is used to configure the network interface card (NIC) on the destination computer, if a network connection is required.

If this section is present, the NIC on the computer is set up, and a default Transmission Control Protocol/Internet Protocol (TCP/IP) stack with Microsoft Network and Novell NetWare redirectors is configured.

If this section does not contain any entries, the Sysprep -factory command scans all present .inf files for a NET class driver that matches the NIC on the computer. If no driver is found, the Sysprep -factory command logs a failure.

If this section does contain entries, only the entries present are matched against the NIC installed on the computer. Optionally, you can suppress the error, and a scan is performed if the DoDeviceIDScanOnError value in the [Factory] section is set to Yes.

NICPnPID

Value: InfPathName
Default: None

NICPnPID must match the Plug and Play hardware ID of the NIC on the computer.

InfFileName is the name of the .inf file containing the specified NICPnPID.


[OEMLink] (Winbom.ini)

[OEMLink]

This section in Winbom.ini contains parameters to add a graphic and text to the Start menu to provide end users with easy access to an OEM's customized folder, .htm file, or .exe for a tour.

OemBrandLinkText

Value: text
Default: ""

Specifies the text that appears when the mouse hovers over the OEM link.

For example, "Welcome to Fabrikam."

OemBrandIcon

Value: path
Default: %windir%\System32\OEMLinkIcon.ico

Specifies the location of an .ico file. Enclose path in quotes if it is a long file name.

OemBrandLink

Value: path
Default: %windir%\System32\OemLink.htm

Specifies the path to a customized .htm file or an .exe file. Enclose path in quotes if it is a long file name.

OemBrandInfoTip

Value: text
Default: ""

Specifies the text that appears in the ToolTip when the mouse passes over the OEM link image.

Sample [OEMLink] Section

This sample demonstrates how to specify a graphic and text to link to a local Web page for a fictional company named Fabrikam, in the OEMLink area of the Start menu.

[OEMLink]
OemBrandLinkText=Welcome to Fabrikam
OemBrandIcon=%windir%\System32\OemLinkIcon.ico
OemBrandLink=%windir%\System32\OemLink.htm
OemBrandLinkIconTip="Click here to learn more about Fabrikam."


[OEMRun] (Winbom.ini)

banner

[OEMRun]

This section allows an OEM to control how and when external applications and command shell scripts run when auditing the computer in the factory environment, using the Sysprep -factory command.

Any application or command shell script that is accessible on the local computer, or the network if a network card was specified, can be run.

Commands called in the [OemRun] section are processed asynchronously. Each application runs in the order listed in this section, but the application does not wait for a previous application to finish before it runs.

All executable files and shell command scripts listed in this section should run in a fully automated way. If the executable file for a shell command script stops for end user input, or for any other reason requiring end user interaction, it eventually will time out, and an error is logged.

The executable files or command shell scripts listed in this section are the last processing done by the Sysprep -factory command. The executable files or command shell scripts listed in [OEMRunOnce] are processed before the commands listed in [OemRun].

Value: exedescription, exefilepath
Default: None
Required

exedescription
A short description of the executable file. If the description includes spaces, enclose the string in double quotation marks.
exefilepath
A fully qualified path to the executable file or command shell script to be run. Universal Naming Convention (UNC) paths are supported if a network card is specified. The path can contain environment variables, such as %windir%, which are expanded prior to running the specified executable file for command shell script.

Sample [OEMRun] Section

This sample demonstrates how to specify multiple executable files.

[OEMRun]
"Run Near the End", "c:\windows\near.exe"
"Run Next to Last", "\\server\dir\next.exe"
"Run Last", "c:\%windir%\last.bat"


[OEMRunOnce] (Winbom.ini)

banner

[OEMRunOnce]

This section is used to control the running of external applications and command shell scripts during the running of the Sysprep -factory command. Any application or command shell script that is accessible on the local computer, or the network if a network card is specified, can be run.

Commands called in the [OemRunOnce] section are processed synchronously. Each application runs in the order listed in this section, and each command must finish before the next command is run.

Verify that all executable files and shell command scripts listed in this section run in a fully automated way. If the executable file for a shell command script stops for end user input, or for any other reason requiring end user interaction, it will eventually time out, and Sysprep logs an error in Setuperr.log.

The executable files or command scripts listed in this section are processed before any executable files or command scripts listed in the [OEMRun] section.

Value: display_text, { command_line | section_name, {APP | INF | MSI} }

display_text
Specifies text that is displayed in the OemRunOnce dialog box when Sysprep -factory is processing this section.
command_line
Specifies a command-line to run synchronously with respect to the other commands listed in the [OEMRunOnce] section.
section_name
Specifies the name to use in the [section_name] heading within the [OEMRunOnce] section.
APP
The application or command is not an .inf file or an MSI installation package.
INF
The setup application is an .inf file.
MSI
The setup application to run is an MSI installation package.

[section_name]

The [OEMRunOnce] section contains multiple entries that configure preinstalling applications during Factory mode of Sysprep. The applications are preinstalled using the credentials specified by UserName and Password in the [Factory] section of Winbom.ini.

CmdLine

Value: command_line Optional

Specifies any command-line switches to append to the command line, when running the application specified by SetupFile, and InstallType is Attach or Standard.

command_line
Command-line switches.

Note

  • If InstallType is Detach, and SetupFile does not have a value, then CmdLine is ignored.
  • If InstallType is Stage, CmdLine is ignored.

InstallType

Value: Attach | Detach | Stage | Standard

Specifies the method to use when preinstalling applications.

Attach
Runs a setup program located at StagePath, assuming the application files are already staged on the destination computer.
Detach
Removes the directory specified by StagePath.
Stage
Copies the installed files and directories located in SourcePath to StagePath, but do not configure any registry settings. If SetupFile is specified, then StagePath is ignored and Sysprep -factory assumes that SetupFile is a staging installation application.
Standard
Runs a standard, non-MSI setup application using SetupFile located at SourcePath. The command-line options specified by CmdLine are appended to the command line that runs SetupFile. Standard is required if you are installing an application from an .inf file.

Note

  • If InstallType is Standard, you cannot later process a second Winbom.ini file to detach that application.

Reboot

Value: Yes | No
Default: No

Specifies whether to reboot after completing the processing specified by this section.

Yes
Reboots the computer.
No
Does not reboot the computer.

RemoveStagePath

Value: Yes | No
Default: No

Specifies whether to delete the directory specified by StagePath.

Yes
Deletes the StagePath directory and all of its contents.
No
Does not delete the directory.

SectionName

Value: sectionname

Specifies the section in the .inf file that contains the setup directives.

sectionname
The name of the section containing the setup directives used during an .inf installation.

SectionName is required if the value of InstallType is Standard and the application that is processed is an .inf installation.

If InstallType is Attach, Detach, or Stage, then SectionName is ignored

SetupFile

Value: filename

Specifies the setup or uninstall application located at StagePath.

filename
The file name of the setup application. For example, App1.msi.

SetupFile is required if:

  • The value of InstallType is Stage.
  • The value of InstallType is Attach and the setup program is an MSI application.

If the value of InstallType is Standard, SetupFile is either an .inf file or an .exe file.

If the value of InstallType is Detach, SetupFile is assumed to be Uninstall.exe.

SourcePath

Value: source_path

The interpretation of source_path depends on InstallType.

  • If the value of InstallType is Stage, source_path is the location of the files to be staged on the destination computer.
  • If the value of InstallType is Standard, source_path is the location of Setup.exe or an .inf file.

SourcePath is required if the value of InstallType is Stage.

SourcePath is ignored if the value of InstallType is Attach or Detach.

StagePath

Value: stage_path

If InstallType is Stage or Attach, stage_path is the location where the files are placed.

If InstallType is Detach, target_path is the location of the files to be removed.

StagePath is required if:

  • The value of InstallType is Stage.
  • The value of InstallType is Attach and the setup program is an MSI application.
  • The value of InstallType is Detach.

StagePath is ignored if the value of InstallType is Standard.

Summary of Relationships

The following table summarizes the relationships between the various entries in the [OEMRunOnce] sections:

Entry in [OEMRunOnce] | InstallType
 | Attach | Detach | Stage | Standard
CmdLine | Append to SetupFile | Ignored | Ignored | Append to SetupFile
SectionName | Ignored | Ignored | Ignored | Required
SetupFile | Required if attaching an .msi application. Located in StagePath. | Assumed to be Uninstall.exe | Required if staging an .msi application. Located in StagePath. | Name of the .inf or .exe file
SourcePath | Ignored | Ignored | Location of files to be staged | Location of Setup.exe or .inf file
StagePath | Required if attaching an .msi application. Location where files are staged | Required. Location of files to be removed | Required. Location where files are to be staged | Ignored

Sample [OEMRunOnce] Section for Preinstalling Applications

This sample demonstrates how to stage, attach, detach, and install applications during the manufacturing process.

Preparing the Master Installation

In the first Winbom.ini file, the files for three different applications are copied to the master computer, but the applications themselves are not fully installed. When the computer is shut down, it is configured to restart in Factory mode of Sysprep.

[OEMRunOnce]
"Connect to network share", "net use R: \\server\share"
"First Application Stage", "Application1.Stage", MSI
"Second Application Stage", "Application2.Stage", MSI
"Third Application Stage", "Application3.Stage", MSI

[Application1.Stage]
InstallType = Stage
StagePath = "C:\App1_Temp"
SetupFile = "Application_One.msi"
SourcePath = "R:\ApplicationOne"

[Application2.Stage]
InstallType = Stage
StagePath = "C:\App2_Temp"
SetupFile = "Application_Two.msi"
SourcePath = "R:\ApplicationTwo"

[Application3.Stage]
InstallType = Stage
StagePath = "C:\App3_Temp"
SetupFile = "Application_Three.msi"
SourcePath = "R:\ApplicationThree"

[Factory]
ResealMode = Factory
Reseal = Yes

At this point, make an image of the master installation and place this image on the destination computer. The next time the computer starts, it is in the Factory mode of Sysprep, which processes a second Winbom.ini file.

Configuring the Build-to-Order Destination Computer

This second Winbom.ini file causes the first application to be fully installed, and the files for the second application to be located on the computer but the application itself is not installed. The files for the third application are completely removed from the computer. The computer then shuts down and is ready for distribution to the customer.

[OEMRunOnce]
"First Application Attach", "Application1.Attach", MSI
"Third Application Detach", "Application3.Detach", MSI

[Application1.Attach]
InstallType = Attach
StagePath = "C:\App1_Temp"
SetupFile = "Application_One.msi"

[Application3.Detach]
InstallType = Detach
StagePath = "C:\App3_Temp"

[Factory]
ResealMode = OOBE
Reseal = Shutdown


[PnPDrivers] (Winbom.ini)

banner

[PnPDrivers]

This section lists all the updated drivers to be copied onto the computer.

Each line indicates a driver set, which can be one or more files contained in one or more directories. The entire source directory tree is copied to the local computer.

All source directories must be located at the root of the specified source location, a local drive, or a shared network location.

Use [PnPDrivers] to update the drivers on a previously created image of the operating system rather than using OemPnPDriversPath in the [Unattended] section of Sysprep.inf.

Value: targetpath = subdirectory_name

The targetpath is a fully qualified path to the updated driver. The full directory tree at that location is copied. The path can be either to a local drive or a Universal Naming Convention (UNC) path. If targetpath has the keyword FLOPPY:\ as the root, then the first local floppy-disk drive is used. If targetpath has the keyword CDROM:\ as the root, then the first local CD-ROM drive is used.

If targetpath is a UNC path, it must be of the form \\server\share\path, so that a local drive mapping to \\server\share can be established by using the optional user credentials specified by Domain, UserName, and Password in the [PnPDriverUpdate] section. If these entries are not specified in [PnPDriverUpdate], Sysprep in Factory mode uses the values specified by UserName and Password in the [Factory] section of Winbom.ini.

subdirectory_name is a directory located on the local computer in %windir%\Drivers. If the specified path does not already exist, it is created. To copy drivers starting at the root of %windir%\Drivers, specify a single dot (.) for the subdirectory_name.

To specify a directory on the destination computer other than %windir%\Drivers, use the TargetRoot entry in the [PnPDriverUpdate] section.

Example:

[PnPDrivers]
a:\video\video2000=Video2000
\\server\share\video\ati\allinone=AllinOne
FLOPPY:\=Audio
CDROM:\drivers=.

[PnPDriverUpdate]
TargetRoot = %windir%\NewPlace


[PnPDriverUpdate] (Winbom.ini)

banner

[PnPDriverUpdate]

The [PnPDriverUpdate] section in Winbom.ini specifies optional user credentials and a source location of drivers that you want to place on an installed image. You can supply updated drivers from either local media or a network. On the next reboot of the system, Plug and Play installs the updated drivers.

If a specific user account must be used in order to access files from a remote location, then the UserName, Password, and optionally a Domain must be specified, and those user credentials are used to create a connection to the remote location. If these entries are not specified, Sysprep in Factory mode uses the values specified by UserName and Password in the [Factory] section of Winbom.ini.

When the computer restarts in Factory mode, the drivers are copied while the computer is still in system context, before Plug and Play detection occurs.

Drivers supplied through this mechanism must be digitally signed and must have a higher installation rank than drivers provided in the box for the same hardware. See http://www.microsoft.com/hwtest/device/default.asp and the Plug and Play driver installation documentation for more details.

DevicePath

Value: path_and_directory_name[;path_and_directory_name]...
Default: No change to existing setting.

Specifies one or more local directories to append to the device path in the registry, along with any directories listed in the [PnPDrivers] section. Paths are relative to TargetRoot.

Note

  • Use DevicePath when you only need to update the device path to contain directories where you have manually copied driver files. To copy files into these directories at the same time, specify additional directories in the [PnPDrivers] section, instead of in DevicePath.

Domain

Value: domain
Default: None

Specifies the domain for the end user specified by UserName logs on.

Password

Value: password
Default: None

Specifies a valid password for the end user specified by UserName.

TargetRoot

Value: path
Default: %windir%\Drivers

Specifies the location on the local computer where the new drivers are copied. Subdirectories within TargetRoot are specified by the value of subdirectory_name in the [PnPDrivers] section.

Example:

[PnPDrivers]
a:\video\video2000=Video2000
\\server\share\video\ati\allinone=AllinOne
FLOPPY:\=Audio
CDROM:\drivers=.

[PnPDriverUpdate]
TargetRoot = %windir%\NewPlace

In this example, the files in a:\video\video2000 are copied to %windir%\NewPlace\Video2000; the files in \\server\share\video\ati\allinone are copied to %windir%\NewPlace\AllinOne; the files on the floppy disk are copied to %windir%\NewPlace\Audio; and the files in the \drivers subdirectory on the CD-ROM are copied to %windir%\NewPlace.

UpdateInstalledDrivers

Value: Yes | No
Default: Yes if rebooting into Windows Welcome or if a [PnPDrivers] section is present; No otherwise

Specifies whether Plug and Play is called after [PnPDrivers] is processed, to re-enumerate all the installed drivers and install any updated drivers in the driver path.

UserName

Value: username
Default: None

Specifies a valid user name that has appropriate permissions to connect to and copy files from a network share point, using the password specified by Password. If necessary, use Domain to specify the domain.

WaitForPnP

Value: Yes | No
Default: No

Specifies whether the Factory tool waits until Plug and Play detection is complete before processing the remainder of the Winbom.ini file.

Yes
Specifies that the Factory tool waits until Plug and Play detection is complete before processing the remainder of the Winbom.ini file
No
Specifies that the Winbom.ini file continues to be processed, but Sysprep is not started until until Plug and Play detection is complete.


[PnPDrivers] (Winbom.ini)

banner

[SetupHomenet]

This section is used to set up the firewall on a computer with a preconfigured Internet connection.

EnableFirewall

Value: Yes | No
Default: No change to existing settings

Installs the Internet Connection Firewall feature.

If the entry is not present, the default setting is used.

Yes
Enables an Internet Connection Firewall on all local area network (LAN), virtual private network (VPN), and dial-up connections.
No
Disables Internet Connection Firewall on all connections.

Important

The following network connections do not require a firewall:

  • The private network connection of an Internet Connection Sharing
  • A bridged connection


[Shell] (Winbom.ini)

banner

[Shell]

This is the [Shell] section for Winbom.ini. For the Unattend.txt section, see [Shell] (Unattend.txt).

CustomDefaultThemeFile

Value: path_and_file_name
Default: none

Specifies the complete path to a .theme file. Windows XP uses the visual style defined in this file rather than its default visual style.

Enclose path_and_file_name in quotes if it is a long file name. If path_and_file_name contains the environment variable %windir%, you must follow %windir% with a backward slash character.

If a custom theme is specified in CustomDefaultThemeFile, then DefaultThemesOff is ignored. The theme determines whether Windows XP uses the classic Windows visual style.

DefaultStartPanelOff

Value: Yes | No
Default: No change to existing setting

Use the classic Windows Start menu instead of the Windows XP Start menu. Icons for My Computer and My Documents are displayed on the Windows desktop.

DefaultThemesOff

Value: Yes | No
Default: No change to existing setting

Use the classic Windows visual style instead of the default Windows XP visual style.

DefaultThemesOff is ignored if a valid theme is specified in CustomDefaultThemeFile

DelayCleanup

Value: Yes | No
Default: No change to existing setting

Specifies whether the first instance of desktop cleanup is delayed until seven days after the end user first starts the computer.

Specifically, the first time the user starts the computer, any shortcuts installed in the desktop folder (for example, %systemdrive%:\Documents and Settings\UserName\Desktop) are moved to the subfolder of %systemdrive%\Program Files specified by DesktopShortcutsFolderName in the [DesktopShortcutsFolder] section of Winbom.ini. If no folder name is specified, the default location is %systemdrive%\Program Files\Program Shortcuts.

If the initial cleanup is delayed, then seven days after the first-run experience, the Desktop Cleanup wizard runs for the first time. This wizard allows the end user to place unused Windows desktop icons and folders into the "Unused Desktop Items" folder on the desktop.

MSNExplorer

Value: Yes | No
Default: No change to existing setting

Specifies whether to replace the MSN Explorer shortcut with a shortcut to MSN Internet Access.

Important

  • Do not change the MSN Explorer icon unless you install an alternative browser and uninstall any visible entry points (shortcuts) to Internet Explorer, using the IEAccess entry in the [Components] section of Winbom.ini or Unattend.txt.
  • Do not change the MSN Explorer icon if the MSN Internet Access sign-up offer is available to the end user in Windows Welcome.

StartMessenger

Value: Yes | No
Default: No change to existing setting

Specifies whether Windows Messenger starts automatically when the end user logs in to Windows XP.

Yes
Windows Messenger start automatically when the end user logs in to Windows XP.
No
Windows Messenger does not start automatically when the end user logs in to Windows XP.

Note

  • After the end user explicitly starts Windows Messenger, either from the Start menu or by using Windows Messenger functionality from within an application, Windows Messenger will subsequently start automatically on each log in.


[StartMenuMFUList] (Winbom.ini)

banner

[StartMenuMFUList]

On Windows XP, the Start menu contains a set of shortcuts to the Most Frequently Used programs on the computer. Windows XP automatically manages this set of shortcuts over time as end users use their computer. OEMs can prepopulate the Most Frequently Used programs list with shortcuts to preinstalled applications, as specified in their OEM License Agreement and in the Preinstallation Requirements and Customization Guidelines section of the OEM Preinstallation Kit User's Guide.

Each of these items in the [StartMenuMFUList] section specify the complete path and file name of a shortcut (.lnk) file on the destination computer.

The value of linkpath must refer to an .lnk file in one of the following locations. You can use environment variables such as %ALLUSERSPROFILE% as part of the path.

  • The All Users Desktop directory.

    "C:\Documents and Settings\All Users\Desktop"

  • The All Users Programs directory or one of its subdirectories.

    For example: "C:\Documents and Settings\All Users\Start Menu\Programs"

You may also use linkpath to refer to an .lnk file located in one of the following locations. However, unless you know the name of the user accounts that will be configured on the computer, the end user will not be able to use these options.

  • A user-specific Desktop directory.

    For example: "C:\Documents and Settings\UserId\Desktop", where UserID is the name of a user account that will be used by the end user.

  • A user-specific Programs directory or one of its subdirectories.

    For example: "C:\Documents and Settings\UserId\Start Menu\Programs", where UserID is the name of a user account that will be used by the end user.

The value of linkpath is not a path to an application (.exe). Instead, the location of the corresponding .exe file is specified in the shortcut itself.

When building a master installation, be sure the .lnk file is located within the %OEM$ directory in a location equivalent to the one specified by linkpath, so that the .lnk file is installed during unattended Setup.

Sysprep adds these links to the Most Frequently Used programs list, located below the separator line on the Start menu. These entries have no effect on the "All Programs" area of the Start menu.

Note

  • You may include up to four links in the [StartMenuMFUList] section. However, only the first three items appear in the Most-Frequently-Used list in the Start menu, unless one of these three items duplicates or replaces a pre-populated Microsoft item. In that case, the fourth link is included in the Most-Frequently-Used list.

Link0

Value: link_path
Default: None

The full path and file name of an .lnk file installed on the destination computer. Enclose linkpath in quotes if it is a long file name.

Link1

Value: link_path
Default: None

The full path and file name of an .lnk file installed on the destination computer. Enclose linkpath in quotes if it is a long file name.

Link2

Value: link_path
Default: None

The full path and file name of an .lnk file installed on the destination computer. Enclose linkpath in quotes if it is a long file name.

Link3

Value: link_path
Default: None

The full path and file name of an .lnk file installed on the destination computer. Enclose linkpath in quotes if it is a long file name.

Sample [StartMenuMFUlist] Section

This sample demonstrates how to specify links to MSN Explorer, Wordpad, and Windows Media Player in the Most Frequently Used programs list on the Start menu.

[StartMenuMFUlist]
Link0="C:\Documents and Settings\All Users\Start Menu\Programs\MSN Explorer.lnk"
Link1="C:\Documents and Settings\All Users\Start Menu\Programs\Accessories\WordPad.lnk"
Link2="C:\Documents and Settings\All Users\Start Menu\Programs\Accessories\Entertainment\Windows Media Player.lnk"


[UpdateSystem] (Winbom.ini)

banner

[UpdateSystem]

This section is used to update any of the computer's files or registry entries. The format of this section conforms to Windows .inf processing standards.

The entries in [UpdateSystem] are directives, used to perform operations on the registry or the file system. For information about .inf sections and directives, see the Microsoft Driver Development Kit.

The section names in .inf files can be defined by you, or you can use the predefined system names. [UpdateSystem] in the following sample is an example of a user-defined name and [SourceDisksFiles] is an example of a system-defined name.

By declaring the directives in [UpdateSystem], you can then append them to UpdateSystem to create user-defined section names, such as [UpdateSystem.AddReg].

Example 1: Using [UpdateSystem] for file management

The following sample uses user-defined and system-defined section names and directives.

[UpdateSystem]
AddReg    = UpdateSystem.AddReg
DelReg    = UpdateSystem.DelReg
CopyFiles = UpdateSystem.CopyFiles
RenFiles  = UpdateSystem.RenFiles
DelFiles  = UpdateSystem.Delfiles

[UpdateSystem.AddReg]
HKLM, "Software\Test","String Value", "Value"
HKLM, "Software\Test","Number Value",0x00010001, 10

[UpdateSystem.DelReg]
HKLM, "Software\Test", "Delete Value"
HKLM, "Software\Test2"

[UpdateSystem.CopyFiles]
file.dat

[UpdateSystem.RenFiles]
file2.old, file2.dat

[UpdateSystem.Delfiles]
file3.dat, 0x00000001

[SourceDisksFiles]
file.dat=776

[SourceDisksNames]
776="Boot Drive", "", 0, "\Source"

[DestinationDirs]
UpdateSystem.CopyFiles =30,"\Dest"
UpdateSystem.RenFiles  =30,"\Dest"
UpdateSystem.Delfiles  =30,"\Dest"

The UpdateInis Directive

The UpdateInis directive is extremely useful. Each named section referenced by an UpdateInis directive has the following form:

[UpdateThisFile]

Value: ini_file_and_path, ini_section[, old_ini_entry][, new_ini_entry][, flags]

An [UpdateThisFile] section can have any number of entries, each on a separate line.

ini_file_and_path
Specifies the name of the .ini file to be updated on the destination computer.
ini_section
Specifies the name of the section within the .ini file. If old_ini_entry and new_ini_entry are specified, the value of the entry is changed. If old_ini_entry is omitted but new_ini_entry is provided, the entry is added to the section.
old_ini_entry
Specifies the name of an entry within the given ini_section, usually expressed as "entry = value". The asterisk (*) can be specified as a wildcard for either entry or value.
new_ini_entry
Specifies either a change to a give old_ini_entry or the addition of a new entry, expressed in the same manner as old_ini_entry.
flags
This parameter is only used in advanced cases. See the Microsoft Driver Development Kit for more information.

Example 2: Using [UpdateSystem] and the UpdateInis Directive to modify .ini files

Example 2: Using [UpdateSystem] and the UpdateInis Directive to modify .ini files

The following example using the UpdateInis directive.

In this example, the [Unattended] and [GuiUnattended] sections of Sysprep.inf are updated.

[UpdateSystem]
UpdateInis = UpdateSysprepLikeThis

[UpdateSysprepLikeThis]
C:\sysprep\sysprep.inf, Unattended, , OemPreinstall = Yes
C:\sysprep\sysprep.inf, Unattended, , OemSkipEula = yes

[Sysprep.inf.GuiUnattended]
C:\sysprep\sysprep.inf, GuiUnattended, , AdminPassword = *
C:\sysprep\sysprep.inf, GuiUnattended, , AutoLogonCount	= 1
C:\sysprep\sysprep.inf, GuiUnattended, , OemSkipRegional = Yes
C:\sysprep\sysprep.inf, GuiUnattended, , OemSkipWelcome = yes
C:\sysprep\sysprep.inf, GuiUnattended, Timezone = 8, Timezone = 4


[UserAccounts] (Winbom.ini)

banner

[UserAccounts]

This section controls the creation of user accounts on the destination computer.

name

Value: name
Default: none

name is a unique value for the destination computer. It is also a portion of a section name in Winbom.ini of the form [name.Account] that contains all of the entries of the new account.

The value of name must be unique. Use a friendly, familiar name for each user account, such as "Michael", rather than a randomly generated or overly technical name, such as "User12345".

[name.Account]

This section controls the creation of a specific user account, and is used with [UserAccounts].

Alias

Value = alias
Default: Value of Name

The alias to be used for the account. The alias is displayed in the Windows logon/sign-in screen, for example.

Description

Value = description
Default: blank

The description of the account.

Passport

Value = passport
Default: blank

The Windows Passport account associated with this user account.

Example:

[Mom.Account]
Description = Mom’s Account
Password=123456password
Alias=Mom
Passport=Mom@hotmail.com

Password

Value = password
Default: blank

The password to be used for the account.

Example [UserAccounts] sections

[UserAccounts]
Mom
Dad
Son

[Mom.Account]
Description = Mom’s Account
Password=123456password
Alias=Mom
Passport=Mom@hotmail.com

[Dad.Account]
Description=Dad’s Account
Password=654321password
Alias=Dad
Passport=dad@passport.com

[Son.Account]
Description=Son’s Account
Password=2468password
Alias=Son
Passport=son@passport.com


[UserDefined] (Winbom.ini)

banner

[UserDefined]

This is an end-user defined section that can contain branding information or any other data that other processes might need to access.

This section can use any name other than the existing reserved section names used in Winbom.ini.


Internet Settings (.ins) Files

The Internet settings (.ins) file is the mechanism used to configure computers for broadband or dial-up Internet access during Windows Welcome. At the end of the Internet service provider (ISP) sign-up offer, the ISP sign-up server creates an .ins file that contains the specified Internet settings and returns the file to the computer. Windows Welcome then processes the .ins file and applies the settings to the computer.

The .ins file is used to configure dial-up networking, Connection Manager, Microsoft® Internet Explorer, and Microsoft® Outlook Express. For broadband Internet connections, the .ins file can also contain Transmission Control Protocol/Internet Protocol (TCP/IP) and other connection-related settings.

For more information, see Internet Settings (.ins entries) for Broadband Connections.

The following sections appear in the .ins files:

Section | Description
[Animation] | Specify the location of your custom animated bitmap files that appear in the Setup Wizard.
[ActiveSetup] | Specify the location of your custom bitmap files that appear in the Internet Explorer 6 Customization Wizard.
[ActiveSetupSites] | Specify the names and locations of the custom packages that you make available to your users as a download.
[Batch] | Specify the types of installation media available for your custom package.
[Big_Logo] | Specify the name and path of your 38-by-38 pixel bitmap file that appears in the top right corner of the browser.
[Branding] | Specify information about the custom branding and setup information included in your browser package.
[BrowserToolbars] | Customize the appearance of the Microsoft Internet Explorer toolbar.
[CabSigning] | Specify the information that is used to sign your programs.
[ConnectionSettings] | Specify information about the dial-up networking (DUN) connection settings used to install your custom Internet Explorer package. This creates a common DUN on all users' workstations.
[CustomBranding] | Specify the URL for your branding cabinet file.
[CustomWallpaper] | Specify the HTML and supporting files for your custom wallpaper.
[Device] | Specify the type of connection used for setup.
[Entry] | Specify whether the information in this .ins file overrides the name of the dial-up networking in your custom package.
[ExtRegInf] | Specify the names of your information (.inf) files and the installation mode for components.
[FavoritesEx] | Specify the path to your icon file for Favorites and whether Favorites are available offline. You can also specify the URL to each Favorite site.
[HideCustom] | Specify whether the globally unique identifier (GUID) is hidden. Each custom component has a GUID that is based on system information and other parameters, such as the time of day it is created.
[ICW_IEAK] | Specify the path to your custom bitmaps that appear in the Internet Connection Wizard.
[Internet_Mail] | Specify your custom Outlook Express information.
[Internet_News] | Specify your custom news information and whether Outlook Express is the default news client.
[ISP_Security] | Specify the root certificate you are adding to your custom package.
[LDAP] | Specify information for your Lightweight Directory Access Protocol (LDAP) server. Also specify whether Outlook Express always checks names and e-mail addresses against the LDAP server.
[Mail_Signature] | Specify an e-mail signature for news and whether to use the signature.
[Media] | Specify the types of media your installation package is available in, such as CD, download, and floppy disk.
[Outlook_Express] | Specify which pieces of Outlook Express you are branding or customizing in your package.
[Outlook_Express_Global] | Specify your branding for the Outlook Express service.
[Phone] | Specify the telephone information that is used for your dial-up connection.
[Proxy] | Specify whether to use a proxy server and the host names for the proxy server.
[Script_File] | Specify the text of the script file that is associated with dial-up networking.
[Scripting] | Specify the names and paths of your dial-up networking script files.
[Security Imports] | Specify whether to import security information from your computer to your custom package.
[Server] | Specify information about your network server.
[Signature] | Specify whether to use an Outlook Express signature and the text of that signature.
[SignupFiles] | Specify the name of the files that appear during sign-up, such as sign-up.htm.
[Small_Logo] | Specify the name and path of your 22-by-22 pixel bitmap file that appears in the top right corner of the browser.
[TCP/IP] | Specify the IP number of the DNS server to use. You can also specify whether to use a remote gateway, an IP address, and a server address.
[URL] | Specify whether to use an auto-configured proxy server and the URLs for the pages that appear when users connect to that server.
[User] | Specify the logon information required by your users.


Sample .ins File (.ins)

banner

Sample .ins File

Here is a sample .ins file.

[Entry]
Entry_Name=Fabrikam

[Phone]
Dial_As_Is=no
Phone_Number=555-4567
Area_Code=206
Country_Code=1
Country_ID=1

[Server]
Type=PPP
SW_Compress=yes
PW_Encrypt=no
Negotiate_TCP/IP=yes

[TCP/IP]
Specify_IP_Address=no
Specify_Server_Address=no
IP_Header_Compress=yes
Gateway_On_Remote=yes

[User]
Name=InternetUser
Password=secret

[Favorites]
Microsoft Software and Service\Microsoft Product Support Services URL=http://www.microsoft.com/support/
Microsoft Software and Service\The Microsoft Corporation URL=http://www.microsoft.com/


Internet Settings (.ins entries) for Broadband Connections

In Windows Millennium Edition, Windows Welcome is enhanced to allow for the configuration of a new broadband Internet account. The following settings are extensions to the existing .ini file format that enable this broadband configuration. These settings replace any similar settings described in the .ins entries for dial-up connections.

[Device]
Type = {modem, isdn, atm, ethernet, ethernet_1483, cable(?)}
Modem, ISDN and ATM will bind entries to RAS
Modem, ISDN and Ethernet (& cable) look only for [TCP/IP] header
ATM looks for [TCP/IP] and [ATM] headers
Ethernet_1483 looks for [TCP/IP] and [Ethernet_1483] headers
PPPOE looks for [TCP/IP] and [PPPOE] headers
Name = {friendly name of the device}
Pnpid = {Plug and Play ID of the device, or for multifunction
adapters, only the Plug and Play ID of the configured-network device required}

Note

  • The OEM places the device name and Plug and Play ID of the broadband device on the computer before shipping it. This information is transmitted to the Internet service provider (ISP) during the end user sign-up process. The ISP then adds these entries to the .ins file so that the correct device is configured during the sign-up process.
[TCP/IP]
Specify_IP_Address = {yes for static, no for DHCP}
IP_Address = {static IP address if used}
Subnet_Mask = {ip address}
Specify_DNS_Address = {yes if use, else no}
DNS List = {ip address},{ip address}, …
IP_Header_Compress = {yes if used, else no}
Gateway_On_Remote = {yes if used, else no}
Default_Gateway_List = {ip address},{ip address}, …
Domain_Name = {string},{string}, …
Host_Name = {string if used}
Domain_Suffix_Search_List = {ip address},{ip address}, …
Specify_WINS_Address = {yes,no}
WINS_List = {ip address},{ip address}, …
[PPPoverATM] or [Ethernet_1483]
Circuit_Speed = {flag}
0 = Line Rate
1 = User Specified
Or actual value of rate in kilobytes (512, 1536, 25000, 155000)
Circuit_QOS = {flag}
0 = UBR
1 = VBR
2 = CBR
3 = ABR
Circuit_Type = {0 if SVC, 1 if PVC}
Speed_Adjust = {yes or no}
QOS_Adjust = {yes or no}
Encapsulation = {flag}
0 – PPP over ATM (null encapsulation)
1 – PPP over ATM (LLC)
2 – Bridged Ethernet/802.3 (LLC/SNAP) Not defined for PPPOA
3 – Routed IPv4 (LLC/SNAP) Not defined for PPPOA
4 – Bridged Ethernet/802.3 (null encapsulation) Not defined for
PPPOA
5 – Routed IPv4 (null encapsulation) Not defined for PPPOA
VPI = {numeric value} Only for PVC
VCI = {numeric value}
Vendor_Config = {yes or no}
Show_Status = {yes or no}
Enable_Log = {yes or no}
[Phone]
PhoneNumber = NSAP address if ATM, else phone number

Note

  • These are extensions to the existing .ins file format that work only in the Out-Of-Box Experience (Windows Welcome) for Windows Me.


[Animation](.ins)

[Animation]

Big_Name

Value: file name

Name of the bitmap file that contains the frames for the 38x38-pixel animation.

Big_Path

Value: file path

Full path to the 38x38-pixel animated bitmap file.

DoAnimation

Value: 0 | 1

Specifies whether to customize the animation. Set to 1 to customize the animation.

Small_Name

Value: file name

Name of the bitmap file that contains the frames for the 22x22-pixel animation.

Small_Path

Value: file path

Full path to the 22x22-pixel animated bitmap file.


[ActiveSetup](.ins)

[ActiveSetup]

Name

Value: file name

The name of the 38 by 38-pixel bitmap file that appears in the top-right corner of the browser window.

Path

Value: file path

The path to the 38 by 38-pixel bitmap file that appears in the top-right corner of the browser window.


[ActiveSetupSites](.ins)

[ActiveSetupSites]

SiteName0

Value: string

Friendly name of the site from which users download files.

SiteRegion0

Value: string

Geographical region where the first download site is located.

SiteURL0

Value: URL

URL of the first download site.

SiteName1

Value: string

Friendly name of the second site from which users download files.

SiteRegion1

Value: string

Geographical region where the second download site is located.

SiteURL1

Value: URL

URL of the second download site.

SiteNameX

Value: string

Friendly name of the third or subsequent site users download files from.

SiteRegionX

Value: string

Geographical region where the third or subsequent download site is located.

SiteURLX

Value: URL

URL of the third or subsequent download site.

TestCertsOK

Value: 0 | 1

Specifies whether to use test certificates. Set to 1 to use test certificates.


[Batch](.ins)

[Batch]

Build_CD

Value: 0 | 1

Specifies whether you are building a custom package for CD distribution. Set to 1 to build a package for CD distribution.

Build_Floppy

Value: 0 | 1

Specifies whether you are building a custom package for distribution on a single floppy disk. Set to 1 to build a package for distribution on a single floppy disk.

Build_MultiFloppy

Value: 0 | 1

Specifies whether you are building a custom package for distribution on multiple floppy disks. Set to 1 to build a package for distribution on multiple floppy disks.

Build_W31

Value: 0 | 1

Specifies whether to build a package for distribution to Windows 3.1 users. Set to 1 to build a package for distribution to Windows 3.1 users.


[Big_Logo](.ins)

[Big_Logo]

Name

Value: file name

The name of the 38 by 38-pixel bitmap file that appears in the upper-right corner of the browser window.

Path

Value: file path

The path to the 38 by 38-pixel bitmap file that appears in the upper-right corner of the browser window.


[Branding] (.ins)

banner

[Branding]

Add on URL

Value: http://server/addons/addon.htm

Add-on URL for Product Updates command in browser.

BrowserDefault

Value: 0 | 1 | 2

In corporate administrator mode, the value is set to 0 to lock down Internet Explorer as the default browser; to 1 to preserve the existing default browser; or to 2 to let the end user decide.

CMBitmapName

Value: file_name

Specifies the file name of the Connection Manager custom bitmap.

CMBitmapPath

Value: path

Specifies the full path to the Connection Manager custom bitmap file.

CMProfileName

Value: file_name

Specifies the name of the Connection Manager profile.

CMProfilePath

Value: path

Specifies the full path to the Connection Manager profile.

CMUseCustom

Value: 0 | 1

Specifies whether to use a custom Connection Manager profile. Set this value to 1 to use a custom profile.

CompanyName

Value: name

Specifies the name of the company with a valid Internet Explorer Administration Kit (IEAK) license that is building this .ins file.

EncodeFavs

Value: 0 | 1

Set this value to 1 to correctly encode the [Favorites] section generated by the IEAK for versions of Internet Explorer earlier than 5.0.

FavoritesDelete

Value: hexadecimal

Set this value to 0x89 to remove all pre-existing Favorites and Quick Links. This feature is only for use by corporate administrators.

FavoritesOnTop

Value: 0 | 1

Set this value to 1 to add new favorites to the top of the Favorites menu.

IE4WelcomeMsg

Value: 0 | 1

Set this value to 1 to go to a welcome page the first time the browser is opened.

LanguageID

Value: number

The code page of the language used.

LanguageLocale

Value: locale

The locale of the Internet Explorer version being customized, as denoted by a two-letter string — for example, EN for English.

NoDial

Value: 0 | 1

For ISPs: set this value to 1 if you are not using any kind of an IEAK-based sign-up process.

NoIELite

Value: 0 | 1

Set this value to 1 if you want the Active Setup wizard to optimize for downloading, using existing files if possible.

SilentInstall

Value: 0 | 1

For corporate administrators: set this value to 1 if you want Windows Update Setup to run noninteractively, but to show progress and error messages.

StealthInstall

Value: 0 | 1

For corporate administrators: set this value to 1 if you want Windows Update Setup to run without any visual feedback.

ToolbarBitmap

Value: path_and_file_name

The full path to the bitmap that appears on the browser toolbar.

Type

Value: 0 | 1 | 2

Specifies the type of customization being used: 2 = Corporate Administrator, 1 = Internet service provider, 0 = Internet content provider.

UserAgent

Value: string

The string that is appended to the default User Agent string.

Version

Value: string

The browser version — for example, 5, 0, 0, 1.

WebIntegrated

Value: 0 | 1

Specifies whether the Internet Explorer 4.x integrated shell is included in this package. Set this value to 1 if it is included.

Win32DownloadSite

Value: url

The URL from which the Windows Update Setup file (IEsetup.exe) is downloaded.

Window_Title

Value: string

The customized window title for Internet Explorer.

Window_Title_CN

Value: string

The company name that is appended to the window title.

WizardVersion

Value: string

The version of the IEAK wizard that created the .ins file. For example, 5.00.0707.2800.


[BrowserToolbars] (.ins)

banner

[BrowserToolbars]

Action0

Action0

Value: path_and_file_name

Path and file name for the executable file associated with a custom toolbar button.

Caption0

Value: caption

The caption for the custom toolbar button.

DeleteButtons

Value: 0 | 1

Specifies whether to delete existing custom toolbar buttons during installation. Set this value to 1 to delete the buttons.

HotIcon0

Value: path_and_file_name

The highlighted icon (an .ico file) that appears on the button when it is moused over.

Icon0

Value: path_and_file_name

The dimmed icon (an .ico file) that appears on the button when it is not moused over.

Show0

Value: 0 | 1

Specifies whether to display the new button on the toolbar by default. Set this value to 1 to display the button.

ToolTipText0

Value: text

ToolTip text for the custom button.


[ConnectionSettings] (.ins)

banner

[ConnectionSettings]

ConnectName0

Value: string

The name for the connection.

ConnectName1

Value: string

DeleteConnectionSettings

Value: 0 | 1

Specifies whether to remove the existing connection settings during installation. In corporate Administrator mode only: Set this value to 1 to remove the settings.

Option

Value: 0 | 1

Set this value to 1 to give the end user the option to import connection settings in the IEAK Wizard.


[CabSigning](.ins)

[CabSigning]

InfoURL

Value: URL

The URL that appears on the certificate dialog box.

Name

Value: string

The company name that is associated with the certificate.

pvkFile

Value: file path

The path to the privacy key file.

spcFile

Value: file path

The path to the certificate file.


[CustomBranding](.ins)

banner

[CustomBranding]

Branding

Value: url

URL for the branding .cab file, for example, http://www.yourserver.net/cabs/branding.cab.


[CustomWallpaper] (.ins)

banner

[CustomWallpaper]

File0

Value: file_name

The HTML file for the custom wallpaper, also known as background, to be installed.

File1

Value: file_name

The supporting files for custom background.

NumFiles

Value: 2

The total number of files for custom background.


[Device] (.ins)

banner

[Device]

Type

Value: string

The type of connection used for Windows Update Setup (for example, modem).


[Entry] (.ins)

banner

[Entry]

Cancel

Value: Yes | No

Specifies whether to cancel the sign-up process. Used by the Internet Connection Wizard. If the value is set to Yes, then this .ins file cancels the sign-up process.

Entry_Name

Value: string

The name of the Dial-Up Networking (DUN) connection.


[ExtRegInf](.ins)

[ExtRegInf]

Chat

Value: string

Information (.inf) file and install mode for components, for example: *,chat.inf,DefaultInstall.

Conf

Value: string

Information (.inf) file and install mode for components, for example: *,conf.inf,DefaultInstall.

Inetres

Value: string

Information (.inf) file and install mode for components, for example: *,inetres.inf,DefaultInstall.

Inetset

Value: string

Information (.inf) file and install mode for components, for example: *,inetset.inf,DefaultInstall.

Oe

Value: string

Information (.inf) file and install mode for components, for example: *,oe.inf,DefaultInstall.

Shell

Value: string

Information (.inf) file and install mode for components, for example: *,shell.inf,DefaultInstall.

Sp1shell

Value: string

Information (.inf) file and install mode for components, for example: *,sp1shell.inf,DefaultInstall.

Subs

Value: string

Information (.inf) file and install mode for components, for example: *,subs.inf,DefaultInstall.

ConnectionSettings

Value: string

Information (.inf) file and install mode for components, for example: *,connect.inf,DefaultInstall.


[FavoritesEx] (.ins)

banner

[FavoritesEx]

IconFile1

Value: path_and_file_name

The icon for the favorite to be added.

Offline1

Value: 0 | 1

Specifies whether the favorite will be available for offline browsing. Set this value to 1 to make it available.

Title1

Value: string

The title of the favorite.

Url1

Value: url

The URL for the favorite.


[HideCustom](.ins)

[HideCustom]

GUID

Value: 0 | 1

Specifies whether this is a hidden component. Set to 1 if this is a hidden component.


[ICW_IEAK](.ins)

[ICW_IEAK]

Header_Bitmap

Value: file path

Specifies the path to the custom header bitmap file that appears in the Internet Connection Wizard (ICW).

Watermark_Bitmap

Value: file path

Specifies the path to the custom watermark bitmap that appears in the ICW.


[Internet_Mail] (.ins)

banner

[Internet_Mail]

Default_Client

Value: Yes | No

Specifies whether Internet Mail is the default client (for Internet Explorer 4.x Custom).

Infopane

Value: path_and_file_name

The HTML file for the branded infopane of customized Outlook Express.

Infopane_Bitmap

Value: path_and_file_name

The branded .gif file for customized Outlook Express.

Junk_Mail_Filtering

Value: 0 | 1

Specifies whether to activate the junk-mail filtering feature by default. Set this value to 1 to activate this feature.

Logon_Using_SPA

Value: Yes | No

Specifies whether to log on using Secure Password Authentication.

POP_Server

Value: string

The host name of the POP3 Server to be set by default.

For example: pop.fabrikam.com

SMTP_Logon_Required

Value: 0 | 1

Specifies whether to require logging on to the Simple Mail Transfer Protocol (SMTP) Server by default. If the value is set to 1, this requires logging on.

SMTP_Logon_Using_SPA

Value: Yes | No

Specifies whether to log on to the SMTP Server using Secure Password Authentication.

SMTP_Server

Value: string

The host name of the SMTP server this is set by default.

For example: smtp.fabrikam.com

Use_IMAP

Value: Yes | No

Specifies whether to use the IMAP4 protocol for e-mail.

Welcome_Address

Value: string

The "From Address" for the Welcome message in Outlook Express.

For example, welcome@fabrikam.com

Welcome_Message

Value: path_and_file_name

The location of the HTML file containing the Welcome message.

Welcome_Name

Value: string

The friendly name of the "From Address" for the welcome message — for example, "Welcome To Custom Internet Mail!"

Window_Title

Value: string

The custom window title for Outlook Express.


[Internet_News] (.ins)

banner

[Internet_News]

Default_Client

Value: Yes | No

Specifies whether to use Outlook Express as the default news client.

Logon_Required

Value: 0 | 1

Specifies whether the Network News Transfer Protocol (NNTP) server requires that end users log on to it. Set this value to 1 if end users must log on.

Logon_Using_SPA

Value: Yes | No

Specifies whether the NNTP server uses Secure Password Authentication.

NNTP_Server

Value: string

The host name of your NNTP server.

For example: news.fabrikam.com


[ISP_Security] (.ins)

banner

[ISP_Security]

RootCertPath

Value: path_and_file_name

A root certificate to add to the system.


[LDAP] (.ins)

banner

[LDAP]

AuthType

Value: 0 | 2

Specifies how the Windows Address Book accesses directory services. Set to 0 to authenticate through the built-in access to popular directories. Set to 2 to authenticate through SPA. For more information, see Address Book Directory Service.

Bitmap

Value: path_and_file_name

C:\My Documents\Branding\LDAP.bmp

Checknames

Value: 0 | 1

Specifies whether to have Outlook Express always check names and e-mail addresses against the Lightweight Directory Access Protocol (LDAP) server. Set this value to 1 to make Outlook Express always check.

FriendlyName

Value: string

The friendly name for the LDAP server account.

HomePage

Value: url

The location of the home page for the browser.

SearchBase

Value: url

The location of the search page for the browser.

Server

Value: string

The host name of LDAP server — for example, LDAP-SRV-1.


[Mail_Signature] (.ins)

banner

[Mail_Signature]

Signature_Text

Value: string

The boilerplate text that is automatically added to the end of e-mail messages or newsgroup postings. The text ends with the characters "\n".

Use_Mail_For_News

Value: 0 | 1

Specifies whether to append the value of Signature_Text to the end of postings to newsgroups. Set this value to 1 to include the signature.

Use_Signature

Value: 0 | 1

Specifies whether to append the value of Signature_Text to the end of e-mail messages. Set this value to 1 to include the signature.


[Media](.ins)

[Media]

Build_CD

Value: 0 | 1

Specifies whether you are creating a CD installation package. Set to 1 to create the package.

Build_Download

Value: 0 | 1

Specifies whether you are creating an installation package that your users can download. Set to 1 to create the package.

Build_Floppy

Value: 0 | 1

Specifies whether you are creating a branding-only installation package that fits on a single floppy disk. Set to 1 to create the package.

Build_LAN

Value: 0 | 1

Specifies whether you are creating a LAN-based installation package. Set to 1 to create the package.

Build_MultiFloppy

Value: 0 | 1

Specifies whether you are creating an installation package that fits on multiple floppy disks. Set to 1 to create the package.


[Outlook_Express] (.ins)

banner

[Outlook_Express]

Contacts

Value: 0 | 1

Specifies whether to display contacts by default.

Folder_Bar

Value: 0 | 1

Specifies whether to display the folder bar by default.

Folder_List

Value: 0 | 1

Specifies whether to display the folder list by default.

Outlook_Bar

Value: 0 | 1

Specifies whether to display the Outlook bar by default.

Preview_Pane

Value: 0 | 1

Specifies whether to display the preview pane by default.

Show_Preview_Beside_Msgs

Value: 0 | 1

Specifies whether to display the message preview. If the value is set to 1, the display message will preview.

Show_Preview_Header

Value: 0 | 1

Specifies whether to display the preview pane header bar by default.

Show_Toolbar_Text

Value: 0 | 1

Specifies whether to display the toolbar text by default.

Status_Bar

Value: 0 | 1

Specifies whether to display the status bar by default.

Tip_Day

Value: 0 | 1

Specifies whether to display the tip of the day by default.

Toolbar

Value: 0 | 1

Specifies whether to display the toolbar by default.


[Outlook_Express_Global] (.ins)

banner

[Outlook_Express_Global]

Read_Only

Value: 0 | 1

Specifies whether to make server names read-only in the Outlook Express settings. Set to 1 to make the server names read-only.

Service_Name

Value: name

A company name.

Service_URL

Value: url

The location of the e-mail service.


[Phone] (.ins)

banner

[Phone]

Area_Code

Value: number

The area code for the dial-up connection.

Country_Code

Value: number

The country\region code for the dial-up connection.

Country_ID

Value: number

The country\region ID number for the dial-up connection.

Dial_As_Is

Value: Yes | No

Dials the phone number as is, without appending an area code or any other numbers.

Phone_Number

Value: number

The phone number to dial.


[Proxy] (.ins)

banner

[Proxy]

FTP_Proxy_Server

Value: proxy

The host name for the proxy server.

Gopher_Proxy_Server

Value: proxy

The host name for the proxy server that uses the Internet utility Gopher.

HTTP_Proxy_Server

Value: proxy

The host name for proxy server that uses the Hypertext Transfer Protocol (HTTP).

Proxy_Enable

Value: 0 | 1

Specifies whether to use a proxy server.

Proxy_Override

Value: string

The host name for the proxy server — for example, <LOCAL>.

Secure_Proxy_Server

Value: proxy

The host name for the proxy server.

Socks_Proxy_Server

Value: proxy

The host name for the proxy server that uses SOCKS, a security package.

Use_Same_Proxy

Value: 0 | 1

Specifies whether to use one proxy server for all services.


[Script_File] (.ins)

banner

[Script_File]

1

Value: text

The first line of the script file.

2

Value: text

The second line of the script file.

3

Value: text

The third line of the script file.

n

Value: text

The text of line n in the script file.


[Scripting] (.ins)

banner

[Scripting]

Name

Value: file_name

The file name of the Network Connections script — for example, sis.scp.

Name16

Value: file_name

The file name of the 16-bit Network Connections script.

Name32

Value: file_name

The file name of the 32-bit Network Connections script.

Path16

Value: path_and_file_name

The full path to the 16-bit script.

Path32

Value: path_and_file_name

The full path to the 32-bit script.


[Security Imports] (.ins)

banner

[Security Imports]

ImportAuthCode

Value: 0 | 1

Specifies whether to import the existing Authenticode settings.

ImportRatings

Value: 0 | 1

Specifies whether to import the existing Content Ratings settings.

ImportSecZones

Value: 0 | 1

Imports the existing Security Zones settings.

ImportSiteCert

Value: 0 | 1

Specifies whether to import existing site Certificate Authorities

Win16SiteCerts

Value: 0 | 1

Specifies whether to use site certificates for 16-bit Windows computers.


[Server] (.ins)

banner

[Server]

Disable_LCP

Value: Yes | No

The default connection settings used by the Internet Connection Wizard.

Negotiate_IPX_SPX

Value: Yes | No

Specifies whether to use the Internet Packet Exchange (IPX) protocol.

Negotiate_NetBEUI

Value: Yes | No

Specifies whether to use the NetBIOS Extended User Interface (NetBEUI) protocol.

Negotiate_TCP_IP

Value: Yes | No

Specifies whether to use the Transmission Control Protocol/Internet Protocol (TCP/IP) protocol.

Network_Logon

Value: Yes | No

Specifies whether to log on to a network.

PW_Encrypt

Value: Yes | No

Specifies whether to use an encrypted password.

SW_Compress

Value: Yes | No

Specifies whether to use software compression.

SW_Encrypt

Value: Yes | No

Specifies whether to require data encryption.

Type

Value: string

Specifies the server type — for example, "ppp".


[Signature] (.ins)

banner

[Signature]

Signature_Text

Value: string

The text of an e-mail signature. The text ends with the characters "\n".

Use_Signature

Value: 0 | 1

Specifies whether to use a signature.


[SignupFiles](.ins)

[SignupFiles]

File0

Value: file name

Name of the first file used in your sign-up process, for example, cancel.ins.

File1

Value: file name

Name of the second file used in your sign-up process, for example, sign-up.htm.

File2

Value: file name

Name of the third file used in your sign-up process, for example, sign-up.isp.

File3

Value: file name

Name of the fourth file used in your sign-up process.


[Small_Logo](.ins)

[Small_Logo]

Name

Value: file name

The name of the 22x22-pixel bitmap file that appears in the top right corner of the browser.

Path

Value: file path

The path to the 22x22-pixel bitmap file that appears in the top right corner of the browser.


[TCP/IP] (.ins)

banner

[TCP/IP]

DNS_Address

Value: string

The IP number of the DNS server to use — for example, 127.0.0.1 .

DNS_Alt_Address

Value: string

The IP number of an alternate DNS server to use — for example, 127.0.0.1 .

Gateway_On_Remote

Value: Yes | No

Specifies whether to use a remote gateway.

IP_Header_Compress

Value: Yes | No

Specifies whether to use IP header compression.

Specify_IP_Address

Value: Yes | No

Specifies whether to use an IP address.

Specify_Server_Address

Value: Yes | No

Specifies a server address to use.


[URL] (.ins)

banner

[URL]

AutoConfig

Value: 0 | 1

Specifies whether to use an autoconfigured proxy server.

AutoConfigJSURL

Value: url

The URL of the automatic proxy file, which is in either JavaScript or Microsoft® JScript®.

AutoConfigTime

Value: integer

Automatically configures the browser after running the specified number of minutes.

AutoConfigURL

Value: url

The URL of the autoproxy file.

FirstHomePage

Value: url

The page to browse the first time the customized browser is run.

Help_Page

Value: url

The URL of a Web page offering technical support.

Home_Page

Value: url

The URL for the default home page.

NoWelcome

Value: 0 | 1

Specifies whether to not display a welcome page the first time the browser is used. Set this value to 1 to not display the welcome page.

Quick_Link_1

Value: url

Quick link URL.

Quick_Link_1_Name

Value: string

The name associated with Quick_Link_1.

Quick_Link_2

Value: url

The second quick link URL.

Quick_Link_2_Name

Value: string

The name associated with Quick_Link_2.

Quick_Link_X

Value: url

The quick link URL.

Quick_link_X_icon

Value: path_and_file_name

The quick link icon.

Quick_Link_X_Name

Value: string

The name associated with Quick_Link_X.

Quick_Link_X_Offline

Value: 0 | 1

Specifies whether to make the quick link available for offline browsing.

Search_Page

Value: url

The default Search page.

Signup

Value: path_and_file_name

The path to the page containing a link to the .ins file for the sign-up server.

UseLocalIns

Value: 0 | 1

Specifies whether to use a local .ins file.


[User] (.ins)

banner

[User]

Display_Password

Value: Yes | No

Specifies whether to display the password.

Name

Value: string

The user name.

Password

Value: string

The password.

Requires_Logon

Value: Yes | No

Specifies whether the end user is required to log on.


Oeminfo.ini

To fulfill the terms of the Microsoft® Windows® XP OEM license agreement, you are required to identify your company and provide a link to information about your product support offerings in System Properties.

To include your support information in System Properties

  • Copy the Oeminfo.ini file from the \Samples\Branding directory on the OPK CD to the \$OEM$\$$\System32 subfolder of the distribution folder.
  • Remove all fictitious sample values from this file, and replace them with your specific information.

The following sections appear in Oeminfo.ini:

Section | Optional or required
[General] | Required
[OEMSpecific] | Optional
[ICW] | Optional
[Support Information] | Required. You must localize the required [Support Information] section in Oeminfo.ini for each language in which you ship your product.

Note

  • Do not include any information in Oeminfo.ini that will no longer be true if the customer upgrades the computer to a later version of Windows.

Example Oeminfo.ini file

[General]
Manufacturer = Fabrikam, Inc.
Model = Brand X Pentium Processor
supporturl=www.fabrikam.com

[OEMSpecific]
SubModel = 456A0123
SerialNo = 12345678
OEM1 = Built from image 20010630
OEM2 = Factory location: Redmond, Washington

[ICW]
Product = Brand X from Fabrikam, Inc.

[Support Information]
Line1 = For technical support:
Line2 =   In the USA:
Line3 =     Call 1-800-555-1234 from 8 A.M. to 8 P.M. EST
Line4 =     for software and hardware support.
Line5 =
Line6 =   In England:
Line7 =     Call 444-3324 for hardware configuration support.
Line8 =     Call 555-6648 for software support.
Line9 =


[General] (Oeminfo.ini)

banner

[General]

This section in Oeminfo.ini adds text to the General tab in System Properties that identifies your company, the model of the computer, and where customers can find product support information. This section is required in Oeminfo.ini.

Manufacturer

Value: string

The name of the company that manufactured the computer. Do not leave any trailing spaces at the end of this string. Required.

Important

  • You must make sure that you specify your company name in the Manufacturer entry for Oeminfo.ini before you preinstall Windows. If Windows cannot find a value for this entry, critical support information will not be available to end users.

Model

Value: string

The name of this particular model line.

supporturl

Value: string

Provide your Internet URL as a support resource; Windows Update displays this URL as a link for your customers.

Example

[General]
Manufacturer=Fabrikam
Model=Fabrikam DTP/433
supporturl=http://www.fabrikam.com


[OEMSpecific] (Oeminfo.ini)

banner

[OEMSpecific]

You can store more specific information about the computer in this section of Oeminfo.ini. This information will not appear anywhere in the Windows end user interface. However, a support technician can gain access to this information by instructing the end user to click Start, to click Run, and then type Oeminfo.ini.

You can create any entries you want in this section. There are no length limitations.

Using Winbom.ini to store order-specific information on the computer

If your factory uses a build-to-order process, you may be programmatically generating a Winbom.ini file during your order entry process. If so, you can use the [UpdateSystem] sections in Winbom.ini to write specific information about the order or customer into Oeminfo.ini during Factory mode of Sysprep.

Example

Include this section in Winbom.ini:

[UpdateSystem]
UpdateInis = UpdatesToOeminfoFile

[UpdatesToOeminfoFile]
%windir%\System32\Oeminfo.ini, OEMSpecific, , Submodel = 456A0123
%windir%\System32\Oeminfo.ini, OEMSpecific, , SerialNo = 12345678
%windir%\System32\Oeminfo.ini, OEMSpecific, , OEM1 = Built from image 20010630
%windir%\System32\Oeminfo.ini, OEMSpecific, , OEM2 = Factory location: Redmond, Washington

When this Winbom.ini file is processed by Sysprep in Factory mode, it writes the following information into Oeminfo.ini:

[OEMSpecific]
SubModel = 456A0123
SerialNo = 12345678
OEM1 = Built from image 20010630
OEM2 = Factory location: Redmond, Washington


[ICW] (Oeminfo.ini)

banner

[ICW]

This section in Oeminfo.ini can be read by server-side applications to further identify the computer.

Product

Value: string

Text identifying this specific computer model.

Example

[ICW]
Product = Brand X from Fabrikam, Inc.


[Support Information] (Oeminfo.ini)

banner

[Support Information]

This section in Oeminfo.ini adds text to the General tab in System Properties that identifies contact information for your company's product support, including:

  • The telephone numbers and hours for your technical support group.
  • A link to the technical information page of your company's Web site.
  • Information for several countries or regions with a common language and different support contact information.

Important

  • This section is required in Oeminfo.ini.
  • Do not include any information in this section that does not directly pertain to support. Specifically, do not include any marketing or promotional information.

LineXX

XX is a number from 1 to 99. For the first entry, XX must be 1.

Value: string

Text giving contact information for product support.

At least one entry (Line1) is required.

You can include multiple lines of text by using multiple Line XX entries. The numbers must be consecutive, with no duplicates. If a number is missing in the sequence, the remaining entries are not displayed to the end user. To include a blank line, use an empty Line XX entry.

The text:

  • Appears in a fixed-font, read-only text box.
  • Automatically scrolls horizontally and vertically if the lines are too long or if there are more lines than can be displayed on a single page.

Important

  • You must localize the required [Support Information] section in Oeminfo.ini for each language in which you distribute your product. Microsoft includes only an English (U.S.) sample in this OPK.

Example

[Support Information]
Line1 = For technical support:
Line2 =   In the USA:
Line3 =     Call 1-800-555-1234 from 8 A.M. to 8 P.M. EST
Line4 =     for software and hardware support.
Line5 =
Line6 =   In England:
Line7 =     Call 44-3324 for hardware configuration support.
Line8 =     Call 55-6648 for software support.
Line9 =


Oobeinfo.ini

Oobeinfo.ini allows you to customize the Windows Welcome experience for your customers. Create the file by using Setup Manager. You can later modify this file by using Setup Manager or any text editor.

You can also use Sysprep in Factory mode to manipulate the contents of this file, as controlled by the settings in the [UpdateSystem] section in Winbom.ini.

The following sections appear in Oobeinfo.ini:

Section | Description
[Branding] | Allows you to incorporate your company name into Windows Welcome.
[DesktopReminders] | Allows you to place reminders for registration and the ISP sign-up offer on the Windows desktop.
[DUN] | The settings for Dial-Up Networking (DUN) that are used when collecting user registration information.
[OEMHardwareTutorial] | Allows you to include a custom hardware tutorial in Windows Welcome.
[OEMRegistrationPage] | The configuration options for customer registration.
[Options] | A variety of configuration options.
[Signup] | The Internet sign-up parameters.
[StartupOptions] | The parameters used to configure the appearance and operation of Msoobe.exe.
[UserInfo] | Allows you to personalize the text on the Welcome screen, and prepopulate the user information fields seen by end users during registration.
[Version] | Allows you to prepopulate the Product Key.

For more information about Oobeinfo.ini changes in Microsoft® Windows® XP, see What's New in Windows Welcome.


[Branding] (Oobeinfo.ini)

banner

[Branding]

This section in Oobeinfo.ini contains parameters for incorporating your company name into Windows Welcome.

OEMName

Value: CorporateName
Default: ""

CorporateName
Name of OEM

This string appears on two pages in Windows Welcome:

  • On the Opening screen, where the text says:

    Thank you for purchasing a CorporateName computer with Windows XP.

  • On the Registration page, this string appears accompanied by the contact information for product support.

This string can also be transmitted to an Internet service provider (ISP) as part of the query string used to establish an Internet account for the end user.

This entry can be defined in Setup Manager or set manually in the Oobeinfo.ini file.

To programmatically determine the value of OEMName, use the Signup.get_OEMName method.

OEMLogo

Value: oemlogo
Default: ""

OEMLogo
OEM logo

You can add a graphic of your logo to Windows Welcome in .bmp, .gif, .jpg, or .png formats. The logo file must be in the ..\oobe\images folder. You cannot specify paths with the file name. The only valid entry is of the form OEMLogo = oemlogo.ext. If you leave OEMLogo blank or set it to anything other than a valid logo in the ..\oobe\images folder, no graphic or error is displayed.

If you use a logo larger than 255x40 pixels, cropping or truncation will be done to the right and bottom side of the logo. If you use a logo smaller than 255x40, its actual size will be used. The unused area will be transparent and the Windows Welcome background will be visible.


[DesktopReminders] (Oobeinfo.ini)

banner

[DesktopReminders]

  • DesktopRegRemind
  • RegRemind1
  • RegRemind2
  • RegRemind3
  • DesktopISPRemind
  • ISPRemind1
  • ISPRemind2
  • ISPRemind3

This section in Oobeinfo.ini contains parameters for reminders.

DesktopRegRemind

Value: 0 | 1
Default: 0

0
Do not enable product registration reminders.
1
Enable product registration reminders.

RegRemind1

Value: days
Default: 0

days
DWORD. Number of days before the end user is reminded to register their copy of Microsoft Windows. Must be a positive integer less than or equal to 30. If 0, no reminder is set.

Important

  • This entry is ignored unless DesktopRegRemind = 1.

RegRemind2

Value: days
Default: 0

days
DWORD. Number of days before the end user is reminded a second time to register their copy of Microsoft Windows. Must be a positive integer less than or equal to 30. If 0, no reminder is set.

Important

  • This entry is ignored unless DesktopRegRemind = 1.

RegRemind3

Value: days
Default: 0

days
DWORD. Number of days before the end user is reminded a third time to register their copy of Microsoft Windows. Must be a positive integer less than or equal to 30. If 0, no reminder is set

Important

  • This entry is ignored unless DesktopRegRemind = 1.

DesktopISPRemind

Value: 0 | 1
Default: 0

0
If the end user skips ISP registration during Windows Welcome, do not remind the end user to sign up for Internet access.
1
If the end user skips ISP registration during Windows Welcome, give the end user one or more opportunities to sign up for Internet access from the Windows desktop.

Notes

  • The end user experience during desktop ISP reminders is similar to Windows Welcome, except the pages are displayed within a browser window, not in a full screen.
  • The first file in this ISP sign-up offer must be named Dtsgnup.htm. The "Dt" in the file name stands for desktop. You may want to name any succeeding files similarly, as part of a series (for example, Dtsgnup2.htm, Dtsgnup3.htm, and so on). The file must be located in REF:\Windows\System32\Oobe\Html\Ispsgnup.

ISPRemind1

Value: days
Default: 0

days
DWORD. Number of days before the end user is reminded to sign up for Internet access. Must be a positive integer less than or equal to 30. If 0, no reminder is set.

Important

  • ISPRemind1 is ignored unless DesktopISPRemind = 1.

ISPRemind2

Value: days
Default: 0

days
DWORD. Number of days before the end user is reminded a second time to sign up for Internet access. Must be a positive integer less than or equal to 30. If 0, no reminder is set.

Important

  • ISPRemind2 is ignored unless DesktopISPRemind = 1.

ISPRemind3

Value: days
Default: 0

days
DWORD. Number of days before the end user is reminded a third time to sign up for Internet access. Must be a positive integer less than or equal to 30. If 0, no reminder is set.

Important

  • ISPRemind3 is ignored unless DesktopISPRemind = 1.

Example

In the following example, reminders are scheduled to occur 5, 10, and 15 days after the end user completes Windows Welcome, if the end user does not sign up for Internet access during the Windows Welcome experience.

[DesktopReminders]
DesktopISPRemind= 1
ISPremind1=5
ISPRemind2=10
ISPRemind3=15


[DUN] (Oobeinfo.ini)

banner

[DUN]

This section in Oobeinfo.ini contains parameters for setting the Dial-Up Networking username into Windows Welcome.

UserName

Value: username
Default: "username@reg.ms.com"

UserName
Name of user

"Username@reg.ms.com" is the username used for the Dial-Up Networking login. UserName is case-sensitive.

UserName is required if the OEM chooses to collect online user registration information through the Microsoft dial-up network. UserName can be populated with Setup Manager or by editing Oobeinfo.ini. For information on obtaining a DUN username from Microsoft, please refer to the TBD section.


[OEMHardwareTutorial] (Oobeinfo.ini)

banner

[OEMHardwareTutorial]

This section in Oobeinfo.ini contains parameters for various options.

OEMHWTutorial

Value: 0 | 1
Default: 0

0
Do not include a custom OEM hardware tutorial page in Windows Welcome.
1
Include a custom OEM hardware tutorial page in Windows Welcome.

The custom tutorial must meet the guidelines specified in the OEM Preinstallation Kit User's Guide.


[OEMRegistrationPage] (Oobeinfo.ini)

banner

[OEMRegistrationPage]

This section in Oobeinfo.ini contains parameters for various options.

PostToOEM

Value: 0 | 1
Default: 0

0
Do not transmit registration information to the OEM's server.
1
Transmit registration information to the OEM's server.

If PostToOEM = 1, Windows Welcome includes a check box on the registration page so that the end user can choose whether to transmit their registration data to your company. In addition, PostToOEM enables a hyperlink on this page to a Web page containing your company's privacy policy.

To programmatically determine the value of PostToOEM, use the Register.get_PostToOEM method.

RegPostURL

Value: URL
Default: ""

URL
URL of location where Windows Welcome posts registration information.

To programmatically determine the value of RegPostURL, use the Directions.get_DoOEMAddRegistration method.

To programmatically determine the value of RegPostURL, use the Register.get_RegPostURL method.


[Options] (Oobeinfo.ini)

banner

[Options]

This section in Oobeinfo.ini contains parameters for configuring which pages appear in Windows Welcome.

AreaCode

Value: [string, areacode]

string
The string used to dial an outside line.
areacode
The local areacode.

DefaultKeyboard

Value: keyboard_value

keyboard_value
The default keyboard value of the version of Windows XP you are installing.

It is recommended that you preconfigure this entry and do not display the INTL_Settings page to the users unless you are uncertain of the country in which the computer will be purchased.

Changing this entry is necessary when customizing [RegionalSettings] after running Sysprep -reseal on Windows XP Personal and Windows XP Professional. Any settings specified in the [RegionalSettings] section in Unattend.txt are not maintained if Sysprep is run on the computer, unless the corresponding settings are also specified in Sysprep.inf.

Index values corresponding to each language - Click here to see a table listing the numeric value corresponding to each language.

This table lists the numeric value corresponding to the list of keyboards installed by default Windows XP. Additional keyboards may be available if support for Asian languages or complex script is also installed.

Index | Language
41c | Albanian
82c | Azeri Cyrillic
42c | Azeri Latin
423 | Belarusian
1080c | Belgian (Comma)
813 | Belgian (Period)
80c | Belgian French
402 | Bulgarian
10402 | Bulgarian (Latin)
1009 | Canadian French
c0c | Canadian French (Legacy)
11009 | Canadian Multilingual Standard
41a | Croatian
405 | Czech
10405 | Czech (QWERTY)
20405 | Czech Programmers
406 | Danish
413 | Dutch
425 | Estonian
438 | Faeroese
40b | Finnish
40c | French
11809 | Gaelic
407 | German
10407 | German (IBM)
408 | Greek
10408 | Greek (220)
30408 | Greek (220) Latin
20408 | Greek (319)
40408 | Greek (319) Latin
50408 | Greek Latin
60408 | Greek Polytonic
40e | Hungarian
1040e | Hungarian 101
40f | Icelandic
1809 | Irish
410 | Italian
10410 | Italian (142)
43f | Kazakh
440 | Kyrgyz Cyrillic
80a | Latin American
426 | Latvian
10426 | Latvian (QWERTY)
10427 | Lithuanian
427 | Lithuanian IBM
42f | FYRO Macedonian
450 | Mongolian Cyrillic
414 | Norwegian
10415 | Polish (214)
415 | Polish (Programmers)
816 | Portuguese
416 | Portuguese (Brazilian ABNT)
10416 | Portuguese (Brazilian ABNT2)
418 | Romanian
419 | Russian
10419 | Russian (Typewriter)
c1a | Serbian (Cyrillic)
81a | Serbian (Latin)
41b | Slovak
1041b | Slovak (QWERTY)
424 | Slovenian
40a | Spanish
1040a | Spanish Variation
41d | Swedish
100c | Swiss French
807 | Swiss German
444 | Tatar
1041f | Turkish F
41f | Turkish Q
422 | Ukrainian
809 | United Kingdom
10409 | United States (Dvorak)
30409 | United States (Dvorak for left hand)
40409 | United States (Dvorak for right hand)
20409 | United States (International)
409 | United States
843 | Uzbek Cyrillic

DefaultLanguage

Value: language_value

language_value
The default language value of the version of Windows XP you are installing.

It is recommended that you preconfigure this entry and do not display the INTL_Settings page to the users unless you are uncertain of the country in which the computer will be purchased.

Changing this entry is necessary when customizing [RegionalSettings] after running Sysprep -reseal on Windows XP Personal and Windows XP Professional. Any settings specified in the [RegionalSettings] section in Unattend.txt are not maintained if Sysprep is run on the computer, unless the corresponding settings are also specified in Sysprep.inf.

Index values corresponding to each language - Click here to see a table listing the numeric value corresponding to each language.

This table lists the numeric value corresponding to each language.

Index | Language
436 | Afrikaans
41c | Albanian
82c | Azeri (Cyrillic)
42c | Azeri (Latin)
42d | Basque
423 | Belarusian
402 | Bulgarian
403 | Catalan
41a | Croatian
405 | Czech
406 | Danish
813 | Dutch (Belgium)
413 | Dutch (Netherlands)
c09 | English (Australia)
2809 | English (Belize)
1009 | English (Canada)
2409 | English (Caribbean)
1809 | English (Ireland)
2009 | English (Jamaica)
1409 | English (New Zealand)
3409 | English (Philippines)
1c09 | English (South Africa)
2c09 | English (Trinidad)
809 | English (United Kingdom)
409 | English (United States)
3009 | English (Zimbabwe)
425 | Estonian
438 | Faeroese
40b | Finnish
80c | French (Belgium)
c0c | French (Canada)
40c | French (France)
140c | French (Luxembourg)
180c | French (Monaco)
100c | French (Switzerland)
456 | Galician
c07 | German (Austria)
407 | German (Germany)
1407 | German (Liechtenstein)
1007 | German (Luxembourg)
807 | German (Switzerland)
408 | Greek
40e | Hungarian
40f | Icelandic
421 | Indonesian
410 | Italian (Italy)
810 | Italian (Switzerland)
43f | Kazakh
440 | Kyrgyz (Cyrillic)
426 | Latvian
427 | Lithuanian
42f | FYRO Macedonian
83e | Malay (Brunei Darussalam)
43e | Malay (Malaysia)
450 | Mongolian (Cyrillic)
414 | Norwegian (Bokmal)
814 | Norwegian (Nynorsk)
415 | Polish
416 | Portuguese (Brazil)
816 | Portuguese (Portugal)
418 | Romanian
419 | Russian
c1a | Serbian (Cyrillic)
81a | Serbian (Latin)
41b | Slovak
424 | Slovenian
2c0a | Spanish (Argentina)
400a | Spanish (Bolivia)
340a | Spanish (Chile)
240a | Spanish (Colombia)
140a | Spanish (Costa Rica)
1c0a | Spanish (Dominican Republic)
300a | Spanish (Ecuador)
440a | Spanish (El Salvador)
100a | Spanish (Guatemala)
480a | Spanish (Honduras)
80a | Spanish (Mexico)
4c0a | Spanish (Nicaragua)
180a | Spanish (Panama)
3c0a | Spanish (Paraguay)
280a | Spanish (Peru)
500a | Spanish (Puerto Rico)
40a | Spanish (Spain)
380a | Spanish (Uruguay)
200a | Spanish (Venezuela)
441 | Swahili
41d | Swedish
81d | Swedish (Finland)
444 | Tatar
41f | Turkish
422 | Ukrainian
843 | Uzbek (Cyrillic)
443 | Uzbek (Latin)

DefaultRegion

Value: region_value

region_value
The default regional value of the version of Windows XP you are installing.

It is recommended that you preconfigure this entry and do not display the INTL_Settings page to the users unless you are uncertain of the country in which the computer will be purchased.

Changing this entry is necessary when customizing [RegionalSettings] after running Sysprep -reseal on Windows XP Personal and Windows XP Professional. Any settings specified in the [RegionalSettings] section in Unattend.txt are not maintained if Sysprep is run on the computer, unless the corresponding settings are also specified in Sysprep.inf.

Index values corresponding to each region or location - Click here to see a table listing the numeric value corresponding to each region or location.

This table lists the numeric value corresponding to each region or location.

Index | Region or Location
3 | Afghanistan
6 | Albania
4 | Algeria
10 | American Samoa
8 | Andorra
9 | Angola
300 | Anguilla
301 | Antarctica
2 | Antigua and Barbuda
11 | Argentina
7 | Armenia
302 | Aruba
303 | Ascension Island
304 | Ashmore and Cartier Islands
12 | Australia
14 | Austria
5 | Azerbaijan
22 | Bahamas, The
17 | Bahrain
305 | Baker Island
23 | Bangladesh
18 | Barbados
29 | Belarus
21 | Belgium
24 | Belize
28 | Benin
20 | Bermuda
34 | Bhutan
26 | Bolivia
25 | Bosnia and Herzegovina
19 | Botswana
306 | Bouvet Island
32 | Brazil
114 | British Indian Ocean Territory
37 | Brunei
35 | Bulgaria
245 | Burkina Faso
38 | Burundi
40 | Cambodia
49 | Cameroon
39 | Canada
57 | Cape Verde
307 | Cayman Islands
55 | Central African Republic
41 | Chad
308 | Channel Islands
46 | Chile
45 | China
309 | Christmas Island
310 | Clipperton Island
311 | Cocos (Keeling) Islands
51 | Colombia
50 | Comoros
43 | Congo
44 | Congo (DRC)
312 | Cook Islands
313 | Coral Sea Islands
54 | Costa Rica
119 | Côte d’Ivoire
108 | Croatia
56 | Cuba
59 | Cyprus
75 | Czech Republic
61 | Denmark
314 | Diego Garcia
62 | Djibouti
63 | Dominica
65 | Dominican Republic
7299303 | East Timor
66 | Ecuador
67 | Egypt
72 | El Salvador
69 | Equatorial Guinea
71 | Eritrea
70 | Estonia
73 | Ethiopia
315 | Falkland Islands (Islas Malvinas)
81 | Faroe Islands
78 | Fiji Islands
77 | Finland
84 | France
317 | French Guiana
318 | French Polynesia
319 | French Southern and Antarctic Lands
87 | Gabon
86 | Gambia, The
320 | Gaza Strip
88 | Georgia
94 | Germany
89 | Ghana
90 | Gibraltar
98 | Greece
93 | Greenland
91 | Grenada
321 | Guadeloupe
322 | Guam
323 | Guantanamo Bay
99 | Guatemala
324 | Guernsey
100 | Guinea
196 | Guinea-Bissau
101 | Guyana
103 | Haiti
325 | Heard Island and McDonald Islands
106 | Honduras
104 | Hong Kong S.A.R.
326 | Howland Island
109 | Hungary
110 | Iceland
113 | India
111 | Indonesia
116 | Iran
121 | Iraq
68 | Ireland
117 | Israel
118 | Italy
124 | Jamaica
125 | Jan Mayen
122 | Japan
327 | Jarvis Island
328 | Jersey
127 | Johnston Atoll
126 | Jordan
137 | Kazakhstan
129 | Kenya
329 | Kingman Reef
133 | Kiribati
134 | Korea
136 | Kuwait
130 | Kyrgyzstan
138 | Laos
140 | Latvia
139 | Lebanon
146 | Lesotho
142 | Liberia
148 | Libya
145 | Liechtenstein
141 | Lithuania
147 | Luxembourg
151 | Macau S.A.R.
19618 | FYRO Macedonia
149 | Madagascar
156 | Malawi
167 | Malaysia
165 | Maldives
157 | Mali
163 | Malta
15126 | Man, Isle of
199 | Marshall Islands
330 | Martinique
162 | Mauritania
160 | Mauritius
331 | Mayotte
166 | Mexico
80 | Micronesia
21242 | Midway Islands
152 | Moldova
158 | Monaco
154 | Mongolia
332 | Montserrat
159 | Morocco
168 | Mozambique
27 | Myanmar
254 | Namibia
180 | Nauru
178 | Nepal
333 | Netherlands Antilles
176 | Netherlands, The
334 | New Caledonia
183 | New Zealand
182 | Nicaragua
173 | Niger
175 | Nigeria
335 | Niue
336 | Norfolk Island
131 | North Korea
337 | Northern Mariana Islands
177 | Norway
164 | Oman
190 | Pakistan
195 | Palau
184 | Palestinian Authority
338 | Palmyra Atoll
192 | Panama
194 | Papua New Guinea
185 | Paraguay
187 | Peru
201 | Philippines
339 | Pitcairn Islands
191 | Poland
193 | Portugal
202 | Puerto Rico
197 | Qatar
198 | Reunion
200 | Romania
340 | Rota Island
203 | Russia
204 | Rwanda
341 | Saipan
259 | Samoa
214 | San Marino
233 | São Tomé and Príncipe
205 | Saudi Arabia
210 | Senegal
208 | Seychelles
213 | Sierra Leone
215 | Singapore
143 | Slovakia
212 | Slovenia
30 | Solomon Islands
216 | Somalia
209 | South Africa
342 | South Georgia and the South Sandwich Islands
217 | Spain
42 | Sri Lanka
343 | St. Helena
207 | St. Kitts and Nevis
218 | St. Lucia
206 | St. Pierre and Miquelon
248 | St. Vincent and the Grenadines
219 | Sudan
181 | Suriname
220 | Svalbard
260 | Swaziland
221 | Sweden
223 | Switzerland
222 | Syria
237 | Taiwan
229 | Tajikistan
239 | Tanzania
227 | Thailand
346 | Tinian Island
232 | Togo
347 | Tokelau
231 | Tonga
225 | Trinidad and Tobago
348 | Tristan da Cunha
234 | Tunisia
235 | Turkey
238 | Turkmenistan
349 | Turks and Caicos Islands
236 | Tuvalu
240 | Uganda
241 | Ukraine
224 | United Arab Emirates
242 | United Kingdom
244 | United States
246 | Uruguay
247 | Uzbekistan
174 | Vanuatu
253 | Vatican City
249 | Venezuela
251 | Vietnam
252 | Virgin Islands
351 | Virgin Islands, British
258 | Wake Island
352 | Wallis and Futuna
261 | Yemen
269 | Yugoslavia
263a | Zambia
264 | Zimbabwe

FontSmoothing

Value: 0 | 1
Default: 1

0
Anti-aliasing of fonts is turned off during Windows Welcome.
1
Anti-aliasing of fonts is turned on during Windows Welcome.

FontSmoothing only affects the appearance of screen fonts in Windows Welcome. This setting does not change the display settings of the Windows desktop.

IMETutorial

Value: 0 | 1
Default: 0

0
Does not include an Input Method Editor (IME) tutorial in Windows Welcome.
1
Includes an IME tutorial in Windows Welcome.

You may create a custom IME tutorial for the Japanese, traditional Chinese, simplified Chinese, and Korean versions of Windows, if these are permitted by your license agreement. Microsoft does not provide a default IME tutorial.

To programmatically determine the value of IMETutorial, use the Directions.get_DoIMETutorial method.

INTL_Settings

Value: 0 | 1
Default: 0

0
Do not display the Regional and Keyboard Settings screen in Windows Welcome.
1
Displays the Regional and Keyboard Settings screen in Windows Welcome.

It is recommended that you preconfigure the DefaultKeyboard, DefaultLanguage, and DefaultRegion settings and do not display the Regional and Keyboard Settings page to the users unless you are uncertain of the country in which the computer will be purchased.

If the regional and keyboard settings have been preconfigured, then the Regional and Keyboard Settings page in Windows Welcome is not displayed. If any values on this screen are invalid, then the screen is displayed to the end user.

To programmatically determine the value of the Regional and Keyboard Settings page, use the Directions.get_DoRegionalKeyboard method.

The behavior of the Regional and Keyboard Settings page is as follows:

  • If the page is not displayed (default) and you preconfigure the values in Setup Manager, then the values are applied without user input.
  • If the page is displayed and you preconfigure the defaults, then the preconfigured values are displayed to the user, who can then modify the values.
  • If the page is not displayed (default) and you do not preconfigure any values, then the defaults for the particular language are applied without user input. For examnple, an English system sold in Australia would have the United States default settings.
  • If the page is displayed but you do not preconfigure the defaults, then the defaults for the installed language are displayed to the user, who can then modify the values.

IntroOnly

Value: 0 | 1
Default: 1

0
After the introductory video finishes playing, Windows Welcome proceeds to the Welcome page.
1
Windows Welcome ends after the introductory video is finished.

MouseTutorial

Value: 0 | 2
Default: 0

0
Does not include a mouse tutorial in Windows Welcome.
2
Includes the sample HTML-based mouse tutorial in Windows Welcome.

If your computer is configured with a pointing device other than a standard desktop mouse, set MouseTutorial = 2 and modify the old HTML mouse tutorial pages.

To programmatically determine the value of MouseTutorial, use the Directions.get_DoMouseTutorial method.

OutsideLine

Value: prefix
Default: ""

prefix
The TAPI object dials this number before dialing any phone number.

SupportPhoneNumber

Value: phone
Default: ""

phone
The phone number for your product support that the end user can call if they encounter any problems in setting up the computer.

To programmatically determine the value of SupportPhoneNumber, use the GetSupportPhoneNum method.

TimeZone

Value: 0 | 1
Default: 0

0
Does not display the time zone page in Windows Welcome.
1
Displays the time zone page in Windows Welcome.

If you want to preconfigure the time zone setting, do not use TimeZone = 1. Instead, use TimeZoneValue.

TimeZoneValue

Value: index
Registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\
TimeZoneInformation\DaylightName

Specifies the time zone of the computer. If the entry is not present, the end user is prompted to select a time zone.

Index values corresponding to each time zone - Click here to see a table listing the numeric value corresponding to each time zone.

This table lists the numeric value corresponding to each time zone.

Index | Time zone
000 | International Dateline
001 | Samoa
002 | Hawaii
003 | Alaskan
004 | Pacific
010 | Mountain (U.S. and Canada)
015 | U.S. Mountain: Arizona
020 | Central (U.S. and Canada)
025 | Canada Central
030 | Mexico
033 | Central America
035 | Eastern (U.S. and Canada)
040 | U.S. Eastern: Indiana (East)
045 | S.A. Pacific
050 | Atlantic (Canada)
055 | S.A. Western
056 | Pacific S.A.
060 | Newfoundland
065 | E. South America
070 | S.A. Eastern
073 | Greenland
075 | Mid-Atlantic
080 | Azores
083 | Cape Verde Islands
085 | GMT (Greenwich Mean Time)
090 | GMT Greenwich
095 | Central Europe
100 | Central European
105 | Romance
110 | W. Europe
113 | W. Central Africa
115 | E. Europe
120 | Egypt
125 | EET (Helsinki, Riga, Tallinn)
130 | EET (Athens, Istanbul, Minsk)
135 | Israel: Jerusalem
140 | S. Africa: Harare, Pretoria
145 | Russian
150 | Arab
155 | E. Africa
160 | Iran
165 | Arabian
170 | Caucasus Pacific (U.S. and Canada)
175 | Afghanistan
180 | Russia Yekaterinburg
185 | W. Asia
190 | India
193 | Nepal
195 | Central Asia
200 | Sri Lanka
201 | N. Central Asia
203 | Myanmar: Rangoon
205 | S.E. Asia
207 | N. Asia
210 | China
215 | Singapore
220 | Taipei
225 | W. Australia
227 | N. Asia East
230 | Korea: Seoul
235 | Tokyo
240 | Sakha Yakutsk
245 | A.U.S. Central: Darwin
250 | Central Australia
255 | A.U.S. Eastern
260 | E. Australia
265 | Tasmania
270 | Vladivostok
275 | W. Pacific
280 | Central Pacific
285 | Fiji Islands
290 | New Zealand
300 | Tonga

TonePulse

Value: 0 | 1
Default: 0

0
Uses pulse dialing to dial a phone modem.
1
Uses tone dialing to dial a phone modem.

The default is 0, pulse, unless the Telephony API settings specify tone. If TAPI settings specify tone, then TonePulse defaults to 1, tone.

USBKeyboard

Value: 0 | 1
Default: 0

0
Does not check for the presence of a USB keyboard.
1
Checks for the presence of a USB keyboard.

See comments following USBMouse.

USBMouse

Value: 0 | 1
Default: 0

0
Does not check for the presence of a USB mouse.
1
Checks for the presence of a USB mouse.

If enabled, the USB keyboard and mouse check is performed just prior to the Welcome screen. If the checks pass, then the Welcome screen appears. If one or both of the checks fail (meaning that no USB keyboard or mouse are connected to the computer), Windows Welcome automatically displays the following error page:

ROOT:\Windows\System32\Oobe\Setup\Nousbkbd.htm (no keyboard)

ROOT:\Windows\System32\Oobe\Setup\Nousbms.htm (no mouse)

ROOT:\Windows\System32\Oobe\Setup\Nousbkm.htm (no keyboard and no mouse)

You need to modify these pages with information appropriate to each model of computer you ship. Microsoft recommends that on these pages you display a picture or drawing showing the end user exactly where they need to plug in the keyboard and/or mouse.

Sample files for these pages are in: OPK:\Samples\Oobe\Oemhw

Note

  • Windows Welcome does not check for PS/2 or serial mice/keyboards.


[Signup] (Oobeinfo.ini)

banner

[Signup]

This section in Oobeinfo.ini contains parameters for Internet sign-up.

ISPSignup

Value: isp_provider
Default: ""

MSN
Microsoft® MSN® Internet Access is the only specific ISP offer available to the end user. The end user still has the option of migrating an existing Internet account (through any ISP supporting this feature in the Microsoft® Internet Referral Service) or using Internet Connection Sharing if present.
OFFLINE
Display a precached (local) list of ISP offers.
PRECONFIG
Preconfigure Internet service at the factory to use a specific new Internet account, created for this end user.
None
Do not include an ISP sign-up offer in Windows Welcome.

See the OEM Preinstallation Kit User's Guide for more information about ISP sign-up offers.

To programmatically determine the value of ISPSignup, use the Directions.get_ISPSignup method.

OEMOfferCode

Value: 0
Default: 0

The value is always 0, because you must display one of the four Internet Signup options, specified with ISPSignup.

To programmatically determine the value of OEMOfferCode, use the Directions.get_OEMOfferCode method.


[StartupOptions] (Oobeinfo.ini)

banner

[StartupOptions]

This section in Oobeinfo.ini contains parameters for startup options.

DesktopStartURL

Value: URL
Default: ""

URL
URL of initial page displayed for ISP sign-up that occurs after the user has completed Windows Welcome.

DesktopWindowHeight

Value: height
Default: 530

height
Size, in pixels, of the height of the Windows Welcome window in desktop mode.

DesktopWindowWidth

Value: width
Default: 640

width
Size, in pixels, of the width of the Windows Welcome window in desktop mode.

OEMAuditBoot

Value: 0 | 1
Default: 0

0
Specifies that when the computer is started after sealing with Sysprep, it restarts in Windows Welcome.
1
Specifies that when the computer is restarted, it restarts in Factory mode.

If you do not include OEMAuditBoot to Oobeinfo.ini, it is the same as specifiying OEMAuditBoot = 0.

Offline

Value: 0 | 1
Default: 0

0
Does not run Windows Welcome in offline mode.
1
Runs Windows Welcome in offline mode.

In offline mode, registration and ISP sign-up are skipped.

This setting is the same as the /offline command-line parameter.

To programmatically determine the value of Offline, use the Directions.get_Offline method.

Registration

Value: 0 | 1
Default: 0

0
Displays the registration pages.
1
Does not display the registration pages.

The value of Registration determines whether Windows Welcome displays the registration pages and whether the Registration checkpoint appears in the status pane of Windows Welcome. See [Signup] for more information.

ScreenResolutionCheck

Value: 0 | 1
Default: 1

0
Windows Welcome does not detect screen resolution. If the screen resolution is less than 800 by 600 pixels, then Windows Welcome is displayed with scroll bars.
1
Windows Welcome detects screen resolution. If the computer hardware supports a minimum 800 by 600 pixel screen resolution and the default screen resolution is set to a smaller number (for example, 640 by 480 pixels), then Windows Welcome reconfigures the computer to use an 800 by 600 pixel screen resolution. If the hardware does not support a screen resolution of at least 800 by 600 pixels, then the first-run experience is Mini-Setup.


[UserInfo] (Oobeinfo.ini)

banner

[UserInfo]

This section in Oobeinfo.ini contains parameters for prepopulating end user information and personalizing the end user experience during Windows Welcome.

FirstName

Value: firstname
Default: ""

firstname
The user’s first name.

To programmatically determine the value of FirstName, use the UserInfo.get_FirstName method.

MiddleInitial

Value: middleinitial
Default: ""

middleinitial
The user’s middle initial.

To programmatically determine the value of MiddleInitial, use the UserInfo.get_MiddleInitial method.

LastName

Value: lastname
Default: ""

lastname
The user’s last name.

To programmatically determine the value of LastName, use the UserInfo.get_LastName method.

FuriganaName

Value: furigana
Default: ""

The Japanese writing system is composed of two different types of characters, kana and kanji. Each kana character has a specific pronunciation.

Individual kanji characters often have more than one pronunciation, and each pronunciation has a different meaning. Kanji characters are often augmented with tiny kana characters written above or next to the kanji characters, where the kana characters indicate the correct pronunciation of the word. Kana used in this way is called furigana.

furigana
The end user’s name, written in furigana.

To programmatically determine the value of FuriganaName, use the UserInfo.get_FuriganaName method.

CompanyName

Value: companyname
Default: ""

companyname
The end user’s company name.

To programmatically determine the value of CompanyName, use the UserInfo.get_CompanyName method.

Address1

Value: address1
Default: ""

address1
The end user’s primary mailing address.

To programmatically determine the value of Address1, use the UserInfo.get_Address1 method.

Address2

Value: address2
Default: ""

address2
The end user’s secondary mailing address.

To programmatically determine the value of Address2, use the UserInfo.get_Address2 method.

City

Value: city
Default: ""

city
The end user’s city.

To programmatically determine the value of City, use the UserInfo.get_city method.

State

Value: state
Default: ""

state
The end user’s state or region.

To programmatically determine the value of State, use the UserInfo.get_State method.

Zip

Value: zip
Default: ""

zip
The end user’s zip or postal code.

To programmatically determine the value of Zip, use the UserInfo.get_Zip method.

Country

Value: country
Default: ""

country
The end user’s country/region.

To programmatically determine the value of Country, use the UserInfo.get_Country method.

PrimaryEmail

Value: primaryemail
Default: ""

primaryemail
The end user’s e-mail address or temporary Windows ID.

To programmatically determine the value of PrimaryEmail, use the UserInfo.get_PrimaryEmail method.

SecondaryEmail

Value: secondaryemail
Default: ""

secondaryemail
The end user’s secondary e-mail address.

To programmatically determine the value of SecondaryEmail, use the UserInfo.get_SecondaryEmail method.

AreaCode

Value: areacode
Default: ""

areacode
The end user’s area or city code.

To programmatically determine the value of AreaCode, use the UserInfo.get_AreaCode method.

PhoneNumber

Value: phonenumber
Default: ""

phonenumber
The end user’s phone number.

To programmatically determine the value of PhoneNumber, use the UserInfo.get_PhoneNumber method.

Identity001

Value: identity001
Default: ""

You can prepopulate up to six end user identities.

identity001
The primary end user’s identity.

To programmatically determine the value of Identity, use the UserInfo.get_Identity method.

Identity002

Value: identity002
Default: ""

You can prepopulate up to six end user identities.

identity002
An additional secondary end user’s identity.

To programmatically determine the value of Identity, use the UserInfo.get_Identity method.

Identity003

Value: identity003
Default: ""

You can prepopulate up to six end user identities.

identity003
An additional secondary end user’s identity.

To programmatically determine the value of Identity, use the UserInfo.get_Identity method.

Identity004

Value: identity004
Default: ""

You can prepopulate up to six end user identities.

identity004
An additional secondary end user’s identity.

To programmatically determine the value of Identity, use the UserInfo.get_Identity method.

Identity005

Value: identity005
Default: ""

You can prepopulate up to six end user identities.

identity005
An additional secondary end user’s identity.

To programmatically determine the value of Identity, use the UserInfo.get_Identity method.

Identity006

Value: identity006
Default: ""

You can prepopulate up to six end user identities.

identity006
An additional secondary end user’s identity.

To programmatically determine the value of Identity, use the UserInfo.get_Identity method.


[Version] (Oobeinfo.ini)

banner

[Version]

ProductKey

Value: "xxxxx-xxxxx-xxxxx-xxxxx-xxxxx"

Specifies the Product Key for this particular installation of Windows XP. Each x is either an alphabetic character or a number. The quotation marks and the hyphens are required.

Important

  • A Product Key is always required.
  • Standard licensing agreements specify that you can only use a given Product Key to activate one installation of Windows XP on one computer. This requirement is enforced by Windows Product Activation (WPA).
  • If you are preinstalling Windows XP under a volume license agreement, consult your specific license agreement to determine the number of installations that can use a given Product Key.


Windows Welcome APIs

  • External APIs
  • API object
  • Directions object
  • Language object
  • Register object
  • Signup object
  • Status object
  • Tapi object
  • UserInfo object


External APIs

The following methods provide access to the object model of Msoobe.exe:

  • API method
  • Directions method
  • Language method
  • Register method
  • Signup method
  • Status method
  • Tapi method
  • UserInfo method

The remainder of the external APIs are a collection of generally useful functions.

  • CheckDialReady method
  • CheckOnlineStatus method
  • CheckPhoneBook method
  • CheckStayConnected method
  • Connect method
  • Dial method
  • DialEx method
  • ExecScriptFn method
  • Finish method
  • get_ConnectionType method
  • get_DialNumber method
  • get_RetailOobe method
  • get_StatusIndex method
  • GetFile method
  • GetLocalUserCount method
  • GetReconnectURL method
  • GetSupportPhoneNum method
  • Hangup method
  • IsICSAvailable method
  • IsProfessionalSKU method
  • PowerDown method
  • PreConfigINS method
  • ProcessINS method
  • ReConnect method
  • ReDial method
  • ReDialEx method
  • RunManualICW method
  • set_DialNumber method


API method

Retrieves a reference to the API object.

Syntax

window.external.API;

Parameters

None

Return Values

Object. A reference to the API object.

Applies To

window.external

Example

var Obj = new Object;
Obj = window.external.API;
var sContents =  Obj.LoadFile("mytext.txt");
alert(sContents);


CheckDialReady method

Checks the end user's computer to see if remote access server (RAS), Transmission Control Protocol/Internet Protocol (TCP/IP), and a modem are installed.

Syntax

iDialStatus = window.external.CheckDialReady();

Parameters

None

Return Values

Integer

Value | Description
0 | The computer is ready to dial: RAS, TCP/IP, and a modem are all installed.
1 | The Welcome process is the dynamic-link library (DLL) required to make the detection.
2 | Error; unknown cause.
3 | A modem is not installed on the computer.
4 | TCP/IP, RAS, or both are not installed on the computer.

Applies To

window.external


CheckOnlineStatus method

Checks whether Windows Welcome is already connected to the Internet. See the CheckStayConnected method for complete usage.

Syntax

window.external.CheckOnlineStatus;

Parameters

None

Return Values

Boolean

Value | Description
0 | Not connected to the Internet.
1 | Connected to the Internet.

Applies To

window.external

Example

if (window.external.CheckOnlineStatus)
     alert ("Windows Welcome is already online.");
else
     alert ("Windows Welcome needs to either dial out first or
            connect thought ICS in order to connect to the
            Internet.");


CheckPhoneBook method

Checks an .isp file to ensure that the end user's country or region matches the one in the phone book.

Note

  • The .isp file must contain a phone book entry:
    [ISP INFO]
PhoneBookFile = myphonebook.obe

Syntax

bValid = window.external.CheckPhoneBook(sIspFile);

Parameters

sISPFile
String. The location and file name of the .isp file.

Return Values

Boolean. Returns the value TRUE if the end user's country or region matches the one in the phone book.

Applies To

window.external


CheckStayConnected method

Detects whether a new server page will be reached through an existing Internet connection. If yes, Windows Welcome navigates to the page without creating a new connection. If no, Windows Welcome closes the previous connection and dials a new connection before navigating to the server page.

Syntax

window.external.CheckStayConnected(sISPFile);

Parameters

sISPFile
String. The location and file name of the .isp file.

Return Values

Boolean

Value | Description
0 | Redial is required before navigating to a new page.
1 | Navigates to a new page using the existing connection.

Applies To

window.external

Example

if (window.external.CheckStayConnected( "phone.isp")
     alert ("New server can be reached with the
          existing connection");
else
     alert ("Dial out first to connect new server");


Connect method

Without dialing, connect through an existing connection using the Sign-up URL specified in the .isp file.

Note

  • If a valid connection exists, Windows Welcome automatically navigates to the URL specified in the .isp file as in the following example:
    [URL]
Signup=http://www.fabrikam.com?

Syntax

window.external.Connect(sISPFile);

Parameters

sISPFile
String. The location and file name of the .isp file.

Return Values

Boolean. Returns the value TRUE if the connection request is processed.

Applies To

window.external


Dial method

Dials an .isp file. See DialEx and ReDial.

Note

  • When the connection is made successfully, Windows Welcome navigates to the URL specified in the .isp file, as in the following example:
    [URL]
Signup=http://www.microsoft.com/

Syntax

window.external.Dial(sISPFile);

Parameters

sISPFile
String. The location and file name of the .isp file.

Return Values

Boolean. Returns the value TRUE if Windows Welcome successfully connects to the phone number specified in the .isp file.

Applies To

window.external


DialEx method

Specifies the connection type for connecting to the Internet service provider (ISP). See the Dial method.

Syntax

window.external.DialEx(ulConnectionType, sISPFile);

Parameters

ulConnectionType
Integer. Index identifying the type of connection.
Value | Description
1 | CONNECTED_REFERAL
2 | CONNECTED_ISP_SIGNUP
3 | CONNECTED_ISP_MIGRATE
4 | CONNECTED_REGISTRATION
sISPFile
String. The location and file name of the .isp file.

Return Values

Boolean. Returns the value TRUE if Windows Welcome successfully completes the connection.

Applies To

window.external

Example

var CONNECTED_REFERAL =1
Window.external.DialEx(CONNECTED_REFERAL, "phone.isp");


Directions method

Retrieves a reference to the Directions object.

Syntax

window.external.Directions;

Parameters

None

Return Values

Object. A reference to the Directions object.

Applies To

window.external

Example

var Obj = new Object;
Obj = window.external.Directions;
var iSignup =  Obj.get_ISPSignup;


ExecScriptFn method

Executes a script function in "MSobshel.htm" directly.

Syntax

window.external.ExecScriptFn(sFunction);

Parameters

sFunction
String. The name of the function to execute.

Return Values

Variant. The return value of the function executed.

Applies To

window.external

Example

var vRet = window.external.ExecScriptFn("GoNext();");


Finish method

Causes Windows Welcome to save its collected data in the correct permanent storage locations and time stamp User.exe.

Important

  • Only call the Finish method when the end user has completed the final checkpoint in Windows Welcome.

Syntax

window.external.Finish();

Parameters

None

Return Values

Integer

Value | Description
0 | Finished successfully.
1 | Finished successfully, although a reboot is now required.
2 | The end user has not accepted the Windows End-User License Agreement (EULA).
4 | The end user has not entered a valid Windows Product Key.
8 | An error occurred while attempting to save the end user's information in the registry and/or time stamp User.exe.

Applies To

window.external


get_ConnectionType method

Determines if the computer is an Internet Connection Sharing (ICS) client.

Syntax

iConnectionType = window.external.get_ConnectionType();

Parameters

None

Return Values

Integer. Returns 1 if the computer is an ICS client, and 0 if it is not.

Applies To

window.external


get_DialNumber method

Returns the number being dialed.

Syntax

sNumber = window.external.get_DialNumber();

Parameters

None

Return Values

String. The number being dialed.

Applies To

window.external


get_RetailOobe method

Detects if Windows is using the retail version of Windows Welcome.

Syntax

window.external.get_RetailOobe();

Parameters

None

Return Values

Boolean. Returns the value TRUE if Windows uses the retail version of Windows Welcome. Returns the value FALSE if Windows uses the OEM version of Windows Welcome.

Applies To

window.external


get_StatusIndex method

Advances the status pane to the next available item.

Syntax

iCurrentItem = window.external.get_StatusIndex();

Parameters

None

Return Values

Integer. The index of the selected checkpoint in the status pane.

Applies To

window.external


GetFile method

Retrieves a file from a URL and saves the file to the specified location.

Syntax

bSuccessful = window.external.GetFile(sUrl, sFileName);

Parameters

sUrl
String. The URL from which to retrieve the file.
sFileName
String. The name under which to save the retrieved file.

Return Values

Boolean. Returns the value TRUE if the file was successfully retrieved and saved to disk.

Applies To

window.external


GetLocalUserCount method

Retrieves the number of available user accounts.

Syntax

window.external.GetLocalUserCount();

Parameters

None

Return Values

Integer. The number of user accounts, not including accounts preconfigured by Windows XP. Examples of preconfigured accounts are administrator, guest, and the help assistant.

Applies To

window.external


GetReconnectURL method

Returns the reconnect URL that Windows Welcome tried to dial (specified in the last .isp file).

Note

  • The URL comes from the query string specified in the Reconnect entry in the [URL] section in an .isp file, as in the following:
    [URL]
Reconnect=http://www.microsoft.com/default.asp?

Syntax

sURL = window.external.GetReconnectURL();

Parameters

None

Return Values

String. The URL to use when reconnecting to the server.

Applies To

window.external


GetSupportPhoneNum method

Returns SupportPhoneNumber from the [Options] section in Oobeinfo.ini.

Syntax

window.external.GetSupportPhoneNum;

Parameters

None

Return Values

String. The telephone number.

Applies To

window.external

Example

var strPhoneNumber = window.external.GetSupportPhoneNum();


Hangup method

Terminates the active dial-up connection if one is running.

Syntax

window.external.Hangup();

Parameters

None

Return Values

None

Applies To

window.external


IsICSAvailable method

Checks to see if a shared Internet connection is available on the home network.

Syntax

window.external.IsICSAvailable;

Parameters

None

Return Values

Boolean

Value | Description
0 | No shared Internet connection exists on the home network.
1 | Shared connection exists on the home network.

Applies To

window.external

Example

if(window.external.IsIcsAvailable)
     alert("You are connected to Home network");
else
     alert("No Home network");


IsProfessionalSKU method

This function determines whether the current system is the Home Edition or the Professional version of the Windows XP operating system.

Syntax

window.external.IsProfessionalSKU();

Parameters

None

Return Values

Boolean

Value | Description
0 | This system is Home Edition.
1 | This system is Professional.

Applies To

window.external


Language method

Retrieves a reference to the Language object.

Syntax

window.external.Language;

Parameters

None

Return Values

Object. A reference to the Language object.

Applies To

window.external

Example

var Obj = new Object;
Obj = window.external.Language;
Obj.set_RegionIndex = 1;


PowerDown method

Shuts down or restarts the end user's computer.

Syntax

window.external.PowerDown(bReboot);

Parameters

bReboot
Boolean. If the return value is TRUE, restart the computer. If the return value is FALSE, shut down the computer.

Return Values

None

Applies To

window.external


PreConfigINS method

Processes the Ispcnfg.ins file on the end user's computer if one is available.

Note

  • Ispcnfg.ins must be located in the %windir%\System32\Oobe directory.

Syntax

bSuccessful = window.external.PreConfigINS();

Parameters

None

Return Values

Boolean. Returns the value TRUE if the Ispcnfg.ins file was found and successfully processed.

Applies To

window.external


ProcessINS method

Processes the .ins file specified.

Syntax

bSuccessful = window.external.ProcessINS(sINSPath);

Parameters

sINSPath
String. Path to the .ins file to process. If the path is a URL, Windows Welcome retrieves the file from the URL and attempts to process it.

Return Values

Boolean. Returns the value TRUE if the .ins file was found and successfully processed.

Applies To

window.external


ReConnect method

Without dialing, reconnects through an existing connection by using the Reconnect URL specified in the .isp file.

Note

  • If a valid connection exists, Windows Welcome automatically navigates to the URL specified in the .isp file, as in the following:
    [URL]
Reconnect=http://www.microsoft.com?

Syntax

window.external.ReConnect(sISPFile);

Parameters

sISPFile
String. The location and file name of the .isp file.

Return Values

Boolean. Returns the value TRUE if the connection request is processed.

Applies To

window.external


ReDial method

Redials the phone number specified in an .isp file.

Note

  • This application programming interface (API) differs from Dial, in that the URL comes from the Reconnect entry in the [URL] section in an .isp file, as in the following:
    [URL]
Reconnect=http://www.microsoft.com/

Syntax

window.external.ReDial(sISPFile);

Parameters

sISPFile
String. The location and file name of the .isp file.

Return Values

Boolean. Returns the value TRUE if Windows Welcome successfully connects to the phone number specified in the .isp file.

Applies To

window.external


ReDialEx method

Specifies the connection type for reattempting to connect to the Internet service provider (ISP). See ReDial.

Syntax

window.external.ReDialEx(ulConnectionType, sISPFile);

Parameters

ulConnectionType
Integer. Index identifying the type of connection.
Value | Description
1 | CONNECTED_REFERAL
2 | CONNECTED_ISP_SIGNUP
3 | CONNECTED_ISP_MIGRATE
4 | CONNECTED_REGISTRATION
sISPFile
String. The location and file name of the .isp file.

Return Values

Boolean. Returns the value TRUE if Windows Welcome successfully completes the connection.

Applies To

window.external

Example

var CONNECTED_REFERAL=1
window.external.ReDialEx(CONNECTED_REFERAL, "phone.isp");


Register method

Retrieves a reference to the Register object.

Syntax

window.external.Register;

Parameters

None

Return Values

Object. A reference to the Register object.

Applies To

window.external

Example

var Obj = new Object;
Obj = window.external.Register;
var bDataPosted = Obj.get_PostToOEM;


RunManualICW method

Starts the Internet Connection Wizard and closes Windows Welcome. Only use RunManualICW in reminder pages for product registration or the ISP sign-up offer.

Syntax

window.external.RunManualICW();

Parameters

None

Return Values

None

Applies To

window.external


set_DialNumber method

Sets the number to dial after a dialing error.

Note

  • Only call this method after a dialing error has occurred and before another attempt to dial the Internet service provider (ISP).

Syntax

window.external.set_DialNumber(sNumber);

Parameters

sNumber
String. The number to dial the next time a dialing attempt is made.

Return Values

None

Applies To

window.external


Signup method

Retrieves a reference to the Signup object.

Syntax

window.external.Signup;

Parameters

None

Return Values

Object. A reference to the Signup object.

Applies To

window.external

Example

var Obj = new Object;
Obj = window.external.Signup;
var sLocale =  Obj.get_Locale;


Status method

Retrieves a reference to the Status object.

Syntax

window.external.Status;

Parameters

None

Return Values

Object. A reference to the Status object.

Applies To

window.external

Example

var Obj = new Object;
Obj = window.external.Status;
var bPIDComplete =  Obj.get_PIDCompleted;


Tapi method

Retrieves a reference to the Tapi object.

Syntax

window.external.Tapi;

Parameters

None

Return Values

Object. A reference to the Tapi object.

Applies To

window.external

Example

var Obj = new Object;
Obj = window.external.Tapi;
Obj.set_AreaCode = "555";


UserInfo method

Retrieves a reference to the UserInfo object.

Syntax

window.external.UserInfo;

Parameters

None

Return Values

Object. A reference to the UserInfo object.

Applies To

window.external

Example

var Obj = new Object;
Obj = window.external.UserInfo;
Obj.set_FirstName = "John";


API object

  • API.DeleteRegKey method
  • API.DeleteRegValue method
  • API.get_CSIDLDirectory method
  • API.get_INIKey method
  • API.get_RegValue method
  • API.get_SystemDirectory method
  • API.LoadFile method
  • API.RegFlushKey method
  • API.SaveFile method
  • API.SaveFileByCSIDL method
  • API.set_RegValue method

Use the window.external.API method to access the API object.


API.DeleteRegKey method

banner

DeleteRegKey method

Deletes a section in the Windows registry.

Syntax

window.external.API.DeleteRegKey (lHKey, sSectionName);

Parameters

lHKey
Long. One of the predefined HKEY values:
0x80000000 - HKEY_CLASSES_ROOT
0x80000001 - HKEY_CURRENT_USER
0x80000002 - HKEY_LOCAL_MACHINE
0x80000003 - HKEY_USERS
0x80000004 - HKEY_PERFORMANCE_DATA
0x80000005 - HKEY_CURRENT_CONFIG
0x80000006 - HKEY_DYN_DATA
sSectionName
String. The section in the Windows registry to delete.

Return Values

None

Applies To

window.external.API

Example

HKEY_LOCAL_MACHINE = 0x80000002;
window.external.API.DeleteRegKey(HKEY_LOCAL_MACHINE,"SOFTWARE\\MySection";


API.DeleteRegValue method

banner

DeleteRegValue method

Deletes a specific value in the Windows registry.

Syntax

window.external.API.DeleteRegValue(lHKey, sSectionName, sKeyName);

Parameters

lHKey
Long. One of the predefined HKEY values:
0x80000000 - HKEY_CLASSES_ROOT
0x80000001 - HKEY_CURRENT_USER
0x80000002 - HKEY_LOCAL_MACHINE
0x80000003 - HKEY_USERS
0x80000004 - HKEY_PERFORMANCE_DATA
0x80000005 - HKEY_CURRENT_CONFIG
0x80000006 - HKEY_DYN_DATA
sSectionName
String. The section in the Windows registry where the registry key is located.
sKeyName
String. The name of the registry key to delete.

Return Values

None

Applies To

window.external.API

Example

HKEY_LOCAL_MACHINE = 0x80000002;
window.external.API.DeleteRegValue(HKEY_LOCAL_MACHINE, "SOFTWARE\\MySection", "MyKey");


API.get_CSIDLDirectory method

banner

get_CSIDLDirectory method

Retrieves the path to the specified CSIDL directory.

Note

  • For details on CSIDL, consult the Microsoft® Platform Software Development Kit (SDK).

Syntax

sPath = window.external.API.get_CSIDLDirectory();

Parameters

None

Return Values

String. The path to the specified CSIDL directory.

Applies To

window.external.API


API.get_INIKey method

banner

get_INIKey method

Retrieves a value from an .ini file.

Syntax

sValue = window.external.API.get_INIKey(sINIFileName, sSectionName, sKeyName);

Parameters

sINIFileName
String. The .ini file where the value is located.
sSectionName
String. The section in the .ini file where the value is located.
sKeyName
String. The entry in the .ini file containing the specified value.

Return Values

Returns a string that is the value of the sKeyName entry in the .ini file.

Applies To

window.external.API


API.get_RegValue method

banner

get_RegValue method

Retrieves a value from a location in the Windows registry.

Note

  • Only registry values stored as strings or DWORDs are supported.

Syntax

sValue = window.external.API.get_RegValue(lHKey, sSectionName, sKeyName);

Parameters

lHKey
Long. One of the predefined HKEY values:
0x80000000 - HKEY_CLASSES_ROOT
0x80000001 - HKEY_CURRENT_USER
0x80000002 - HKEY_LOCAL_MACHINE
0x80000003 - HKEY_USERS
0x80000004 - HKEY_PERFORMANCE_DATA
0x80000005 - HKEY_CURRENT_CONFIG
0x80000006 - HKEY_DYN_DATA
sSectionName
String. The section in the Windows registry where the registry key is located.
sKeyName
String. The name of the registry key for which you want the value.

Return Values

String. The value from the Windows registry.

Applies To

window.external.API

Example

HKEY_LOCAL_MACHINE = 0x80000002;
sValue = window.external.API.get_RegValue(HKEY_LOCAL_MACHINE, "SOFTWARE\\MySection", "MyKey");


API.get_SystemDirectory method

banner

get_SystemDirectory method

Retrieves the path to the Windows system directory, %windir%\System32.

Syntax

sPath = window.external.API.get_SystemDirectory();

Parameters

None

Return Values

String. The path to the Windows system directory, %windir%\System32.

Applies To

window.external.API


API.LoadFile method

banner

LoadFile method

Retrieves the contents of a file.

Syntax

sContents = window.external.API.LoadFile(sPathToFile);

Parameters

sPathToFile
String. Path to the file to read its contents.

Return Values

String. The contents of the file.

Applies To

window.external.API


API.RegFlushKey method

banner

RegFlushKey method

Deletes a specific value in the Windows registry.

Syntax

window.external.API.RegFlushKey(lHKey);

Parameters

lHKey
Long. One of the predefined HKEY values:
0x80000000 - HKEY_CLASSES_ROOT
0x80000001 - HKEY_CURRENT_USER
0x80000002 - HKEY_LOCAL_MACHINE
0x80000003 - HKEY_USERS
0x80000004 - HKEY_PERFORMANCE_DATA
0x80000005 - HKEY_CURRENT_CONFIG
0x80000006 - HKEY_DYN_DATA

Return Values

None

Applies To

window.external.API

Example

HKEY_LOCAL_MACHINE = 0x80000002;
window.external.API.DeleteRegValue(HKEY_LOCAL_MACHINE, "SOFTWARE\\MySection", "MyKey");


API.SaveFile method

banner

SaveFile method

Retrieves a file from a URL and saves it in the specified location.

Note

  • SaveFile uses the Win32 URLDownloadToFile application programming interface (API) in an asynchronous fashion.

Syntax

window.external.API.SaveFile(sURL, sPath [,sNewFileName]);

Parameters

sURL
String. Required. The URL from which to retrieve the file.
sPath
String. Required. The path on the end user computer where the file is saved.
sNewFileName
String. Optional. The name under which this file is saved. If sNewFileName is not specified, the file name is the one returned by the URL.

Return Values

None

Applies To

window.external.API


API.SaveFileByCSIDL method

banner

SaveFileByCSIDL method

Retrieves a file from a URL and saves it in the CSIDL location specified.

Notes

  • SaveFileByCSIDL uses the Win32 URLDownloadToFile application programming interface (API) in an asynchronous fashion.
  • For details on CSIDL, consult the Microsoft® Platform Software Development Kit (SDK).

Syntax

window.external.API.SaveFileByCSIDL(sURL, iPath [,sNewFileName]);

Parameters

sURL
String. Required. The URL from which to retrieve the file.
iPath
Integer. Required. The CSIDL location on the end user's computer where the file is saved.
sNewFileName
String. Optional. The name under which this file is saved. If sNewFileName is not specified, the file name is the one returned by the URL.

Return Values

None

Applies To

window.external.API


API.set_RegValue method

banner

set_RegValue method

Sets a value in a location in the Windows registry.

Note

  • Only registry values stored as strings or DWORDs are supported.

Syntax

window.external.API.set_RegValue(lHKey, sSectionName, sKeyName, sValue);

Parameters

lHKey
Long. One of the predefined HKEY values:
0x80000000 - HKEY_CLASSES_ROOT
0x80000001 - HKEY_CURRENT_USER
0x80000002 - HKEY_LOCAL_MACHINE
0x80000003 - HKEY_USERS
0x80000004 - HKEY_PERFORMANCE_DATA
0x80000005 - HKEY_CURRENT_CONFIG
0x80000006 - HKEY_DYN_DATA
sSectionName
String. The section in the Windows registry where the registry key is located.
sKeyName
String. The name of the registry key where the value is stored.
sValue
String. The value to save in the registry. (This value can also be a DWORD.)

Return Values

None

Applies To

window.external.API

Example

HKEY_LOCAL_MACHINE = 0x80000002;
window.external.API.set_RegValue(HKEY_LOCAL_MACHINE, "SOFTWARE\\MySection", "MyKey", "Hello World");


Directions object

  • Directions.get_DoIMETutorial method
  • Directions.get_DoMouseTutorial method
  • Directions.get_DoOEMAddRegistration method
  • Directions.get_DoOEMHardwareCheck method
  • Directions.get_DoOEMRegistration method
  • Directions.get_DoRegionalKeyboard method
  • Directions.get_ISPSignup method
  • Directions.get_OEMOfferCode method
  • Directions.get_Offline method

Use the window.external.Directions method to access the Directions object.


Directions.get_DoIMETutorial method

banner

get_DoIMETutorial method

Returns the value of IMETutorial in the [Options] section in Oobeinfo.ini.

Syntax

sValue = window.external.Directions.get_DoIMETutorial();

Parameters

None

Return Values

String. The value of IMETutorial in the [Options] section in Oobeinfo.ini.

Applies To

window.external.Directions


Directions.get_DoMouseTutorial method

banner

get_DoMouseTutorial method

Returns the value of MouseTutorial in the [Options] section in Oobeinfo.ini.

Syntax

sValue = window.external.Directions.get_DoMouseTutorial();

Parameters

None

Return Values

String. The value of MouseTutorial in the [Options] section in Oobeinfo.ini.

Applies To

window.external.Directions


Directions.get_DoOEMAddRegistration method

banner

get_DoOEMAddRegistration method

Returns the value of RegPostURL in the [OEMRegistrationPage] section in Oobeinfo.ini.

Syntax

sValue = window.external.Directions.get_DoOEMAddRegistration();

Parameters

None

Return Values

String. The value of RegPostURL in the [OEMRegistrationPage] section in Oobeinfo.ini.

Applies To

window.external.Directions


Directions.get_DoOEMHardwareCheck method

banner

get_DoOEMHardwareCheck method

Returns the value of the OEMHWCheck entry in the [OEMHardwareCheck] section in Oobeinfo.ini.

Syntax

sValue = window.external.Directions.get_DoOEMHardwareCheck();

Parameters

None

Return Values

String. The value of the OEMHWCheck entry in the [OEMHardwareCheck] section in Oobeinfo.ini.

Applies To

window.external.Directions


Directions.get_DoOEMRegistration method

banner

get_DoOEMRegistration method

Returns value of the OEMRegPage entry in the [OEMRegistrationPage] section in Oobeinfo.ini.

Syntax

sValue = window.external.Directions.get_DoOEMRegistration();

Parameters

None

Return Values

String. The value of the OEMRegPage entry in the [OEMRegistrationPage] section in Oobeinfo.ini.

Applies To

window.external.Directions


Directions.get_DoRegionalKeyboard method

banner

get_DoRegionalKeyboard method

Returns the value of the INTL_Settings in the [Options] section in Oobeinfo.ini.

Syntax

sValue = window.external.Directions.get_DoRegionalKeyboard();

Parameters

None

Return Values

String. The value of the INTL_Settings in the [Options] section in Oobeinfo.ini.

Applies To

window.external.Directions


Directions.get_ISPSignup method

banner

get_ISPSignup method

Returns the value of ISPSignup in the [Signup] section in Oobeinfo.ini.

Syntax

sValue = window.external.Directions.get_ISPSignup();

Parameters

None

Return Values

String. The value of ISPSignup in the [Signup] section in Oobeinfo.ini.

Applies To

window.external.Directions


Directions.get_OEMOfferCode method

banner

get_OEMOfferCode method

Returns value of the OEMOfferCode entry in the [Signup] section in Oobeinfo.ini.

Syntax

sValue = window.external.Directions.get_OEMOfferCode();

Parameters

None

Return Values

String. The value of the OEMOfferCode entry in the [Signup] section in Oobeinfo.ini.

Applies To

window.external.Directions


Directions.get_Offline method

banner

get_Offline method

Returns the value of the Offline entry in the [StartupOptions] section in Oobeinfo.ini.

Syntax

sValue = window.external.Directions.get_Offline();

Parameters

None

Return Values

String. The value of the Offline entry in the [StartupOptions] section in Oobeinfo.ini.

Applies To

window.external.Directions


Language object

  • Language.get_KeyboardLayoutIndex method
  • Language.get_KeyboardLayoutName method
  • Language.get_NumOfKeyboardLayouts method
  • Language.get_NumOfRegions method
  • Language.get_RebootState method
  • Language.get_RegionIndex method
  • Language.get_RegionName method
  • Language.SaveSettings method

Use the window.external.Language method to access the Language object.


Language.get_KeyboardLayoutIndex method

banner

get_KeyboardLayoutIndex method

Returns the index of keyboard layouts for the computer.

Syntax

iKeyboardLayoutIndex = window.external.Language.get_KeyboardLayoutIndex();

Parameters

None

Return Values

Integer. The keyboard layout index of the computer.

Applies To

window.external.Language


Language.get_KeyboardLayoutName method

banner

get_KeyboardLayoutName method

Returns the friendly name for a given keyboard layout.

Syntax

sKeyboardLayout = window.external.Language.get_KeyboardLayoutName(iKeyboardLayoutIndex);

Parameters

iKeyboardLayoutIndex
Integer. The corresponding index of the keyboard layouts.

Return Values

String. The friendly name of the keyboard layout.

Applies To

window.external.Language


Language.get_NumOfKeyboardLayouts method

banner

get_NumOfKeyboardLayouts method

Returns the total number of available keyboard layouts.

Syntax

iNumberOfKeyboardLayouts = window.external.Language.get_NumOfKeyboardLayouts();

Parameters

None

Return Values

Integer. The total number of available keyboard layouts.

Applies To

window.external.Language


Language.get_NumOfRegions method

banner

get_NumOfRegions method

Returns the total number of regional options available to the end user.

Syntax

iNumberOfRegions = window.external.Language.get_NumOfRegions();

Parameters

None

Return Values

Integer. The total number of regional options available to the end user.

Applies To

window.external.Language


Language.get_RebootState method

banner

get_RebootState method

Specifies whether the computer must be restarted.

Syntax

iRebootState = window.external.Language.get_RebootState();

Parameters

None

Return Values

Integer. The type of reboot needed if any.

Value | Description
0 | No reboot needed.
1 | Reboot needed now (after the region and keyboard layout are set).
2 | Reboot needed after the end user completes Windows Welcome.

Use the value of get_RebootState to determine if you need to call windows.external.PowerDown.

Applies To

window.external.Language


Language.get_RegionIndex method

banner

get_RegionIndex method

Returns the index of the computer's regional setting.

Syntax

iRegionIndex = window.external.Language.get_RegionIndex();

Parameters

None

Return Values

Integer. The index of the computer's regional setting.

Applies To

window.external.Language


Language.get_RegionName method

banner

get_RegionName method

Returns the friendly name corresponding to a given regional index.

Syntax

sRegionName = window.external.Language.get_RegionName(iRegionIndex);

Parameters

iRegionIndex
Integer. Index of the region.

Return Values

String. The friendly name for a corresponding regional index.

Applies To

window.external.Language


Language.SaveSettings method

banner

SaveSettings method

Saves the current regional and keyboard layout indexes. After calling SaveSettings, call window.external.get_RebootState to determine if the computer must be rebooted.

Syntax

window.external.Language.SaveSettings();

Parameters

None

Return Values

None

Applies To

window.external.Language


Register object

  • Register.get_PostToOEM method
  • Register.get_RegPostURL method

Use the window.external.Register method to access the Register object.


Register.get_PostToOEM method

banner

get_PostToOEM method

Returns the value of the PostToOEM entry in the [OEMRegistrationPage] section of Oobeinfo.ini.

Syntax

iValue = window.external.Register.get_PostToOEM();

Parameters

None

Return Values

Integer. The value of the PostToOEM entry in the [OEMRegistrationPage] section of Oobeinfo.ini.

Applies To

window.external.Register


Register.get_RegPostURL method

banner

get_RegPostURL method

Returns the value of the RegPostURL entry in the [OEMRegistrationPage] section of Oobeinfo.ini.

Syntax

sUrl = window.external.Register.get_RegPostURL();

Parameters

None

Return Values

String. The value of the RegPostURL entry in the [OEMRegistrationPage] section of Oobeinfo.ini.

Applies To

window.external.Register


Signup object

The Signup object identifies the manufacturer of the computer when the end user establishes Internet access using one of the preconfigured ISP sign-up offers.

  • Signup.get_OEMName method

Use the window.external.Signup method to access the Signup object.


Signup.get_OEMName method

banner

get_OEMName method

Returns the value of the OEMName entry in the [Branding] section of Oobeinfo.ini.

Syntax

sIDLocale = window.external.Signup.get_OEMName();

Parameters

None

Return Values

String. The value of the OEMName entry in the [Branding] section of Oobeinfo.ini.

Applies To

window.external.Signup


Status object

  • Status.get_ISPSignupCompleted method
  • Status.get_LanguageCompleted method
  • Status.get_MouseTutorCompleted method
  • Status.get_OEMInfoCompleted method
  • Status.get_PIDCompleted method
  • Status.get_SignatureCompleted method
  • Status.get_Status method
  • Status.get_TAPICompleted method
  • Status.get_TimeZoneCompleted method
  • Status.get_UserInfoPosted method
  • Status.get_UserInfoStamped method
  • Status.set_Status method

Use the window.external.Status method to access the Status object.


Status.get_ISPSignupCompleted method

banner

get_ISPSignupCompleted method

Checks whether the end user has completed the ISP sign-up checkpoint in Windows Welcome.

Syntax

bCompleted= window.external.Status.get_ISPSignupCompleted();

Parameters

None

Return Values

Boolean. Returns the value TRUE if the end user has completed the ISP sign-up checkpoint in Windows Welcome.

Applies To

window.external.Status


Status.get_LanguageCompleted method

banner

get_LanguageCompleted method

Checks whether the end user has completed the Language checkpoint in Windows Welcome.

Syntax

bCompleted= window.external.Status.get_LanguageCompleted();

Parameters

None

Return Values

Boolean. Returns the value TRUE if the end user has completed the Language checkpoint in Windows Welcome.

Applies To

window.external.Status


Status.get_MouseTutorCompleted method

banner

get_MouseTutorCompleted method

Checks whether the end user has completed the mouse tutorial in Windows Welcome.

Syntax

bCompleted= window.external.Status.get_MouseTutorCompleted();

Parameters

None

Return Values

Boolean. Returns the value TRUE if the end user has completed the mouse tutorial in Windows Welcome.

Applies To

window.external.Status


Status.get_OEMInfoCompleted method

banner

get_OEMInfoCompleted method

Checks whether the end user has completed the OEM registration checkpoint in Windows Welcome.

Syntax

bCompleted= window.external.Status.get_OEMInfoCompleted();

Parameters

None

Return Values

Boolean. Returns the value TRUE if the end user has completed the OEM registration checkpoint in Windows Welcome.

Applies To

window.external.Status


Status.get_PIDCompleted method

banner

get_PIDCompleted method

Checks whether the end user has completed the product key checkpoint in Windows Welcome.

Syntax

bCompleted= window.external.Status.get_PIDCompleted();

Parameters

None

Return Values

Boolean. Returns the value TRUE if the end user has completed the PID checkpoint in Windows Welcome.

Applies To

window.external.Status


Status.get_SignatureCompleted method

banner

get_SignatureCompleted method

Checks whether the end user has completed the Microsoft Passport ID checkpoint in Windows Welcome.

Syntax

bCompleted= window.external.Status.get_SignatureCompleted();

Parameters

None

Return Values

Boolean. Returns the value TRUE if the end user has completed the Microsoft Passport ID checkpoint in Windows Welcome.

Applies To

window.external.Status


Status.get_Status method

banner

get_Status method

Checks whether the end user has completed a custom event in Windows Welcome.

Syntax

bCompleted= window.external.Status.get_Status(sCustomEvent);

Parameters

sCustomEvent
String. The name of the custom event to check.

Return Values

Boolean. Returns the value TRUE if the end user has completed a custom event in Windows Welcome.

Applies To

window.external.Status

Example

bCompleted = window.external.Status.get_Status("MyUSBIntroduction");


Status.get_TAPICompleted method

banner

get_TAPICompleted method

Checks whether the end user has completed the Telephony API (TAPI) checkpoint in Windows Welcome.

Syntax

bCompleted= window.external.Status.get_TAPICompleted();

Parameters

None

Return Values

Boolean. Returns the value TRUE if the end user has completed the TAPI checkpoint in Windows Welcome.

Applies To

window.external.Status


Status.get_TimeZoneCompleted method

banner

get_TimeZoneCompleted method

Checks whether the end user has completed the setting of the system clock and time zone checkpoint in Windows Welcome.

Syntax

bCompleted= window.external.Status.get_TimeZoneCompleted();

Parameters

None

Return Values

Boolean. Returns the value TRUE if the end user has completed the setting of the system clock and time zone checkpoint in Windows Welcome.

Applies To

window.external.Status


Status.get_UserInfoPosted method

banner

get_UserInfoPosted method

Checks whether the end user registration information has been posted.

Syntax

bCompleted= window.external.Status.get_UserInfoPosted();

Parameters

None

Return Values

Boolean. Returns the value TRUE if the end user's registration information has been posted.

Applies To

window.external.Status


Status.get_UserInfoStamped method

banner

get_UserInfoStamped method

Checks whether the end user registration information has been stamped into User.exe.

Syntax

bCompleted= window.external.Status.get_UserInfoStamped();

Parameters

None

Return Values

Boolean. Returns the value TRUE if the end user's registration information has been stamped into User.exe.

Applies To

window.external.Status


Status.set_Status method

banner

set_Status method

Sets whether the end user has completed a custom event in Windows Welcome.

Syntax

window.external.Status.set_Status(sCustomEvent, bCompleted);

Parameters

sCustomEvent
String. The name of the custom event to set.
bCompleted
Boolean. Returns the value TRUE if the end user has completed a custom event in Windows Welcome.

Return Values

None

Applies To

window.external.Status

Example

window.external.Status.set_Status("MyUSBIntroduction", true);


Tapi object

  • Tapi.get_AllCountryName method
  • Tapi.get_AreaCode method
  • Tapi.get_CountryIndex method
  • Tapi.get_CountryNameForIndex method
  • Tapi.get_DialOut method
  • Tapi.get_NumOfCountry method
  • Tapi.get_PhoneSystem method
  • Tapi.IsAreaCodeRequired method
  • Tapi.IsTAPIConfigured method
  • Tapi.set_AreaCode method
  • Tapi.set_CountryIndex method
  • Tapi.set_DialOut method
  • Tapi.set_PhoneSystem method

Use the window.external.Tapi method to access the Tapi object.


Tapi.get_AllCountryName method

banner

get_AllCountryName method

Returns a string buffer containing all the Telephony API (TAPI) country/region names formatted for insertion into a Hypertext Markup Language (HTML) <SELECT> element.

Syntax

sBuffer = window.external.Tapi.get_AllCountryName();

Parameters

None

Return Values

String. A string buffer containing all the TAPI country/region names formatted as:

<OPTION>[name of country]</OPTION><OPTION>...

Applies To

window.external.Tapi


Tapi.get_AreaCode method

banner

get_AreaCode method

Returns the area code that the Tapi object uses when dialing.

Syntax

sAreaCode = window.external.Tapi.get_AreaCode();

Parameters

None

Return Values

String. The area code.

Applies To

window.external.Tapi


Tapi.get_CountryIndex method

banner

get_CountryIndex method

Returns the index of the country or region used by the Tapi.

Syntax

iCountryIndex = window.external.Tapi.get_CountryIndex();

Parameters

None

Return Values

Integer. The index number of the country or region.

Applies To

window.external.Tapi


Tapi.get_CountryNameForIndex method

banner

get_CountryNameForIndex method

Returns the friendly name for a given Telephony API (TAPI) country/region index.

Syntax

sCountryName = window.external.Tapi.get_CountryNameForIndex(iCountryIndex);

Parameters

iCountryIndex
Integer. The index number of the TAPI country or region.

Return Values

String. The friendly name corresponding to the TAPI country index value.

Applies To

window.external.Tapi


Tapi.get_DialOut method

banner

get_DialOut method

Returns the number, if any, that the Tapi object dials to reach an outside line.

Syntax

sNumberToDial = window.external.Tapi.get_DialOut();

Parameters

None

Return Values

String. The number the Tapi object dials to reach an outside line.

Applies To

window.external.Tapi


Tapi.get_NumOfCountry method

banner

get_NumOfCountry method

Returns the total number of countries or regions available to the Tapi object.

Syntax

iNumberOfCountries = window.external.Tapi.get_NumOfCountry();

Parameters

None

Return Values

Integer. The total number of countries or regions available.

Applies To

window.external.Tapi


Tapi.get_PhoneSystem method

banner

get_PhoneSystem method

Returns the type of telephone system the Tapi object uses when dialing a telephone modem.

Syntax

iPhoneSystemType = window.external.Tapi.get_PhoneSystem();

Parameters

None

Return Values

Integer. The number value for the type of telephone system the Tapi object uses when dialing a telephone modem.

Value | Description
0 | Pulse dialing
1 | Touch Tone dialing

Applies To

window.external.Tapi


Tapi.IsAreaCodeRequired method

banner

IsAreaCodeRequired method

Specifies whether an area code is required for a particular country, identified by Tapi.get_CountryIndex.

Syntax

bIsRequired = window.external.Tapi.IsAreaCodeRequired(iCountryIndex);

Parameters

iCountryIndex
Integer. The Telephony API (TAPI) country index that is checked.

Return Values

Boolean. Returns the value TRUE if an area code is required for a particular country or region.

Applies To

window.external.Tapi


Tapi.IsTAPIConfigured method

banner

IsTAPIConfigured method

Returns whether or not the Tapi object is configured correctly.

Syntax

bTapiIsSetup = window.external.Tapi.IsTAPIConfigured();

Parameters

None

Return Values

Boolean. Returns the value TRUE if the Tapi object is configured correctly. Returns the value FALSE if the Tapi object must be configured before dialing the modem.

Applies To

window.external.Tapi


Tapi.set_AreaCode method

banner

set_AreaCode method

Sets the area code that the Tapi object uses when dialing.

Syntax

window.external.Tapi.set_AreaCode(sAreaCode);

Parameters

sAreaCode
String. The area code.

Return Values

None

Applies To

window.external.Tapi


Tapi.set_CountryIndex method

banner

set_CountryIndex method

Sets the index of the country or region used by the Tapi.

Syntax

window.external.Tapi.set_CountryIndex(iCountryIndex);

Parameters

iCountryIndex
Integer. The index of the country or region.

Return Values

None

Applies To

window.external.Tapi


Tapi.set_DialOut method

banner

set_DialOut method

Sets the number that the Tapi object dials to reach an outside line.

Syntax

window.external.Tapi.set_DialOut(sNumber);

Parameters

sNumber
String. The number that the Tapi object dials to reach an outside line.

Return Values

None

Applies To

window.external.Tapi


Tapi.set_PhoneSystem method

banner

set_PhoneSystem method

Determines the type of telephone system the Tapi object uses when dialing a telephone modem.

Syntax

window.external.Tapi.set_PhoneSystem(iPhoneSystemType);

Parameters

iPhoneSystemType
Integer. The type of telephone system that the Tapi object uses when dialing a telephone modem.
Value | Description
0 | Pulse dialing
1 | Touch Tone dialing

Return Values

None

Applies To

window.external.Tapi


UserInfo object

The UserInfo object stores specific information about the end user that is transmitted during the registration process. In addition, the UserInfo object stores information to configure the user accounts.

  • UserInfo.check_Identity method
  • UserInfo.get_Address1 method
  • UserInfo.get_Address2 method
  • UserInfo.get_AreaCode method
  • UserInfo.get_City method
  • UserInfo.get_CompanyName method
  • UserInfo.get_Country method
  • UserInfo.get_FirstName method
  • UserInfo.get_FuriganaName method
  • UserInfo.get_IdentitiesMax method
  • UserInfo.get_Identity method
  • UserInfo.get_LastName method
  • UserInfo.get_MiddleInitial method
  • UserInfo.get_PhoneNumber method
  • UserInfo.get_PrimaryEmail method
  • UserInfo.get_SecondaryEmail method
  • UserInfo.get_State method
  • UserInfo.get_Zip method
  • UserInfo.set_Address1 method
  • UserInfo.set_Address2 method
  • UserInfo.set_AreaCode method
  • UserInfo.set_City method
  • UserInfo.set_CompanyName method
  • UserInfo.set_Country method
  • UserInfo.set_FirstName method
  • UserInfo.set_FuriganaName method
  • UserInfo.set_Identity method
  • UserInfo.set_LastName method
  • UserInfo.set_MiddleInitial method
  • UserInfo.set_PhoneNumber method
  • UserInfo.set_PrimaryEmail method
  • UserInfo.set_SecondaryEmail method
  • UserInfo.set_State method
  • UserInfo.set_Zip method

Use the window.external.UserInfo method to access the UserInfo object.


UserInfo.check_Identity method

banner

check_Identity method

Returns the first line of the end user's address, if it is set.

Syntax

sAddress1 = window.external.UserInfo.get_Address1();

Parameters

None

Return Values

String. The value of the first line of the end user's address stored in the UserInfo object.

Applies To

window.external.UserInfo


UserInfo.get_Address1 method

banner

get_Address1 method

Returns the first line of the end user's address, if it is set.

Syntax

sAddress1 = window.external.UserInfo.get_Address1();

Parameters

None

Return Values

String. The value of the first line of the end user's address that is stored in the UserInfo object.

Applies To

window.external.UserInfo


UserInfo.get_Address2 method

banner

get_Address2 method

Returns the second line of the end user's address, if it is set.

Syntax

sAddress2 = window.external.UserInfo.get_Address2();

Parameters

None

Return Values

String. The value of the second line of the end user's address that is stored in the UserInfo object.

Applies To

window.external.UserInfo


UserInfo.get_AreaCode method

banner

get_AreaCode method

Returns the end user's area code.

Syntax

sAreaCode = window.external.UserInfo.get_AreaCode();

Parameters

None

Return Values

String. The value of the area code that is stored in the UserInfo object.

Applies To

window.external.UserInfo


UserInfo.get_City method

banner

get_City method

Returns the name of the end user's city.

Syntax

sCity = window.external.UserInfo.get_City();

Parameters

None

Return Values

String. The value of the city stored in the UserInfo object.

Applies To

window.external.UserInfo


UserInfo.get_CompanyName method

banner

get_CompanyName method

Returns the end user's company name.

Syntax

sCompanyName = window.external.UserInfo.get_CompanyName();

Parameters

None

Return Values

String. The company name that is stored in the UserInfo object.

Applies To

window.external.UserInfo


UserInfo.get_Country method

banner

get_Country method

Returns the end user's country or region.

Syntax

sCountry = window.external.UserInfo.get_Country();

Parameters

None

Return Values

String. The country or region stored in the UserInfo object.

Applies To

window.external.UserInfo


UserInfo.get_FirstName method

banner

get_FirstName method

Returns the end user's first name.

Syntax

sFirstName = window.external.UserInfo.get_FirstName();

Parameters

None

Return Values

String. The value of the end user's first name stored in the UserInfo object.

Applies To

window.external.UserInfo


UserInfo.get_FuriganaName method

banner

get_FuriganaName method

The Japanese writing system is composed of two different types of characters, kana and kanji. Each kana character has a specific pronunciation.

Individual kanji characters often have more than one pronunciation, and each pronunciation has a different meaning. Kanji characters are often augmented with tiny kana characters written above or next to the kanji characters, where the kana characters indicate the correct pronunciation of the word. Kana used in this way is called furigana.

get_FuriganaName returns the furigana version of the end user's name.

Syntax

sFuriganaName = window.external.UserInfo.get_FuriganaName();

Parameters

None

Return Values

String. The value of the furigana version of the end user's name that is stored in the UserInfo object.

Applies To

window.external.UserInfo

See also

UserInfo.get_FirstName

UserInfo.get_LastName

UserInfo.set_FuriganaName


UserInfo.get_IdentitiesMax method

banner

get_IdentitiesMax method

Returns the maximum number of user accounts that the end user can create in Windows Welcome.

Syntax

window.external.UserInfo.get_IdentitiesMax();

Parameters

None

Return Values

Integer. The maximum number of user accounts the end user can create in Windows Welcome.

Applies To

window.external.UserInfo


UserInfo.get_Identity method

banner

get_Identity method

Returns the name of a specific user account.

Syntax

window.external.UserInfo.get_Identity(index);

Parameters

index
Integer. The index of the specified user account. The value is greater than or equal to 0; less than the value of UserInfo.get_IdentitiesMax.

Return Values

String. The user account corresponding to the specified index.

Applies To

window.external.UserInfo


UserInfo.get_LastName method

banner

get_LastName method

Returns the end user's last name.

Syntax

sLastName = window.external.UserInfo.get_LastName();

Parameters

None

Return Values

String. The value of the end user's last name that is stored in the UserInfo object.

Applies To

window.external.UserInfo


UserInfo.get_MiddleInitial method

banner

get_MiddleInitial method

Returns the end user's middle initial.

Syntax

sMiddleInitial = window.external.UserInfo.get_MiddleInitial();

Parameters

None

Return Values

String. The value of the end user's middle initial that is stored in the UserInfo object.

Applies To

window.external.UserInfo


UserInfo.get_PhoneNumber method

banner

get_PhoneNumber method

Returns the end user's telephone number.

Syntax

sPhoneNumber = window.external.UserInfo.get_PhoneNumber();

Parameters

None

Return Values

String. The value of the end user's telephone number that is stored in the UserInfo object.

Applies To

window.external.UserInfo


UserInfo.get_PrimaryEmail method

banner

get_PrimaryEmail method

Returns the end user's primary e-mail address.

Syntax

sPrimaryEmail = window.external.UserInfo.get_PrimaryEmail();

Parameters

None

Return Values

String. The end user's primary e-mail address that is stored in the UserInfo object.

Applies To

window.external.UserInfo


UserInfo.get_SecondaryEmail method

banner

get_SecondaryEmail method

Returns the end user's secondary e-mail address.

Syntax

sSecondaryEmail = window.external.UserInfo.get_SecondaryEmail();

Parameters

None

Return Values

String. The end user's secondary e-mail address that is stored in the UserInfo object.

Applies To

window.external.UserInfo


UserInfo.get_State method

banner

get_State method

Returns the end user's state of residence.

Syntax

sState = window.external.UserInfo.get_State();

Parameters

None

Return Values

String. The value of the end user's state that is stored in the UserInfo object.

Applies To

window.external.UserInfo


UserInfo.get_Zip method

banner

get_Zip method

Returns the end user's ZIP code or postal code.

Syntax

sZip = window.external.UserInfo.get_Zip();

Parameters

None

Return Values

String. The value of the end user's ZIP code or postal code that is stored in the UserInfo object.

Applies To

window.external.UserInfo


UserInfo.set_Address1 method

banner

set_Address1 method

Sets the first line of the end user's address.

Syntax

window.external.UserInfo.set_Address1(sAddress1);

Parameters

sAddress1
String. The value of the first line of the end user's address to save in the UserInfo object.

Return Values

None

Applies To

window.external.UserInfo


UserInfo.set_Address2 method

banner

set_Address2 method

Sets the second line of the end user's address.

Syntax

window.external.UserInfo.set_Address2(sAddress2);

Parameters

sAddress2
String. The value of the second line of the end user's address to save in the UserInfo object.

Return Values

None

Applies To

window.external.UserInfo


UserInfo.set_AreaCode method

banner

set_AreaCode method

Sets the end user's area code.

Syntax

window.external.UserInfo.set_AreaCode(sAreaCode);

Parameters

sAreaCode
String. The value of end user's area code that is stored in the UserInfo object.

Return Values

None

Applies To

window.external.UserInfo


UserInfo.set_City method

banner

set_City method

Sets the name of the end user's city.

Syntax

window.external.UserInfo.set_City(sCity);

Parameters

sCity
String. The name value of end user's city that is stored in the UserInfo object.

Return Values

None

Applies To

window.external.UserInfo


UserInfo.set_CompanyName method

banner

set_CompanyName method

Sets the end user's company name.

Syntax

window.external.UserInfo.set_CompanyName(sCompanyName);

Parameters

sCompanyName
String. The value of end user's company name that is stored in the UserInfo object.

Return Values

None

Applies To

window.external.UserInfo


UserInfo.set_Country method

banner

set_Country method

Sets the name of the end user's country or region.

Syntax

window.external.UserInfo.set_Country(sCountry);

Parameters

sCountry
String. The value of end user's country or region that is stored in the UserInfo object.

Return Values

None

Applies To

window.external.UserInfo


UserInfo.set_FirstName method

banner

set_FirstName method

Sets the end user's first name.

Syntax

window.external.UserInfo.set_FirstName(sFirstName);

Parameters

sFirstName
String. The value of end user's first name that is stored in the UserInfo object.

Return Values

None

Applies To

window.external.UserInfo


UserInfo.set_FuriganaName method

banner

set_FuriganaName method

The Japanese writing system is composed of two different types of characters, kana and kanji. Each kana character has a specific pronunciation.

Individual kanji characters often have more than one pronunciation, and each pronunciation has a different meaning. Kanji characters are often augmented with tiny kana characters written above or next to them to indicate the correct pronunciation of the word. Kana used in this way is called furigana.

set_FuriganaName sets the furigana version of the end user's name.

Syntax

window.external.UserInfo.set_FuriganaName(sFuriganaName);

Parameters

sFuriganaName
String. The furigana version of the end user's name that is stored in the UserInfo object.

Return Values

None

Applies To

window.external.UserInfo

See also

UserInfo.set_FirstName

UserInfo.set_LastName

UserInfo.get_FuriganaName


UserInfo.set_Identity method

banner

set_Identity method

Sets the name of a specific user account.

Syntax

window.external.UserInfo.set_Identity(index, idName);

Parameters

index
Integer. The index number of the specified user account.
idName
String. The name of the specified user account.

Return Values

None

Applies To

window.external.UserInfo


UserInfo.set_LastName method

banner

set_LastName method

Sets the end user's last name.

Syntax

window.external.UserInfo.set_LastName(sLastName);

Parameters

sLastName
String. The value of end user's last name that is stored in the UserInfo object.

Return Values

None

Applies To

window.external.UserInfo


UserInfo.set_MiddleInitial method

banner

set_MiddleInitial method

Sets the end user's middle initial.

Syntax

window.external.UserInfo.set_MiddleInitial(sMiddleInitial);

Parameters

sMiddleInitial
String. The value of the end user's middle initial that is stored in the UserInfo object.

Return Values

None

Applies To

window.external.UserInfo


UserInfo.set_PhoneNumber method

banner

set_PhoneNumber method

Sets the end user's telephone number.

Syntax

window.external.UserInfo.set_PhoneNumber(sPhoneNumber);

Parameters

sPhoneNumber
String. The value of the end user's telephone number that is stored in the UserInfo object.

Return Values

None

Applies To

window.external.UserInfo


UserInfo.set_PrimaryEmail method

banner

set_PrimaryEmail method

Sets the end user's primary e-mail address.

Syntax

window.external.UserInfo.set_PrimaryEmail(sPrimaryEmail);

Parameters

sPrimaryEmail
String. The value of end user's primary e-mail address that is stored in the UserInfo object.

Return Values

None

Applies To

window.external.UserInfo


UserInfo.set_SecondaryEmail method

banner

set_SecondaryEmail method

Sets the end user's secondary e-mail address.

Syntax

window.external.UserInfo.set_SecondaryEmail(sSecondaryEmail);

Parameters

sSecondaryEmail
String. The value of the end user's secondary e-mail address that is stored in the UserInfo object.

Return Values

None

Applies To

window.external.UserInfo


UserInfo.set_State method

banner

set_State method

Sets the name of the end user's state of residence.

Syntax

window.external.UserInfo.set_State(sState);

Parameters

sState
String. The value of the end user's state that is stored in the UserInfo object.

Return Values

None

Applies To

window.external.UserInfo


UserInfo.set_Zip method

banner

set_Zip method

Sets the end user's ZIP code.

Syntax

window.external.UserInfo.set_Zip(sZip);

Parameters

sZip
String. The value of the end user's ZIP code that is stored in the UserInfo object.

Return Values

None

Applies To

window.external.UserInfo


Glossary

Symbols A B C D E F G H I J K L M N O P Q R S T U V W X YZ

Symbols

$$Rename.txt

A file that lists all files contained in a particular folder that need to be renamed from an 8.3 format name to a long file name during Setup. All file names must be in 8.3 format if you run Setup using Winnt.exe, or if you are copying a set of files from one computer to another using MS-DOS.

%windir%

The default directory where Windows is installed, most commonly C:\winnt.

.adm

The file name extension for Administrative Templates files.

.cab file

Cabinet file. A single cabinet file that stores multiple compressed files. These files are commonly used in software installation and to reduce the file size and the associated download time for Web content.

.dll file

See definition for: dynamic-link library (DLL)

.inf file

Information file. A file created for a particular adapter that provides the operating system with information required to set up a device, such as a list of valid logical configurations for the device, the names of driver files associated with the device, and so on. An .inf file is provided typically on a disk by the device manufacturer or may be included in the operating system.

.ini file

Initialization file. Commonly used under Windows 3.x and earlier, .ini files have been used by both the operating system and individual applications to store persistent settings related to an application, driver, or piece of hardware. In Windows 32-bit operating systems, .ini files are supported for backward compatibility, but the registry is the preferred location for storing such settings.

.ins file

Internet settings file. A file that provides Windows Update Setup with Internet settings that configure the browser and associated components. You can create multiple versions of your browser package by changing the .ins file used by each package. Use the Profile Manager to create, save, and load .ins files.

100baseT

The Ethernet standard for local area networks using twisted-pair cable carrying data at 100 megabits per second (Mbps).

8.3

The standard format for file names in MS-DOS and Windows 3.x. A file name with eight or fewer characters, followed by a period (dot), followed by a three-character file extension.

A

account manager

A Microsoft employee who is the primary contact for the business relationship between the OEM and Microsoft.

ACPI

See definition for: Advanced Configuration and Power Interface (ACPI)

activation

See definition for: Windows Product Activation (WPA)

Active Directory

The directory service that stores information about objects on a network and makes this information available to users and network administrators. Active Directory gives network users access to permitted resources anywhere on the network using a single logon process. It provides network administrators with an intuitive, hierarchical view of the network and a single point of administration for all network objects.

See also: service

Active Directory Users and Computers

An administrative tool designed to perform day-to-day Active Directory administration tasks. These tasks include creating, deleting, modifying, moving, and setting permissions on objects stored in the directory. These objects include organizational units, users, contacts, groups, computers, printers, and shared file objects.

See also: permission; Active Directory; object

active partition

A partition from which an x86-based computer starts up. The active partition must be a primary partition on a basic disk. If you use Windows exclusively, the active partition can be the same as the system volume.

See also: basic disk; primary partition; system partition; x86

active volume

The volume from which the computer starts up. The active volume must be a simple volume on a dynamic disk. You cannot mark an existing dynamic volume as the active volume, but you can upgrade a basic disk containing the active partition to a dynamic disk. Once the disk is upgraded to dynamic, the partition becomes a simple volume that is active.

See also: active partition; basic disk; dynamic disk; dynamic volume; simple volume

adapter

See definition for: device

add-on devices

Devices that are traditionally added to the base PC system to increase functionality, such as audio, networking, graphics, or SCSI controller. Add-on devices fall into two categories: devices built onto the system board, and devices on expansion cards, added to the system through a system board connector, such as PCI.

administrator

For Windows XP Professional, a person responsible for setting up and managing domain controllers or local computers and their user and group accounts, assigning passwords and permissions, and helping users with networking problems. Administrators are members of the Administrators group and have full control over the domain or computer.

For Windows XP Home Edition, a person who can make system-wide changes to the computer, install software, and who has access to all files on the computer. A person with a computer administrator account has full access to other user accounts on the computer.

Advanced Configuration and Power Interface (ACPI)

An open industry specification that defines power management on a wide range of mobile, desktop, and server computers and peripherals. ACPI is the foundation for the OnNow industry initiative that allows system manufacturers to deliver computers that will start at the touch of a keyboard. ACPI design is essential to take full advantage of power management and Plug and Play.

See also: Plug and Play

agent character

An interactive animated character who guides users through Windows Welcome. The character interacts with the user in ways similar to the natural aspects of human social communication. Characters can respond using synthesized speech, recorded audio, or text in a cartoon word balloon.

See also: Windows Welcome

allocation unit

The smallest amount of disk space that can be allocated to hold a file. All file systems used by Windows organize hard disks based on allocation units. The smaller the allocation unit size, the more efficiently a disk stores information. If you do not specify an allocation unit size when formatting the disk, Windows picks default sizes based on the size of the volume. These default sizes are selected to reduce the amount of space that is lost and the amount of fragmentation on the volume. An allocation unit is also called a cluster.

See also: file system

American Standard Code for Information Interchange (ASCII)

A standard single-byte character encoding scheme used for text-based data. ASCII uses designated 7-bit or 8-bit number combinations to represent either 128 or 256 possible characters. Standard ASCII uses 7 bits to represent all uppercase and lowercase letters, the numbers 0 through 9, punctuation marks, and special control characters used in U.S. English. Most current x86-based systems support the use of extended (or "high") ASCII. Extended ASCII allows the eighth bit of each character to identify an additional 128 special symbol characters, foreign-language letters, and graphic symbols.

See also: Unicode

answer file

A text file that scripts the answers for a series of graphical user interface (GUI) dialog boxes. The answer file for Setup is commonly called Unattend.txt, but for a network preinstallation, you can name the file anything you like. For a CD-based Setup, the answer file must be named Winnt.sif. The answer files for Sysprep are Sysprep.inf and Winbom.ini. You can create or modify these answer files in a text editor or through Setup Manager.

See also: Unattend.txt

anti-aliasing

A software technique for smoothing the jagged appearance of curved or diagonal lines caused by poor resolution on a display screen. Methods of anti-aliasing include surrounding pixels with intermediate shades and manipulating the size and horizontal alignment of the pixels.

API

See definition for: application programming interface (API)

APIC

Advanced Programmable Interrupt Controller. A distributed set of devices that form an interrupt controller.

AppleTalk

The Apple Computer network architecture and network protocols. A network that has Macintosh clients and a computer running Windows 2000 Server or Windows NT Server with services for Macintosh functions as an AppleTalk network.

application programming interface (API)

A set of routines that an application uses to request and carry out lower-level services performed by a computer's operating system. These routines usually carry out maintenance tasks such as managing files and displaying information.

aspect ratio

The relationship of width and height for an image. When an image is displayed on different screens, the aspect ratio must be kept the same to avoid either vertical or horizontal distortion.

assigned configuration

The resources contained in the device node that are allocated for the device. For Plug and Play cards, the assigned resources for a device can change dynamically or from one system start-up to the next.

asynchronous

Not dependent on timing. Each application or command runs in the specified order, but the specified item does not wait for any previously started processes to finish before application or command runs.

ATM adaptation layer (AAL)

The layer of the ATM protocol stack that parses data into the payload portion of the ATM cell for transport across an ATM network.

attach

Run the Setup program for an application that is already staged on the destination computer.

See also: stage; destination computer; detach

attribute

For files, information that indicates whether a file is read-only, hidden, ready for archiving (backing up), compressed, or encrypted, and whether the file contents should be indexed for fast file searching.

In Active Directory, characteristics of an object and the type of information an object can hold. For each object class, the schema defines what attributes an instance of the class must have and what additional attributes it might have.

audit mode

Verifying, before it is delivered to the end user, that the fully-manufactured computer functions as expected. After auditing, always reseal the operating system to reset the first-run experience for the user.

authentication

The process for verifying that an entity or object is who or what it claims to be. Examples include confirming the source and integrity of information, such as verifying a digital signature or verifying the identity of a user or computer.

See also: smart card

authorized distributor

An independent company licensed by Microsoft Licensing, Inc. to manage the production and distribution of multipacks of Windows XP OEM products to system builders. If you purchase Microsoft software from someone other than a Microsoft authorized distributor, you run the risk of purchasing counterfeit software, which usually has many of the following problems: missing drivers, missing documentation, viruses, bugs, and other defects. Installing legitimate Microsoft products prevents customer problems and reduces requests for customer support.

authorized replicator

An independent company licensed by Microsoft Licensing, Inc. to manage the production and distribution of Microsoft OEM products for royalty OEMs. Microsoft Licensing, Inc. supplies the authorized replicator with the master components, manufacturing and assembly specifications, and other pertinent instructions. The authorized replicator manufactures and assembles genuine Microsoft products to exact specifications. The benefits of using an authorized replicator include protection against piracy, consistent high-quality software, and competitive prices.

autologon

Automatically logging on to the computer using the Administrator account when the computer restarts.

Automatic Private IP Addressing (APIPA)

A feature of Windows XP TCP/IP that automatically configures a unique IP address from the range 169.254.0.1 through 169.254.255.254 and a subnet mask of 255.255.0.0 when the TCP/IP protocol is configured for dynamic addressing and a Dynamic Host Configuration Protocol (DHCP) is not available.

See also: IP address; DHCP server; Transmission Control Protocol/Internet Protocol (TCP/IP)

B

bandwidth

In analog communications, the difference between the highest and lowest frequencies in a given range. For example, an analog telephone line accommodates a bandwidth of 3,000 hertz (Hz), the difference between the lowest (300 Hz) and highest (3,300 Hz) frequencies it can carry. In digital communications, bandwidth is expressed in bits per second (bps).

See also: bits per second (bps)

base character

A character that has meaning independent of other characters, or any graphical character that is not a diacritical mark.

basic disk

A physical disk that can be accessed by MS-DOS and all Windows-based operating systems. Basic disks can contain up to four primary partitions, or three primary partitions and an extended partition with multiple logical drives. If you want to create partitions that span multiple disks, you must first convert the basic disk to a dynamic disk using Disk Management or the Diskpart.exe command-line utility.

See also: dynamic disk; extended partition; logical drive; primary partition

basic input/output system (BIOS)

On x86-based computers, the set of essential software routines that test hardware at startup, start the operating system, and support the transfer of data among hardware devices. The BIOS is stored in read-only memory (ROM) so that it can be executed when you turn on the computer. Although critical to performance, the BIOS is usually invisible to computer users.

See also: Extensible Firmware Interface (EFI); read-only memory (ROM); x86

basic volume

A primary partition or logical drive that resides on a basic disk.

See also: primary partition; basic disk; logical drive

bidi

Bi-Directional text. A mixture of characters that are read from left to right and characters that are read from right to left. For example, most Arabic, Hebrew, Farsi, and Urdu characters are read from right to left, but numbers and quoted Western terms within these languages' text are read from left to right.

BIOS

See definition for: basic input/output system (BIOS)

BIOS enumerator

Responsible in a non-ACPI Plug and Play system for identifying all hardware devices on the motherboard of the computer. The BIOS supports an API that allows all Plug and Play computers to be queried in a common manner.

bit (binary digit)

The smallest unit of information handled by a computer. One bit expresses a 1 or a 0 in a binary numeral, or a true or false logical condition. A group of 8 bits makes up a byte, which can represent many types of information, such as a letter of the alphabet, a decimal digit, or other character. Bit is also called binary digit.

bit specifications

Numbers of colors or levels of gray that can be displayed at one time. Controlled by the amount of memory in the computer's graphics controller card. An 8-bit controller can display 256 colors or levels of gray; a 16-bit controller, 64,000 colors; and a 24-bit controller, 16.8 million colors.

bits per second (bps)

The number of bits transmitted every second, used as a measure of the speed at which a device, such as a modem, can transfer data.

See also: modem (modulator/demodulator)

boot partition

The partition that contains the Windows operating system and its support files. The boot partition can be, but does not have to be, the same as the system partition.

See also: partition; Primary disk; system partition

bootstrap loader

A program that is run automatically when a computer is turned on, or booted. After first performing a few basic hardware tests, the bootstrap loader loads and passes control to a larger loader program, which typically then loads the operating system. The bootstrap loader typically resides in the computer's read-only memory (ROM).

See also: read-only memory (ROM)

branding

To incorporate a company name, logo, support information, and Help files into the Microsoft Windows installation.

Break-the-Seal Microsoft Distribution and Preinstallation Agreement (BTS)

The license agreement between a system builder and Microsoft Licensing Inc. affixed to the side of every OEM Distribution Pack. By opening the package, you agree to all the terms of the Break-The-Seal agreement. If you do not agree to all the terms of the agreement, contact the Microsoft OEM authorized distributor it was purchased from and make arrangements to return the software.

broadband

Of or relating to communications systems in which the medium of transmission (such as a wire or fiber-optic cable) carries multiple messages at a time, each message modulated on its own carrier frequency by a modem.

browser

Software that interprets the markup of files in HTML, formats them into Web pages, and displays them to the end user. Some browsers also permit end users to send and receive e-mail, read newsgroups, and play sound or video files embedded in Web documents.

See also: World Wide Web

build-to-order

Manufacturing and customizing a computer according to customer specifications after receiving the order from the customer.

build-to-plan

Manufacturing a specified number of computers according to a given specification, and then selling the manufactured computers to customers.

built-in groups

The default security groups installed with the operating system. Built-in groups have been granted useful collections of rights and built-in abilities.

In most cases, built-in groups provide all the capabilities needed by a particular user. For example, if a domain user account belongs to the built-in Administrators group, logging on with that account gives a user administrative capabilities over the domain and the domain servers. To provide a needed set of capabilities to a user account, assign it to the appropriate built-in group.

bus

A communication line used for data transfer among the components of a computer system. A bus essentially allows different parts of the system to share data. For example, a bus connects the disk-drive controller, memory, and input/output ports to the microprocessor.

See also: expansion slot; universal serial bus (USB)

C

cache

For DNS and WINS, a local information store of resource records for recently resolved names of remote hosts. Typically, the cache is built dynamically as the computer queries and resolves names. It also helps optimize the time required to resolve queried names.

See also: cache file

cache file

A file used by the Domain Name System (DNS) server to preload its names cache when service is started. Also known as the root hints file because DNS uses resource records stored in this file to help locate root servers that provide referral to authoritative servers for remote names. For Windows DNS servers, the cache file is named Cache.dns and is located in the %SystemRoot%\System32\Dns folder.

See also: cache; systemroot

caching

The process of temporarily storing recently used data values in a special pool in memory for quicker subsequent access. For DNS, typically the ability of the DNS server to store information learned about the DNS namespace during the resolution of DNS queries. (For example, the DNS server can cache DNS records received from other DNS servers.) Caching is also available through the DNS Client service as a way for DNS clients to keep a cache of information learned during recent queries.

CAL

See definition for: client access license (CAL)

CD boot

Starting a computer from the retail product CD-ROM and then installing Windows on the hard disk using the Setup program on the CD. This method is much slower than installing Windows from a network and is not recommended. For an unattended Setup using the CD boot method, the Unattend.txt file must be named Winnt.sif. The user can select in the winnt.sif if they want to manually select the partition or have it automatically selected.

CD-ROM

Compact disc read-only memory. A form of storage characterized by high capacity (roughly 650 MB) and the use of laser optics rather than magnetic means for reading data.

certificate

A digital document that is commonly used for authentication and secure exchange of information on open networks, such as the Internet, extranets, and intranets. A certificate securely binds a public key to the entity that holds the corresponding private key. Certificates are digitally signed by the issuing certification authority and can be issued for a user, a computer, or a service. The most widely accepted format for certificates is defined by the ITU-T X.509 version 3 international standard.

See also: certification authority (CA); private key; public key; service

certificate of authenticity (COA)

A label with sophisticated anti-counterfeiting features that helps the end user identify that the computer is using a validly licensed copy of Microsoft Windows. The product name and a unique product key appear in the center of the label. The OEM must physically attach the COA label to the computer chassis, and it should never be removed from the computer.

certificate revocation list (CRL)

A document maintained and published by a certification authority that lists certificates that have been revoked.

See also: certificate; certification authority (CA)

certificate template

A Windows construct that profiles certificates (that is, it prespecifies the format and content) based on their intended usage. When requesting a certificate from a Windows enterprise certification authority (CA), certificate requestors are, depending on their access rights, able to select from a variety of certificate types that are based on certificate templates, such as User and Code Signing.

See also: certificate; certification authority (CA)

certificate trust list (CTL)

A signed list of root certification authority certificates that an administrator considers reputable for designated purposes, such as client authentication or secure e-mail.

See also: certificate; certification authority (CA); root certificate

certification authority (CA)

An entity responsible for establishing and vouching for the authenticity of public keys belonging to users (end entities) or other certification authorities. Activities of a certification authority can include binding public keys to distinguished names through signed certificates, managing certificate serial numbers, and certificate revocation.

See also: public key; root authority; certificate

character

The simplest element used to represent written languages. The appearance of a character is not constant; a character's appearance depends on the font used, as well as the context of surrounding text.

checkpoint

An identifier for a specific page or a conceptually related set of pages that tracks the user's navigation through Windows Welcome.

child object

An object that resides in another object. A child object implies relation. For example, a file is a child object that resides in a folder, which is the parent object.

See also: object; parent object

clean system

An installation of Windows that has not been modified and has not had any additional software installed on it.

ClearType

A font display technology that dramatically improves font display resolution so that letters on the computer screen appear smooth, not jagged. ClearType dramatically improves the readability of text on color LCD monitors with a digital interface, such as those found in laptops and high-quality flat-panel desktop displays.

client

Any computer or program connecting to, or requesting the services of, another computer or program. Client can also refer to the software that enables the computer or program to establish the connection.

For a local area network (LAN) or the Internet, a computer that uses shared network resources provided by another computer (called a server).

See also: server

client access license (CAL)

A license that specifies the number of client computers that can connect to and use software located on a server.

cluster

In data storage, the smallest amount of disk space that can be allocated to hold a file. All file systems used by Windows organize hard disks based on clusters, which consist of one or more contiguous sectors. The smaller the cluster size, the more efficiently a disk stores information. If no cluster size is specified during formatting, Windows picks defaults based on the size of the volume. These defaults are selected to reduce the amount of space that is lost and the amount of fragmentation on the volume. A cluster is also called an allocation unit.

In computer networking, a group of independent computers that work together to provide a common set of services and present a single-system image to clients. The use of a cluster enhances the availability of the services and the scalability and manageability of the operating system that provides the services.

See also: client; file system

Cmdlines.txt

A text file that GUI-mode Setup executes when installing optional components, such as applications.

COA

See definition for: certificate of authenticity (COA)

code page

A means of providing support for character sets and keyboard layouts for different countries or regions. A code page is a table that relates the binary character codes used by a program to keys on the keyboard or to characters on the display.

collateral

The end-user manual and any other items the OEM packages with a new computer.

compatible ID

An ID used by the Plug and Play Manager. If Plug and Play does not locate a match for the device hardware ID, Plug and Play installs the driver .inf file associated with the compatible ID.

composite character

A text element consisting of a base character and a diacritic or accent mark. Although most common in the Latin script, other scripts (including Greek, Devanagari, and Tamil) also have composite characters.

Configuration Manager

The Windows Plug and Play system component that drives the process of locating devices, setting up their nodes in the hardware tree, and running the resources allocation process. Each of the three phases of configuration management--boot time, real mode, and protected mode--have their own configuration managers.

configuration set

A file and folder structure that contain the necessary configuration settings that control the preinstallation process and define the manufacturers' custom information.

configure-to-order

See definition for: build-to-order

Connection Manager

A client dialer used to obtain Internet access.

console tree

The left pane in a Microsoft Management Console (MMC) that displays the items contained in the console. By default it is the left pane of a console window, but it can be hidden. The items in the console tree and their hierarchical organization determine the capabilities of a console.

See also: Microsoft Management Console (MMC)

counterfeit software

Software that a system builder does not obtain from an authorized distributor, or that a royalty OEM does not obtain from an authorized replicator. Counterfeit software usually has many of the following problems: missing drivers, missing documentation, viruses, bugs, and other defects. Installing legitimate Microsoft products helps ensure the quality of your products, prevents customer problems, and reduces requests for customer support.

customer

The purchaser of a new computer.

D

desktop

The on-screen work area on which windows, icons, menus, and dialog boxes appear.

desktop ISP sign-up offer

A set of HTML pages that offer the end user the opportunity to sign up for Internet access. To view the offer, the end user clicks a link from the OEM link on the Start menu.

desktop registration

The opportunity given to the end user to register with Microsoft and the OEM, if the user failed to register during Windows Welcome.

destination computer

The computers on which you preinstall Windows that will be distributed to customers. You can either run Setup on the destination computer or copy a master installation onto a destination computer.

detach

Remove uninstalled application files from a destination computer.

See also: attach; destination computer; stage

device

Any piece of equipment that can be attached to a network or computer; for example, a computer, printer, joystick, adapter, or modem card, or any other peripheral equipment. Devices normally require a device driver to function with Windows.

See also: device driver

device driver

A program that allows a specific device, such as a modem, network adapter, or printer, to communicate with the operating system. Although a device might be installed on your system, Windows cannot use the device until you have installed and configured the appropriate driver.

If a device is listed in the Hardware Compatibility List (HCL), a driver is usually included with Windows. Device drivers load automatically (for all enabled devices) when a computer is started, and thereafter run invisibly.

See also: Hardware Compatibility List (HCL)

device ID

A unique ASCII string for the device created by enumerators to identify a hardware device and used to cross-reference data about the device stored in the registry. Distinguishes each logical device and bus from all others on the system.

Device Manager

An administrative tool that you can use to manage the devices on your computer. Using Device Manager, you can view and change device properties, update device drivers, configure device settings, and uninstall devices.

See also: device

DHCP server

A computer running the Microsoft DHCP service that offers dynamic configuration of IP addresses and related information to DHCP-enabled clients.

See also: Dynamic Host Configuration Protocol (DHCP); service; IP address

diacritic

Any mark placed over, under, or through a character, usually to indicate a change in phonetic value from the unmarked state. A character that is attached to it is a base character. Most diacritics are non-spacing characters that do not increase the width of the base character.

dial-up connection

The connection to your network if you are using a device that uses the telephone network. This includes modems with a standard phone line, ISDN cards with high-speed ISDN lines, or X.25 networks.

If you are a typical user, you may have one or two dial-up connections, for example, to the Internet and to your corporate network. In a more complex server situation, multiple network modem connections might be used to implement advanced routing.

See also: modem (modulator/demodulator)

Dial-Up Networking (DUN)

A connection to a data communications network using a public-switch telecommunications network rather than a dedicated circuit or other private network.

digital signature

A means for originators of a message, file, or other digitally encoded information to bind their identity to the information. The process of digitally signing information entails transforming the information, as well as some secret information held by the sender, into a tag called a signature. Digital signatures are used in public key environments, and they provide nonrepudiation and integrity services.

See also: service; time stamp

direct OEM

See definition for: royalty OEM

disk

A storage device that is attached to a computer.

See also: basic disk; dynamic disk

disk duplication

Using third-party hardware or software to copy a full master Windows XP installation onto the hard disks of multiple destination computers. The master computer and destination computers must have compatible hardware abstraction layers (HALs). The destination computer can be delivered directly to customers, or it might require additional processing on the factory production line.

See also: hardware abstraction layer (HAL)

diskpart.exe

A command line utility for formatting and managing disk partitions and volumes.

distribution share

The location on your network that contains the OPK tools, the source files for the Windows products you are preinstalling, and your configuration sets.

dock

To connect a laptop or notebook computer to a docking station.

See also: docking station

docking station

A unit for housing a portable computer that contains a power connection, expansion slots, and connections to peripherals, such as a monitor, printer, full-sized keyboard, and mouse. The docking station turns the portable computer into a desktop computer.

See also: dock

domain

A group of computers that are part of a network and share a common directory database. A domain is administered as a unit with common rules and procedures. Each domain has a unique name.

An Active Directory domain is a collection of computers defined by the administrator of a Windows network. These computers share a common directory database, security policies, and security relationships with other domains. An Active Directory domain provides access to the centralized user accounts and group accounts maintained by the domain administrator. An Active Directory forest is made up of one or more domains, each of which can span more than one physical location.

A DNS domain is any tree or subtree within the DNS namespace. Although the names for DNS domains often correspond to Active Directory domains, DNS domains should not be confused with Active Directory domains.

See also: Active Directory

domain controller

In a Windows domain environment, a computer running Active Directory that manages user access to a network, which includes logging on, authentication, and access to the directory and shared resources.

See also: Active Directory; authentication

domain name

The name given by an administrator to a collection of networked computers that share a common directory. Part of the Domain Name System (DNS) naming structure, domain names consist of a sequence of name labels separated by periods.

See also: domain; label; namespace

domain naming master

The domain controller assigned to control the addition or removal of domains in the forest. At any time, there can be only one domain naming master in the forest.

See also: domain controller; forest

domain tree

In DNS, the inverted hierarchical tree structure that is used to index domain names. Domain trees are similar in purpose and concept to the directory trees used by computer filing systems for disk storage.

For example, when numerous files are stored on disk, directories can be used to organize the files into logical collections. When a domain tree has one or more branches, each branch can organize domain names used in the namespace into logical collections.

In Active Directory, a hierarchical structure of one or more domains, connected by transitive, bidirectional trusts, that forms a contiguous namespace. Multiple domain trees may belong to the same forest.

See also: Active Directory; domain; domain name; forest; namespace

double-byte characters

A set of characters in which each character is represented by two bytes. Some languages, such as Japanese, Chinese, and Korean, require double-byte character sets.

driver

Kernel-mode code used either to control or emulate a hardware device.

Driver.cab

A file containing all of the device drivers that ship with Windows XP.

DUN

See definition for: Dial-Up Networking (DUN)

DVD

Digital video disk. A form of storage characterized by high capacity (roughly 650 MB) and the use of laser optics rather than magnetic means for reading data. Optical disk storage commonly used for audio, video, and computer data. DVDs range in capacity from 4.7 GB to 17 GB, and can store significantly more than a CD-ROM.

DWORD

A data type composed of hexadecimal data with a maximum allotted space of 4 bytes.

dynamic disk

A physical disk that can be accessed only by Windows 2000 and Windows XP. Dynamic disks provide features that basic disks do not, such as support for volumes that span multiple disks. Dynamic disks use a hidden database to track information about dynamic volumes on the disk and other dynamic disks in the computer. You convert basic disks to dynamic by using the Disk Management snap-in or the DiskPart command line utility. When you convert a basic disk to dynamic, all existing basic volumes become dynamic volumes.

See also: basic disk; basic volume; dynamic volume; active volume

Dynamic Host Configuration Protocol (DHCP)

A TCP/IP service protocol that offers dynamic leased configuration of host IP addresses and distributes other configuration parameters to eligible network clients. DHCP provides safe, reliable, and simple TCP/IP network configuration, prevents address conflicts, and helps conserve the use of client IP addresses on the network.

DHCP uses a client/server model where the DHCP server maintains centralized management of IP addresses that are used on the network. DHCP-supporting clients can then request and obtain lease of an IP address from a DHCP server as part of their network boot process.

See also: lease; service; Transmission Control Protocol/Internet Protocol (TCP/IP); IP address

dynamic volume

A volume that resides on a dynamic disk. Windows supports five types of dynamic volumes: simple, spanned, striped, mirrored, and RAID-5. A dynamic volume is formatted by using a file system, such as FAT or NTFS, and it has a drive letter assigned to it.

See also: basic disk; basic volume; dynamic disk; mirrored volume; RAID-5 volume; simple volume; spanned volume; striped volume

dynamic-link library (DLL)

An operating system feature that allows executable routines (generally serving a specific function or set of functions) to be stored separately as files with .dll extensions. These routines are loaded only when needed by the program that calls them.

E

EFI

See definition for: Extensible Firmware Interface (EFI)

EFI system partition

On Itanium-based computers, a portion on a GUID partition table (GPT) disk that is formatted with the FAT file system and contains the files necessary to start the computer. Every Itanium-based computer must have at least one GPT disk with an EFI system partition. The EFI system partition serves the same purpose as the system volume found on x86-based computers.

See also: Extensible Firmware Interface (EFI); GUID partition table (GPT); Microsoft Reserved (MSR) partition; Itanium; x86

embedded controller

The general class of microcontrollers used to support OEM-specific implementation, mainly in mobile environments. The embedded controller performs complex low-level functions through a simple interface to the host microprocessor(s).

embedded controller interface

ACPI defines a standard hardware and software communications interface between an operating system driver and an embedded controller, such as Smart Battery and AML code. This allows any operating system to provide a standard driver that can directly communicate with an embedded controller in the system, thus allowing other drivers to communicate with and use the resources of the system embedded controllers.

See also: driver; Advanced Configuration and Power Interface (ACPI)

encryption

The process of disguising a message or data in such a way as to hide its substance.

See also: public key encryption

end user

The person who ultimately receives the computer manufactured by the OEM.

End-User License Agreement (EULA)

A legal agreement between a software or hardware manufacturer and the purchaser, with regard to terms of distribution, resale, and restricted use.

EULA

See definition for: End-User License Agreement (EULA)

event

Any significant occurrence in the system or an application that requires users to be notified or an entry to be added to a log.

Event Viewer

A component you can use to view and manage event logs, gather information about hardware and software problems, and monitor security events. Event Viewer maintains logs about program, security, and system events.

See also: event

expansion slot

A socket in a computer, designed to hold expansion boards and connect them to the system bus.

See also: bus

extended partition

A type of partition that you can create only on basic master boot record (MBR) disks. Extended partitions are useful if you want to create more than four volumes on a basic MBR disk. Unlike primary partitions, you do not format an extended partition with a file system and then assign a drive letter to it. Instead, you create one or more logical drives within the extended partition. After you create a logical drive, you format it and assign it a drive letter. An MBR disk can have up to four primary partitions, or three primary partitions, one extended partition, and multiple logical drives.

See also: basic disk; logical drive; master boot record (MBR); partition; primary partition

Extensible Firmware Interface (EFI)

In computers with the Intel Itanium processor, the interface between a computer's firmware, hardware, and the operating system. The Extensible Firmware Interface (EFI) defines a new partition style called GUID partition table (GPT). EFI serves the same purpose for Itanium-based computers as the BIOS found in x86-based computers. However, it has expanded capabilities that provide a consistent way to start any compatible operating system and an easy way to add EFI drivers for new bootable devices without the need to update the computer's firmware.

See also: Itanium; x86; basic input/output system (BIOS); GUID partition table (GPT)

F

factory mode

A mode of running Sysprep that postpones the first-run experience and allows OEMs to install additional drivers and applications, incorporate build-to-order customer information, and test the Windows installation. To run Sysprep in factory mode, use the command line Sysprep -factory.

FAT

See definition for: file allocation table (FAT)

FAT32

A derivative of the file allocation table (FAT) file system. FAT32 supports smaller cluster sizes and larger volumes than FAT, which results in more efficient space allocation on FAT32 volumes.

See also: file allocation table (FAT); NTFS file system

fault tolerance

The ability of computer hardware or software to ensure data integrity when hardware failures occur. Fault tolerant features appear in many server operating systems and include mirrored volumes, RAID-5 volumes, and server clusters.

See also: cluster; mirrored volume; RAID-5 volume

file allocation table (FAT)

A file system used by MS-DOS and other Windows-based operating systems to organize and manage files. The file allocation table (FAT) is a data structure that Windows creates when you format a volume by using the FAT or FAT32 file systems. Windows stores information about each file in the FAT so that it can retrieve the file later.

See also: FAT32; file system; NTFS file system

file copy

The first of the three stages of Setup, where the Windows program files and any additional files specified are copied to the computers hard disk.

file system

In an operating system, the overall structure in which files are named, stored, and organized. NTFS, FAT, and FAT32 are types of file systems.

See also: FAT; FAT32; NTFS file system

File Transfer Protocol (FTP)

A member of the TCP/IP suite of protocols, used to copy files between two computers on the Internet. Both computers must support their respective FTP roles: one must be an FTP client and the other an FTP server.

See also: Transmission Control Protocol/Internet Protocol (TCP/IP)

firmware

Software routines and low-level input/output instructions stored in read-only memory (ROM). Unlike random-access memory (RAM), read-only memory stays intact even in the absence of electrical power.

first-run experience

The software the end user sees the first time they start a new computer. The first-run experience is known as Windows Welcome in Windows XP and Mini-Setup in the Windows Server family of operating systems.

See also: Windows Welcome

flash the BIOS

Before installing Windows 2000 or later, an end user may need to upgrade the BIOS (basic input/output system) software through a process called "flashing the BIOS", which is usually provided by an OEM.

font

A graphic design applied to a collection of numbers, symbols, and characters. A font describes a certain typeface, along with other qualities such as size, spacing, and pitch.

See also: OpenType fonts

foreground program

The program that runs in the active window (the uppermost window with the highlighted title bar). The foreground program responds to commands issued by the user.

forest

A collection of one or more Windows domains that share a common schema, configuration, and global catalog and are linked with two-way transitive trusts.

See also: domain; domain tree

free space

Available space that you use to create logical drives within an extended partition.

See also: extended partition; logical drive; unallocated space

furigana name

Tiny Japanese kana characters written above or next to kanji characters. The kana characters indicate the correct pronunciation of the word written in kanji.

G

glyph

A graphical representation of either a character, a part of a character, or a sequence of characters.

GPT

See definition for: GUID partition table (GPT)

graceful recovery

Termination of a process that allows the operating system or parent process to regain normal control. Does not crash the machine or result in a general protection default (GPF) or blue screen. The user is not required to close the application, and can continue to use the other functionality.

graphical user interface (GUI)

A display format, like that of Windows, that represents a program's functions with graphic images such as buttons and icons. GUIs allow a user to perform operations and make choices by pointing and clicking with a mouse.

group account

A collection of user accounts. By making a user account a member of a group, you give the related user all the rights and permissions granted to the group.

See also: user account

Group Policy

The Microsoft Management Console (MMC) snap-in that is used to edit Group Policy objects.

See also: Microsoft Management Console (MMC); snap-in

GUI-mode Setup

The third of the three stages of Setup, during which the computers hardware and network settings are configured, you are prompted to provide an Administrator password, and you can personalize the installation.

GUID partition table (GPT)

A disk-partitioning scheme that is used by the Extensible Firmware Interface (EFI) in Itanium-based computers. GPT offers more advantages than master boot record (MBR) partitioning because it allows up to 128 partitions per disk, provides support for volumes up to 18 exabytes in size, allows primary and backup partition tables for redundancy, and supports unique disk and partition IDs (GUIDs).

See also: Extensible Firmware Interface (EFI); master boot record (MBR); Itanium

H

HAL

See definition for: hardware abstraction layer (HAL)

hardware abstraction layer (HAL)

A thin layer of software provided by the hardware manufacturer that hides, or abstracts, hardware differences from higher layers of the operating system. By means of the filter provided by the HAL, different types of hardware look alike to the rest of the operating system. This allows the operating system to be portable from one hardware platform to another. The HAL also provides routines that allow a single device driver to support the same device on all platforms.

hardware branch

The hardware archive root key in the registry that is a superset of the memory-resident hardware tree. Although the hardware tree contains information only about those devices currently detected and running in the system, the registry contains a complete list of all hardware ever installed on the particular computer. The hardware root key is \\HKEY-LOCAL-MACHINE\Hardware.

Hardware Compatibility List (HCL)

A list of the devices supported by Windows XP.

See also: device

hardware ID

A vendor-defined string used by the Plug and Play Manager to find the correct .inf file to install a particular device.

See also: .inf file; Plug and Play

hardware tree

A record in RAM of the current system configuration based on the information for all devices in the hardware branch of the registry. The hardware tree is created each time the system is started or whenever a dynamic change occurs to the system configuration.

See also: hardware branch

hardware type

A classification for similar devices. For example, Imaging Device is a hardware type for digital cameras and scanners.

See also: device

hash

A fixed-size result that is obtained by applying a one-way mathematical function (sometimes called a hash algorithm) to an arbitrary amount of data. If there is a change in the input data, the hash changes. The hash can be used in many operations, including authentication and digital signing. A hash is also called a message digest.

See also: hash algorithm; authentication

hash algorithm

An algorithm used to produce a hash value of some piece of data, such as a message or session key. A good hash algorithm has a quality where changes in the input data can change every bit in the resulting hash value; for this reason, hashes are useful in detecting any modification in a large data object, such as a message. Furthermore, a good hash algorithm makes it computationally infeasible to construct two independent inputs that have the same hash. Typical hash algorithms include MD2, MD4, MD5, and SHA-1. Hash algorithm is also called a hash function.

HCL

See definition for: Hardware Compatibility List (HCL)

HCT

Hardware Compatibility Tests. A suite of tests from WHQL to verify hardware and device driver operations under a specific operating environment. These tests exercise the combination of a device, a software driver, and an operating system under controlled conditions to verify that all components operate properly.

See also: Windows Hardware Quality Labs (WHQL)

headless

BIOS or server appliances without display or input peripherals, such as a keyboard, pointing device, or video monitor.

Help and Support Center

A unified place where a user can access all Help and Support content and services from both Microsoft and the OEM.

hive

A section of the registry that appears as a file on your hard disk. The registry subtree is divided into hives (named for their resemblance to the cellular structure of a beehive). A hive is a discrete body of keys, subkeys, and values that is rooted at the top of the registry hierarchy. A hive is backed by a single file and a .log file, which are in the systemroot\System32\Config or the systemroot\Profiles\username folders.

By default, most hive files (Default, SAM, Security, and System) are stored in the systemroot\System32\Config folder. The systemroot\Profiles folder contains the user profile for each user of the computer. Because a hive is a file, it can be moved from one system to another. However, you must use the Registry Editor to edit the file.

See also: systemroot; registry; key

hotfix

An update to address an issue identified after a software product has been distributed. Hotfix distribution is limited by its licensing terms.

hub

A common connection point for devices in a network. Typically used to connect segments of a local area network (LAN), a hub contains multiple ports. When data arrives at one port, it is copied to the other ports so that all segments of the LAN can see the data.

See also: local area network (LAN); port

Hypertext Markup Language (HTML)

A simple markup language used to create hypertext documents that are portable from one platform to another. HTML files are simple ASCII text files with codes embedded (indicated by markup tags) to denote formatting and hypertext links.

See also: American Standard Code for Information Interchange (ASCII)

I

I/O

See definition for: input/output (I/O) port

I/O request packet (IRP)

Data structures that drivers use to communicate with each other.

IA-PC

Intel Architecture Personal Computer. A general descriptive term for computers built with processors conforming to the architecture defined by the Intel processor family based on the 486 instruction set and having an industry-standard PC architecture.

icon character

The animated icon from the Help and Support Center that guides users through their first-run experience, or Windows Welcome.

See also: Windows Welcome

IDE

Integrated device electronics. A type of disk-drive interface in which the controller electronics reside on the drive itself, eliminating the need for a separate adapter card. IDE offers advantages such as look-ahead caching to increase overall performance.

IEEE

Institute of Electrical and Electronics Engineers, founded in 1963. IEEE is an organization composed of engineers, scientists, and students, best known for developing standards for the computer and electronics industry.

IEEE 1394

A standard for high-speed serial devices such as digital video and digital audio editing equipment.

See also: device

IHV

See definition for: independent hardware vendor (IHV)

IIS

See definition for: Internet Information Services (IIS)

image

In graphical terms, an image is the computerized representation of a picture or graphic. In data representation terms, an image is a collection of files and folders (sometimes compressed into one file) that represent an imitation of the original file and folder structure -- an exact duplicate.

image resolution

The fineness or coarseness of an image as it is digitized, measured in dots per inch (DPI), typically ranging from 200 to 400 DPI.

independent hardware vendor (IHV)

A company that manufactures hardware devices and the associated device drivers.

independent software vendor (ISV)

A third-party software developer; an individual or an organization that independently creates computer software.

input language

The specification of the language you want to type in. Some programs that are designed for Windows recognize this setting. When you add a new input language, a keyboard layout for that language is also added.

input locale

A pairing of the input language (LangID) and the method of input that determines which language is currently being used and how it is being entered.

Input Method Editor (IME)

Programs used to enter the thousands of different characters in written Asian languages with a standard 101-key keyboard. An IME consists of both an engine that converts keystrokes into phonetic and ideographic characters and a dictionary of commonly used ideographic words. As the user enters keystrokes, the IME engine attempts to identify which character or characters the keystrokes should be converted into.

input/output (I/O) port

A channel through which data is transferred between a device and the microprocessor. The port appears to the microprocessor as one or more memory addresses that it can use to send or receive data.

See also: device; memory address; port

install

When referring to software, to add program files and folders to your hard disk and related data to your registry so that the software runs properly. Installing contrasts with upgrading, where existing program files, folders, and registry entries are updated to a more recent version.

When referring to hardware, to physically connect the device to your computer, to load device drivers onto your computer, and to configure device properties and settings.

See also: device driver; registry

integrated device electronics (IDE)

A type of disk-drive interface in which the controller electronics reside on the drive itself, eliminating the need for a separate adapter card. IDE offers advantages such as look-ahead caching to increase overall performance.

internet

internet. Two or more network segments connected by routers. Another term for internetwork.

Internet. A worldwide network of computers. If you have access to the Internet, you can retrieve information from millions of sources, including schools, governments, businesses, and individuals.

See also: World Wide Web

Internet address

An address for a resource on the Internet that is used by Web browsers to locate Internet resources. An Internet address typically starts with a protocol name, followed by the name of the organization that maintains the site; the suffix identifies the kind of organization it is. For example, the address http://www.yale.edu/ provides the following information:

  • http: This Web server uses the Hypertext Transfer Protocol.
  • www: This site is on the World Wide Web.
  • edu: This is an educational institution.
Internet address is also called Uniform Resource Locator (URL).

See also: protocol; Web server

Internet Information Services (IIS)

Software services that support Web site creation, configuration, and management, along with other Internet functions. Internet Information Services include Network News Transfer Protocol (NNTP), File Transfer Protocol (FTP), and Simple Mail Transfer Protocol (SMTP).

See also: Simple Mail Transfer Protocol (SMTP); File Transfer Protocol (FTP); Network News Transfer Protocol (NNTP)

Internet Protocol (IP)

A routable protocol in the TCP/IP protocol suite that is responsible for IP addressing, routing, and the fragmentation and reassembly of IP packets.

See also: Transmission Control Protocol/Internet Protocol (TCP/IP)

Internet service provider (ISP)

A company that provides individuals or companies access to the Internet and the World Wide Web. An ISP provides a telephone number, a user name, a password, and other connection information so users can connect their computers to the ISP's computers. An ISP typically charges a monthly or hourly connection fee.

See also: Web server

Internetwork Packet Exchange (IPX)

A network protocol native to NetWare that controls addressing and routing of packets within and between LANs. IPX does not guarantee that a message will be complete (no lost packets).

See also: IPX/SPX; local area network (LAN)

interrupt request (IRQ)

A signal sent by a device to get the attention of the processor when the device is ready to accept or send information. Each device sends its interrupt requests over a specific hardware line. Each device must be assigned a unique IRQ number.

interrupt request (IRQ) lines

Hardware lines over which devices can send signals to get the attention of the processor when the device is ready to accept or send information. Each device must have a unique IRQ line.

See also: device

IP address

A 32-bit address used to identify a node on an IP internetwork. Each node on the IP internetwork must be assigned a unique IP address, which is made up of the network ID, plus a unique host ID. This address is typically represented with the decimal value of each octet separated by a period (for example, 192.168.7.27). In this version of Windows, you can configure the IP address statically or dynamically through DHCP.

See also: Dynamic Host Configuration Protocol (DHCP)

IPX/SPX

Transport protocols used in Novell NetWare networks, which together correspond to the combination of TCP and IP in the TCP/IP protocol suite. Windows implements IPX through NWLink.

See also: Transmission Control Protocol/Internet Protocol (TCP/IP); Internetwork Packet Exchange (IPX); NWLink

IRP

See definition for: I/O request packet (IRP)

IRQ

See definition for: interrupt request (IRQ)

isochronous

Time dependent. Refers to processes where data must be delivered within certain time constraints. Multimedia streams require an isochronous transport mechanism to ensure that data is delivered as fast as it is displayed, and to ensure that the audio is synchronized with the video.

isolation

The Plug and Play process by which cards on an ISA bus are distinguished from each other after system startup.

ISP

See definition for: Internet service provider (ISP)

ISP sign-up server

An HTTP server that automates the task of adding new customers to an ISP's customer database. The Internet sign-up server collects information from each customer, adds the information to the ISP's customer database, and then passes a configuration packet back to the customer's desktop computer. The configuration packet contains information that is used to configure the customer's Internet browser for subsequent connection to the ISP's services.

ISP signup offer

A set of HTML pages in Windows Welcome that allows end users to sign up for Internet access from a particular Internet service provider.

ISV

See definition for: independent software vendor (ISV)

Itanium

An Intel microprocessor that uses explicitly parallel instruction set computing and 64-bit memory addressing.

J

There are no glossary terms that begin with this letter.

K

kernel

The core of layered architecture that manages the most basic operations of the operating system and the computer's processor. The kernel schedules different blocks of executing code, called threads, for the processor to keep it as busy as possible and coordinates multiple processors to optimize performance. The kernel also synchronizes activities among Executive-level subcomponents, such as I/O Manager and Process Manager, and handles hardware exceptions and other hardware-dependent functions. The kernel works closely with the hardware abstraction layer.

kernel mode

A highly privileged mode of operation where program code has direct access to all memory, including the address spaces of all user-mode processes and applications, and to hardware. Kernel mode is also known as supervisor mode, protected mode, or Ring 0.

kernel-mode driver

Driver for a logical, virtual, or physical device.

key

In Registry Editor, a folder that appears in the left pane of the Registry Editor window. A key can contain subkeys and value entries. For example, Environment is a key of HKEY_CURRENT_USER.

In IP security (IPSec), a value used in combination with an algorithm to encrypt or decrypt data. Key settings for IP security are configurable to provide greater security.

See also: registry; subkey

L

L2TP (Layer 2 Tunneling Protocol)

An industry-standard Internet tunneling protocol. Unlike Point-to-Point Tunneling Protocol (PPTP), L2TP does not require IP connectivity between the client workstation and the server. L2TP requires only that the tunnel medium provide packet-oriented point-to-point connectivity. The protocol can be used over media such as ATM, Frame Relay, and X.25. L2TP provides the same functionality as PPTP. Based on Layer 2 Forwarding (L2F) and PPTP specifications, L2TP allows clients to set up tunnels across intervening networks.

See also: Internet Protocol (IP); Point-to-Point Tunneling Protocol (PPTP)

label

Each part of a full DNS domain name that represents a node in the domain namespace tree. Domain names are made up of a sequence of labels, such as the three labels (example, microsoft, and com) that make up the DNS domain name example.microsoft.com. Each label used in a DNS name must be 63 bytes or less in character length.

See also: domain name; node

LAN

See definition for: local area network (LAN)

language group

A term used to describe the supported script families in Microsoft Windows.

Language ID

A 16-bit value which consists of a primary and a secondary language ID. Bits 0-9 make up the primary language ID and bits 10-15 comprise the sub-language ID.

layered driver

One of a collection of drivers that responds to the same IRPs. Layered driver describes the highest-level and lowest-level drivers in a chain of layered drivers that process the same IRPs, along with all intermediate drivers in the chain.

LBA

Logical block addressing. A method used with SCSI and IDE disk drives to translate the cylinder, head, and sector specifications of the drive into addresses that can be used by an enhanced BIOS. LBA is used with drives that are larger than 528MB.

lease

The length of time for which a DHCP client can use a dynamically assigned IP address configuration. Before the lease time expires, the client must either renew or obtain a new lease with DHCP.

See also: Dynamic Host Configuration Protocol (DHCP); IP address

legacy

Any feature in the computer system based on older technology for which compatibility continues to be maintained in other system components.

license

The right of a person or company to use software in a particular way, as described in the terms of the license agreement. Copyright law also limits how a person may use the software. A person needs a license agreement for each software program they use.

Lightweight Directory Access Protocol (LDAP)

The primary access protocol for Active Directory. Lightweight Directory Access Protocol (LDAP) version 3 is defined by a set of Proposed Standard documents in Internet Engineering Task Force (IETF) RFC 2251.

See also: protocol; Active Directory

local area network (LAN)

A communications network connecting a group of computers, printers, and other devices located within a relatively limited area (for example, a building). A LAN allows any connected device to interact with any other on the network.

See also: NetBIOS Extended User Interface (NetBEUI); network basic input/output system (NetBIOS); workgroup

local bus

Usually refers to a system bus directly connected to the microprocessor on a system board. Local bus is used colloquially to refer to system board buses located closer to the microprocessor than ordinary expansion buses (thus requiring less buffering), which make them capable of greater throughput.

Locale

A group of user preference information, such as date/time formatting, represented as a list of values related to the user's language and sub-language,

Locale ID

A 32-bit value which consists of the language ID in the low word (bits 0-15) and the sorting ID (bits 16-19) and a reserved value (bits 20-31) in the high word.

logical drive

A volume that you create within an extended partition on a basic master boot record (MBR) disk. Logical drives are similar to primary partitions, except that you are limited to four primary partitions per disk, whereas you can create an unlimited number of logical drives per disk. A logical drive can be formatted and assigned a drive letter.

See also: basic disk; basic volume; extended partition; master boot record (MBR); primary partition

long file name

A folder name or file name longer than the 8.3 file name standard (up to eight characters followed by a period and an extension of up to three characters). Most versions of Windows, including Windows XP, Windows 2000, Window NT, and Windows 9x, support long file names up to 255 characters.

LPT device

See definition for: parallel device

M

mass-storage device

A generic term for disk, optical disk, or other device that provides persistent storage for computer data.

master boot record (MBR)

The first sector on a hard disk, which starts the process of booting the computer. The MBR contains the partition table for the disk and a small amount of executable code called the master boot code.

See also: Recovery Console; partition boot sector

master computer

A fully-assembled computer containing a master installation.

See also: master installation

Master File Table (MFT)

An NTFS system file on NTFS-formatted volumes that contains information about each file and folder on the volume. The MFT is the first file on an NTFS volume.

See also: NTFS file system; file allocation table (FAT)

master installation

A customized installation of Windows that an OEM plans to duplicate onto one or more destination computers.

memory address

A portion of computer memory that can be allocated to a device or used by a program or the operating system. Devices are usually allocated a range of memory addresses.

See also: device

Message Queuing

A message queuing and routing system for Windows that enables distributed applications running at different times to communicate across heterogeneous networks and with computers that may be offline. Message Queuing provides guaranteed message delivery, efficient routing, security, and priority-based messaging. Message Queuing was formerly known as MSMQ.

See also: MSMQ

MFU list

Most-frequently used list. A list of applications that the end user has recently used.

Microsoft Management Console (MMC)

A framework for hosting administrative tools, called consoles. A console may contain tools, folders or other containers, World Wide Web pages, and other administrative items. These items are displayed in the left pane of the console, called a console tree. A console has one or more windows that can provide views of the console tree.

The main MMC window provides commands and tools for authoring consoles. The authoring features of MMC and the console tree itself may be hidden when a console is in User Mode.

See also: console tree; snap-in

Microsoft Reserved (MSR) partition

A required partition on every GUID partition table (GPT) disk. System components can allocate portions of the MSR partition into new partitions for their own use. For example, when you convert a basic GPT disk to dynamic, the system allocates a portion of the MSR partition to be used as the Logical Disk Manager (LDM) metadata partition. The MSR partition varies in size based on the size of the GPT disk. For disks smaller than 16 GB, the MSR partition is 32 MB. For disks larger than 16 GB, the MSR partition is 128 MB. The MSR partition is not visible in Disk Management, and you cannot store data on the MSR partition or delete it.

See also: GUID partition table (GPT); partition

MIDI

Musical Instrument Digital Interface. An industry-standard connection for computer control of musical instruments and devices. A hardware and data standard for communication between hardware. Most references involve only the data standard, which is a byte stream used for controlling musical instruments and storing the output of such instruments.

Mini-Setup

A subset of GUI-mode Setup, Mini-Setup is the first-run experience on the Windows Server family of products. Mini-Setup prompts for user-specific information, detects new hardware, and regenerates system IDs.

MIPS

Millions of instructions per second. A common measure of processor speed.

mirrored volume

A fault-tolerant volume that duplicates data on two physical disks. A mirrored volume provides data redundancy by using two identical volumes, which are called mirrors, to duplicate the information contained on the volume. A mirror is always located on a different disk. If one of the physical disks fails, the data on the failed disk becomes unavailable, but the system continues to operate in the mirror on the remaining disk. You can create mirrored volumes only on dynamic disks.

See also: fault tolerance; RAID-5 volume; dynamic disk; dynamic volume

mixed mode

The default domain mode setting on Windows 2000 or Windows XP domain controllers. Mixed mode allows backup domain controllers to co-exist in a Windows 2000 or Windows XP domain. Mixed mode does not support the universal and nested group enhancements of Windows 2000 or Windows XP. You can change the domain mode setting to native mode when all domain controllers are removed from a domain.

modem (modulator/demodulator)

A device that allows computer information to be transmitted and received over a telephone line. The transmitting modem translates digital computer data into analog signals that can be carried over a phone line. The receiving modem translates the analog signals back to digital form.

See also: port; Telephony API (TAPI)

monolithic driver

A driver that contains many different classes of functionality.

motherboard

The main circuit board of a microcomputer. The motherboard contains the connectors for attaching additional boards.

MSDN

Microsoft Developer Network.

MSMQ

The message queuing and routing system for Windows NT 4.0, Windows 95, and Windows 98. For Windows 2000 and Windows XP, this feature is called Message Queuing.

See also: Message Queuing

Multi-Language User Interface (MUI)

A separate, standalone release of Windows XP Professional that includes user interface resources for each supported language. MUI allows users to set the user-interface language according to their preferences, provided the required language files are present on the computer. It is designed to allow large corporations to deploy a single version of Windows worldwide, while allowing their local users or groups to select the user interface language.. Local users can then select the user interface language, or the language setting can be manage using Group Policy. MUI also allows users of different languages to share the same workstation: one user might choose to see system menus, dialog boxes, and other text in Japanese, while another user might choose to see the corresponding text in French. The following items are not localized in MUI versions: all 16-bit code, bitmaps, registry keys and values, folders and file names, and .inf files.

MultiByte Character Set (MBCS)

A mixed-width character set, in which some characters consist of more than 1 byte. A double byte character set (DBCS), which is a specific type of multibyte character set, includes some characters that consist of 1 byte and some characters that consist of 2 bytes.

multimedia

Refers to the delivery of information that combines different content formats, such as video, audio, still images, graphics, animation, and text.

multiprocessor

Two or more connected and roughly equal processors that can each carry out one or more processes (programs or sets of instructions) in tandem.

N

name resolution

The process of having software translate between names that are easy for users to work with and numerical IP addresses, which are difficult for users but necessary for TCP/IP communications. Name resolution can be provided by software components such as DNS or WINS.

See also: Transmission Control Protocol/Internet Protocol (TCP/IP); Windows Internet Name Service (WINS)

namespace

A set of unique names for resources or items used in a shared computing environment.

For Microsoft Management Console (MMC), the namespace is represented by the console tree, which displays all of the snap-ins and resources that are accessible to a console.

For Domain Name System (DNS), namespace is the vertical or hierarchical structure of the domain name tree. For example, each domain label, such as host1 or example, used in a fully qualified domain name, such as host1.example.microsoft.com, indicates a branch in the domain namespace tree.

See also: console tree; label; resource; snap-in

native mode

The condition in which all domain controllers in the domain have been upgraded to Windows 2000 and an administrator has enabled native mode operation (through Active Directory Users and Computers).

See also: Active Directory Users and Computers

NCW

See definition for: New Connection Wizard (NCW)

NetBIOS Extended User Interface (NetBEUI)

A network protocol native to Microsoft Networking. It is usually used in small, department-size local area networks (LANs) of 1 to 200 clients. It can use Token Ring source routing as its only method of routing. It is the Microsoft implementation of the NetBIOS standard.

See also: local area network (LAN); network basic input/output system (NetBIOS); protocol

network adapter

See definition for: network interface card (NIC)

network basic input/output system (NetBIOS)

An application programming interface (API) that can be used by programs on a local area network (LAN). NetBIOS provides programs with a uniform set of commands for requesting the lower-level services required to manage names, conduct sessions, and send datagrams between nodes on a network.

See also: application programming interface (API); basic input/output system (BIOS); local area network (LAN); node; service

network card

See definition for: network interface card (NIC)

network card driver

A device driver that works directly with the network card, acting as an intermediary between the card and the protocol driver.

network interface card (NIC)

An expansion card or other device used to provide network access to a computer or other device, such as a printer. Network interface cards mediate between the computer and physical media, such as cabling, over which transmissions travel. Also called network adapter or network card.

Network News Transfer Protocol (NNTP)

A member of the TCP/IP suite of protocols used to distribute network news messages to NNTP servers and clients (newsreaders) on the Internet. NNTP is designed so that news articles are stored on a server in a central database, thus enabling a user to select specific items to read.

See also: Transmission Control Protocol/Internet Protocol (TCP/IP)

New Connection Wizard (NCW)

A tool that helps users sign up for Internet service and automatically handles the software configuration steps necessary for gaining access to the Internet.

NIC

See definition for: network interface card (NIC)

node

For tree structures, a location on the tree that can have links to one or more items below it.

For local area networks (LANs), a device that is connected to the network and is capable of communicating with other network devices.

For server clusters, a computer system running Windows 2000 Advanced Server or Windows 2000 Datacenter Server or later versions of these operating systems that is an active or inactive member of a cluster.

See also: local area network (LAN); server cluster

non-spacing character

A character, such as diacritic, that has no meaning by itself, but overlaps a base character to modify it, sometimes referred to as a "combining character".

NTFS file system

An advanced file system that provides performance, security, reliability, and advanced features that are not found in any version of FAT. For example, NTFS guarantees volume consistency by using standard transaction logging and recovery techniques. If a system fails, NTFS uses its log file and checkpoint information to restore the consistency of the file system. In Windows 2000 and Windows XP, NTFS also provides advanced features such as file and folder permissions, encryption, disk quotas, and compression.

See also: FAT32; file allocation table (FAT); file system

NWLink

An implementation of the Internetwork Packet Exchange (IPX), Sequenced Packet Exchange (SPX), and NetBIOS protocols used in Novell networks. NWLink is a standard network protocol that supports routing and can support NetWare client-server applications, where NetWare-aware Sockets-based applications communicate with IPX/SPX Sockets-based applications.

See also: IPX/SPX; network basic input/output system (NetBIOS)

O

object

An entity, such as a file, folder, shared folder, printer, or Active Directory object, described by a distinct, named set of attributes. For example, the attributes of a File object include its name, location, and size; the attributes of an Active Directory User object might include the user's first name, last name, and e-mail address.

For OLE and ActiveX, an object can also be any piece of information that can be linked to, or embedded into, another object.

See also: attribute; child object; parent object

OEM

See definition for: original equipment manufacturer (OEM)

OEM branding

To incorporate a company name, logo, support information, and Help files into the Microsoft Windows installation.

OEM ISP sign-up offer

A set of HTML pages created by either the OEM or a third-party company that lets end users sign up for Internet access from a particular Internet service provider (ISP). You can incorporate these pages into Windows Welcome, or include a shortcut to the first page of the OEM link on the Start menu.

See also: OEM link; Windows Welcome

OEM License Agreement

A legal agreement between Microsoft Licensing, Inc., and OEMs regarding the terms of preinstalling, customizing, and distributing Microsoft Windows XP. For System Builders, the corresponding agreement is affixed to the side of every OEM Distribution Pack. By opening the package you agree to all the terms of the Break-The-Seal (BTS) agreement. For royalty OEMs, the license agreement is a signed contract. The specific requirements and customization options that apply to either or both license agreements is documented in the OPK User's Guide.

See also: Break-the-Seal Microsoft Distribution and Preinstallation Agreement (BTS); royalty OEM; system builder

OEM link

A link on the Start menu where OEMs can place any desired links or shortcuts.

OEM Preinstallation Kit (OPK)

A set of tools, documentation, and samples that enable OEMs to efficiently preinstall Windows on new computers according to the terms of the OEM Licensing Agreement.

Oem.chm

The HTML Help file that you customize to provide OEM-specific support information in Windows Help.

Oeminfo.ini

A file used to provide required OEM information, such as company name, computer model, company telephone number, and customer support information.

OnNow

See definition for: Advanced Configuration and Power Interface (ACPI)

OOBE

See definition for: Windows Welcome

OpenType fonts

Outline fonts that are rendered from line and curve commands, and can be scaled and rotated. OpenType fonts are clear and readable in all sizes and on all output devices supported by Windows. OpenType is an extension of TrueType font technology.

See also: font

OPK

See definition for: OEM Preinstallation Kit (OPK)

original equipment manufacturer (OEM)

A company that typically purchases computer components from other manufacturers, uses the components to build a personal computer, preinstalls Windows onto that computer, and then sells the computer to the public.

Out-Of-Box Experience (OOBE)

See definition for: Windows Welcome

P

paging file

A hidden file on the hard disk that Windows uses to hold parts of programs and data files that do not fit in memory. The paging file and physical memory, or RAM, comprise virtual memory. Windows moves data from the paging file to memory as needed and moves data from memory to the paging file to make room for new data. Paging file is also called a swap file.

parallel device

A device that uses a parallel connection.

parent object

The object in which another object resides. A parent object implies relation. For example, a folder is a parent object in which a file, or child object, resides. An object can be both a parent and a child object. For example, a subfolder that contains files is both the child of the parent folder and the parent folder of the files.

See also: child object; object

partition

A portion of a physical disk that functions as though it were a physically separate disk. After you create a partition, you must format it and assign it a drive letter before you can store data on it.

On basic disks, partitions are known as basic volumes, which include primary partitions and logical drives. On dynamic disks, partitions are known as dynamic volumes, which include simple, striped, spanned, mirrored, and RAID-5 volumes.

See also: basic disk; basic volume; dynamic volume; extended partition; primary partition; system partition

partition boot sector

A portion of a hard disk partition that contains information about the disk's file system and a short machine language program that loads the Windows operating system.

See also: partition

passport

A single sign-in service that lets you use a single name and password on multiple participating Web sites.

password

A security measure used to restrict logon names to user accounts and access to computer systems and resources. A password is a string of characters that must be provided before a logon name or an access is authorized. A password can be made up of letters, numbers, and symbols, and it is case sensitive.

See also: user account

PC Card

A removable device, approximately the size of a credit card, that can be plugged into a Personal Computer Memory Card International Association (PCMCIA) slot in a portable computer. PCMCIA devices can include modems, network cards, and hard disk drives.

See also: modem (modulator/demodulator)

PC Health

A suite of technologies and features focused on providing end users with improved technical support by enabling web-based support solutions. PC Health also provides better operating system reliability, and an enhanced end-user experience, by providing easier access to help content and support services.

PCMCIA device

A removable device, approximately the size of a credit card, that can be plugged into a PCMCIA slot in a portable computer. PCMCIA devices can include modems, network adapters, and hard disk drives.

Some PCMCIA cards can be connected to and disconnected from your computer without restarting it. Before you remove the PCMCIA card, however, you should use the Add Hardware Wizard to notify Windows that you are doing so. Windows will then notify you when you can remove the device.

permission

A rule associated with an object to regulate which users can gain access to the object and in what manner. Permissions are granted or denied by the object's owner.

See also: object

PIC

Programmable Interrupt Controller. This type of hardware cannot be used in computers with multiple processes, and the processing speed is slower than similar APIC hardware.

piracy

Unauthorized copying, distribution, and use of computer software, or software theft.

pixels

An abbreviation for picture elements. The minimum raster display element, represented as a point, with a specified color or intensity level. One way to measure picture resolution is by the number of pixels used to create images.

Plug and Play

A set of specifications developed by Intel that allows a computer to automatically detect and configure a device and install the appropriate device drivers.

See also: universal serial bus (USB)

Plug and Play BIOS

A BIOS with responsibility for configuring Plug and Play cards and system-board devices during system power up. Provides runtime configuration services for system board devices after startup.

See also: BIOS; Advanced Configuration and Power Interface (ACPI); system board

Point-to-Point Protocol (PPP)

An industry standard suite of protocols for the use of point-to-point links to transport multiprotocol datagrams. PPP is documented in RFC 1661.

See also: remote access; Transmission Control Protocol/Internet Protocol (TCP/IP)

Point-to-Point Tunneling Protocol (PPTP)

Networking technology that supports multiprotocol virtual private networks (VPNs), enabling remote users to access corporate networks securely across the Internet or other networks by dialing into an Internet service provider (ISP) or by connecting directly to the Internet. The Point-to-Point Tunneling Protocol (PPTP) tunnels, or encapsulates, IP, IPX, or NetBEUI traffic inside of IP packets. This means that users can remotely run applications that are dependent upon particular network protocols.

See also: Internet Protocol (IP); Internetwork Packet Exchange (IPX); NetBIOS Extended User Interface (NetBEUI)

port

A connection point on your computer where you can connect devices that pass data into and out of a computer. For example, a printer is typically connected to a parallel port (also called an LPT port), and a modem is typically connected to a serial port (also called a COM port).

See also: universal serial bus (USB)

POST

See definition for: power-on self test (POST)

power management

Mechanisms in software and hardware to minimize system power consumption, manage system thermal limits, and maximize system battery life. Power management involves trade-offs among system speed, noise, battery life, processing speed, and power consumption.

power-on self test (POST)

A set of routines stored in read-only memory (ROM) that tests various system components such as RAM, the disk drives, and the keyboard, to see if they are properly connected and operating. If problems are found, these routines alert the user with a series of beeps or a message, often accompanied by a diagnostic numeric value. If the POST is successful, it passes control to the bootstrap loader.

precached ISP signup offer

See definition for: OEM ISP sign-up offer

precomposed character

A single character that represents a sequence of characters, usually a combination of a base character and one or more diacritics.

preconfigured ISP signup

Configuring the operating system during the manufacturing process to use a specific account for access to the Internet.

predefined key

A key that represents one of the main divisions of the registry. Each predefined key is displayed in a separate Registry Editor window, with the key's name appearing in the window's title bar. For example, HKEY_CLASSES_ROOT is a predefined key.

See also: registry; hive; key

preinstallation

To load Windows XP on new computers for distribution to end users.

Primary disk

The hard disk drive that contains the system and boot partitions used to start Windows.

See also: boot partition; system partition

primary partition

A type of partition that you can create on basic disks. A primary partition is a portion of a physical disk that functions as though it were a physically separate disk. On basic master boot record (MBR) disks, you can create up to four primary partitions on a basic disk, or three primary partitions and an extended partition with multiple logical drives. On basic GPT disks, you can create up to 128 primary partitions. Primary partitions are also known as volumes.

See also: basic disk; extended partition; GUID partition table (GPT); logical drive; master boot record (MBR); partition

private key

The secret half of a cryptographic key pair that is used with a public key algorithm. Private keys are typically used to decrypt a symmetric session key, digitally sign data, or decrypt data that has been encrypted with the corresponding public key.

See also: public key; public key encryption

product activation

See definition for: Windows Product Activation (WPA)

Product Key

A 25-character, alpha-numeric string. Customers must enter this string to activate their installation of Windows. The product key is located on the certificate of authenticity, which is attached to the computer chassis.

property set

A method defined to set and get properties on a driver. Each property set has a unique identifier, which represents types of related information and is used to access the property set.

Protective MBR

The first sector of a GUID partition table (GPT) disk that is structured like the first sector of a master boot record (MBR) disk to prevent x86-based disk utilities from destroying GPT partitions. The Protective MBR contains one partition that reserves the entire space used on the disk by GPT partitions.

See also: Extensible Firmware Interface (EFI); GUID partition table (GPT); master boot record (MBR); x86

protocol

A set of rules and conventions for sending information over a network. These rules govern the content, format, timing, sequencing, and error control of messages exchanged among network devices.

See also: Transmission Control Protocol/Internet Protocol (TCP/IP)

proxy

A firewall and content cache server that provides Internet security and improves network performance.

public key

The nonsecret half of a cryptographic key pair that is used with a public key algorithm. Public keys are typically used when encrypting a session key, verifying a digital signature, or encrypting data that can be decrypted with the corresponding private key.

See also: private key; public key encryption; key

public key encryption

A method of encryption that uses two encryption keys that are mathematically related. One key is called the private key and is kept confidential. The other is called the public key and is freely given out to all potential correspondents. In a typical scenario, a sender uses the receiver's public key to encrypt a message. Only the receiver has the related private key to decrypt the message. The complexity of the relationship between the public key and the private key means that, provided the keys are long enough, it is computationally infeasible to determine one from the other. Public key encryption is also called asymmetric encryption.

See also: encryption; private key; public key

public key infrastructure (PKI)

The term generally used to describe the laws, policies, standards, and software that regulate or manipulate certificates and public and private keys. In practice, it is a system of digital certificates, certification authorities, and other registration authorities that verify and authenticate the validity of each party involved in an electronic transaction. Standards for PKI are still evolving, even though they are being widely implemented as a necessary element of electronic commerce.

See also: certification authority (CA); public key; certificate

Q

QFE

Quick-Fix Engineering. This is usually referred to as a hotfix.

See also: hotfix

quiet mode

Running a command-line application so that it does not display confirmation messages or any other user interface items that normally appear on screen. The switch for quiet mode is typically /q.

R

RAID-5 volume

A fault-tolerant volume with data and parity striped intermittently across three or more physical disks. Parity is a calculated value that is used to reconstruct data after a failure. If a portion of a physical disk fails, Windows recreates the data that was on the failed portion from the remaining data and parity. You can create RAID-5 volumes only on dynamic disks, and you cannot mirror or extend RAID-5 volumes.

See also: dynamic disk; dynamic volume; fault tolerance

RAM

See definition for: random access memory (RAM)

random access memory (RAM)

Memory that can be read from or written to by a computer or other devices. Information stored in RAM is lost when the computer is turned off.

ranking

Windows XP ranks drivers to determine which is the best for a device. The lower the rank, the better the match of the driver to the device.

read-only memory (ROM)

A semiconductor circuit that contains information that cannot be modified.

rebinding state

A state used by DHCP clients to extend and renew their address lease when the current lease is close to expiring. In this state, the client broadcasts to the network to locate any DHCP server that can either renew or replace its currently leased configuration. The rebinding state begins when 87.5 percent of the client's lease time has elapsed.

See also: Dynamic Host Configuration Protocol (DHCP); lease

reboot

To restart a computer by reloading the operating system. This can be done by performing either a cold boot, such as turning the computer off and then back on, or a warm boot, such as turning the computer off by typically pressing CTRL + ALT + DEL, clicking Shut Down, and then clicking Restart.

Recovery Console

A command-line interface that provides a limited set of administrative commands that are useful for repairing a computer.

See also: NTFS file system

recovery media

Media provided by the OEM to the customer that allows the customer to repair or reinstall their installation of Windows.

reduced instruction set computing

A type of microprocessor design that focuses on rapid and efficient processing of a relatively small set of instructions. RISC architecture limits the number of instructions that are built into the microprocessor, but optimizes each so it can be carried out very rapidly{bmct emdash.bmp}usually within a single clock cycle.

Redundant Array of Independent Disks (RAID)

A method used to standardize and categorize fault-tolerant disk systems. RAID levels provide various mixes of performance, reliability, and cost. Some servers provide three of the RAID levels: Level 0 (striping), Level 1 (mirroring), and Level 5 (RAID-5).

See also: fault tolerance; mirrored volume; RAID-5 volume; striped volume

reference computer

See definition for: technician computer

registration

Providing the user's name, address, and other demographic information to Microsoft or to both Microsoft and the OEM. Registration information is commonly used for marketing purposes. Registration is different from activation; a user may activate their installation of Windows without providing any identification or demographic information.

See also: Windows Product Activation (WPA)

registry

A database repository for information about a computer's configuration. The registry contains information that Windows continually references during operation, such as:

  • Profiles for each user.
  • The programs installed on the computer and the types of documents each can create.
  • Property settings for folders and program icons.
  • What hardware exists on the system.
  • Which ports are being used.

The registry is organized hierarchically as a tree and is made up of keys and their subkeys, hives, and value entries.

See also: hive; key; subtree; value entry

registry key

An identifier for a record or group of records in the registry.

remote access

Part of the integrated Routing and Remote Access service that provides remote networking for telecommuters, mobile workers, and system administrators who monitor and manage servers at multiple branch offices. Users with a computer running Windows and Network Connections can dial in to remotely access their networks for services such as file and printer sharing, electronic mail, scheduling, and SQL database access.

See also: remote access server; service

remote access server

A Windows-based computer running the Routing and Remote Access service and configured to provide remote access.

See also: remote access

Remote Installation Server (RIS)

An optional component that remotely installs Windows XP Professional. RIS installs the operating system on remote boot-enabled client computers by connecting the computer to the network, starting the client computer, logging on with a valid user account, and copying an operating system image to the client computer.

reseal

To prepare the operating system for delivery to the end user, after completing any additional processing or validation in the factory. Run Sysprep -reseal at the end of your Factory processing to seal the computer.

resource

Generally, any part of a computer system or network, such as a disk drive, printer, or memory, that can be allotted to a running program or a process.

For Device Manager, any of four system components that control how the devices on a computer work. These four system resources are interrupt request (IRQ) lines, direct memory access (DMA) channels, input/output (I/O) ports, and memory addresses.

For server clusters, a physical or logical entity that is capable of being managed by a cluster, brought online and taken offline, and moved between nodes. A resource can be owned only by a single node at any point in time.

See also: input/output (I/O) port; interrupt request (IRQ) lines; memory address; node; resource; server cluster

RIS

See definition for: Remote Installation Server (RIS)

RISC

See definition for: reduced instruction set computing

root

The highest or uppermost level in a hierarchically organized set of information. The root is the point from which further subsets are branched in a logical sequence that moves from a broad or general focus to narrower perspectives.

root authority

The certification authority (CA) at the top of a certification hierarchy. The root CA has a self-signed certificate. Also called the root certification authority.

See also: certification authority (CA); root

root certificate

A self-signed certification authority certificate. It is called a root certificate because it is the certificate for the root authority. The root authority must sign its own certificate because by definition there is no higher certifying authority in the certification hierarchy.

See also: certificate; certification authority (CA); root authority

routing

The process of forwarding a packet through an internetwork from a source host to a destination host.

royalty OEM

A computer original equipment manufacturer who has signed a license agreement directly with Microsoft Licensing, Inc. Royalty OEMs receive a "golden master" copy of Windows from Microsoft. The royalty OEM may customize Windows as described in the OPK, their license agreement, or a signed addendum.

RunOnce application

An application that is configured to run the next time the computer is restarted. The application does not run after any subsequent reboots of the system.

S

script

A type of program consisting of a set of instructions to an application or tool program. A script usually expresses instructions by using the application's or tool's rules and syntax, combined with simple control structures such as loops and if/then expressions. "Batch program" is often used interchangeably with "script" in the Windows environment.

SCSI

See definition for: small computer system interface (SCSI)

seal

See definition for: reseal

security ID (SID)

A data structure of variable length that identifies user, group, and computer accounts. Every account on a network is issued a unique SID when the account is first created. Internal processes in Windows refer to an account's SID rather than the account's user or group name.

See also: group account; user account; user name

serial (COM) device

A string of up to 256 characters with five mandatory fields and ten optional fields, as defined in Section 3 of the Plug and Play External COM Device Specification, v. 1.0.

server

In general, a computer that provides shared resources to network users.

See also: client

server cluster

A group of independent computer systems, known as nodes, working together as a single system to ensure that mission-critical applications and resources remain available to clients. A server cluster is the type of cluster that Cluster service implements.

See also: cluster; node

service

A program, routine, or process that performs a specific system function to support other programs, particularly at a low (close to the hardware) level. When services are provided over a network, they can be published in Active Directory, facilitating service-centric administration and usage. Some examples of services are the Security Accounts Manager service, File Replication service, and Routing and Remote Access service.

See also: Active Directory; Dynamic Host Configuration Protocol (DHCP)

service mark

A mark used in the sale or advertising of services to identify and distinguish them from services provided by another company.

Service Pack

A software upgrade to an existing software distribution that contains updated files consisting of patches and hot fixes.

Setup Manager

A utility for creating and modifying answer files and configuration sets.

See also: answer file; configuration set

Setupapi.log

A log file provides valuable information for troubleshooting and debugging Setup, device installation, and related issues. The information stored in the log file includes errors, warnings, and related information from Windows Setup, including time information.

Setupcl.exe

An executable program invoked by Sysprep.exe that recognizes security IDs (SIDs). It must reside in the same folder as Sysprep.exe.

See also: security ID (SID); Sysprep.exe

signature

See definition for: digital signature

signed driver

A driver that has passed testing by the Windows Hardware Quality Lab (WHQL) to ensure that the driver is compatible with Windows XP, and that the driver meets the criteria of the Windows Logo program. For performance and stability, Microsoft strongly recommends that you use only signed drivers for new or updated drivers.

Simple Mail Transfer Protocol (SMTP)

A member of the TCP/IP suite of protocols that governs the exchange of electronic mail between message transfer agents.

See also: protocol; Transmission Control Protocol/Internet Protocol (TCP/IP)

Simple TCP/IP Services

Four TCP/IP services: Character Generator, Daytime Discard, Echo, and Quote of the Day.

See also: service; Transmission Control Protocol/Internet Protocol (TCP/IP)

simple volume

A dynamic volume made up of disk space from a single dynamic disk. A simple volume can consist of a single region on a disk or multiple regions of the same disk that are linked together. You can extend a simple volume within the same disk or onto additional disks. If you extend a simple volume across multiple disks, it becomes a spanned volume. You can create simple volumes only on dynamic disks. Simple volumes are not fault tolerant, but you can mirror them to create mirrored volumes.

See also: dynamic disk; dynamic volume; fault tolerance; mirrored volume; spanned volume

single sign-on

A process that allows a user with a domain account to log on to a network once, using a password or smart card, and to gain access to any computer in the domain.

See also: domain; smart card

single-byte character set

A character encoding in which each character is represented by 1 byte. Single byte character sets are mathematically limited to 256 characters.

SKU

Shelf keeping unit. A particular product; in this case, a particular edition of Windows XP.

small computer system interface (SCSI)

A standard high-speed parallel interface defined by the American National Standards Institute (ANSI). A SCSI interface is used for connecting microcomputers to peripheral devices such as hard disks and printers, and to other computers and local area networks (LANs).

See also: local area network (LAN); device

smart card

A credit card-sized device that is used with an access code to enable certificate-based authentication and single sign-on to the enterprise. Smart cards securely store certificates, public and private keys, passwords, and other types of personal information. A smart card reader attached to the computer reads the smart card.

See also: authentication; single sign-on; smart card reader

smart card reader

A device that is installed in computers to enable the use of smart cards for enhanced security features.

See also: smart card

snap-in

A type of tool you can add to a console supported by Microsoft Management Console (MMC). A stand-alone snap-in can be added by itself; an extension snap-in can only be added to extend the function of another snap-in.

See also: Microsoft Management Console (MMC)

spacing character

A character with a non-zero width.

spanned volume

A dynamic volume consisting of disk space on more than one physical disk. You can increase the size of a spanned volume by extending it onto additional dynamic disks. You can create spanned volumes only on dynamic disks. Spanned volumes are not fault tolerant and cannot be mirrored.

See also: dynamic disk; dynamic volume; fault tolerance; mirrored volume; simple volume

stage

Copy the directories and files to be installed to a destination computer, but do not configure any registry settings.

See also: attach; destination computer; detach

standalone server

A computer that runs Windows 2000 Server but does not participate in a domain. A standalone server has only its own database of end users, and it processes logon requests by itself. It does not share account information with any other computer and cannot provide access to domain accounts.

See also: domain

striped volume

A dynamic volume that stores data in stripes on two or more physical disks. Data in a striped volume is allocated alternately and evenly (in stripes) across the disks. Striped volumes offer the best performance of all the volumes that are available in Windows, but they do not provide fault tolerance. If a disk in a striped volume fails, the data in the entire volume is lost. You can create striped volumes only on dynamic disks. Striped volumes cannot be mirrored or extended.

See also: dynamic disk; dynamic volume; fault tolerance

subkey

A key within a key. In the registry structure, subkeys are subordinate to subtrees and keys. Keys and subkeys are similar to the section header in .ini files; however, subkeys can carry out functions.

See also: registry; key; subkey

subtree

Any node within a tree, along with any selection of connected descendant nodes. In the registry structure, subtrees are the primary nodes that contain keys, subkeys, and value entries.

See also: node; registry; key; subkey; value entry

SVGA

Super VGA. A video standard established by BESA to provide high-resolution color display on IBM-compatible computers.The most commonly implemented SVGA standard is 1024x768 pixels resolution.

synchronous

Each application or command runs in the order listed, and each item must finish before the next command is run.

Syspart

A process that executes through an optional parameter of Winnt32.exe. Used for clean installations to computers that have dissimilar hardware. This automated installation method reduces deployment time by eliminating the file-copy phase of Setup.

Sysprep

A tool designed for corporate system administrators, OEMs, and others who need to deploy Windows XP on multiple computers. Sysprep must be run again as the last step in your production process, to reset the first-run experience (either Windows Welcome or Mini-Setup) to run the next time the computer is started. By modifying the local computer security identifier (SID) so that it is unique for each destination computer, Sysprep prepares a master installation to be copied to a destination computer that uses similar hardware. Sysprep can be run multiple times on an installation.

See also: security ID (SID); destination computer; first-run experience

Sysprep.exe

The System Preparation utility that uses the Sysprep.inf answer file to prepare a system disk image for duplication.

Sysprep.inf

An optional answer file used by Sysprep that automates Mini-Setup and further customizes the installed operating system.

See also: answer file

system board

Also called a motherboard or planar. The primary circuit board in a PC that contains most of the basic components of the system.

system builder

Anyone who purchases an OEM Distribution Pack of Windows (available from distributors) and preinstalls Windows onto new computers. System Builders are subject to the terms of the Break-the-Seal (BTS) agreement attached to the outside of the OEM Distribution Pack.

See also: Break-the-Seal Microsoft Distribution and Preinstallation Agreement (BTS)

system context

The state of Windows after it first starts when some system services are loaded but no user is logged in and per-user settings are not available.

system devices

Devices on a system board, such as interrupt controllers, keyboard controller, real-time clock, DMA page registers, DMA controllers, memory controllers, FDC, IDE ports, serial and parallel ports, PCI bridges, and so on. In today's PCs, these devices are typically integrated in the supporting chip set.

system drive

The drive letter of the mass-storage device (usually a hard disk) where Windows is installed.

system engineer

A Microsoft employee who assists one or more specific royalty OEMs as they prepare to manufacture computers that will use the version of Microsoft Windows that is currently under development.

System File Protection

See definition for: Windows File Protection (WFP)

system locale

Determines which script non-Unicode applications will support. Thus it is the locale emulated by the system, as seen by applications. For example, if the system locale for US is set to Hebrew, then ANSI applications will see it as Hebrew localized, although the user interface of the system will still be in English. The system locale is system wide, in that it applies to all users. Changing the system locale requires a reboot.

system partition

The partition that contains the hardware-specific files needed to load Windows (for example, Ntldr, Osloader, Boot.ini, Ntdetect.com). The system partition can be, but does not have to be, the same as the boot partition.

See also: boot partition; partition

System Restore

A tool that reverses harmful changes to your computer and restore its settings and performance. System Restore returns your computer to an earlier time (called a restore point) without causing you to lose recent work, such as saved documents, e-mails, or history and favorites. Any changes that System Restore makes to your computer are completely reversible. Your computer automatically creates restore points, but you can also use System Restore to create your own restore points. This is useful if you are about to make a major change to your system such as installing a new program or changing your registry.

systemroot

The path and folder name where the Windows system files are located. Typically, this is C:\Windows, although you can designate a different drive or folder when you install Windows. You can use the value %systemroot% to replace the actual location of the folder that contains the Window system files. To identify your systemroot folder, click Start, click Run, type %systemroot%, and then click OK.

T

TAM

See definition for: technical account manager (TAM)

TAPI

See definition for: Telephony API (TAPI)

target computer

See definition for: destination computer

taxonomy

In the Windows XP Help and Support Center, the classification system that organizes Help topics into specific categories.

TCP/IP

See definition for: Transmission Control Protocol/Internet Protocol (TCP/IP)

technical account manager (TAM)

A Microsoft employee who provides technical assistance to one or more specific royalty OEMs as they manufacture computers installed with a released version of Microsoft Windows.

technician computer

The computer that you install Setup Manager on. Normally, the configuration sets and the distribution share are also located on this computer.

See also: configuration set; distribution share; Setup Manager

Telephony API (TAPI)

An application programming interface (API) used by communications programs to work with telephony and network services. Communications programs like HyperTerminal and Phone Dialer use TAPI to dial, answer, and route telephone calls on conventional telephony devices, including PBXs, modems, and fax machines. TAPI 3.0 also provides Internet Protocol (IP) telephony support, which Phone Dialer and other programs use to transmit, route, and control real-time audio and video signals over IP-based networks such as the Internet.

See also: application programming interface (API); Internet Protocol (IP); modem (modulator/demodulator); service

text-mode Setup

The second of the three stages of Setup, where the basic hardware of the computer (CPU, motherboard, hard disk controllers, file systems, and memory) is determined, the base operating system necessary to continue is installed, and specified folders are created.

third-party drivers

Device drivers that are not included in Driver.cab.

See also: Driver.cab

time stamp

A certification by a trusted third party specifying that a particular message existed at a specific time and date. In a digital context, trusted third parties generate a trusted time stamp for a given message by having a time stamping service append a time value to a message and then digitally signing the result.

See also: digital signature; service

topology

In Windows, the relationships among a set of network components. In the context of Active Directory replication, topology refers to the set of connections that domain controllers use to replicate information among themselves.

See also: Active Directory; domain controller

trail byte

The byte value that is the second half of a double-byte character.

Transmission Control Protocol/Internet Protocol (TCP/IP)

A set of networking protocols widely used on the Internet that provides communications across interconnected networks of computers with diverse hardware architectures and various operating systems. TCP/IP includes standards for how computers communicate and conventions for connecting networks and routing traffic.

See also: Internet Protocol (IP); protocol

Txtsetup.oem

A text file identifying supported hardware components, the files to copy from the distribution disk for the hardware component, and listing the registry keys and values to create for the hardware component. This is used only during text-mode Setup.

U

unallocated space

Available disk space that is not allocated to any volume. The type of volume that you can create on unallocated space depends on the disk type. On basic disks, you can use unallocated space to create primary or extended partitions. On dynamic disks, you can use unallocated space to create dynamic volumes.

See also: basic disk; dynamic disk; extended partition; logical drive; object; partition; primary partition

Unattend.txt

The generic name for the Windows Setup answer file. In the CD boot preinstallation method, Unattend.txt must be named Winnt.sif.

See also: answer file; CD boot; Windows Setup; Winnt.exe

unattended Setup

An automated, hands-free method of installing Windows. During installation, unattended Setup uses an answer file to supply data to Setup instead of requiring that an administrator interactively provide the answers.

UNC

See definition for: Universal Naming Convention (UNC)

uni-processor

A computer with a single processor.

See also: multiprocessor

Unicode

A character encoding standard developed by the Unicode Consortium that represents almost all of the written languages of the world. The Unicode character repertoire has multiple representation forms, including UTF-8, UTF-16, and UTF-32. Most Windows interfaces use the UTF-16 form.

See also: American Standard Code for Information Interchange (ASCII)

Universal Naming Convention (UNC)

A convention for naming files and other resources beginning with two backslashes (\), indicating that the resource exists on a network computer. UNC names conform to the \\SERVERNAME\SHARENAME syntax, where SERVERNAME is the server's name and SHARENAME is the name of the shared resource. The UNC name of a directory or file can also include the directory path after the share name, with the following syntax: \\SERVERNAME\SHARENAME\DIRECTORY\FILENAME.

universal serial bus (USB)

An external bus that supports Plug and Play installation. Using USB, you can connect and disconnect devices without shutting down or restarting your computer. You can use a single USB port to connect up to 127 peripheral devices, including speakers, telephones, CD-ROM drives, joysticks, tape drives, keyboards, scanners, and cameras. A USB port is usually located on the back of your computer near the serial port or parallel port.

See also: bus; Plug and Play; port

USB

See definition for: universal serial bus (USB)

user account

A record that consists of all the information that defines a user to Windows. This includes the user name and password required for the user to log on, the groups in which the user account has membership, and the rights and permissions the user has for using the computer and network, and accessing their resources. For Windows XP Professional and member servers, user accounts are managed with Local Users and Groups. For Windows Server domain controllers, user accounts are managed with Microsoft Active Directory Users and Computers.

See also: permission; Active Directory Users and Computers; password; resource; user name

user interface language

The language in which the operating system displays its menus, help files, and dialog boxes.

user locale

The user preferences for formatting of dates, currencies, numbers, and so on. The user locale is a per-user setting, and does not require restarting the computer.

user mode

The processing mode in which applications run.

user name

A unique name identifying a user account to Windows. An account's user name must be unique among the other group names and user names within its own domain or workgroup.

See also: domain; user account; workgroup

user password

The password stored in each user's account. Each user generally has a unique user password and must type that password when logging on or accessing a server.

See also: password; user account

user principal name

A user account name (sometimes referred to as the user logon name) and a domain name identifying the domain in which the user account is located. This is the standard usage for logging on to a Windows domain. The format is: user@domain.com (as for an e-mail address).

See also: user account; domain; domain name

user rights

Tasks that a user is permitted to perform on a computer system or domain. There are two types of user rights: privileges and logon rights. An example of a privilege is the right to shut down the system. An example of a logon right is the right to log on to a computer locally. Both types are assigned by administrators to individual users or groups as part of the security settings for the computer.

See also: administrator; domain

V

value added reseller (VAR)

A company that resells hardware and software packages to developers and/or end users.

value entry

The string of data that appears in the right pane of a registry window and that defines the value of the currently selected key. A value entry has three parts: name, data type, and the value itself.

See also: registry; key

VAR

See definition for: value added reseller (VAR)

VGA

Video graphics array. A video adapter that supports 640 x 480 pixels color resolution. VGA is the video display standard for boot devices under Windows operating systems and provides medium-resolution text and graphics.

volume set

A partition consisting of disk space on one or more physical disks that was created with Windows NT 4.0 or earlier. You can delete volume sets only with Windows&nsbsp;2000 or Windows XP. To create new volumes that span multiple disks, use spanned volumes on dynamic disks.

See also: basic disk; dynamic disk; partition; spanned volume

W

WDL

See definition for: Windows Driver Library (WDL)

Web server

A computer that is maintained by a system administrator or Internet service provider (ISP) and that responds to requests from a user's browser.

See also: Internet service provider (ISP)

WHQL

See definition for: Windows Hardware Quality Labs (WHQL)

wide area network (WAN)

A communications network connecting geographically separated computers, printers, and other devices. A WAN allows any connected device to interact with any other on the network.

See also: device; local area network (LAN)

Windows Driver Library (WDL)

A distribution point on www.microsoft.com for third-party drivers that meet the Windows Logo requirements.

Windows File Protection (WFP)

A Windows 2000 feature that runs in the background and protects your system files from being overwritten. When a file in a protected folder is modified, WFP determines if the new file is the correct Microsoft version or if the file is digitally signed. If not, the modified file is replaced with a valid version.

Windows Hardware Quality Labs (WHQL)

Provides compatibility testing services to test hardware and drivers for Windows operating systems.

Windows Installer

An operating system service that allows the operating system to manage the installation process. Windows Installer technologies are divided into two parts that work in combination: a clientside installer service (Msiexec.exe) and a package file (.msi file). Windows Installer uses the information contained within a package file to install the application.

Windows Internet Name Service (WINS)

A software service that dynamically maps IP addresses to computer names (NetBIOS names). This allows users to access resources by name instead of requiring them to use IP addresses that are difficult to recognize and remember. WINS servers support clients running Windows NT 4.0 and earlier versions of Microsoft operating systems.

See also: network basic input/output system (NetBIOS); resource; service; IP address

Windows Logo Program

A certification program to help customers identify systems, hardware, and software that meet a baseline definition of platform features and quality goals and ensure a good user experience of Windows.

Windows Management Instrumentation (WMI)

A management infrastructure in Windows that supports monitoring and controlling system resources through a common set of interfaces and provides a logically organized, consistent model of Windows operation, configuration, and status.

See also: resource

Windows Preinstallation Environment (WinPE)

A minimal Win32 operating system with limited services, built on the Windows XP Professional kernel running in protected mode. WinPE is only available to OEMs.

Windows Product Activation (WPA)

A technology that reduces software piracy by requiring that each installation of a Windows product be activated with Microsoft, either through the Internet or by telephone. A unique product key is required for each installation of Windows, but Microsoft does not request or collect any information other than the Product Key during the installation. The end user may reinstall Windows using the same Product Key on the same computer as many times as necessary, but it cannot be used to install Windows on another computer. The end user can make incremental hardware upgrades to the computer. However, if the hardware is significantly altered, the end user will be required to reactivate the installation of Windows.

Windows Setup

The program that installs the Windows operating system.

Windows Welcome

The end user's first experience of Microsoft Windows in Windows XP Home Edition and Windows XP Professional. Through a series of full-screen, HTML-based pages, Windows Welcome quickly and easily takes end users through the final steps of setting up their personal computer. End users are then prompted for any additional information that is needed to personalize their settings, which can include regional settings, network configuration (where applicable), and Internet connection settings. Windows Welcome is formerly known as Out-Of-Box Experience (OOBE).

Winnt.exe

A command line utility used to start an unattended Windows XP Setup from computers running MS-DOS, Windows 3.1, or Windows for Workgroups.

Winnt.sif

The answer file that contains information used by Setup when you install Windows using the CD boot method.

See also: answer file; CD boot

Winnt32.exe

A command line utility used to start an unattended Windows XP Setup from computers running Windows 95, Windows 98, Windows NT, Windows 2000, or Windows XP.

WinPE

See definition for: Windows Preinstallation Environment (WinPE)

WINS

See definition for: Windows Internet Name Service (WINS)

Winsock

Windows Sockets. An application programming interface (API) standard for software that provides a TCP/IP interface under Windows.

See also: Transmission Control Protocol/Internet Protocol (TCP/IP); application programming interface (API)

WMI

See definition for: Windows Management Instrumentation (WMI)

workgroup

A simple grouping of computers, intended only to help users find such things as printers and shared folders within that group. Workgroups in Windows do not offer the centralized user accounts and authentication offered by domains.

See also: user account; authentication; domain

World Wide Web

A system for exploring the Internet by using hyperlinks. When you use a Web browser, the Web appears as a collection of text, pictures, sounds, and digital movies.

See also: internet

X

x86

Refers to microprocessors that have or emulate the 32-bit Intel processor architecture.

Y

There are no glossary terms that begin with this letter.

Z

There are no glossary terms that begin with this letter.


Legal Notices

Information in this document, including URL and other Internet Web site references, is subject to change without notice. Unless otherwise noted, the example companies, organizations, products, domain names, e-mail addresses, logos, people, places and events depicted herein are fictitious, and no association with any real company, organization, product, domain name, e-mail address, logo, person, place or event is intended or should be inferred. Complying with all applicable copyright laws is the responsibility of the user. Without limiting the rights under copyright, no part of this document may be reproduced, stored in or introduced into a retrieval system, or transmitted in any form or by any means (electronic, mechanical, photocopying, recording, or otherwise), or for any purpose, without the express written permission of Microsoft Corporation.

Microsoft may have patents, patent applications, trademarks, copyrights, or other intellectual property rights covering subject matter in this document. Except as expressly provided in any written license agreement from Microsoft, the furnishing of this document does not give you any license to these patents, trademarks, copyrights, or other intellectual property.

© 2001 Microsoft Corporation. All rights reserved.

Active Desktop, ActiveX, Authenticode, BackOffice, ClearType, DirectX, FrontPage, Hotmail, JScript, Microsoft, Microsoft Press, MS-DOS, MSDN, MSN, Visual Basic, Win32, Win64, Windows, Windows logo, Windows Media, Windows NT, and Windows Start logo are either registered trademarks or trademarks of Microsoft Corporation in the U.S.A. and/or other countries.

The codename "Windows 2002 [___] Server" may change before the final release of these products. References in this document to these products or family of products are codename placeholders only.

TrueType is a registered trademark of Apple, Inc.

The names of actual companies and products mentioned herein may be the trademarks of their respective owners.


Syntax Changes in Windows Welcome Files (Oobeinfo.ini)

banner

Changes in Windows Welcome Files

The following are changes in Oobeinfo.ini and in the set of Windows Welcome Application Programming Interfaces (APIs) that have occurred since the Windows Millenium Edition.

Changes to Oobeinfo.ini

Additions

The following Oobeinfo.ini items are new in Windows XP.

[Options] section

  • OutsideLine

[StartupOptions] section

  • OEMAuditBoot
  • ScreenResolutionCheck

[UserInfo] section

The [UserInfo] section has been added so that you can personalize the Welcome screen, and prepopulate the end user information fields seen by end users during registration. See [UserInfo] for more information.

Deletions

The following Oobeinfo.ini items have been deleted in Windows XP.

[BrowseNow] section

This section is no longer present in Oobeinfo.ini. [BrowseNow] contained the following entry:

  • BrowseNow

[StatusItems-XXX] sections

  • [Status Items-MSN]
  • [Status Items-Preconfig]
  • [Status Items-Offline]
  • [Status Items-None]
  • [Status Items-No Modem]
  • [Status Items-MSN(No Reg)]
  • [Status Items-Preconfig(No Reg)]
  • [Status Items-Offline(No Reg)]
  • [Status Items-None(No Reg)]

[OEMRegistrationPage] section

  • PostToMSN

    This setting is always on in Windows XP.

[StartupOptions] section

  • FullScreenMode

[StatusPane] section

  • Logo
  • LogoBackground

Use Setup Manager to replace or modify Oemlogo.gif. Watermrk.gif is no longer used in Windows Welcome.

[WindowsLogon] section

This section is no longer present in Oobeinfo.ini. [WindowsLogon] contained the following entries:

  • AutoLogon
  • DefaultUserName

[Signup] section

  • Locale
  • Text1
  • Text2

Changes to Windows Welcome APIs

Additions

The following APIs are new in Windows XP:

Windows.External

  • get_RetailOOBE
  • GetLocalUserCount
  • IsProfessionalSKU

API object

  • API.RegFlushKey

UserInfo object

  • check_Identity
  • get_IdentitiesMax
  • get_Identity
  • set_Identity


Microsoft Windows Preinstallation Reference

banner1 banner2

This reference helps you to preinstall, customize, and deploy these products in the Windows family of operating systems:

Windows XP Home Edition
Windows XP Professional
Windows XP 64-Bit Edition

© 1985-2001 Microsoft Corporation. All rights reserved. Terms of Use.


[Homenet] (Unattend.txt)

The [Homenet] section is for Unattend.txt only. Use it to set Home Networking settings for network adapters, Internet Connection Sharing (ICS), and Internet Connection Firewall (ICF).

Bridge

Value: adapter1_name, adapter2_name[, adapter3_name,...]

Specifies the adapters to bridge together a home network. This section requires at least two adapters from those specified in the [NetAdapters] section of Unattend.txt.

When an adapter is bridged, it cannot be specified in InternetConnectionFirewall, InternalAdapter, or ExternalAdapter.

EnableICS

Value: Yes | No
Default: No

Enables or disables ICS.

ExternalAdapter

Value: adapter_name

The adapter used for the ICS external connection. The adapter is one of those specified in the [NetAdapters] section of Unattend.txt. This entry requires that EnableICS = Yes.

Note

  • This entry cannot be used in an unattended upgrade from either Windows 98 or Windows Millennium Edition to Windows XP Home Edition.

InternalAdapter

Value: adapter_name

Specifies the adapter used for the ICS internal connection. The adapter is one of those specified in the [NetAdapters] section of Unattend.txt. This entry requires that InternalIsBridge = No. This entry requires that EnableICS = Yes.

InternetConnectionFirewall

Value: adapter_name[, adapter_name,...]

The adapters on which the Internet Connection Firewall (ICF) should be turned on. The adapters are those identified in the [NetAdapters] section of Unattend.txt.

Adapters with the firewall turned on cannot be specified in InternalAdapter or in Bridge.

InternalIsBridge

Value: Yes | No
Default: No

Specifies whether the internal adapter is a bridge. This entry requires that EnableICS = Yes.

Yes
The internal adapter is a bridge. The Bridge entry has to specify the adapters to bridge together a home network.
No
The internal adapter is not a bridge. The InternalAdapter field will contain the name of the adapter.

ShowTrayIcon

Value: Yes | No
Default: Yes

Enables or disables the display of the ICS tray icon. This entry requires that EnableICS = Yes.