Installation Types

Setup Manager helps administrators to create answer files, which are used by Windows Setup to perform unattended installations or upgrades of Windows. Answer files answer the questions that Setup would normally ask the user while it is installing or upgrading Windows. For example, Setup normally asks the user to supply a name for the computer. But if you supply the name for the computer in the answer file, Setup does not prompt the end user.

When you use Setup Manager to create an answer file, it prompts you for the information required on the pages you see when running an attended Setup. Answer files do not automatically eliminate the need for user input when Setup runs. You must configure the entries in answer files to require little or no user interaction.

Windows Unattended Setup

Windows Setup runs in one of five unattended modes that controls how much it interacts with the user. In a fully unattended installation, Setup does not prompt the user for any information, and you must supply all required information in the answer file. In this case, Setup Manager requires that you specify data for all required settings. When using any of the other unattended modes, Setup Manager lets you not specify some data. If you do not want to specify a particular setting in the answer file, leave that field blank, or select "Do not specify this setting" in certain cases.

Note

  • If you are upgrading an existing Windows XP installation, Setup uses the parameters of the existing installation and ignores parameters specified in the answer file.

Sysprep Installation

When you create an answer file for a Sysprep installation, an .inf file is generated. To use this answer file it must be placed on your system drive under the folder "Sysprep" (for example, C:\Sysprep) or on a floppy disk that is inserted when the Windows boot menu appears.

The files Sysprep.exe, Setupcl.exe, and Factory.exe must also be in the %systemdrive%\Sysprep folder. Running Sysprep.exe or the .bat file generated by Setup Manager will prepare the hard disk for duplication. For ease of use, select to have Setup Manager create the %systemdrive%\Sysprep folder for you with all the necessary files. Only choose to do this if you are running Setup Manager on the computer to be duplicated.

Note

  • The %systemdrive%\Sysprep folder is automatically deleted after the hard disk is powered up and Windows Setup completes.

See Sysprep.exe for more detailed information about using the Sysprep tool.

Remote Installation Services

When you create an answer file to be used with Remote Installation Service (RIS), Setup Manager creates an .sif file instead of the usual .txt file.

A sample batch script is not created in this case. You must use the Administration tools shipped with RIS to enable your new .sif file.


Using Winnt32.exe to Run Setup

You can run Winnt32.exe from a command prompt to start Windows Setup on a computer that is running any of the following operating systems:

  • Windows XP
  • Windows 2000
  • Windows NT
  • Windows Millennium Edition
  • Windows 98
  • Windows 95

For a complete list of the Winnt32.exe command-line options, see Winnt32.exe Command-Line Options.

To run Setup using Winnt32.exe

  1. On the technician computer, prepare an Unattend.txt file built using Setup Manager.
  2. Start the computer where you want to install Windows. This computer must boot using one of the operating systems listed above.
  3. Click Start, click Run, and then type:

    path_to_winn32\winnt32/unattend:filename

    where:

    path_to_winnt32
    Specifies the path to the location of Winnt32.exe. For example, \\server\share\I386.
    filename
    Specifies the name of the answer file, which contains answers to installation questions you want to automate. The value of filename is usually Unattend.txt.

After Setup is complete, preinstall applications, audit the system, and run Sysprep to convert the system to a customer-ready state. For more information, see Preinstalling Applications, Using Sysprep for Auditing Installations, and Sysprep.exe.

Notes

  • To ensure a clean installation, make sure you do not install Windows XP as an upgrade.
  • Another network-based system for preinstalling Windows XP is Remote Installation Server, which is discussed in the Microsoft Windows 2002 Server Resource Kit.

Running Windows Setup on Computers Without Mice

If you run Windows Setup in a preinstallation environment without mice attached to the computer and you expect that a PS/2 mouse may be used on this computer rather than a USB mouse, add the following to the [Sysprep] section of the Sysprep.inf:

[Sysprep]
BuildMassStorageSection = Yes

This entry automatically populates the [SysprepMassStorage] section with the appropriate Plug and Play IDs from Machine.inf, Scsi.inf, Pnpscsi.inf, and Mshdc.inf.


Using Winnt.exe to Run Setup

You can run Winnt.exe from a command prompt to start Windows Setup onto a computer that is running any of the following legacy operating systems:

  • MS-DOS
  • Windows 3.1
  • Windows for Workgroups

These operating systems do not support long file names, and all files and folders in the distribution folder must be in 8.3 format for Windows Setup (Winnt.exe) to copy the files. To restore any file names in 8.3 format to long file names during Windows Setup, include the $$Rename.txt file in the distribution folder. For more information, see Converting Short File Names to Long File Names.

For a complete list of the Winnt32.exe command-line options, see Winnt.exe Command-Line Options.

You can also use the Winnt.exe command to install Windows over the network. Each destination computer must start using one of the operating systems listed above, located on some sort of removable media. For example, you could use an MS-DOS boot disk that also contained network support.

To run Setup using Winnt.exe

  1. Make sure that the drivers needed for the CD-ROM drive are available on the disk or drive and that they are loaded correctly.
  2. On the technician computer, use Setup Manager to build an Unattend.txt file.
  3. Start the computer where you want to install Windows. This computer must boot using one of the operating systems listed above.
  4. Click Start, click Run, and then type:

    winnt /s:install_source /u:filename

    where:

    install_source
    Specifies the location of the Windows files.
    filename
    Specifies the name of the answer file, which contains answers to installation questions you want to automate. The value of filename is usually Unattend.txt.

After Setup completes, you are ready to preinstall applications, audit the system, and run Sysprep to convert the system to a customer-ready state.

For more information, see Preinstalling Applications, Using Sysprep for Auditing Installations, and Sysprep.exe.

Note

  • When you run unattended Setup mode on a computer that has multiple hard disks or partitions, you must specify the destination location. Use the Winnt /t or Winnt32 /tempdrive command-line option to specify the destination.

Running Windows Setup on Computers Without Mice

If you run Windows Setup in a preinstallation environment without mice attached to the computer and you expect that a PS/2 mouse may be used on this computer rather than a USB mouse, add the following to the [Sysprep] section of the Sysprep.inf:

[Sysprep]
BuildMassStorageSection = Yes

This entry automatically populates the [SysprepMassStorage] section with the appropriate Plug and Play IDs from Machine.inf, Scsi.inf, Pnpscsi.inf, and Mshdc.inf.


Converting Short File Names to Long File Names

If you are using Winnt.exe to preinstall the operating system, all files and folders in the distribution folders must be in 8.3 format for Windows Setup to copy the files. In addition, you must always use 8.3 file names if you are copying a set of files from one computer to another using MS-DOS.

Use the $$Rename.txt file to restore these 8.3 names to long file names during Windows Setup. Place $$Rename.txt in any subfolder of the distribution folder that contains the files that need to be renamed. Each folder containing files with short file names that must be renamed must contain its own $$Rename.txt file.

Syntax for $$Rename.txt

The syntax for $$Rename.txt is as follows:

[Section_name_1]
Short_name_1 = "Long_name_1[$$]"
Short_name_2 = "Long_name_2[$$]"
.
.
Short_name_x = "Long_name_x[$$]"

[Section_name_2]
.
.

Parameters

Section_name_1, Section_name_2, and so on
Paths to the folders that contain the files. A section can be unnamed, or it can have a backslash (\) as its name. The backslash indicates that the section contains the names of the files or subfolders that are on the root of the drive.
Short_name_1, Short_name_2, and so on
Names of the files or subfolders in this folder to be renamed. Do not enclose the names in quotation marks.
Long_name_1, Long_name_2, and so on
New names of the files or subfolders. Enclose these names in quotation marks if they have spaces or commas.

If Long_name_x is the name of the Profiles directory and has a "$$" appended to the end, Setup merges this directory with the current Profiles directory.

For example, if the $$Rename.txt file contained the following entries:

[\]
D = "Documents and Settings$$"

Files listed in this section are placed in the "Documents and Settings$$" Profiles directory. There are no limitations on the number of characters.


Setting the Administrator Password

In the [GuiUnattended] section of the Unattend.txt file, you can set the Administrator password by using the AdminPassword entry, as follows:

AdminPassword
Value: password | *

If the value is *, Setup sets the Administrator password as blank (or NULL). It is recommended that you make the Administrator password blank for computers that are distributed to end users.

Note

  • The password may contain as many as 127 characters.

When you set the Administrator password, keep in mind that:

  • If you specify a password by using AdminPassword, that password is used when you automatically log on. After the installation is complete, the password is deleted from the copy of the answer file left on the computer.
  • If AdminPassword = * (is blank) and AutoLogon = Yes, the computer logs on only one time, regardless of the value given for AutoLogonCount. However, if AdminPassword = password, the computer logs on repeatedly and the non-blank password is saved in the registry.
  • The computer automatically logs on the number of times specified for AutoLogonCount only when AdminPassword = password.

Important

  • Using a common, non-blank administrator password for all computers provided to end users may present a security breach. Before you run Sysprep, you should use an automation process to set the Administrator password to blank. End users can then specify their own passwords.


Preinstalling Applications

When selecting software to preinstall on the computers you manufacture, Microsoft recommends you select software that meets the requirements of the Certified for Windows Program (http://msdn.microsoft.com/certification/). For more information on the benefits of this certification, see Microsoft Windows Logo Programs.

The preferred time to preinstall applications on Windows XP systems is during Factory mode of Sysprep, using the [OEMRunOnce] section in Winbom.ini. This technique is faster and provides greater flexibility in the manufacturing environment.

One way to build these computers is to start with a basic image of the operating system, customized with only company branding and configured to start with Sysprep in Factory mode on the next reboot. For each order, the technician places the basic image on the destination computer, installs each application as ordered by the customer, and seals the computer to prepare it for distribution. These applications can be installed by hand or by using the [OEMRunOnce] section in Winbom.ini.

However, if the applications are Windows Installer (MSI) installation packages, a more efficient way of offering the same degree of customization is to stage all of the applications on the master installation. When you stage an application, all the files are placed on the computer but no changes are made to the registry. After the image of the master installation is placed onto the destination computer, you can either attach (complete the installation) or detach (remove all the files) each application, to configure the computer as ordered by the customer. Setup of the attached application is faster, because the setup program does not need to copy the files to the computer. It is also much faster to delete files from a computer than to install an application over a network connection, especially if this application is installed on a majority of the computers that you manufacture.

Using [GuiRunOnce] or Cmdlines.txt to Preinstall Applications

For backward compatibility, you can continue to use the same techniques you used to preinstall applications in Windows 2000. However, these techniques will increase the time required when the end user starts the computer for the first time and therefore, these are not recommended. For more information, see Preinstalling Applications Using Legacy Techniques.

Example: Preinstalling Commonly-Sold Applications

For example, Fabrikam, Inc. is an OEM that manufactures build-to-order computers. Fabrikam offers three general-productivity applications as standard options. From past sales, Fabrikam knows that 80 percent of its customers order the first application, 70 percent of customers order the second application, and 50 percent of customers order the third application.

Fabrikam builds a base Windows XP installation that it uses for this type of computer, and they build a Winbom.ini file. The [OEMRunOnce] section of this Winbom.ini file directs the files for three different applications to be copied to the master computer. However, the applications themselves are not fully installed. When the computer is shut down, it is configured to restart in Factory mode of Sysprep.

Fabrikam uses these specific settings in the Winbom.ini file:

[OEMRunOnce]
"Connect to network share", "net use R: \\server\share"
"First Application Stage", "Application1.Stage", MSI
"Second Application Stage", "Application2.Stage", MSI
"Third Application Stage", "Application3.Stage", MSI

[Application1.Stage]
InstallType = Stage
StagePath = "C:\App1_Temp"
SetupFile = "Application_One.msi"
SourcePath = "R:\ApplicationOne"

[Application2.Stage]
InstallType = Stage
StagePath = "C:\App2_Temp"
SetupFile = "Application_Two.msi"
SourcePath = "R:\ApplicationTwo"

[Application3.Stage]
InstallType = Stage
StagePath = "C:\App3_Temp"
SetupFile = "Application_Three.msi"
SourcePath = "R:\ApplicationThree"

[Factory]
ResealMode = Factory
Reseal = Yes

Fabrikam makes an image of the master installation. In addition, Fabrikam's technical staff has created a custom tool to generate a customer-specific Winbom.ini file corresponding to each customer order and placed that file on a floppy disk.

In the factory, the assembler receives an order and the corresponding floppy disk, copies the master image to the destination computer, and places the floppy disk in the drive. The computer is rebooted on the factory floor. The computer starts up in Factory mode of Sysprep, which processes this customer-specific Winbom.ini file.

For this particular order, this Winbom.ini file causes the first application to be fully installed, and the files for the second and third application are completely removed from the computer. The computer then shuts down and is ready for distribution to the customer.

Fabrikam uses these specific settings in the Winbom.ini file:

[OEMRunOnce]
"First Application Attach", "Application1.Attach", MSI
"Second Application Detach", "Application2.Detach", MSI
"Third Application Detach", "Application3.Detach", MSI

[Application1.Attach]
InstallType = Attach
StagePath = "C:\App1_Temp"
SetupFile = "Application_One.msi"

[Application2.Detach]
InstallType = Detach
StagePath = "C:\App2_Temp"

[Application3.Detach]
InstallType = Detach
StagePath = "C:\App3_Temp"

[Factory]
ResealMode = OOBE
Reseal = Shutdown

Placing Application Shortcuts on the Start Menu

If you want to place a shortcut to the application on the Most Frequently Used list of programs on the Start menu, make sure a path to the shortcut file (.lnk) is listed in the [StartMenuMFUlist] section of Winbom.ini. When building a master installation, be sure the .lnk file is located within the %OEM$ directory in a location equivalent to the one specified in [StartMenuMFUList], so that the .lnk file is installed during unattended Setup.

Repackaging Applications for Preinstallation

If the application does not have a Windows Installer (.msi) setup package, you can use a third-party tool to repackage applications into the .msi format. The .msi format is preferred because it allows you to:

  • Install the applications during Windows unattended Setup.
  • Help reduce .dll version-management issues.

For more information about Windows Installer, see http://www.microsoft.com/windows2000/library/howitworks/management/installer.asp

You can also use an application's own built-in installation routine, if Setup is able to run in unattended mode (without user intervention) by using a /q (quiet) or /s (silent) command-line option.

The setup command-line options vary among applications. For example, a useful option some applications use is /l to create a log file to monitor the installation. It is important that you check with the application’s vendor for information, instructions, and tools before you preinstall an application.

Important

  • You must meet the licensing requirements for any application you include on the computer, regardless of the method you use to preinstall the application.
  • If the setup program for an application replaces a current Windows system file with the older system file in its installation package, Windows File Protection replaces the old system file with the current system file that was installed as part of Windows.


Preinstalling Applications Using Legacy Techniques

The preferred time to preinstall applications on Windows XP systems is during Factory mode of Sysprep, using the [OEMRunOnce] section in Winbom.ini. This technique is faster and provides greater flexibility in the manufacturing environment. For more information, see Preinstalling Applications.

For backward compatibility, you can continue to use the same techniques you used to preinstall applications in Windows 2000. However, these techniques will increase the time required when the end user starts the computer for the first time and are not recommended.

Preinstalling Applications Using Cmdlines.txt

Use Cmdlines.txt when:

  • You are installing from the \$OEM$ distribution folder.
  • You are installing applications during GUI-mode Setup.
  • The application you are installing is designed for installation by one user and you need to replicate user-specific information across all users of the computer.

The Cmdlines.txt file contains the commands that GUI-mode Setup runs when installing optional components, such as applications. For example, you can use the commands specified in this file to run an .inf file by using the Rundll32.exe command or to perform some other action. If you plan to use Cmdlines.txt to install an application, place the application you are installing in the \$OEM$ subfolder of the distribution folder.

Note

  • For additional information about using Rundll32.exe with .inf files, see the Microsoft Platform Software Development Kit at http://msdn.microsoft.com/library/.

The syntax for Cmdlines.txt is as follows:

[Commands]
"command_1"
"command_2"
     .
     .
"command_x"

where:

"command_1", "command_2" and so on
Specifies the commands you want to run (and in what order) when GUI-mode Setup calls Cmdlines.txt. Note that all commands must appear in quotation marks.

Limitations of and Usage Notes on Cmdlines.txt

The following limitations apply to Cmdlines.txt:

  • When Cmdlines.txt runs, there is no logged-on user and no network connectivity. All user-specific information is written to the default user registry, and all subsequently created users inherit those registry settings.
  • You must place the files necessary for an application or utility to run in the distribution folders.
  • When you install applications by using Cmdlines.txt, install the application in unattended Setup mode so that the user does not need to respond to prompts about the application.
  • You cannot install Windows Installer (.msi) applications using Cmdlines.txt. Use [GuiRunOnce] instead.

Preinstalling Applications Using [GuiRunOnce]

Use [GuiRunOnce] when:

  • You are installing from any source including networks, hard disks, or CD-ROM drives.
  • You cannot install the application during GUI-mode Setup.
  • You want to log on as a user and you do not want to automatically replicate those registry settings to future users.
  • The application you are installing requires that a user be logged on to the computer.

Note

  • [GuiRunOnce] requires the log-on function to be enabled (use the AutoLogon entry in the [GuiUnattended] section). For more information, see Automating the Logon Process.

The [GuiRunOnce] section of the Unattend.txt file contains a list of commands that run the first time the end user logs on to the computer after GUI-mode Setup runs. Each line enclosed in quotation marks specifies a command, which is stored in the GuiRunOnce key in the Windows registry. For example, you enter the following line to [GuiRunOnce] to run Sysprep as part of unattended Setup.

[GuiRunOnce]
"%systemdrive%\Sysprep\Sysprep -quiet"

If an application requires that the Windows Explorer shell be installed, you may use [GuiRunOnce] to create an automated factory installation that completes Setup, automatically logs on to the computer, installs the application, and then shuts down the computer. You can also use [GuiRunOnce] to control the order in which applications are installed.

Important

  • You cannot use [GuiRunOnce] to enable the execution of shells, other programs, and so on, during the end-user boot.

Automating the Logon Process

You can set up the automatic logon process by adding AutoLogon = Yes in the [GuiUnattended] section of the Unattend.txt file (the answer file). Windows then automatically logs on using the Administrator account and password after the first reboot after Setup is complete. The Administrator account password can be blank, or you can specify a password in the answer file. The default setting for AutoLogon is No.

Note

  • If the Administrator account password is blank, the computer logs on one time. If a password is assigned, the computer logs on repeatedly and Windows saves the password in the registry.

For more information, see Setting the Administrator Password.

Controlling Application Installation

If you want to control how multiple applications are installed, you can create a batch file that contains the individual installation commands and uses the Start command with the /wait command-line option. This method ensures that your applications install sequentially and that each application is fully installed before the next application begins its installation routine. The batch file is then run from the [GuiRunOnce] section of the answer file.

The following steps explain how to:

  • Create the batch file.
  • Install the application.
  • Remove all references to the batch file after installation is complete.

To install applications using a batch file

  1. Create a batch file containing lines similar to the following syntax:

    Start /wait path\Setup [-x ...]
    ...
    Exit

    where:

    path
    Specifies the path to the executable file that starts the installation.
    Setup
    Specifies the name of the executable file that starts the installation.
    x
    Specifies any available unattended options appropriate for the application you want to install.
  2. Copy the batch file to the distribution folder or another folder that can be accessed during Setup.

    Note

    • You can also copy the batch file filename.bat to the Sysprep folder of your distribution folders. The batch file is then local to the destination computer. After Sysprep runs, the user completes the first-run experience, the computer reboots, and the Sysprep folder and all of its contents are deleted. You do not have to delete the batch file using another process. For more information, see Using Sysprep.
  3. Using filename.bat as the name of the batch file, include an entry in the [GuiRunOnce] section of the answer file to run the batch file. For example:
    [GuiRunOnce]
Command0() = "%systemdrive%\sysprep\filename.bat"
Command1() = "path-1\Command-1.exe"
Commandn() = "path-n\Command-n.exe"
Commandn+1() = "%systemdrive%\sysprep\sysprep.exe –quiet"

    where:

    path\Command-1.exe and path-n\Command-n.exe
    Specifies fully qualified paths to additional applications, utility installations, configuration tools, or another batch file. These paths must be available during Setup.

This example assumes the batch file was copied to the Sysprep folder on the local hard disk, although you can place the batch file anywhere that Setup can access during an installation.


Including Additional Files in the Distribution Folder

A distribution folder enables you to supply your own files that Windows Setup automatically copies to the destination computers. Setup Manager can guide you through the process of creating a distribution folder.

Such files could include Help files that you want to install on every computer in your organization or device drivers not shipped with Windows XP. They could also be your own applications that you want to deploy to the destination computers.

When you create a distribution folder by using Setup Manager, you need at least enough free disk space to hold the Windows product CD plus the amount of disk space needed to store the files you are deploying yourself.


Using Batch Scripts

Setup Manager creates a sample batch script to illustrate how to use the answer file you created. In certain cases, the sample batch script must be modified before it will work properly.

In all cases, the answer file must be passed to Windows Setup using the /unattend: option of either the Winnt32 (for Win32 systems) or the Winnt commands (for MS-DOS). For more information, see Winnt32.exe Command-Line Options Winnt.exe Command-Line Options; see the sample batch script for an example.

If you are deploying using a distribution folder, the sample batch script must be changed to refer to the correct distribution folder.

If you copied the answer file to a different location, the batch script must be modified to refer to the new location.

Using .Udf Files

If you specified multiple computer names, Setup Manager creates a batch script that expects the computer name to be passed on the command line. In this case, the .udf file must also be present.

When using the .udf file to manage name assignments for multiple computers, you must use the /udf option with either Winnt32.exe or Winnt.exe. For an example, see the sample batch script created by Setup Manager.


Modifying Group Policy Settings

When preinstalling applications with Windows XP that modify local user Group Policy objects (using Group Policy), or when creating new local user groups that are given specific permissions, you should:

  1. Wait approximately five minutes after the local Group Policy objects have been modified or added to make sure the changes have taken effect.

    —OR—

    Restart the computer.

  2. Run Sysprep.

Take these steps when you modify group policies for any local groups or when you create new groups and policies on a system prior to running Sysprep. For example, take these steps when you are:

  • Preinstalling a version of Windows Server with specific group permissions.
  • Preinstalling corporate workstation computers with custom user group permissions.


Using Setup Manager

Use Setup Manager to create or modify the files that control an unattended Setup.

Setup Manager can:

  • Create answer files that can be used to automate the installation of Windows XP on multiple computers.
  • Extract the configuration information from a preconfigured system into an answer file, which can then be used to replicate that configuration on other computers.
  • Create a distribution share point for network installations. In addition to the Windows XP installation files, this network installation share can contain additional applications, drivers, additional commands to run at the end of Setup, and other custom components, as specified by the system administrator.

Setup Manager does not affect the system files of the technician computer on which the tool is run and does not actually run Windows Setup.

You do not need to specify all of your customizations using Setup Manager. Instead, you can create an Unattend.txt file in Setup Manager and then manually edit the file. If you later open that Unattend.txt file in Setup Manager, the tool displays your changed settings.

Starting Setup Manager

To run Setup Manager, you must use Windows 2000 or Windows XP (32-bit version).

To install and run Setup Manager

  1. From the Deploy.cab file in the \Support\Tools folder of the Windows XP product CD, copy the Setupmgr.exe file to your hard disk.
  2. From the command prompt, change the current directory to the directory where you copied the files, and then type:

    setupmgr

For More Information

For more information about specific tasks you can accomplish with Setup Manager, see:

  • Installation Types
  • Including Additional Files in the Distribution Folder
  • Using Batch Scripts

For more information on the specific steps of creating an Unattend.txt file, see:

  • New or Existing Answer File Page
  • Product to Install Page
  • Choose Platform Page
  • Licensing Agreement Page
  • User Interaction Level Page
  • Distribution Folder Page
  • Location of Setup Files Page
  • Customize the Software Page
  • Display Settings Page
  • Time Zone Page
  • Licensing Mode Page
  • Computer Name Page
  • Computer Names Page
  • Administrator Password Page
  • Networking Components Page
  • Workgroup or Domain Page
  • Telephony Page
  • Regional Options Page
  • Languages Page
  • Browser and Shell Settings Page
  • Installation Folder Page
  • Install Printers Page
  • Run Once Page
  • Additional Commands Page
  • OEM Duplicator String Page
  • Setup Information File Text Page

For detailed information about deploying Windows, visit the Deployment pages of the Microsoft Windows Server Web site (http://www.microsoft.com/windows2000/techinfo/planning/).


New or Existing Answer File Page

Use this page to create a new answer file or to modify an existing one.

An answer file is a way to script the answers for a series of graphical user interface (GUI) dialog boxes. The answer file for Setup tells Setup how to interact with the distribution folders and files you create, and supplies Setup with all of the information that the end user is prompted to provide during a typical Windows Setup.

To create a new answer file

  • Click Create a new answer file, and then click Next.

To modify an existing answer file

  1. Click Modify an existing answer file.
  2. Enter the path and file name of the answer file in your distribution folder.
  3. Click Next.

The Setup Manager settings from this page are saved in the following location:

Unattend.txt


Product to Install Page

Use this page to choose which type of installation to create the answer file for. This answer file will either be unattend.txt, sysprep.inf, or winnt.sif.

An answer file is a way to script the answers for a series of graphical user interface (GUI) dialog boxes. The answer file for Setup tells Setup how to interact with the distribution folders and files you create and supplies Setup with all of the information that the end user is prompted to provide during a typical Windows Setup.

To specify the type of installation

Click the type of installation you want to create an answer file for:

  • Windows XP Unattended Installation

    The answer file for Setup is commonly called Unattend.txt, but for a network preinstallation, you can name the file anything you like. For a CD-based Setup, the answer file must be named Winnt.sif.

  • Sysprep Install

    Sysprep.inf is an optional answer file that can be used to automate Mini-Setup. Normally, when Mini-Setup runs, it prompts the end user for a few standard pieces of information used to configure the computer. However, if Sysprep.inf is present, Mini-Setup uses information in Sysprep.inf instead of prompting the end user. By using Sysprep.inf, you can have Mini-Setup prompt for certain information, or you can create a completely automated installation that does not prompt the end user for information at all.

  • Remote Installation Services

    When you create an answer file to be used with a Remote Installation Server (RIS), Setup Manager creates an .sif file (the default name is remboot.sif).

The Setup Manager settings from this page are saved in the following location:

Windows Unattended Installation and Sysprep Install:

Unattend.txt

Remote Installation Services:

[Remote Install]


Choose Platform Page

Use this page to choose which product you are creating an answer file for.

To specify the platform to install

  • Click the product you want to create an answer file for.

The Setup Manager settings from this page are saved in the following location:

Unattend.txt


Licensing Agreement Page

Use this page to accept the End-User License Agreement (EULA), and any Microsoft license agreements you have for the version of Windows you are installing, on behalf of the end users.

By accepting this now, the user will not see or be prompted to accept the license agreement.

To accept the license agreement and fully automate the installation

  • Click Yes, fully automate the installation.


User Interaction Level Page

As end users go through Windows Setup, they may be prompted to provide information for this particular installation. Examples include the computer name (as it appears on the network), network and user account information, and regional options.

You can select from a wide range of end user interaction. You can:

  • Provide default settings for some or all of the pages
  • Display all, some, or none of the settings
  • Allow the end user to change some, none, or all of the settings

To specify the level of end user interaction during Windows Setup

Click one of the following:

  • Provide Defaults

    You provide default answers, and Windows Setup prompts the end user to review them. During Setup, the end user can change any of the answers that you provided.

  • Fully automated

    You provide all of the answers, and Windows Setup does not prompt the end user for changes to any answers.

  • Hide pages

    If you provide all of the answers on the Windows Setup pages, Setup hides the pages from the end user. The end user can only view and change answers on pages that you have not provided answers for.

  • Read only

    If you provide answers on a Windows Setup page, the page is not hidden but the end user cannot make changes to the settings on that page. The end user can only view and change answers on pages that you have not provided answers for.

  • GUI attended

    Only the text-mode portion of Windows Setup is automated.

The Setup Manager settings from this page are saved in the following location:

Unattend.txt
[Unattended]


Distribution Folder Page

Use this page to specify whether you want to install from Windows Setup files in a distribution folder on a computer or network, or install from a CD.

If you use a distribution folder, you can add files to customize your installations, such as additional device drivers.

To specify whether to use a distribution folder

Click one of the following:

  • Yes, create or modify a distribution folder

    If you select this option you will be prompted later in Setup Manager to specify the location of the distribution folder, so that the Windows Setup files can be copied there.

  • No, this answer file will be used to install from a CD

The Setup Manager settings from this page are saved in the following location:

Unattend.txt
[SetupMgr]
DistFolder=
DistShare=


Location of Setup Files Page

Use this page to specify where to copy the Windows Setup files from for use with this answer file. Later in Setup Manager, you will be prompted to specify the location of the distribution folder where these files will be copied to.

To specify the source of the Windows Setup files

Click one of the following:

  • Copy the files from CD

    Later, when Setup Manager is ready to copy the Windows Setup files to your distribution folder, it will copy the files from the CD on the computer where you are running Setup Manager.

  • Copy the files from this location

    Later, when Setup Manager is ready to copy the Windows Setup files to your distribution folder, it will copy the files from the computer or network location you specify here.

The Setup Manager settings from this page are saved in the following location:

Unattend.txt


Customize the Software Page

Use this page to specify the name and organization for the end user of this computer. If you do not provide this information, the end user will be prompted to enter it during Windows Setup.

To specify the end user's name and organization

  1. In the Name box type the end user's name.
  2. In the Organization box type the end user's organization.

The Setup Manager settings from this page are saved in the following location:

Unattend.txt
[UserData]
 FullName=
OrgName=


Display Settings Page

Use this page to specify the Display settings for the end user's computer. You can use the default Windows settings, select from several standard settings, or use the Custom button to specify other values not offered in the lists.

To specify Display settings

  • Use the default settings for your monitor and display card by choosing Use Windows default in the Colors, Screen area, and Refresh frequency boxes.
  • Use one of the standard settings by selecting a setting in the Colors, Screen area, or Refresh frequency boxes.
  • Specify a custom setting for the Colors, Screen area, or Refresh frequency boxes by clicking Custom.

    After you add values in the Custom Display Settings dialog box, those values appear in the settings box on the Display Settings page, and are added to the values available from the associated list box.

The Setup Manager settings from this page are saved in the following location:

Unattend.txt
[Display]
BitsPerPel=
XResolution=
YResolution=
VRefresh=


Time Zone Page

Use this page to specify the time zone for the end user.

To specify the time zone for the end user

  • Click a time zone in the list.

The Setup Manager settings from this page are saved in the following location:

Unattend.txt
[GuiUnattended]
TimeZone=


Product Key Page

You can enter the Product Key if you want to prepopulate the target computer. This Product Key must match the Product Key provided to you by Microsoft Licensing, Inc., as it appears on the certificate of authenticity (COA) label on the destination computer.

To specify the Product Key

  • In the Product Key boxes, type the Product Key.

The Setup Manager settings from this page are saved in the following location:

Unattend.txt
[UserData]
ProductID


Licensing Mode Page

Use this page to select the licensing mode you want to use on the servers you are setting up.

To select the server licensing mode

Select one of the following licensing modes:

  • Click Per server if you are licensing by connection.

    You must also specify the number in Number of concurrent connections.

  • Click Per seat if you are licensing by computer.

The Setup Manager settings from this page are saved in the following location:

Unattend.txt and Sysprep.inf

[LicenseFilePrintData]


Computer Name Page

Use this page to assign the destination computer a name that identifies it on the end user's network.

To specify the computer name

Select how you want to assign the computer name:

  • Click Automatically generate computer name if you want Setup to generate a name for the computer.
  • Click Specify destination computer name if you want to specify the computer name, and then type the name in the Enter the computer name box.

The Setup Manager settings from this page are saved in the following location:

Unattend.txt
[UserData]
ComputerName=


Computer Names Page

Use this page to assign each destination computer a name to uniquely identify it on the end user's network. There are two ways you can specify computer names: by adding them to a list, or by automatically generating names based on your organization’s name. You add computer names to the list by either adding them individually, importing the names from one or more text files, or by doing a combination of both. If you automatically generate names, the names in the Computers to be installed list are ignored.

To add computer names to the list

  • If you want to add names individually, type a name in the Computer name box, and then click Add.

    The name is added to the Computers to be installed list.

  • If you have a list of names that you want to import from a text file, click Import and then specify the location of the text file that contains the computer names. The file must contain one name per line.

    The names are added to the Computers to be installed list in addition to the names already in the list.

  • To remove a computer already on the list, click the computer name, and then click Remove.

To automatically generate names based on your organization’s name

  • Select Automatically generate names based on organization name.

    If this check box is unavailable, then no organization name has been specified in Setup Manager. To specify an organization’s name, click Customize the Software in the left navigation pane, and then type the name in the Organization name box.

The Setup Manager settings from this page are saved in the following location:

Unattend.txt
[SetupMgr]
ComputerName0=
ComputerName1=
ComputerName2=
ComputerName3=


Administrator Password Page

Use this page to specify how to set up the password for the Administrator account on the destination computers.

If you allow end users to set their own password, they have full control of system and network settings, and can add and remove programs.

If you specify an Administrator password for the end user during Windows Setup, and have a secure record of that password, then in the future authorized personnel such as a help desk technician or network administrator can fix or change system, network, or program settings on the computers.

To allow the end user to set the Administrator password

  • Select Prompt the user for an Administrator password.

To specify an Administrator password for the end user

  1. Select Use the following Administrator password.
  2. Type the password in the Password and Confirm Password boxes.
  3. If you want to protect this password so that others cannot view it in the answer file, select Encrypt administrator password in answer file.

    It will then be encoded so that only Windows Setup will be able to read it.

The Setup Manager settings from this page are saved in the following location:

Unattend.txt
[GuiUnattended]
AdminPassword=
EncryptedAdminPassword=


Networking Components Page

Use this page to specify which networking components to install, such as clients, services, and protocols. These are the same components the end user can install or remove in the Networks Control Panel.

To specify which networking components to install

Select one of the following:

  • Click Typical Settings to install TCP/IP, enable Dynamic Host Configuration Protocol (DHCP), and install the Client for Microsoft Networks protocol for each destination computer.
  • Click Customize, and then click Add to add a component to the list. To remove a component from this list, click the component, and then click Remove. For more information on a component, click the component in the list and view the description below the list, or click Properties for specific settings for that component.

The Setup Manager settings from this page are saved in the following location:

Unattend.txt

[Networking]
InstallDefaultComponents=

If the Networking Components settings are customized, additional entries will appear under these entries:

[NetAdapters]
[NetClients]
[NetProtocols]


Workgroup or Domain Page

Use this page to specify whether to link the destination computers to a workgroup or domain.

To specify a workgroup or domain

Select one of the following:

  • Click Workgroup and then type the workgroup name.
  • Click Windows Server domain and then type the domain name.

    • If you want to set up the user account on the domain, click Create a computer account in the domain, and then type the User name, Password, and Confirm password entries.

    If you specify a domain but don't set up a user account, the end user will be prompted for a valid user name and password the first time the computer logs on to the domain after Windows Setup.

The Setup Manager settings from this page are saved in the following location:

Unattend.txt


Telephony Page

Use this page to specify telephone information about the end user's location, so that calls are dialed correctly.

To specify telephone information

You do not have to specify any of the information on this page, all of the following information fields are optional:

  • Select the end user's country in the What country/region are you in? box, or select Do not specify this setting.
  • Type the end user's telephone area code or city code in the What area (or city) code are you in? box.
  • Type an access number, if one is required at the end user's location, in the If you dial a number to access an outside line, what is it? box.
  • Select the type of phone system at the end user's location in the The phone system at this location uses box, or select Do not specify this setting.

The Setup Manager settings from this page are saved in the following location:

Unattend.txt


Regional Options Page

Use this page to customize Windows for different regions and languages. You can use default settings for the region or language you are installing on your version of Windows, specify custom settings, or allow the end user to specify the settings during Windows Setup.

To specify regional and language settings

Select one of the following options:

  • Click Use the default regional options for the Windows version you are installing if you want to use the default language for menus and messages, locale for numbers, time, currency and dates, and input locale associated with this version of Windows.
  • Click User can select regional options during Setup if you want the user to select these settings during Windows Setup.
  • Click Specify regional options in the answer file, and then select a language, if you want to base the regional options on a specific language.

    If you want to specify the language separately for menus and messages, the locale for numbers, time, currency and dates, or the input locale, select Customize the default language settings, and then click Custom.

The Setup Manager settings from this page are saved in the following location:

Unattend.txt


Languages Page

Use this page to add support for other language groups. This support allows end users to view Web pages and other content encoded in a different language and character set. Adding languages does not guarantee that your computer has all of the fonts required to display content in your preferred languages. When accessing such content, the end user may be prompted to download additional language components from the Internet to support different language groups.

To add support for other language groups

  • In the Language groups list, click each language group you want to add. You can select more than one language group.

The Setup Manager settings from this page are saved in the following location:

Unattend.txt


Browser and Shell Settings Page

Use this page to specify whether to use the default settings for Windows® Internet Explorer or custom settings for browser configuration.

To specify Internet Explorer and browser configuration settings

Select one of the following options:

  • Click Use default Internet Explorer settings if you do not want to provide any custom settings.
  • Click Use an autoconfiguration script created by the Internet Explorer Administration Kit to configure your browser, and then click Custom Settings to specify the install.ins file and whether to use an autoconfiguration file.
  • Click Individually specify proxy and default home page settings, and then click the Proxy Settings and Browser Settings buttons to specify their respective settings.

The Setup Manager settings from this page are saved in the following location:

Unattend.txt


Installation Folder Page

Use this page to specify the name of the folder where Windows is installed on the destination computer.

To specify the Windows installation folder

Select one of the following:

  • Click A folder named Windows for standard installation. This name is most recognizable to end users and support technicians in identifying and locating Windows system files and folders.
  • Click A uniquely named folder generated by Setup if you want the Windows system folders to be less obvious or identifiable by end users. The folder name is recorded in the Windows registry, so programs and program installations can easily access Windows system files and folders.
  • Click This folder and then type the folder name. This option allows you to standardize an internal name or naming convention to distinguish your installations.

The Setup Manager settings from this page are saved in the following location:

Unattend.txt


Install Printers Page

Use this page to install network printers on the destination computer. The printers specified will be installed the first time the end user logs on after Setup, providing the end user has the appropriate network permissions for each printer.

To install network printers

  • To add a printer, type the name in the Network printer name box, and then click Add.

    The name is added to the Install these printers list.

  • To remove a printer, click the printer name in the list, and then click Remove.

The Setup Manager settings from this page are saved in the following location:

Unattend.txt


Run Once Page

Use this page to specify command lines to run the first time an end user logs on after Setup. To specify command lines to run at the end of unattended Setup, use the Additional Commands page of Setup Manager.

To specify command lines to run the first time the end user logs on

  • In the Command to run box, type the command and then click Add.
  • To arrange the order that commands are run, click a command in the Run these commands list, and then click Move Up or Move Down.
  • To remove a command, click the command in the list, and then click Remove.

The Setup Manager settings from this page are saved in the following location:

Unattend.txt


Additional Commands Page

Use this page to specify command lines to run at the end of unattended Setup. To specify command lines to run later, when the end user first logs on after Setup, use the Run Once page of Setup Manager.

To specify command lines to run at the end of unattended Setup

  • In the Command to run box, type the command and then click Add.
  • To arrange the order that commands are run, click a command in the Run these commands list, and then click Move Up or Move Down.
  • To remove a command, click the command in the list, and then click Remove.

The Setup Manager settings from this page are saved in the following location:

Cmdlines.txt

[Commands]


OEM Duplicator String Page

Use this page to add a string to the registry on the destination computers. This description or comment can be used to help you identify the particular Sysprep image installed on the destination computer. This is the last page in Setup Manager, so when you click Finish, you will be prompted to save the settings to an answer file.

To add an OEM Duplicator string

  • Type the information in the Sysprep information box.

The Setup Manager settings from this page are saved in the following location:

Unattend.txt


Setup Information File Text Page

Use this page to specify a description and help string for this operating system image on Remote Installation Servers (RISs).

This is the last page in Setup Manager, so when you click Finish, you will be prompted to save the settings to an answer file.

To add information about this operating system image

  1. Type a description in the Description string box, such as the version of the operating system and the type of installation. This description is displayed in lists of images available on the RIS.
  2. Type additional information about this installation in the Help string box. This information is displayed on the RIS when the name in the Description string box is selected from the list of available images.

The Setup Manager settings from this page are saved in the following location:

Unattend.txt


Sysprep

Sysprep is a tool designed for corporate system administrators, OEMs, and others who need to deploy Windows XP on multiple computers. After performing the initial setup steps on a single system, you can run Sysprep to prepare the sample computer for cloning. Sysprep assigns a unique security ID (SID) to each destination computer the first time the computer is restarted. Sysprep configures the operating system to use Windows Welcome or Mini-Setup to run the first time the end user restarts the computer. This shortened form of GUI-mode Setup takes five or six minutes instead of the usual 45 to 60 minutes, and it prompts the end user only for required and user-specific information, such as accepting the End-User License Agreement (EULA) and entering the Product Key, user name, and company name.

Sysprep is a valuable utility even if you do not use disk duplication. You can run Sysprep with the -nosidgen switch to configure Windows Welcome or Mini-Setup on a single computer. In this case, Sysprep allows for auditing that may have been done; automates the Mini-Setup portion of the process so that users can still enter user-specific information, such as regional options and TAPI information; and bypasses setting up unique SIDs, because the SIDs will already be unique when Setup is actually run on the computer.

For more information about Sysprep, see:

  • Using Sysprep
  • Using Sysprep in Factory Mode
  • Sysprep Components
  • Preparing Images for Disk Duplication
  • Using Sysprep for Auditing Installations
  • Automating Mini-Setup
  • Sysprep Command-Line Options


Using Sysprep

When deploying Windows XP, completely install the operating system and preconfigure the shell and applications to the degree required. You can then use Sysprep to enable user-specific customization when the computer is delivered or set up for the user. In this case, the first time the end user starts the computer, Windows Welcome or Mini-Setup prompt the user for a minimal amount of information. The Sysprep folder is deleted automatically from the hard disk after the first-run experience completes.

The Sysprep utility can be used in three different contexts:

  • Disk duplication. Using Sysprep to prepare images for disk duplication allows you to copy fully installed systems onto similar hardware. Sysprep modifies the local computer Security ID (SID) so that it is unique to each computer.
  • Auditing. When you use Sysprep after auditing the computer (using the -nosidgen command-line option), Sysprep will be ready for the end user to run Windows.
  • Automating Mini-Setup. Sysprep creates a shortened GUI-mode Setup that takes five or six minutes instead of the usual 45 to 60 minutes, and it prompts the end user only for required user-specific information, such as accepting the EULA, entering the Product Key, and entering the user name and company name. To use Sysprep in this mode, preinstall Windows XP on the local computer, and then run Sysprep with the -nosidgen parameter, using the steps below.

For more information, see:

  • Using Sysprep in Factory Mode
  • Sysprep Command-Line Options
  • Sysprep Components

To manually restore the computer to an end-user-ready state with Sysprep

  1. Click Start, click Run, and then type:

    cmd

  2. At the command prompt, change to the root of the system drive (%systemdrive%), and then type:

    md sysprep

  3. From the \Support\Tools\Deploy.cab file of the Windows XP product CD, copy Sysprep.exe and Setupcl.exe to the Sysprep folder you created.
  4. Remove the operating-system CD.
  5. At the command prompt, change to the Sysprep folder, and then type:

    sysprep -nosidgen

    with the parameters you select. See Sysprep Command-Line Options for a list of command-line parameters.

  6. The computer will shut down automatically if it is ACPI-compatible. If it is not ACPI-compatible, a message appears telling you to shut down the computer when the process completes.

To automate the process of restoring the computer to an end-user-ready state

  1. In the \$OEM$\$1 folder of your distribution folders, create a subfolder named \Sysprep.
  2. Add Sysprep.exe and Setupcl.exe to the \$OEM$\$1\Sysprep folder from the \Support\Tools\Deploy.cab file located on the Windows XP product CD. A Sysprep.inf answer file can also be created and placed in this folder, if needed.
  3. In your answer file, add the following line to the bottom of the [GuiRunOnce] section:
    %systemdrive%\sysprep\sysprep.exe -quiet additional parameters as required
    See Sysprep Command-Line Options for a list of command-line parameters.
  4. After Windows Setup completes, the computer automatically shuts down if it is ACPI-compatible. If it is not ACPI-compatible, a message appears telling you to shut down the computer when the process completes.

Notes

In Windows XP:

  • You can run Sysprep from any location, including a floppy disk.
  • Sysprep runs only if the computer is a member of a workgroup, not a domain. If the computer is joined to a domain, Sysprep removes it from the domain.
  • You can run additional programs or commands at the end of Mini-Setup by providing a Cmdlines.txt in your \Sysprep folder.

    For more information on Cmdlines.txt, see Preinstalling Applications Using Legacy Techniques.

  • You cannot run Sysprep on a computer that has been configured as a Cluster Service server, a Certificate Services server, or a domain controller. You can run Sysprep on a standalone server.
  • If you run Sysprep on an NTFS file system partition that contains encrypted files or folders, the data in those folders become completely unreadable and unrecoverable.
  • You can only use this version of Sysprep on Windows XP installations. You cannot use this version of Sysprep on a Windows 2000 installation.


Using Sysprep in Factory Mode

The Factory mode of Sysprep is a method of preconfiguring installation options that can reduce the number of images an OEM needs to maintain.

Use Factory mode to install additional drivers and applications at the stage after the reboot that follows Sysprep. Normally, running Sysprep as the last step in the preinstallation process prepares the computer for delivery. When rebooted, the computer displays Windows Welcome or Mini-Setup. By running Sysprep with the -factory option, the computer reboots in a network-enabled state without starting Windows Welcome or Mini-Setup. In this state, Factory.exe processes its answer file, Winbom.ini, and performs the following actions:

  • Copies drivers from a network source to the computer
  • Starts Plug and Play enumeration
  • Stages, installs, and uninstalls applications on the computer from source files located on either the computer or a network source
  • Adds customer data

In this state, you can audit the computer. When finished, run Sysprep with the -reseal option to prepare the computer for delivery to the customer.

For example, you can create a master installation that contains a minimal set of drivers, run sysprep -factory, create an image of the installation, and copy the image to multiple destination computers. If any destination computers require additional drivers, run sysprep -factory on the destination computer and load those drivers at that time.

Note

  • You can restart the computer after sealing it with Sysprep, without restarting in Windows Welcome, by adding the OEMAuditBoot = 1 entry to the [Options] section in Oobeinfo.ini.

For more information about other Sysprep options, see Sysprep Command-Line Options.

Build-to-Order Modifications to Images

OEMs that use the build-to-order scenario can integrate their sales-order systems by using Factory mode to prepopulate customer information in the answer file Winbom.ini, such as name, time zone, and so on. You can also update other .ini or answer files, such as Sysprep.inf, Oobeinfo.ini, or .isp and .ins files, during Factory mode.

Managing the Appearance of the Sysprep Dialog Box

You can change registry settings to hide the appearance of the Sysprep dialog box. For more information, see Using the Registry to Control Sysprep in Factory Mode.

The Sysprep dialog box is shown below:

Sysprep dialog box

Locating a Winbom.ini File

Sysprep searches the following locations in order for a Winbom.ini file:

  1. The path and file name specified by the registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Factory\Winbom.
  2. The root of all removable media drives that are not CD-ROM drives, such as a floppy disk drive.
  3. The root of all CD-ROM drives.
  4. The location of Factory.exe, usually the %systemdrive%\Sysprep folder.
  5. The root of %systemdrive.

After locating a Winbom.ini file, Sysprep reads the value of the WinbomType entry in the [Factory] section.

If the value of WinbomType is not appropriate in this context, the Winbom.ini file is ignored and Sysprep continues searching for a Winbom.ini file. If the value of WinbomType is appropriate in this context, Sysprep reads the value of the NewWinbom entry in the [Factory] section. If a value is specified for NewWinbom, and a Winbom.ini file is located at that location, Sysprep examines that Winbom.ini file for a NewWinbom entry.

This cycle contines until Sysprep locates a Winbom.ini file of the correct type that does not contain a NewWinbom entry or for a maximum of ten times, whichever occurs first. Sysprep then continues to run in Factory mode, using the settings in the last identified Winbom.ini file.

When you run Sysprep in Factory mode, NewWinbom is only processed once at each boot.


Sysprep Components

The files that make up the Sysprep components are:

  • Sysprep.exe
  • Setupcl.exe
  • Factory.exe
  • Sysprep.inf
  • Winbom.ini

The application files (Sysprep.exe, Setupcl.exe, and Factory.exe) are required files and are dependent on each other.

Sysprep.inf

Sysprep.inf is an optional answer file that you can use to fully or partially automate Mini-Setup, the end-user first-run experience on the Windows 2002 Server family of operating systems. Mini-Setup prompts the user for a few standard pieces of information required to configure the computer, such as time zone and keyboard settings. However, if Sysprep.inf is present and contains values for the required element(s), Mini-Setup uses the information from Sysprep.inf instead of prompting the user.

The syntax of Sysprep.inf is similar to the unattended Setup answer file, Unattend.txt. Sysprep.inf supports a subset of the sections and entries supported by Unattend.txt plus a few Sysprep-specific entries.

Winbom.ini

Winbom.ini specifies a "bill of materials" for the Factory tool to use when updating a master installation. To use the Factory tool, run sysprep -factory.

For more information, see Using Sysprep in Factory Mode and Sysprep Command-Line Options.

Location of the Sysprep Files

The Sysprep files can exist either on a floppy disk or on a hard disk (in the %systemdrive%\Sysprep folder).

When you run Sysprep.exe, Sysprep removes the %systemdrive%\Sysprep folder and its contents after it finishes running. If you want this folder to remain on the hard drive after running Sysprep, in the [Unattended] section of Unattend.txt, set FactoryMode equal to Yes.

To ensure that the options you specify in Sysprep.inf take effect, you must place Sysprep.inf in the same location as Sysprep.exe. The Winbom.ini file can be in an alternate location. For more information, see Winbom.ini.

Note

  • When you do not include the -nosidgen command-line option, Sysprep invokes Setupcl.exe; you cannot use this tool directly. Setupcl.exe must reside in the same folder as Sysprep.exe.

If you edit the security permissions on files or in the registy before running Sysprep, you must ensure that the "System" account has read/write permission in all security contexts. If not, the next time the computer starts, the operating system may fail.


Preparing Images for Disk Duplication

To use Sysprep as part of the disk duplication process, the following requirements must be met:

  • The master installation and the destination computers must have compatible hardware abstraction layers (HALs). For example, HAL APIC and HAL MPs (multiprocessor systems) are compatible, whereas HAL PIC (Programmable Interrupt Controller) is not compatible with either HAL APIC or HAL MPs.
  • The mass-storage controllers (IDE or SCSI) must be identical between the reference and destination computers.
  • Plug and Play devices such as modems, sound cards, network cards, video cards, and so on, do not have to be the same. However, any device drivers not included in Drivers.cab should be included in the master installation before you run Sysprep. Alternatively, make sure the uninstalled drivers are available on the destination computer at first run, so Plug and Play can detect and install the drivers.
  • Third-party software or disk-duplicating hardware devices are required. These products create binary images of a computer’s hard disk, and they either duplicate the image to another hard disk or store the image in a file on a separate disk.
  • The size of the destination computer’s hard disk must be at least the same size as the hard disk of the master installation. If the destination computer has a larger hard disk, the difference is not included in the primary partition. However, you can use the ExtendOemPartition entry in the Sysprep.inf file to extend the primary partition if it was formatted to use the NTFS file system.

    Note

    • If the reference and destination computers have different BIOS versions, you should test the process first to ensure success.

    When using Sysprep for Disk Duplication, Sysprep modifies the local computer Security ID (SID) so that it is unique to each computer.

To prepare a master installation for cloning

  1. Install Windows XP on a master computer. As a best practice, Microsoft recommends that Windows XP be installed from a distribution folder by using an answer file to help ensure consistency in configuring the master installation, so that iterative builds can be created and tested more readily. See Unattend.txt for information about automating Windows Setup using an answer file.
  2. Log on to the computer as an administrator.
  3. (Optional) Install and customize applications, such as Microsoft Office, Internet Explorer favorite items, and so on.
  4. (Optional) Install any device drivers not included in Drivers.cab and not installed by the answer file.
  5. (Optional) Run audit tests.
  6. (Optional) If you want, create a Sysprep.inf file manually or with the aid of Setup Manager. This file is used to further customize each computer for the user and helps to set the amount of information for which the user will be prompted during Mini-Setup.
  7. Run Sysprep.exe. Make sure that both the Sysprep.exe and Setupcl.exe files exist together in the %systemdrive%\Sysprep folder on the local hard disk. When used, the Sysprep.inf also needs to be in the same folder or on a floppy disk that is inserted when the Windows boot menu appears.

    Important

    • If Setupcl.exe is not in the same directory as Sysprep.exe, Sysprep will not work.
  8. If the computer is ACPI-compliant, the computer will shut down by itself. If not, a dialog box appears stating that it is safe to shut down the computer.
  9. Take out the system drive and follow the steps for duplicating the system on other computers. You must have special equipment or software for duplicating hard disks.

After a duplicated hard disk is inserted into a computer, when the user turns the computer on, the following occurs:

  1. Plug and Play detection occurs - this takes approximately three minutes.
  2. Mini-Setup prompts users to:
    • Accept the EULA.
    • Specify their name and organization.
    • Join a domain or a workgroup.
    • Specify regional options information.
    • Specify TAPI information.
    • Specify the networking protocols and services to install.

    Note

    • If a Sysprep.inf file was used when running Sysprep.exe, only the dialog boxes omitted in the .inf file are presented to the user. If display settings are omitted, the default settings are used instead.
  3. The local Sysprep folder containing Sysprep.exe and Sysprep.inf in %systemdrive% is deleted.
  4. The computer restarts and a logon prompt displays.

For more information, see Using Sysprep in Factory Mode.


Using Sysprep for Auditing Installations

Use the auditing process to verify that a computer is functional before it is delivered to the user. During the auditing process you can check that the operating system loads and that applications start properly, run a disk defragmenter program, run Chkdsk to check for corrupted hard disk files, verify that the licensing agreements are not being violated, and verify that all installed devices in Device Manager are properly recognized.

Windows XP deployment is set up so that you can use your own auditing tools to examine each computer that has Windows preinstalled. You can examine the computer as it will exist at the user site and then use the Sysprep tool to return the computer to an end-user-ready state. Then, when the user receives the computer and turns it on for the first time, the computer runs either Windows Welcome or Mini-Setup.

To audit a destination computer that has Windows installed

  1. Install Windows using the steps described in Using Sysprep. When Setup completes and the destination computer restarts, the computer is running a fully installed version of Windows.
  2. Create the \Sysprep folder, and then copy Sysprep.exe and Setupcl.exe to it. See Using Sysprep for more information.

    If you plan to run Sysprep from a floppy disk, you can skip this step.

  3. Audit the system using a third-party auditing tool.

    Important

    • When you are auditing, do not overwrite any system files or otherwise disturb the preconfigured computer, because Sysprep does not detect or restore system files that your auditing tools have changed.
    • You can reboot as many times as necessary while auditing the computer.
  4. When auditing completes, remove any files or folders placed on the hard disk during the auditing process. At the command prompt, change to the directory containing Sysprep.exe, and then type the following command with the command-line options you want:

    sysprep -nosidgen

    followed by any other options you want.

    For more information, see Sysprep Command-Line Options.

  5. When Sysprep finishes, immediately shut down Windows. The computer is now ready to deliver to the end user.


Automating Mini-Setup

You can take either or both of the following steps to automate Mini-Setup.

To automate Mini-Setup

  • Create a Sysprep folder on the %systemdrive% of the master installation,

    –Or–

  • Create the Sysprep.inf file, save the .inf file to a floppy disk, and insert the disk at the beginning of Mini-Setup.

Note

  • The Sysprep folder is deleted after Mini-Setup completes.

You can also automate Mini-Setup by combining the two methods listed above. For example, if you are auditing a computer, run a Sysprep.inf file from a floppy disk with all the necessary responses to speed up the audit. After auditing, set up the original Sysprep.inf to run from the %systemdrive%\Sysprep\ folder, so that the customer can respond to the necessary questions during Mini-Setup.

Note

  • If you use InstallFilesPath or OemPnpDriversPath in your Sysprep.inf file, make sure the paths specified for these entries are consistent for all Sysprep.inf files.

Use the Oobeinfo.ini file to automate Windows Welcome.


Using the Registry to Control Sysprep in Factory Mode

The easiest way to automate Sysprep is to use the Sysprep command line in a script. However, you can also use registry settings to automate Sysprep or to control the visual appearance of Sysprep in Factory mode.

Sysprep is controlled by the HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\OEMReset_Switch registry key. Sysprep is constantly monitoring this registry key. As soon as this registry key is changed, Sysprep processes the new command.

The syntax of this registry key is as follows:

OEMReset_Switch = [{a | p | r | s};[h][;[l]]

where:

Option | Action
a | Reboot into factory mode for auditing. Equivalent to sysprep -audit.
h | Hide the Sysprep dialog box.
l | Log actions to C:\Reset.txt.
p | Audit power down. Equivalent to sysprep -noreboot.
r | Reboot. Equivalent to sysprep -reboot.
s | Shutdown. Equivalent to sysprep -forceshutdown.

This registry key accepts multiple values, separated by a semicolon (;).


Helpful Command-Line Tools

The following tools in Deploy.cab can be run from the command line:

  • Sysprep Command-Line Options
  • Cvtarea Command-Line Options
  • Oformat Command-Line Options

The following tools are contained in the Windows XP operating system and are useful when deploying Windows XP:

  • Convert Command-Line Options
  • Diskpart Commands
  • Diskpart Scripting
  • Winnt32.exe Command-Line Options
  • Winnt.exe Command-Line Options


Sysprep Command-Line Options

The Microsoft Windows System Preparation (Sysprep) tool prepares a PC's hard disk for delivery to the end user.

The syntax of the Sysprep tool is as follows:

sysprep {[-clean] | [-activated] [-audit] [-factory] [-forceshutdown] [-mini] [-noreboot] [-nosidgen] [-pnp] [-quiet] [-reboot] [-reseal]}

where:

Option | Action
-activated Do not reset the grace period for Windows Product Activation. Use this option only if you have activated the Windows installation in the factory.

Important

  • The Product Key you use to activate the Windows installation must match the Product Key located on the COA sticker attached to that particular computer.
-audit Reboots the computer into Factory mode without generating new security IDs (SIDs) or processing any items in the [OEMRunOnce] section of Winbom.ini.

Only use this command-line option if the computer is already in Factory mode.
-clean | Clears the critical devices database used by the [SysprepMassStorage] section in Sysprep.inf.
-factory Restarts in a network-enabled state without displaying Windows Welcome or Mini-Setup. This option is useful for updating drivers, running Plug and Play enumeration, installing applications, testing, configuring the computer with customer data, or making other configuration changes in your factory environment. For companies that use disk imaging (or cloning) software, Factory mode can reduce the number of images required.

When you have finished your desired set of tasks in Factory mode, run Sysprep with the -reseal option to prepare the computer for end-user delivery.
-forceshutdown Shuts down the computer after Sysprep is complete.

Note

  • Use this option with computers with ACPI BIOS that do not shut down properly with Sysprep's default behavior.
-mini | Configures Windows XP Professional to use Mini-Setup rather than Windows Welcome. This option has no effect on Windows XP Home Edition, where the first-run experience is always Windows Welcome.
-noreboot | Modifies registry keys (SID, OemDuplicatorString, and so on) without the system rebooting or preparing for duplication. This option is mainly used for testing, specifically to see if the registry is modified properly. This option is not recommended because making changes to a computer after Sysprep has run may invalidate the preparation done by Sysprep. Do not use this option in a production environment.
-nosidgen | Runs Sysprep without generating new SIDs. You must use this option if you are not duplicating the computer on which you are running Sysprep or if you are preinstalling domain controllers.
-pnp Runs the full Plug and Play device enumeration and installation during Mini-Setup. This command-line option has no effect if the first-run experience is Windows Welcome.

Use -pnp only when you need to detect and install legacy, non-Plug and Play devices. Do not use sysprep -pnp on computer systems that only use Plug and Play devices. Otherwise, you will increase the time required for the first-run experience, without providing any additional benefit to the user.
-quiet | Runs Sysprep without displaying onscreen confirmation messages. This is useful if you are automating Sysprep. For example, if you plan to run Sysprep immediately following unattended Setup, add sysprep -quiet to the [GuiRunOnce] section of the Unattend.txt file.
-reboot | Forces the computer to automatically reboot and then start Windows Welcome Mini-Setup, or Factory mode, as specified. This is useful when you want to audit the system and verify that the first-run experience is operating correctly.
-reseal | Clears the Event Viewer logs and prepares the computer for delivery to the customer. Windows Welcome or Mini-Setup is set to start at the next boot. If you run the command sysprep -factory, you must seal the installation as the last step in your preinstallation process, either by running the command sysprep -reseal or by clicking the Reseal button in the Sysprep dialog box.


Cvtarea Command-Line Options

Cvtarea is a flexible tool for analyzing the placement of FAT files from MS-DOS.

Detecting the Amount of Free Space on a FAT Volume

The syntax of the Cvtarea tool for seeing the clusters of free space on a FAT volume is as follows:

cvtarea drivename /freespace

where:

Option | Action
drivename | The drive letter, followed by a colon. For example, C:
/freespace | Display the available chunks of free space.

Creating a File

The syntax of the Cvtarea tool for creating a file is as follows:

cvtarea filename size [units] [/contig] [/firstcluster cluster [clusterunits] [/strictlocation]]

where:

Option | Action
filename | The name of the file to create. This file must be located in the root directory of the drive that is to be converted.
size | A 32-bit integer specifying the size of the area to create.
units The unit of measure for size; valid options are KB, MB, GB, %disk, and %free.
%disk
Indicates that the file size is a percentage of the total disk size.
%free
Indicates that the file size is a percentage of the current free space on the disk.
/contig | The file must be created contiguously on the disk.
/firstcluster:cluster | The first cluster where the file is to be located.
clusunits
/strictlocation

Displaying the Number of Clusters Used by a File

The syntax of the Cvtarea tool for seeing the clusters used by a file is as follows:

cvtarea filename /info

where:

Option | Action
filename | The name of an existing file.
/info | Display the number of clusters allocated for a given file.


Oformat Command-Line Options

Oformat creates a FAT32 volume with clusters that are aligned in an optimal way for when the volume is later converted to NTFS file system format.

This tool is based on Format.exe from Windows 98 Second Edition. However, Oformat has important modifications specifically designed to meet the needs of computer manufacturers:

  • Oformat does not force you to verify sectors if this is the first time you have formatted the disk. As a result, you can do a Quick Format immediately after creating a new partition, which is significantly faster in the manufacturing environment than using the conventional Format.exe.
  • Oformat does not prompt for confirmation before formatting a disk.
  • With the /a command-line option, Oformat aligns FAT data clusters at a specified sector, which prepares the disk to be efficiently converted to NTFS.

The syntax of the Oformat tool that is relevant to preinstalling Windows is as follows:

oformat driveletter [/a:number] [/autotest|/v:disklabel] [/q]

where:

Option | Action
driveletter | Specifies the drive to be formatted.
/a:number | Aligns system sectors for NTFS-friendly FAT. The value of number can be 2, 4, 8, 16, 32, 64, 128.
/autotest | Runs silently. Do not use with /v.
/q | Performs a Quick Format.
/v:disklabel | Specifies the volume label. Do not use with /autotest.

Important

  • If you do not use the /q option, Oformat takes the same amount of time as Format.exe.
  • The /a:8 command-line option formats the volume so that the FAT data clusters are aligned at 4 KB boundaries. This configuration is recommended because it is the most efficient to convert to NTFS.

Example

The following command line formats the volume on drive E: by overwriting the boot sector, FAT, and root folder with clean structures on a newly partitioned hard disk. In addition, it optimally configures the disk for NTFS conversion.

oformat e: /q /autotest /a:8

For more information, see Convert Command-Line Options.

Additional Oformat Command-line Options

Oformat contains additional command-line options. The complete syntax of the Oformat tool is as follows:

oformat driveletter [/a:number] [/autotest|/v:disklabel] [/b | /s] [/c] [/f:size] [/q] [/t:tracks /n:sectors] [/u] [/1] [/4] [/8]

where:

Option | Action
/b | Allocates space on the formatted disk for system files.
/c | Tests clusters that are currently marked bad clusters;
/f:size | Specifies the size of the floppy disk to format. The value of size can be 160, 180, 320, 360, 720, 1.2, 1.44, 2.88.
/n:sectors | Specifies the number of sectors per track.
/s | Copies system files to the formatted disk.
/t:tracks | Specifies the number of tracks per disk side.
/u | Do not save recovery information that can be used to unformat the disk.
/l | Formats a single side of a floppy disk.
/4 | Formats a 5.25-inch 360 KB floppy disk in a high-density drive.
/8 | Formats eight sectors per track.

How Oformat Differs from Format.exe

Unlike the Format tool, Oformat gives you the option to not verify disk integrity or overwrite existing data in the data area. To preserve the disk geometry the values in the BIOS parameter block (BPB) of the original boot sector are inserted into the new boot sector. For an unformatted partition, Oformat uses the BPB values calculated by the MS-DOS initialization code, rather than the values from the existing boot sector. This modification allows a Quick Format to proceed when the boot sector is not valid, as it is just after the disk is partitioned. Oformat retrieves the parameters for the disk directly from the MS-DOS BIOS, which calculates them from the partition information, so that the boot sector that Oformat eventually places on the disk will be correct. These modifications allow a hard disk of any size to be formatted in about five seconds, whether or not the drive has been previously formatted.

Oformat does not verify the disk, and so it is possible that you may not detect any hard-sector errors that are present on the disk. Evaluate this risk based on the presence of a zero-defect guarantee from the drive manufacturer.


Convert Command-Line Options

Convert is a command-line tool in Windows XP and the Windows 2002 Server family of operating systems. It converts FAT and FAT32 volumes to the NTFS file system. You cannot convert an NTFS volume back to FAT32.

The syntax of the Convert tool is as follows:

convert [volume] /fs:ntfs [/v] [/cvtarea:filename] [/nosecurity] [/x]

where:

Option | Action
volume | Specifies the drive letter (followed by a colon), mount point, or volume name to convert to NTFS.
/fs:ntfs | Required. Converts the volume to NTFS.
/v | Specifies verbose mode, that is, all messages will be displayed during conversion.
/cvtarea:filename For advanced users only. Specifies that the Master File Table (MFT) and other NTFS metadata files are written to an existing, contiguous placeholder file. This file must be in the root directory of the file system to be converted. Using the /CVTAREA parameter can result in a less fragmented file system after conversion. For best results, the size of this file should be 1 KB multiplied by the number of files and directories in the file system; however the convert utility will accept a file of any size.

For more information about using the /cvtarea parameter, see "File Systems" at the Microsoft Windows Resource Kits Web site (http://www.microsoft.com/).

Important

  • You must create the placeholder file using the fsutil file createnew command prior to running convert. Convert does not create this file for you. Convert overwrites this file with NTFS metadata. After conversion, any unused space in this file is freed. For more information about the fsutil file command, see Windows Help.
/nosecurity | Specifies the converted files and directory security settings are accessible by everyone.
/x | Dismounts the volume, if necessary, before it is converted. Any open handles to the volume will no longer be valid.

Notes

  • To recreate the behavior of the Convert command in Windows 2000, use the following command:

    convert /nosecurity

  • To recreate the default behavior in Windows 2000 and automatically starting Chkdsk after converting a system volume, use the following command:

    convert

Remarks

  • You must specify that the drive should be converted when the computer is restarted. Otherwise, you cannot convert the current drive.
  • If convert cannot lock the drive (for example, the system volume or the current drive), it will offer to convert it the next time the computer restarts.
  • The location of the MFT is different on volumes that have been converted from previous version of NTFS, so volume performance might not be as good on volumes converted from Windows NT.
  • Volumes converted from FAT to NTFS lack some performance benefits compared to volumes initially formatted with NTFS. On converted volumes, the MFT might become fragmented. In addition, on converted boot volumes, NTFS permissions are not applied after the volume is converted.

Example

To convert the volume on drive E: to NTFS and display all messages, type:

convert e: /fs:ntfs /v


Diskpart Commands

DiskPart is a text-mode command interpreter contained in the Windows XP and the Windows 2002 Server family of operating systems. This tool enables you to manage objects (disks, partitions, or volumes) by using scripts or direct input from a command prompt. Before you can use DiskPart commands on a disk, partition, or volume, you must first list and then select the object to give it focus. When an object has focus, any DiskPart commands that you type act on that object.

You can list the available objects and determine an object's number or drive letter by using the list disk, list volume, and list partition commands. The list disk and list volume commands display all disks and volumes on the computer. However, the list partition command only displays partitions on the disk that have focus. When you use the list commands, an asterisk (*) appears next to the object with focus. You select an object by its number or drive letter, such as disk 0, partition 1, volume 3, or volume C.

When you select an object, the focus remains on that object until you select a different object. For example, if the focus is set on disk 0, and you select volume 8 on disk 2, the focus shifts from disk 0 to disk 2, volume 8. Some commands automatically change the focus. For example, when you create a new partition, the focus automatically switches to the new partition.

You can only give focus to a partition on the selected disk. When a partition has focus, the related volume (if any) also has focus. When a volume has focus, the related disk and partition also have focus if the volume maps to a single specific partition. If this is not the case, then focus on the disk and partition is lost.

For more information about DiskPart, see Disk Management at the Microsoft Windows Resource Kits Web site.(http://www.microsoft.com/)

DiskPart commands

active

On basic disks, marks the partition with focus as active. This informs the basic input/output system (BIOS) or Extensible Firmware Interface (EFI) that the partition or volume is a valid system partition or system volume.

Only partitions can be marked as active.

Important

  • DiskPart verifies only that the partition is capable of containing an operating system's startup files. DiskPart does not check the contents of the partition. If you mistakenly mark a partition as "active" and it does not contain the operating system's startup files, your computer might not start.

Syntax

active

add disk

Mirrors the simple volume with focus to the specified disk.

Syntax

add disk=n [noerr]

Parameters

n
Specifies the disk to contain the mirror. You can mirror only simple volumes. The specified disk must have unallocated space at least as large as the size of the simple volume you want to mirror.
noerr
For scripting only. When an error is encountered, specifies that DiskPart continues to process commands as if the error did not occur. Without the noerr parameter, an error causes DiskPart to exit with an error code.

assign

Assigns a drive letter or mount point to the volume with focus. If no drive letter or mount point is specified, then the next available drive letter is assigned. If the assigned drive letter or mount point is already in use, an error is generated.

Using the assign command, you can change the drive letter associated with a removable drive.

You cannot assign drive letters to system volumes, boot volumes, or volumes that contain the paging file. In addition, you cannot assign a drive letter to an original equipment manufacturer (OEM) partition or any GPT partition other than a basic MSDATA partition.

Syntax

assign [{letter=d|mount=path}] [noerr]

Parameters

letter=d
The drive letter you want to assign to the volume.
mount=path
The mount point path you want to assign to the volume.
noerr
For scripting only. When an error is encountered, specifies that DiskPart continues to process commands as if the error did not occur. Without the noerr parameter, an error causes DiskPart to exit with an error code.

break disk

Applies to dynamic disks only. Breaks the mirrored volume with focus into two simple volumes. One simple volume retains the drive letter and any mount points of the mirrored volume, while the other simple volume receives the focus so you can assign it a drive letter.

By default, the contents of both halves of the mirror are retained; each half becomes a simple volume. Using the nokeep parameter, only one half of the mirror is retained as a simple volume, while the other half is deleted and converted to free space. Neither volume receives the focus.

Syntax

break disk=n [nokeep] [noerr]

Parameters

n
Specifies the disk that contains the mirrored volume.
nokeep
Specifies that only one of the mirrored volumes is retained; the other simple volume is deleted and converted to free space. Neither volume receives the focus.
noerr
For scripting only. When an error is encountered, specifies that DiskPart continues to process commands as if the error did not occur. Without the noerr parameter, an error causes DiskPart to exit with an error code.

clean

Removes any and all partition or volume formatting from the disk with focus. On master boot record (MBR) disks, only the MBR partitioning information and hidden sector information are overwritten. On GUID Partition Table (GPT) disks, the GPT partitioning information, including the Protective MBR, is overwritten; there is no hidden sector information.

Syntax

clean [all]

Parameter

all
Specifies that each and every sector on the disk is zeroed, which completely deletes all data contained on the disk.

convert basic

Converts an empty dynamic disk into a basic disk.

Syntax

convert basic [noerr]

Parameter

noerr
For scripting only. When an error is encountered, specifies that DiskPart continues to process commands as if the error did not occur. Without the noerr parameter, an error causes DiskPart to exit with an error code.

convert dynamic

Converts a basic disk into a dynamic disk.

Syntax

convert dynamic [noerr]

Parameter

noerr
For scripting only. When an error is encountered, specifies that DiskPart continues to process commands as if the error did not occur. Without the noerr parameter, an error causes DiskPart to exit with an error code.

convert gpt

On Itanium-based computers, converts an empty basic disk with the master boot record (MBR) partition style into a basic disk with the GUID partition table (GPT) partition style.

Important

  • The disk must be empty to convert it to a GPT disk. Back up your data and then delete all partitions or volumes before converting the disk.

Syntax

convert gpt [noerr]

Parameter

noerr
For scripting only. When an error is encountered, specifies that DiskPart continues to process commands as if the error did not occur. Without the noerr parameter, an error causes DiskPart to exit with an error code.

convert mbr

On Itanium-based computers, converts an empty basic disk with the GUID Partition Table (GPT) partition style to a basic disk with the master boot record (MBR) partition style.

Important

  • The disk must be empty to convert it to an MBR disk. Back up your data and then delete all partitions or volumes before converting the disk.

Syntax

convert mbr [noerr]

Parameter

noerr
For scripting only. When an error is encountered, specifies that DiskPart continues to process commands as if the error did not occur. Without the noerr parameter, an error causes DiskPart to exit with an error code.

create partition efi

On Itanium-based computers, creates an Extensible Firmware Interface (EFI) system partition on a GUID Partition Table (GPT) disk. After the partition has been created, the focus is given to the new partition.

Syntax

create partition efi [size=n] [offset=n] [noerr]

Parameters

size=n
The size of the partition in megabytes (MB). If no size is given, then the partition continues until there is no more free space in the current region.
offset=n
The byte offset at which to create the partition. If no offset is given, the partition is placed in the first disk extent that is large enough to hold it.
noerr
For scripting only. When an error is encountered, specifies that DiskPart continues to process commands as if the error did not occur. Without the noerr parameter, an error causes DiskPart to exit with an error code.

create partition extended

Creates an extended partition on the current drive. After the partition has been created, the focus automatically shifts to the new partition. Only one extended partition can be created per disk. This command fails if you attempt to create an extended partition within another extended partition. You must create an extended partition before you can create logical drives.

Syntax

create partition extended [size=n] [offset=n] [noerr]

Parameters

size=n
The size of the extended partition in megabytes (MB). If no size is given, then the partition continues until there is no more free space in the region. The size is cylinder snapped; the size is rounded to the closest cylinder boundary. For example, if you specify a size of 500 MB, the partition would be rounded up to 504 MB.
offset=n
Applies to master boot record (MBR) disks only. The byte offset at which to create the extended partition. If no offset is given, the partition will start at the beginning of the first free space on the disk. The offset is cylinder snapped; the offset is rounded to the closest cylinder boundary. For example, if you specify an offset that is 27 MB and the cylinder size is 8 MB, the offset is rounded to the 24 MB boundary.
noerr
For scripting only. When an error is encountered, specifies that DiskPart continues to process commands as if the error did not occur. Without the noerr parameter, an error causes DiskPart to exit with an error code.

create partition logical

Creates a logical drive in the extended partition. After the partition has been created, the focus automatically shifts to the new logical drive.

Syntax

create partition logical [size=n] [offset=n] [noerr]

Parameters

size=n
The size of the logical drive in megabytes (MB). If no size is given, then the partition continues until there is no more free space in the current region.
offset=n
Applies to master boot record (MBR) disks only. The byte offset at which to create the logical drive. The offset is cylinder snapped; that is, the offset is rounded up to completely fill whatever cylinder size is being used. If no offset is given, then the partition is placed in the first disk extent that is large enough to hold it. The partition is at least as long in bytes as the number specified by size=n. If you specify a size for the logical drive, it must be smaller than the extended partition.
noerr
For scripting only. When an error is encountered, specifies that DiskPart continues to process commands as if the error did not occur. Without the noerr parameter, an error causes DiskPart to exit with an error code.

create partition msr

On Itanium-based computers, creates a Microsoft Reserved (MSR) partition on a GUID Partition Table (GPT) disk.

Caution

  • Be very careful when using the create partition msr command. GPT disks require a specific partition layout, and so creating Microsoft reserved partitions could cause the disk to become unreadable. On GPT disks that are used to start Windows XP 64-Bit Edition, Windows 2002 Advanced Server 64-Bit Edition, or Windows 2002 Datacenter Server 64-Bit Edition, the EFI system partition is the first partition on the disk, followed by the Microsoft Reserved partition. GPT disks used only for data storage do not have an EFI system partition; the Microsoft Reserved partition is the first partition.

    Windows XP and the Windows 2002 Server family do not mount Microsoft Reserved partitions. You cannot store data on them and you cannot delete them.

Syntax

create partition msr [size=n] [offset=n] [noerr]

Parameters

size=n
The size of the partition in megabytes (MB). The partition is at least as long in bytes as the number specified by size=n. If no size is given, the partition continues until there is no more free space in the current region.
offset=n
The byte offset at which to create the partition. The partition starts at the byte offset specified by offset=n. It is sector snapped; that is, the offset is rounded up to completely fill whatever sector size is being used. If no offset is given, then the partition is placed in the first disk extent that is large enough to hold it.
noerr
For scripting only. When an error is encountered, specifies that DiskPart continues to process commands as if the error did not occur. Without the noerr parameter, an error causes DiskPart to exit with an error code.

create partition primary

Creates a primary partition on the current basic disk. After you create the partition, the focus automatically shifts to the new partition. The partition does not receive a drive letter; you must use the assign command to assign a drive letter to the partition.

Syntax

create partition primary [size=n] [offset=n] [ID={byte|GUID}] [noerr]

Parameters

size=n
The size of the partition in megabytes (MB). If no size is given, the partition continues until there is no more unallocated space in the current region. The size is cylinder snapped; the size is rounded to the closest cylinder boundary. For example, if you specify a size of 500 MB, the partition would be rounded up to 504 MB.
offset=n
The byte offset at which to create the partition. If no offset is given, the partition will start at the beginning of the first free space on the disk. For master boot record (MBR) disks, the offset is cylinder snapped; the offset is rounded to the closest cylinder boundary. For example, if you specify an offset that is 27 MB and the cylinder size is 8 MB, the offset is rounded to the 24 MB boundary.
ID={byte|GUID}
Intended for original equipment manufacturer (OEM) use only.

Caution

  • Creating partitions with this parameter might cause your computer to crash or be unable to start up. Unless you are an OEM or an IT professional experienced with GPT disks, do not create partitions on GPT disks using the ID=byte | GUID parameter. Instead, always use the create partition efi command to create EFI System partitions, the create partition msr command to create Microsoft Reserved partitions, and the create partition primary command (without the ID=byte | GUID parameter) to create primary partitions on GPT disks.

For MBR disks, you can specify a partition type byte for the partition. If no partition type byte is specified on an MBR disk, the create partition primary command creates a partition of type 0x6. Any partition type byte can be specified with the ID=byte | GUID parameter. DiskPart does not check the partition type byte for validity, nor does it perform any other checking of the ID parameter.

For GPT disks, you can specify a partition type GUID for the partition you want to create:

  • EFI System partition: c12a7328-f81f-11d2-ba4b-00a0c93ec93b
  • Microsoft reserved partition: e3c9e316-0b5c-4db8-817d-f92df00215ae
  • MSDATA partition: ebd0a0a2-b9e5-4433-87c0-68b6b72699c7
  • LDM Metadata partition on a dynamic disk: 5808c8aa-7e8f-42e0-85d2-e1e90434cfb3
  • LDM Data partition on a dynamic disk: af9b60a0-1431-4f62-bc68-3311714a69ad

If no partition type GUID is specified, the create partition primary command creates an MSDATA partition. Any partition type can be specified with the ID=byte | GUID parameter. DiskPart does not check the partition GUID for validity, nor does it perform any other checking of the ID parameter.

noerr
For scripting only. When an error is encountered, specifies that DiskPart continues to process commands as if the error did not occur. Without the noerr parameter, an error causes DiskPart to exit with an error code.

create volume raid

Creates a RAID-5 volume on the specified dynamic disks. After you create the volume, the focus automatically shifts to the new volume.

Syntax

create volume raid [size=n] [disk=n[,[n,…]] [noerr]

Parameters

size=n
The amount of disk space, in megabytes (MB), that the volume will occupy on each disk. If no size is given, the largest possible RAID-5 volume will be created. The disk with the smallest available contiguous free space determines the size for the RAID-5 volume and the same amount of space is allocated from each disk. The actual amount of usable disk space in the RAID-5 volume is less than the combined amount of disk space because some of the disk space is required for parity.
disk=n
The dynamic disks on which to create the volume. An amount of space equal to size=n is allocated on each disk.
noerr
For scripting only. When an error is encountered, specifies that DiskPart continues to process commands as if the error did not occur. Without the noerr parameter, an error causes DiskPart to exit with an error code.

create volume simple

Creates a simple volume. After you create the volume, the focus automatically shifts to the new volume.

Syntax

create volume simple [size=n] [disk=n] [noerr]

Parameters

size=n
The size of the volume in megabytes (MB). If no size is given, the new volume takes up the remaining free space on the disk.
disk=n
The dynamic disk on which to create the volume. If no disk is given, the current disk is used.
noerr
For scripting only. When an error is encountered, specifies that DiskPart continues to process commands as if the error did not occur. Without the noerr parameter, an error causes DiskPart to exit with an error code.

create volume stripe

Creates a striped volume on the specified disks. After you create the volume, the focus automatically shifts to the new volume.

Syntax

create volume stripe [size=n] [disk=n[,[n,…]] [noerr]

Parameters

size=n
The amount of disk space, in megabytes (MB), that the volume will occupy on each disk. If no size is given, the new volume takes up the remaining free space on the smallest disk and an equal amount of space on each subsequent disk.
disk=n
The dynamic disks on which to create the volume. An amount of space equal to size=n is allocated on each disk.
noerr
For scripting only. When an error is encountered, specifies that DiskPart continues to process commands as if the error did not occur. Without the noerr parameter, an error causes DiskPart to exit with an error code.

delete disk

Deletes a missing dynamic disk from the disk list.

Syntax

delete disk [noerr]

Parameters

noerr
For scripting only. When an error is encountered, specifies that DiskPart continues to process commands as if the error did not occur. Without the noerr parameter, an error causes DiskPart to exit with an error code.

delete partition

On a basic disk, deletes the partition with focus. You cannot delete the system partition, boot partition, or any partition that contains the active paging file or crash dump (memory dump).

Caution

  • Deleting a partition on a dynamic disk can delete all offline dynamic volumes on the disk, thus destroying any data and converting the disk to a basic disk. To delete a dynamic volume, always use the delete volume command instead.

Partitions can be deleted from dynamic disks, but they should not be created. For example, it is possible to delete an unrecognized GUID Partition Table (GPT) partition on a dynamic GPT disk. Deleting such a partition does not cause the resulting free space to become available. This command is particularly intended to allow reclamation of the space on a corrupted offline dynamic disk in an emergency situation where the clean command cannot be used.

Syntax

delete partition [noerr] [override]

Parameters

noerr
For scripting only. When an error is encountered, specifies that DiskPart continues to process commands as if the error did not occur. Without the noerr parameter, an error causes DiskPart to exit with an error code.
override
Enables DiskPart to delete any partition regardless of type. Normally, DiskPart will only allow you to delete known data partitions.

delete volume

Deletes the selected volume. You cannot delete the system volume, boot volume, or any volume that contains the active paging file or crash dump (memory dump).

Syntax

delete volume [noerr]

Parameter

noerr
For scripting only. When an error is encountered, specifies that DiskPart continues to process commands as if the error did not occur. Without the noerr parameter, an error causes DiskPart to exit with an error code.

detail disk

Displays the properties of the selected disk and the volumes on that disk.

Syntax

detail disk

detail volume

Displays the disks on which the current volume resides.

Syntax

detail volume

exit

Exits the DiskPart command interpreter.

Syntax

exit

extend

Extends the volume with focus into the next contiguous unallocated space. For basic volumes, the unallocated space must be on the same disk as, and must follow (be of higher sector offset than), the partition with focus. A dynamic simple or spanned volume can be extended to any empty space on any dynamic disk. Using this command, you can extend an existing volume into newly created space.

If the partition was previously formatted with the NTFS file system, the file system is automatically extended to occupy the larger partition. No data loss occurs. If the partition was previously formatted with any file system format other than NTFS, the command fails with no change to the partition.

You cannot extend the current system or boot partitions.

Syntax

extend [size=n] [disk=n] [noerr]

Parameters

size=n
The amount of space, in megabytes (MB), to add to the current partition. If you do not specify a size, the disk is extended to take up all of the next contiguous unallocated space.
disk=n
The dynamic disk on which to extend the volume. An amount of space equal to size=n is allocated on the disk. If no disk is specified, the volume is extended on the current disk.
noerr
For scripting only. When an error is encountered, specifies that DiskPart continues to process commands as if the error did not occur. Without the noerr parameter, an error causes DiskPart to exit with an error code.

help

Displays a list of the available commands.

Syntax

help

import

Imports a foreign disk group into the local computer's disk group. The import command imports every disk that is in the same group as the disk that has focus.

Syntax

import [noerr]

Parameter

noerr
For scripting only. When an error is encountered, specifies that DiskPart continues to process commands as if the error did not occur. Without the noerr parameter, an error causes DiskPart to exit with an error code.

list disk

Displays a list of disks and information about them, such as their size, amount of available free space, whether the disk is a basic or dynamic disk, and whether the disk uses the master boot record (MBR) or GUID partition table (GPT) partition style. The disk marked with an asterisk (*) has focus.

Syntax

list disk

list partition

Displays the partitions listed in the partition table of the current disk. On dynamic disks, these partitions may not correspond to the dynamic volumes on the disk. This discrepancy occurs because dynamic disks contain entries in the partition table for the system volume or boot volume (if present on the disk) and a partition that occupies the remainder of the disk in order to reserve the space for use by dynamic volumes.

Syntax

list partition

list volume

Displays a list of basic and dynamic volumes on all disks.

Syntax

list volume

online

Brings an offline disk or volume with focus online.

Syntax

online [noerr]

Parameter

noerr
For scripting only. When an error is encountered, specifies that DiskPart continues to process commands as if the error did not occur. Without the noerr parameter, an error causes DiskPart to exit with an error code.

rem

Provides a way to add comments to a script.

Syntax

rem

Example

rem These commands set up 3 drives.

create partition primary size=2048

assign d:

create partition extend

create partition logical size=2048

assign e:

create partition logical

assign f:

remove

Removes a drive letter or mount point from the volume with focus. If the all parameter is used, all current drive letters and mount points are removed. If no drive letter or mount point is specified, then DiskPart removes the first drive letter or mount point it encounters.

The remove command can be used to change the drive letter associated with a removable drive. You cannot remove the drive letters on system, boot, or paging volumes. In addition, you cannot remove the drive letter for an OEM partition, any GPT partition with an unrecognized GUID, or any of the special, non-data, GPT partitions such as the EFI system partition.

Syntax

remove [{letter=d|mount=path [all]}] [noerr]

Parameters

letter=d
The drive letter to be removed.
mount=path
The mount point path to be removed.
all
Removes all current drive letters and mount points.
noerr
For scripting only. When an error is encountered, specifies that DiskPart continues to process commands as if the error did not occur. Without the noerr parameter, an error causes DiskPart to exit with an error code.

rescan

Locates new disks that may have been added to the computer.

Syntax

rescan

retain

Prepares an existing dynamic simple volume to be used as a boot or system volume.

On an x86-based computer, creates a partition entry in the master boot record (MBR) on the dynamic simple volume with focus. To create an MBR partition, the dynamic simple volume must start at a cylinder aligned offset and be an integral number of cylinders in size.

On an Itanium-based computer, creates a partition entry in the GUID partition table (GPT) on the dynamic simple volume with focus.

Note

  • The retain command is intended for use only during Unattended Setup or by Original Equipment Manufacturers (OEMs).

Syntax

retain

select disk

Selects the specified disk and shifts the focus to it.

Syntax

select disk=[n]

Parameters

n
The disk number of the disk to receive focus. If no disk number is specified, the select command lists the disk that currently has the focus. You can view the numbers for all disks on the computer by using the list disk command.

select partition

Selects the specified partition and gives it focus. If no partition is specified, the select command lists the current partition with focus. You can view the numbers of all partitions on the current disk by using the list partition command.

Syntax

select partition=[{n|d}]

Parameters

n
The number of the partition to receive the focus.
d
The drive letter or mount point path of the partition to receive the focus.

select volume

Selects the specified volume and shifts the focus to it. If no volume is specified, the select command lists the current volume with focus. You can specify the volume by number, drive letter, or mount point path. On a basic disk, selecting a volume also gives the corresponding partition focus. You can view the numbers of all volumes on the computer by using the list volume command.

Syntax

select volume=[{n|d}]

Parameters

n
The number of the volume to receive the focus.
d
The drive letter or mount point path of the volume to receive the focus.

For more information, see Diskpart Scripting.


Diskpart Scripting

Using the DiskPart command-line tool, you can create scripts to automate disk-related tasks, such as creating volumes or converting disks to dynamic. Scripting these tasks is useful if you are deploying Windows by using Unattended Setup or Sysprep, which do not support creating volumes other than the boot volume.

For more information about DiskPart scripts, see "Disk Management" in the Microsoft Windows XP Professional Resource Kit.

To start a DiskPart script, at the command prompt, type:

DiskPart /S scriptname.txt

Where scriptname.txt is the name of the text file that contains your script.

To redirect DiskPart's scripting output to a file, type:

DiskPart /S scriptname.txt > logfile.txt

Where logfile.txt is the name of the text file where DiskPart writes its output.

When DiskPart starts, the DiskPart version and computer name are displayed at the command prompt. By default, if DiskPart encounters an error while attempting to perform a scripted task, DiskPart stops processing the script and displays an error code (unless you specified the noerr parameter). However, DiskPart always returns errors when it encounters syntax errors, regardless of whether you used the noerr parameter. The noerr parameter enables you to perform useful tasks such as using a single script to delete all partitions on all disks regardless of the total number of disks.

The following table lists the DiskPart error codes:

Error | Description
0 | No errors occurred. The entire script ran without failure.
1 | A fatal exception occurred. There may be a serious problem.
2 | The parameters specified for a DiskPart command were incorrect.
3 | DiskPart was unable to open the specified script or output file.
4 | One of the services DiskPart uses returned a failure.
5 | A command syntax error occurred. The script failed because an object was improperly selected or was invalid for use with that command.


Winnt32.exe Command-Line Options

From a command prompt, use Winnt32.exe to start Windows Setup from a computer that is running one of the following operating systems:

  • Windows XP
  • Windows 2000
  • Windows NT
  • Windows Millennium Edition
  • Windows 98
  • Windows 95

Note

  • If you run winnt32 on an Itanium-based computer, the command can be run from the Extensible Firmware Interface (EFI) or from Windows XP (not from an earlier operating system). Also, on an Itanium-based computer, /cmdcons and /syspart are not available, and options relating to upgrades are also not available.

The syntax of the Winnt32 command is as follows:

winnt32 [/checkupgradeonly] [/cmd:command_line] [/cmdcons] [/copydir:{i386|ia64}\folder_name] [/copysource:folder_name] [/debug[level]:[filename]] [/dudisable] [/duprepare:pathname] [/dushare:pathname] [/emsport:{com1|com2|usebiossettings|off}] [/emsbaudrate:baudrate] [/m:folder_name] [/makelocalsource] [/noreboot] [/s:sourcepath] [/syspart:drive_letter] [/tempdrive:drive_letter] [/udf:id [,UDB_file]] [/unattend[num]:[answer_file]]

where:

Option | Action
/checkupgradeonly Checks your computer for upgrade compatibility with this version of Windows.

If you use this option with /unattend, no user input is required. Otherwise, the results are displayed on the screen, and you can save them under the file name you specify. The default file name is Upgrade.txt in the systemroot folder.
/cmd:command_line | Instructs Setup to execute a specific command before the final phase of Setup. This would occur after your computer has restarted and after Setup has collected the necessary configuration information, but before Setup is complete.
/cmdcons | Installs the Recovery Console as a startup option on a functioning x86-based computer. The Recovery Console is a command-line interface from which you can perform tasks such as starting and stopping services and accessing the local drive (including drives formatted with NTFS). You can only use the /cmdcons option after normal Setup is finished.
/copydir:{i386|ia64}\folder_name Creates an additional folder within the folder in which the Windows files are installed.

Folder_name refers to a folder that you have created to hold modifications just for your site. For example, for x86-based computers, you could create a folder called Private_drivers within the i386 source folder for your installation, and place driver files in the folder. Then you could type /copydir:i386\Private_drivers to have Setup copy that folder to your newly installed computer, making the new folder location systemroot\Private_drivers. You can use /copydir to create as many additional folders as you want.
/copysource:folder_name Creates a temporary additional folder within the folder in which the Windows files are installed.

Folder_name refers to a folder that you have created to hold modifications just for your site. For example, you could create a folder called Private_drivers within the source folder for your installation, and place driver files in the folder. Then you could type /copysource:Private_drivers to have Setup copy that folder to your newly installed computer and use its files during Setup, making the temporary folder location systemroot\Private_drivers. You can use /copysource to create as many additional folders as you want. Unlike the folders /copydir creates, /copysource folders are deleted after Setup completes.
/debug[level]:[filename] | Creates a debug log at the level specified, for example, /debug4:Debug.log. The default log file is C:\systemroot\Winnt32.log, and the default debug level is 2. The log levels are as follows: 0 represents severe errors, 1 represents errors, 2 represents warnings, 3 represents information, and 4 represents detailed information for debugging. Each level includes the levels below it.
/dudisable | Prevents Dynamic Update from running. Without Dynamic Update, Setup runs only with the original Setup files. This option will disable Dynamic Update even if you set DisableDynamicUpdates equal to No in the [Unattended] section of the Unattend.txt file.
/duprepare:pathname | Carries out preparations on an installation share so that it can be used with Dynamic Update files that you downloaded from the Windows Update Web site. This share can then be used for installing Windows for multiple clients.
/dushare:pathname | Specifies a share on which you previously downloaded Dynamic Update files (updated files for use with Setup) from the Windows Update Web site, and on which you previously ran /duprepare:pathname. When run on a client, specifies that the client installation will make use of the updated files on the share specified in pathname.
/emsport:{com1|com2|usebiossettings|off} Enables or disables Emergency Management Services (EMS) during Setup and after Windows 2002 Server has been installed. With EMS, you can remotely manage a server in emergency situations that would typically require a local keyboard, mouse, and monitor, such as when the network is unavailable or the server is not functioning properly. EMS has specific hardware requirements, and is available only for products in the Windows 2002 Server family of operating systems.

Usebiossettings is the default, and uses the setting specified in the BIOS Serial Port Console Redirection (SPCR) table, or, in Itanium-based systems, through the Extensible Firmware Interface (EFI) console device path. If you specify usebiossettings and there is no SPCR table or appropriate EFI console device path, EMS will not be enabled.

Com1 and com2 are applicable only for x86-based computers (not Itanium-based computers).

If you disable EMS by specifying /emsport:off, you can later enable it by modifying the boot settings. For information about modifying boot settings, see the Windows XP Professional Resource Kit.
/emsbaudrate:baudrate For x86-based computers, specifies the baud rate for EMS. (The option is not applicable for Itanium-based computers.) Must be used with /emsport:com1 or /emsport:com2 (otherwise, /emsbaudrate is ignored).

baudrate can be 9600, 19200, 57600, or 115200. 9600 is the default.
/m:folder_name | Specifies that Setup copies replacement files from an alternate location. Instructs Setup to look in the alternate location first, and if files are present, to use them instead of the files from the default location.
/makelocalsource | Instructs Setup to copy all installation source files to your local hard disk. Use /makelocalsource when installing from a CD to provide installation files when the CD is not available later in the installation.
/noreboot | Instructs Setup to not restart the computer after the file copy phase of Setup is completed so that you can execute another command.
/s:sourcepath Specifies the location of the Windows files. To simultaneously copy files from multiple servers, type the /s:sourcepath option multiple times (up to a maximum of eight). For example:
winnt32 /s:server1 /s:server2

If you type the option multiple times, the first server specified must be available, or Setup fails.
/syspart:drive_letter On an x86-based computer, specifies that you can copy Setup startup files to a hard disk, mark the disk as active, and then install the disk into another computer. When you start that computer, it automatically starts with the next phase of Setup. You must always use the /tempdrive parameter with the /syspart parameter.

You can start Winnt32 with the /syspart option on an x86-based computer running Windows NT 4.0, Windows 2000, or Windows XP. The computer cannot be running Windows 95, Windows 98, or Windows Millennium Edition.
/tempdrive:drive_letter | Directs Setup to place temporary files on the specified partition. For a new installation, Windows is installed on the specified partition. For an upgrade, the /tempdrive option affects the placement of temporary files only; the operating system is upgraded in the partition from which you run winnt32.
/udf:id[,UDB_file] Indicates an identifier (id) that Setup uses to specify how a Uniqueness Database (UDB) file modifies an answer file (see the /unattend entry).

The UDB overrides values in the answer file, and the identifier determines which values in the UDB file are used. For example, /udf:RAS_user,Our_company.udb overrides settings specified for the RAS_user identifier in the Our_company.udb file. If no UDB_file is specified, Setup prompts the user to insert a disk that contains the $Unique$.udb file.

If you boot from the product CD and run an unattended Setup, you cannot use the /udf command-line option for Winnt32.exe.
/unattend | Upgrades your previous version of Windows 98, Windows Millennium Edition, Windows NT 4.0, or Windows 2000 in unattended Setup mode. Setup downloads the Dynamic Update files from Windows Update and includes these files in the installation. All user settings are taken from the previous installation, so no user intervention is required during Setup.
/unattend[num]:[answer_file] Performs a fresh installation of Windows in unattended Setup mode. Setup downloads the Dynamic Update files from the Windows Update Web site and includes these files in the installation. The specified answer_file provides Setup with your custom specifications.
num
The number of seconds between the time that Setup finishes copying the files and the time Setup restarts. You can use num on any computer running Windows 98, Windows Millennium Edition, Windows NT, Windows 2000, or Windows XP.
answer_file
The name of the answer file. For more information about answer files, see the Microsoft Windows XP Deployment Guide.

Using the /unattend command-line option to automate Setup affirms that you have read and accepted the End-User License Agreement (EULA) for Windows. Before using this command-line option to install Windows on behalf of an organization other than your own, you must confirm that the end user (whether an individual, or a single entity) has received, read, and accepted the terms of the Microsoft End-User License Agreement for Windows. OEMs may not specify this key on machines being sold to end users.

For more information about Winnt32.exe, see Using Winnt32.exe to Run Setup.


Winnt.exe Command-Line Options

From a command prompt, use Winnt.exe to start Windows Setup from a computer that is running one of the following operating systems:

  • MS-DOS
  • Windows 3.1
  • Windows for Workgroups

The syntax of the Winnt command is as follows:

winnt [/s:[sourcepath]] [/t:[tempdrive]] [/u:[answer_file]] [/udf:id [,UDB_file]] [/r:folder] [/rx:folder] [/e:command] [/a]

where:

Option | Action
/s:sourcepath | Specifies the source location of the Windows files. The location must be a full path of the form x:\[path] or \\server\share[\path]. The default is the current folder.
/t:tempdrive | Directs Setup to place temporary files on the specified drive and to install Windows on that drive. If you do not specify a location, Setup attempts to locate a drive for you.
/u:answer_file | Performs unattended Setup using an answer file. The answer file provides answers to some or all of the prompts the end user normally responds to during Setup. If you use /u, you must also use /s.
/udf:id [,UDB_file] | Indicates an identifier (id) that Setup uses to specify how a Uniqueness Database (UDB) file modifies an answer file (see /u). The UDB overrides values in the answer file, and the identifier determines which values in the UDB file are used. If no UDB_file is specified, Setup prompts the user to insert a disk that contains the $Unique$.udb file. For example, /udf:RAS_user, Our_company.udb overrides settings specified for the identifier RAS_user in the Our_company.udb file.
/r:folder | Specifies an optional folder to be installed. The folder remains after Setup finishes.
/rx:folder | Specifies an optional folder to be copied. The folder is deleted after Setup finishes.
/e:command | Specifies a command to be run after GUI-mode Setup.
/a | Enables accessibility options.

For more information about Winnt.exe, see Using Winnt.exe to Run Setup and Converting Short File Names to Long File Names.


Glossary

Symbols A B C D E F G H I J K L M N O P Q R S T U V W X YZ

Symbols

$$Rename.txt

A file that lists all files contained in a particular folder that need to be renamed from an 8.3 format name to a long file name during Setup. All file names must be in 8.3 format if you run Setup using Winnt.exe, or if you are copying a set of files from one computer to another using MS-DOS.

%windir%

The default directory where Windows is installed, most commonly C:\winnt.

.adm

The file name extension for Administrative Templates files.

.cab file

Cabinet file. A single cabinet file that stores multiple compressed files. These files are commonly used in software installation and to reduce the file size and the associated download time for Web content.

.dll file

See definition for: dynamic-link library (DLL)

.inf file

Information file. A file created for a particular adapter that provides the operating system with information required to set up a device, such as a list of valid logical configurations for the device, the names of driver files associated with the device, and so on. An .inf file is provided typically on a disk by the device manufacturer or may be included in the operating system.

.ini file

Initialization file. Commonly used under Windows 3.x and earlier, .ini files have been used by both the operating system and individual applications to store persistent settings related to an application, driver, or piece of hardware. In Windows 32-bit operating systems, .ini files are supported for backward compatibility, but the registry is the preferred location for storing such settings.

.ins file

Internet settings file. A file that provides Windows Update Setup with Internet settings that configure the browser and associated components. You can create multiple versions of your browser package by changing the .ins file used by each package. Use the Profile Manager to create, save, and load .ins files.

100baseT

The Ethernet standard for local area networks using twisted-pair cable carrying data at 100 megabits per second (Mbps).

8.3

The standard format for file names in MS-DOS and Windows 3.x. A file name with eight or fewer characters, followed by a period (dot), followed by a three-character file extension.

A

account manager

A Microsoft employee who is the primary contact for the business relationship between the OEM and Microsoft.

ACPI

See definition for: Advanced Configuration and Power Interface (ACPI)

activation

See definition for: Windows Product Activation (WPA)

Active Directory

The directory service that stores information about objects on a network and makes this information available to users and network administrators. Active Directory gives network users access to permitted resources anywhere on the network using a single logon process. It provides network administrators with an intuitive, hierarchical view of the network and a single point of administration for all network objects.

See also: service

Active Directory Users and Computers

An administrative tool designed to perform day-to-day Active Directory administration tasks. These tasks include creating, deleting, modifying, moving, and setting permissions on objects stored in the directory. These objects include organizational units, users, contacts, groups, computers, printers, and shared file objects.

See also: permission; Active Directory; object

active partition

A partition from which an x86-based computer starts up. The active partition must be a primary partition on a basic disk. If you use Windows exclusively, the active partition can be the same as the system volume.

See also: basic disk; primary partition; system partition; x86

active volume

The volume from which the computer starts up. The active volume must be a simple volume on a dynamic disk. You cannot mark an existing dynamic volume as the active volume, but you can upgrade a basic disk containing the active partition to a dynamic disk. Once the disk is upgraded to dynamic, the partition becomes a simple volume that is active.

See also: active partition; basic disk; dynamic disk; dynamic volume; simple volume

adapter

See definition for: device

add-on devices

Devices that are traditionally added to the base PC system to increase functionality, such as audio, networking, graphics, or SCSI controller. Add-on devices fall into two categories: devices built onto the system board, and devices on expansion cards, added to the system through a system board connector, such as PCI.

administrator

For Windows XP Professional, a person responsible for setting up and managing domain controllers or local computers and their user and group accounts, assigning passwords and permissions, and helping users with networking problems. Administrators are members of the Administrators group and have full control over the domain or computer.

For Windows XP Home Edition, a person who can make system-wide changes to the computer, install software, and who has access to all files on the computer. A person with a computer administrator account has full access to other user accounts on the computer.

Advanced Configuration and Power Interface (ACPI)

An open industry specification that defines power management on a wide range of mobile, desktop, and server computers and peripherals. ACPI is the foundation for the OnNow industry initiative that allows system manufacturers to deliver computers that will start at the touch of a keyboard. ACPI design is essential to take full advantage of power management and Plug and Play.

See also: Plug and Play

agent character

An interactive animated character who guides users through Windows Welcome. The character interacts with the user in ways similar to the natural aspects of human social communication. Characters can respond using synthesized speech, recorded audio, or text in a cartoon word balloon.

See also: Windows Welcome

allocation unit

The smallest amount of disk space that can be allocated to hold a file. All file systems used by Windows organize hard disks based on allocation units. The smaller the allocation unit size, the more efficiently a disk stores information. If you do not specify an allocation unit size when formatting the disk, Windows picks default sizes based on the size of the volume. These default sizes are selected to reduce the amount of space that is lost and the amount of fragmentation on the volume. An allocation unit is also called a cluster.

See also: file system

American Standard Code for Information Interchange (ASCII)

A standard single-byte character encoding scheme used for text-based data. ASCII uses designated 7-bit or 8-bit number combinations to represent either 128 or 256 possible characters. Standard ASCII uses 7 bits to represent all uppercase and lowercase letters, the numbers 0 through 9, punctuation marks, and special control characters used in U.S. English. Most current x86-based systems support the use of extended (or "high") ASCII. Extended ASCII allows the eighth bit of each character to identify an additional 128 special symbol characters, foreign-language letters, and graphic symbols.

See also: Unicode

answer file

A text file that scripts the answers for a series of graphical user interface (GUI) dialog boxes. The answer file for Setup is commonly called Unattend.txt, but for a network preinstallation, you can name the file anything you like. For a CD-based Setup, the answer file must be named Winnt.sif. The answer files for Sysprep are Sysprep.inf and Winbom.ini. You can create or modify these answer files in a text editor or through Setup Manager.

See also: Unattend.txt

anti-aliasing

A software technique for smoothing the jagged appearance of curved or diagonal lines caused by poor resolution on a display screen. Methods of anti-aliasing include surrounding pixels with intermediate shades and manipulating the size and horizontal alignment of the pixels.

API

See definition for: application programming interface (API)

APIC

Advanced Programmable Interrupt Controller. A distributed set of devices that form an interrupt controller.

AppleTalk

The Apple Computer network architecture and network protocols. A network that has Macintosh clients and a computer running Windows 2000 Server or Windows NT Server with services for Macintosh functions as an AppleTalk network.

application programming interface (API)

A set of routines that an application uses to request and carry out lower-level services performed by a computer's operating system. These routines usually carry out maintenance tasks such as managing files and displaying information.

aspect ratio

The relationship of width and height for an image. When an image is displayed on different screens, the aspect ratio must be kept the same to avoid either vertical or horizontal distortion.

assigned configuration

The resources contained in the device node that are allocated for the device. For Plug and Play cards, the assigned resources for a device can change dynamically or from one system start-up to the next.

asynchronous

Not dependent on timing. Each application or command runs in the specified order, but the specified item does not wait for any previously started processes to finish before application or command runs.

ATM adaptation layer (AAL)

The layer of the ATM protocol stack that parses data into the payload portion of the ATM cell for transport across an ATM network.

attach

Run the Setup program for an application that is already staged on the destination computer.

See also: stage; destination computer; detach

attribute

For files, information that indicates whether a file is read-only, hidden, ready for archiving (backing up), compressed, or encrypted, and whether the file contents should be indexed for fast file searching.

In Active Directory, characteristics of an object and the type of information an object can hold. For each object class, the schema defines what attributes an instance of the class must have and what additional attributes it might have.

audit mode

Verifying, before it is delivered to the end user, that the fully-manufactured computer functions as expected. After auditing, always reseal the operating system to reset the first-run experience for the user.

authentication

The process for verifying that an entity or object is who or what it claims to be. Examples include confirming the source and integrity of information, such as verifying a digital signature or verifying the identity of a user or computer.

See also: smart card

authorized distributor

An independent company licensed by Microsoft Licensing, Inc. to manage the production and distribution of multipacks of Windows XP OEM products to system builders. If you purchase Microsoft software from someone other than a Microsoft authorized distributor, you run the risk of purchasing counterfeit software, which usually has many of the following problems: missing drivers, missing documentation, viruses, bugs, and other defects. Installing legitimate Microsoft products prevents customer problems and reduces requests for customer support.

authorized replicator

An independent company licensed by Microsoft Licensing, Inc. to manage the production and distribution of Microsoft OEM products for royalty OEMs. Microsoft Licensing, Inc. supplies the authorized replicator with the master components, manufacturing and assembly specifications, and other pertinent instructions. The authorized replicator manufactures and assembles genuine Microsoft products to exact specifications. The benefits of using an authorized replicator include protection against piracy, consistent high-quality software, and competitive prices.

autologon

Automatically logging on to the computer using the Administrator account when the computer restarts.

Automatic Private IP Addressing (APIPA)

A feature of Windows XP TCP/IP that automatically configures a unique IP address from the range 169.254.0.1 through 169.254.255.254 and a subnet mask of 255.255.0.0 when the TCP/IP protocol is configured for dynamic addressing and a Dynamic Host Configuration Protocol (DHCP) is not available.

See also: IP address; DHCP server; Transmission Control Protocol/Internet Protocol (TCP/IP)

B

bandwidth

In analog communications, the difference between the highest and lowest frequencies in a given range. For example, an analog telephone line accommodates a bandwidth of 3,000 hertz (Hz), the difference between the lowest (300 Hz) and highest (3,300 Hz) frequencies it can carry. In digital communications, bandwidth is expressed in bits per second (bps).

See also: bits per second (bps)

base character

A character that has meaning independent of other characters, or any graphical character that is not a diacritical mark.

basic disk

A physical disk that can be accessed by MS-DOS and all Windows-based operating systems. Basic disks can contain up to four primary partitions, or three primary partitions and an extended partition with multiple logical drives. If you want to create partitions that span multiple disks, you must first convert the basic disk to a dynamic disk using Disk Management or the Diskpart.exe command-line utility.

See also: dynamic disk; extended partition; logical drive; primary partition

basic input/output system (BIOS)

On x86-based computers, the set of essential software routines that test hardware at startup, start the operating system, and support the transfer of data among hardware devices. The BIOS is stored in read-only memory (ROM) so that it can be executed when you turn on the computer. Although critical to performance, the BIOS is usually invisible to computer users.

See also: Extensible Firmware Interface (EFI); read-only memory (ROM); x86

basic volume

A primary partition or logical drive that resides on a basic disk.

See also: primary partition; basic disk; logical drive

bidi

Bi-Directional text. A mixture of characters that are read from left to right and characters that are read from right to left. For example, most Arabic, Hebrew, Farsi, and Urdu characters are read from right to left, but numbers and quoted Western terms within these languages' text are read from left to right.

BIOS

See definition for: basic input/output system (BIOS)

BIOS enumerator

Responsible in a non-ACPI Plug and Play system for identifying all hardware devices on the motherboard of the computer. The BIOS supports an API that allows all Plug and Play computers to be queried in a common manner.

bit (binary digit)

The smallest unit of information handled by a computer. One bit expresses a 1 or a 0 in a binary numeral, or a true or false logical condition. A group of 8 bits makes up a byte, which can represent many types of information, such as a letter of the alphabet, a decimal digit, or other character. Bit is also called binary digit.

bit specifications

Numbers of colors or levels of gray that can be displayed at one time. Controlled by the amount of memory in the computer's graphics controller card. An 8-bit controller can display 256 colors or levels of gray; a 16-bit controller, 64,000 colors; and a 24-bit controller, 16.8 million colors.

bits per second (bps)

The number of bits transmitted every second, used as a measure of the speed at which a device, such as a modem, can transfer data.

See also: modem (modulator/demodulator)

boot partition

The partition that contains the Windows operating system and its support files. The boot partition can be, but does not have to be, the same as the system partition.

See also: partition; Primary disk; system partition

bootstrap loader

A program that is run automatically when a computer is turned on, or booted. After first performing a few basic hardware tests, the bootstrap loader loads and passes control to a larger loader program, which typically then loads the operating system. The bootstrap loader typically resides in the computer's read-only memory (ROM).

See also: read-only memory (ROM)

branding

To incorporate a company name, logo, support information, and Help files into the Microsoft Windows installation.

Break-the-Seal Microsoft Distribution and Preinstallation Agreement (BTS)

The license agreement between a system builder and Microsoft Licensing Inc. affixed to the side of every OEM Distribution Pack. By opening the package, you agree to all the terms of the Break-The-Seal agreement. If you do not agree to all the terms of the agreement, contact the Microsoft OEM authorized distributor it was purchased from and make arrangements to return the software.

broadband

Of or relating to communications systems in which the medium of transmission (such as a wire or fiber-optic cable) carries multiple messages at a time, each message modulated on its own carrier frequency by a modem.

browser

Software that interprets the markup of files in HTML, formats them into Web pages, and displays them to the end user. Some browsers also permit end users to send and receive e-mail, read newsgroups, and play sound or video files embedded in Web documents.

See also: World Wide Web

build-to-order

Manufacturing and customizing a computer according to customer specifications after receiving the order from the customer.

build-to-plan

Manufacturing a specified number of computers according to a given specification, and then selling the manufactured computers to customers.

built-in groups

The default security groups installed with the operating system. Built-in groups have been granted useful collections of rights and built-in abilities.

In most cases, built-in groups provide all the capabilities needed by a particular user. For example, if a domain user account belongs to the built-in Administrators group, logging on with that account gives a user administrative capabilities over the domain and the domain servers. To provide a needed set of capabilities to a user account, assign it to the appropriate built-in group.

bus

A communication line used for data transfer among the components of a computer system. A bus essentially allows different parts of the system to share data. For example, a bus connects the disk-drive controller, memory, and input/output ports to the microprocessor.

See also: expansion slot; universal serial bus (USB)

C

cache

For DNS and WINS, a local information store of resource records for recently resolved names of remote hosts. Typically, the cache is built dynamically as the computer queries and resolves names. It also helps optimize the time required to resolve queried names.

See also: cache file

cache file

A file used by the Domain Name System (DNS) server to preload its names cache when service is started. Also known as the root hints file because DNS uses resource records stored in this file to help locate root servers that provide referral to authoritative servers for remote names. For Windows DNS servers, the cache file is named Cache.dns and is located in the %SystemRoot%\System32\Dns folder.

See also: cache; systemroot

caching

The process of temporarily storing recently used data values in a special pool in memory for quicker subsequent access. For DNS, typically the ability of the DNS server to store information learned about the DNS namespace during the resolution of DNS queries. (For example, the DNS server can cache DNS records received from other DNS servers.) Caching is also available through the DNS Client service as a way for DNS clients to keep a cache of information learned during recent queries.

CAL

See definition for: client access license (CAL)

CD boot

Starting a computer from the retail product CD-ROM and then installing Windows on the hard disk using the Setup program on the CD. This method is much slower than installing Windows from a network and is not recommended. For an unattended Setup using the CD boot method, the Unattend.txt file must be named Winnt.sif. The user can select in the winnt.sif if they want to manually select the partition or have it automatically selected.

CD-ROM

Compact disc read-only memory. A form of storage characterized by high capacity (roughly 650 MB) and the use of laser optics rather than magnetic means for reading data.

certificate

A digital document that is commonly used for authentication and secure exchange of information on open networks, such as the Internet, extranets, and intranets. A certificate securely binds a public key to the entity that holds the corresponding private key. Certificates are digitally signed by the issuing certification authority and can be issued for a user, a computer, or a service. The most widely accepted format for certificates is defined by the ITU-T X.509 version 3 international standard.

See also: certification authority (CA); private key; public key; service

certificate of authenticity (COA)

A label with sophisticated anti-counterfeiting features that helps the end user identify that the computer is using a validly licensed copy of Microsoft Windows. The product name and a unique product key appear in the center of the label. The OEM must physically attach the COA label to the computer chassis, and it should never be removed from the computer.

certificate revocation list (CRL)

A document maintained and published by a certification authority that lists certificates that have been revoked.

See also: certificate; certification authority (CA)

certificate template

A Windows construct that profiles certificates (that is, it prespecifies the format and content) based on their intended usage. When requesting a certificate from a Windows enterprise certification authority (CA), certificate requestors are, depending on their access rights, able to select from a variety of certificate types that are based on certificate templates, such as User and Code Signing.

See also: certificate; certification authority (CA)

certificate trust list (CTL)

A signed list of root certification authority certificates that an administrator considers reputable for designated purposes, such as client authentication or secure e-mail.

See also: certificate; certification authority (CA); root certificate

certification authority (CA)

An entity responsible for establishing and vouching for the authenticity of public keys belonging to users (end entities) or other certification authorities. Activities of a certification authority can include binding public keys to distinguished names through signed certificates, managing certificate serial numbers, and certificate revocation.

See also: public key; root authority; certificate

character

The simplest element used to represent written languages. The appearance of a character is not constant; a character's appearance depends on the font used, as well as the context of surrounding text.

checkpoint

An identifier for a specific page or a conceptually related set of pages that tracks the user's navigation through Windows Welcome.

child object

An object that resides in another object. A child object implies relation. For example, a file is a child object that resides in a folder, which is the parent object.

See also: object; parent object

clean system

An installation of Windows that has not been modified and has not had any additional software installed on it.

ClearType

A font display technology that dramatically improves font display resolution so that letters on the computer screen appear smooth, not jagged. ClearType dramatically improves the readability of text on color LCD monitors with a digital interface, such as those found in laptops and high-quality flat-panel desktop displays.

client

Any computer or program connecting to, or requesting the services of, another computer or program. Client can also refer to the software that enables the computer or program to establish the connection.

For a local area network (LAN) or the Internet, a computer that uses shared network resources provided by another computer (called a server).

See also: server

client access license (CAL)

A license that specifies the number of client computers that can connect to and use software located on a server.

cluster

In data storage, the smallest amount of disk space that can be allocated to hold a file. All file systems used by Windows organize hard disks based on clusters, which consist of one or more contiguous sectors. The smaller the cluster size, the more efficiently a disk stores information. If no cluster size is specified during formatting, Windows picks defaults based on the size of the volume. These defaults are selected to reduce the amount of space that is lost and the amount of fragmentation on the volume. A cluster is also called an allocation unit.

In computer networking, a group of independent computers that work together to provide a common set of services and present a single-system image to clients. The use of a cluster enhances the availability of the services and the scalability and manageability of the operating system that provides the services.

See also: client; file system

Cmdlines.txt

A text file that GUI-mode Setup executes when installing optional components, such as applications.

COA

See definition for: certificate of authenticity (COA)

code page

A means of providing support for character sets and keyboard layouts for different countries or regions. A code page is a table that relates the binary character codes used by a program to keys on the keyboard or to characters on the display.

collateral

The end-user manual and any other items the OEM packages with a new computer.

compatible ID

An ID used by the Plug and Play Manager. If Plug and Play does not locate a match for the device hardware ID, Plug and Play installs the driver .inf file associated with the compatible ID.

composite character

A text element consisting of a base character and a diacritic or accent mark. Although most common in the Latin script, other scripts (including Greek, Devanagari, and Tamil) also have composite characters.

Configuration Manager

The Windows Plug and Play system component that drives the process of locating devices, setting up their nodes in the hardware tree, and running the resources allocation process. Each of the three phases of configuration management--boot time, real mode, and protected mode--have their own configuration managers.

configuration set

A file and folder structure that contain the necessary configuration settings that control the preinstallation process and define the manufacturers' custom information.

configure-to-order

See definition for: build-to-order

Connection Manager

A client dialer used to obtain Internet access.

console tree

The left pane in a Microsoft Management Console (MMC) that displays the items contained in the console. By default it is the left pane of a console window, but it can be hidden. The items in the console tree and their hierarchical organization determine the capabilities of a console.

See also: Microsoft Management Console (MMC)

counterfeit software

Software that a system builder does not obtain from an authorized distributor, or that a royalty OEM does not obtain from an authorized replicator. Counterfeit software usually has many of the following problems: missing drivers, missing documentation, viruses, bugs, and other defects. Installing legitimate Microsoft products helps ensure the quality of your products, prevents customer problems, and reduces requests for customer support.

customer

The purchaser of a new computer.

D

desktop

The on-screen work area on which windows, icons, menus, and dialog boxes appear.

desktop ISP sign-up offer

A set of HTML pages that offer the end user the opportunity to sign up for Internet access. To view the offer, the end user clicks a link from the OEM link on the Start menu.

desktop registration

The opportunity given to the end user to register with Microsoft and the OEM, if the user failed to register during Windows Welcome.

destination computer

The computers on which you preinstall Windows that will be distributed to customers. You can either run Setup on the destination computer or copy a master installation onto a destination computer.

detach

Remove uninstalled application files from a destination computer.

See also: attach; destination computer; stage

device

Any piece of equipment that can be attached to a network or computer; for example, a computer, printer, joystick, adapter, or modem card, or any other peripheral equipment. Devices normally require a device driver to function with Windows.

See also: device driver

device driver

A program that allows a specific device, such as a modem, network adapter, or printer, to communicate with the operating system. Although a device might be installed on your system, Windows cannot use the device until you have installed and configured the appropriate driver.

If a device is listed in the Hardware Compatibility List (HCL), a driver is usually included with Windows. Device drivers load automatically (for all enabled devices) when a computer is started, and thereafter run invisibly.

See also: Hardware Compatibility List (HCL)

device ID

A unique ASCII string for the device created by enumerators to identify a hardware device and used to cross-reference data about the device stored in the registry. Distinguishes each logical device and bus from all others on the system.

Device Manager

An administrative tool that you can use to manage the devices on your computer. Using Device Manager, you can view and change device properties, update device drivers, configure device settings, and uninstall devices.

See also: device

DHCP server

A computer running the Microsoft DHCP service that offers dynamic configuration of IP addresses and related information to DHCP-enabled clients.

See also: Dynamic Host Configuration Protocol (DHCP); service; IP address

diacritic

Any mark placed over, under, or through a character, usually to indicate a change in phonetic value from the unmarked state. A character that is attached to it is a base character. Most diacritics are non-spacing characters that do not increase the width of the base character.

dial-up connection

The connection to your network if you are using a device that uses the telephone network. This includes modems with a standard phone line, ISDN cards with high-speed ISDN lines, or X.25 networks.

If you are a typical user, you may have one or two dial-up connections, for example, to the Internet and to your corporate network. In a more complex server situation, multiple network modem connections might be used to implement advanced routing.

See also: modem (modulator/demodulator)

Dial-Up Networking (DUN)

A connection to a data communications network using a public-switch telecommunications network rather than a dedicated circuit or other private network.

digital signature

A means for originators of a message, file, or other digitally encoded information to bind their identity to the information. The process of digitally signing information entails transforming the information, as well as some secret information held by the sender, into a tag called a signature. Digital signatures are used in public key environments, and they provide nonrepudiation and integrity services.

See also: service; time stamp

direct OEM

See definition for: royalty OEM

disk

A storage device that is attached to a computer.

See also: basic disk; dynamic disk

disk duplication

Using third-party hardware or software to copy a full master Windows XP installation onto the hard disks of multiple destination computers. The master computer and destination computers must have compatible hardware abstraction layers (HALs). The destination computer can be delivered directly to customers, or it might require additional processing on the factory production line.

See also: hardware abstraction layer (HAL)

diskpart.exe

A command line utility for formatting and managing disk partitions and volumes.

distribution share

The location on your network that contains the OPK tools, the source files for the Windows products you are preinstalling, and your configuration sets.

dock

To connect a laptop or notebook computer to a docking station.

See also: docking station

docking station

A unit for housing a portable computer that contains a power connection, expansion slots, and connections to peripherals, such as a monitor, printer, full-sized keyboard, and mouse. The docking station turns the portable computer into a desktop computer.

See also: dock

domain

A group of computers that are part of a network and share a common directory database. A domain is administered as a unit with common rules and procedures. Each domain has a unique name.

An Active Directory domain is a collection of computers defined by the administrator of a Windows network. These computers share a common directory database, security policies, and security relationships with other domains. An Active Directory domain provides access to the centralized user accounts and group accounts maintained by the domain administrator. An Active Directory forest is made up of one or more domains, each of which can span more than one physical location.

A DNS domain is any tree or subtree within the DNS namespace. Although the names for DNS domains often correspond to Active Directory domains, DNS domains should not be confused with Active Directory domains.

See also: Active Directory

domain controller

In a Windows domain environment, a computer running Active Directory that manages user access to a network, which includes logging on, authentication, and access to the directory and shared resources.

See also: Active Directory; authentication

domain name

The name given by an administrator to a collection of networked computers that share a common directory. Part of the Domain Name System (DNS) naming structure, domain names consist of a sequence of name labels separated by periods.

See also: domain; label; namespace

domain naming master

The domain controller assigned to control the addition or removal of domains in the forest. At any time, there can be only one domain naming master in the forest.

See also: domain controller; forest

domain tree

In DNS, the inverted hierarchical tree structure that is used to index domain names. Domain trees are similar in purpose and concept to the directory trees used by computer filing systems for disk storage.

For example, when numerous files are stored on disk, directories can be used to organize the files into logical collections. When a domain tree has one or more branches, each branch can organize domain names used in the namespace into logical collections.

In Active Directory, a hierarchical structure of one or more domains, connected by transitive, bidirectional trusts, that forms a contiguous namespace. Multiple domain trees may belong to the same forest.

See also: Active Directory; domain; domain name; forest; namespace

double-byte characters

A set of characters in which each character is represented by two bytes. Some languages, such as Japanese, Chinese, and Korean, require double-byte character sets.

driver

Kernel-mode code used either to control or emulate a hardware device.

Driver.cab

A file containing all of the device drivers that ship with Windows XP.

DUN

See definition for: Dial-Up Networking (DUN)

DVD

Digital video disk. A form of storage characterized by high capacity (roughly 650 MB) and the use of laser optics rather than magnetic means for reading data. Optical disk storage commonly used for audio, video, and computer data. DVDs range in capacity from 4.7 GB to 17 GB, and can store significantly more than a CD-ROM.

DWORD

A data type composed of hexadecimal data with a maximum allotted space of 4 bytes.

dynamic disk

A physical disk that can be accessed only by Windows 2000 and Windows XP. Dynamic disks provide features that basic disks do not, such as support for volumes that span multiple disks. Dynamic disks use a hidden database to track information about dynamic volumes on the disk and other dynamic disks in the computer. You convert basic disks to dynamic by using the Disk Management snap-in or the DiskPart command line utility. When you convert a basic disk to dynamic, all existing basic volumes become dynamic volumes.

See also: basic disk; basic volume; dynamic volume; active volume

Dynamic Host Configuration Protocol (DHCP)

A TCP/IP service protocol that offers dynamic leased configuration of host IP addresses and distributes other configuration parameters to eligible network clients. DHCP provides safe, reliable, and simple TCP/IP network configuration, prevents address conflicts, and helps conserve the use of client IP addresses on the network.

DHCP uses a client/server model where the DHCP server maintains centralized management of IP addresses that are used on the network. DHCP-supporting clients can then request and obtain lease of an IP address from a DHCP server as part of their network boot process.

See also: lease; service; Transmission Control Protocol/Internet Protocol (TCP/IP); IP address

dynamic volume

A volume that resides on a dynamic disk. Windows supports five types of dynamic volumes: simple, spanned, striped, mirrored, and RAID-5. A dynamic volume is formatted by using a file system, such as FAT or NTFS, and it has a drive letter assigned to it.

See also: basic disk; basic volume; dynamic disk; mirrored volume; RAID-5 volume; simple volume; spanned volume; striped volume

dynamic-link library (DLL)

An operating system feature that allows executable routines (generally serving a specific function or set of functions) to be stored separately as files with .dll extensions. These routines are loaded only when needed by the program that calls them.

E

EFI

See definition for: Extensible Firmware Interface (EFI)

EFI system partition

On Itanium-based computers, a portion on a GUID partition table (GPT) disk that is formatted with the FAT file system and contains the files necessary to start the computer. Every Itanium-based computer must have at least one GPT disk with an EFI system partition. The EFI system partition serves the same purpose as the system volume found on x86-based computers.

See also: Extensible Firmware Interface (EFI); GUID partition table (GPT); Microsoft Reserved (MSR) partition; Itanium; x86

embedded controller

The general class of microcontrollers used to support OEM-specific implementation, mainly in mobile environments. The embedded controller performs complex low-level functions through a simple interface to the host microprocessor(s).

embedded controller interface

ACPI defines a standard hardware and software communications interface between an operating system driver and an embedded controller, such as Smart Battery and AML code. This allows any operating system to provide a standard driver that can directly communicate with an embedded controller in the system, thus allowing other drivers to communicate with and use the resources of the system embedded controllers.

See also: driver; Advanced Configuration and Power Interface (ACPI)

encryption

The process of disguising a message or data in such a way as to hide its substance.

See also: public key encryption

end user

The person who ultimately receives the computer manufactured by the OEM.

End-User License Agreement (EULA)

A legal agreement between a software or hardware manufacturer and the purchaser, with regard to terms of distribution, resale, and restricted use.

EULA

See definition for: End-User License Agreement (EULA)

event

Any significant occurrence in the system or an application that requires users to be notified or an entry to be added to a log.

Event Viewer

A component you can use to view and manage event logs, gather information about hardware and software problems, and monitor security events. Event Viewer maintains logs about program, security, and system events.

See also: event

expansion slot

A socket in a computer, designed to hold expansion boards and connect them to the system bus.

See also: bus

extended partition

A type of partition that you can create only on basic master boot record (MBR) disks. Extended partitions are useful if you want to create more than four volumes on a basic MBR disk. Unlike primary partitions, you do not format an extended partition with a file system and then assign a drive letter to it. Instead, you create one or more logical drives within the extended partition. After you create a logical drive, you format it and assign it a drive letter. An MBR disk can have up to four primary partitions, or three primary partitions, one extended partition, and multiple logical drives.

See also: basic disk; logical drive; master boot record (MBR); partition; primary partition

Extensible Firmware Interface (EFI)

In computers with the Intel Itanium processor, the interface between a computer's firmware, hardware, and the operating system. The Extensible Firmware Interface (EFI) defines a new partition style called GUID partition table (GPT). EFI serves the same purpose for Itanium-based computers as the BIOS found in x86-based computers. However, it has expanded capabilities that provide a consistent way to start any compatible operating system and an easy way to add EFI drivers for new bootable devices without the need to update the computer's firmware.

See also: Itanium; x86; basic input/output system (BIOS); GUID partition table (GPT)

F

factory mode

A mode of running Sysprep that postpones the first-run experience and allows OEMs to install additional drivers and applications, incorporate build-to-order customer information, and test the Windows installation. To run Sysprep in factory mode, use the command line Sysprep -factory.

FAT

See definition for: file allocation table (FAT)

FAT32

A derivative of the file allocation table (FAT) file system. FAT32 supports smaller cluster sizes and larger volumes than FAT, which results in more efficient space allocation on FAT32 volumes.

See also: file allocation table (FAT); NTFS file system

fault tolerance

The ability of computer hardware or software to ensure data integrity when hardware failures occur. Fault tolerant features appear in many server operating systems and include mirrored volumes, RAID-5 volumes, and server clusters.

See also: cluster; mirrored volume; RAID-5 volume

file allocation table (FAT)

A file system used by MS-DOS and other Windows-based operating systems to organize and manage files. The file allocation table (FAT) is a data structure that Windows creates when you format a volume by using the FAT or FAT32 file systems. Windows stores information about each file in the FAT so that it can retrieve the file later.

See also: FAT32; file system; NTFS file system

file copy

The first of the three stages of Setup, where the Windows program files and any additional files specified are copied to the computers hard disk.

file system

In an operating system, the overall structure in which files are named, stored, and organized. NTFS, FAT, and FAT32 are types of file systems.

See also: FAT; FAT32; NTFS file system

File Transfer Protocol (FTP)

A member of the TCP/IP suite of protocols, used to copy files between two computers on the Internet. Both computers must support their respective FTP roles: one must be an FTP client and the other an FTP server.

See also: Transmission Control Protocol/Internet Protocol (TCP/IP)

firmware

Software routines and low-level input/output instructions stored in read-only memory (ROM). Unlike random-access memory (RAM), read-only memory stays intact even in the absence of electrical power.

first-run experience

The software the end user sees the first time they start a new computer. The first-run experience is known as Windows Welcome in Windows XP and Mini-Setup in the Windows Server family of operating systems.

See also: Windows Welcome

flash the BIOS

Before installing Windows 2000 or later, an end user may need to upgrade the BIOS (basic input/output system) software through a process called "flashing the BIOS", which is usually provided by an OEM.

font

A graphic design applied to a collection of numbers, symbols, and characters. A font describes a certain typeface, along with other qualities such as size, spacing, and pitch.

See also: OpenType fonts

foreground program

The program that runs in the active window (the uppermost window with the highlighted title bar). The foreground program responds to commands issued by the user.

forest

A collection of one or more Windows domains that share a common schema, configuration, and global catalog and are linked with two-way transitive trusts.

See also: domain; domain tree

free space

Available space that you use to create logical drives within an extended partition.

See also: extended partition; logical drive; unallocated space

furigana name

Tiny Japanese kana characters written above or next to kanji characters. The kana characters indicate the correct pronunciation of the word written in kanji.

G

glyph

A graphical representation of either a character, a part of a character, or a sequence of characters.

GPT

See definition for: GUID partition table (GPT)

graceful recovery

Termination of a process that allows the operating system or parent process to regain normal control. Does not crash the machine or result in a general protection default (GPF) or blue screen. The user is not required to close the application, and can continue to use the other functionality.

graphical user interface (GUI)

A display format, like that of Windows, that represents a program's functions with graphic images such as buttons and icons. GUIs allow a user to perform operations and make choices by pointing and clicking with a mouse.

group account

A collection of user accounts. By making a user account a member of a group, you give the related user all the rights and permissions granted to the group.

See also: user account

Group Policy

The Microsoft Management Console (MMC) snap-in that is used to edit Group Policy objects.

See also: Microsoft Management Console (MMC); snap-in

GUI-mode Setup

The third of the three stages of Setup, during which the computers hardware and network settings are configured, you are prompted to provide an Administrator password, and you can personalize the installation.

GUID partition table (GPT)

A disk-partitioning scheme that is used by the Extensible Firmware Interface (EFI) in Itanium-based computers. GPT offers more advantages than master boot record (MBR) partitioning because it allows up to 128 partitions per disk, provides support for volumes up to 18 exabytes in size, allows primary and backup partition tables for redundancy, and supports unique disk and partition IDs (GUIDs).

See also: Extensible Firmware Interface (EFI); master boot record (MBR); Itanium

H

HAL

See definition for: hardware abstraction layer (HAL)

hardware abstraction layer (HAL)

A thin layer of software provided by the hardware manufacturer that hides, or abstracts, hardware differences from higher layers of the operating system. By means of the filter provided by the HAL, different types of hardware look alike to the rest of the operating system. This allows the operating system to be portable from one hardware platform to another. The HAL also provides routines that allow a single device driver to support the same device on all platforms.

hardware branch

The hardware archive root key in the registry that is a superset of the memory-resident hardware tree. Although the hardware tree contains information only about those devices currently detected and running in the system, the registry contains a complete list of all hardware ever installed on the particular computer. The hardware root key is \\HKEY-LOCAL-MACHINE\Hardware.

Hardware Compatibility List (HCL)

A list of the devices supported by Windows XP.

See also: device

hardware ID

A vendor-defined string used by the Plug and Play Manager to find the correct .inf file to install a particular device.

See also: .inf file; Plug and Play

hardware tree

A record in RAM of the current system configuration based on the information for all devices in the hardware branch of the registry. The hardware tree is created each time the system is started or whenever a dynamic change occurs to the system configuration.

See also: hardware branch

hardware type

A classification for similar devices. For example, Imaging Device is a hardware type for digital cameras and scanners.

See also: device

hash

A fixed-size result that is obtained by applying a one-way mathematical function (sometimes called a hash algorithm) to an arbitrary amount of data. If there is a change in the input data, the hash changes. The hash can be used in many operations, including authentication and digital signing. A hash is also called a message digest.

See also: hash algorithm; authentication

hash algorithm

An algorithm used to produce a hash value of some piece of data, such as a message or session key. A good hash algorithm has a quality where changes in the input data can change every bit in the resulting hash value; for this reason, hashes are useful in detecting any modification in a large data object, such as a message. Furthermore, a good hash algorithm makes it computationally infeasible to construct two independent inputs that have the same hash. Typical hash algorithms include MD2, MD4, MD5, and SHA-1. Hash algorithm is also called a hash function.

HCL

See definition for: Hardware Compatibility List (HCL)

HCT

Hardware Compatibility Tests. A suite of tests from WHQL to verify hardware and device driver operations under a specific operating environment. These tests exercise the combination of a device, a software driver, and an operating system under controlled conditions to verify that all components operate properly.

See also: Windows Hardware Quality Labs (WHQL)

headless

BIOS or server appliances without display or input peripherals, such as a keyboard, pointing device, or video monitor.

Help and Support Center

A unified place where a user can access all Help and Support content and services from both Microsoft and the OEM.

hive

A section of the registry that appears as a file on your hard disk. The registry subtree is divided into hives (named for their resemblance to the cellular structure of a beehive). A hive is a discrete body of keys, subkeys, and values that is rooted at the top of the registry hierarchy. A hive is backed by a single file and a .log file, which are in the systemroot\System32\Config or the systemroot\Profiles\username folders.

By default, most hive files (Default, SAM, Security, and System) are stored in the systemroot\System32\Config folder. The systemroot\Profiles folder contains the user profile for each user of the computer. Because a hive is a file, it can be moved from one system to another. However, you must use the Registry Editor to edit the file.

See also: systemroot; registry; key

hotfix

An update to address an issue identified after a software product has been distributed. Hotfix distribution is limited by its licensing terms.

hub

A common connection point for devices in a network. Typically used to connect segments of a local area network (LAN), a hub contains multiple ports. When data arrives at one port, it is copied to the other ports so that all segments of the LAN can see the data.

See also: local area network (LAN); port

Hypertext Markup Language (HTML)

A simple markup language used to create hypertext documents that are portable from one platform to another. HTML files are simple ASCII text files with codes embedded (indicated by markup tags) to denote formatting and hypertext links.

See also: American Standard Code for Information Interchange (ASCII)

I

I/O

See definition for: input/output (I/O) port

I/O request packet (IRP)

Data structures that drivers use to communicate with each other.

IA-PC

Intel Architecture Personal Computer. A general descriptive term for computers built with processors conforming to the architecture defined by the Intel processor family based on the 486 instruction set and having an industry-standard PC architecture.

icon character

The animated icon from the Help and Support Center that guides users through their first-run experience, or Windows Welcome.

See also: Windows Welcome

IDE

Integrated device electronics. A type of disk-drive interface in which the controller electronics reside on the drive itself, eliminating the need for a separate adapter card. IDE offers advantages such as look-ahead caching to increase overall performance.

IEEE

Institute of Electrical and Electronics Engineers, founded in 1963. IEEE is an organization composed of engineers, scientists, and students, best known for developing standards for the computer and electronics industry.

IEEE 1394

A standard for high-speed serial devices such as digital video and digital audio editing equipment.

See also: device

IHV

See definition for: independent hardware vendor (IHV)

IIS

See definition for: Internet Information Services (IIS)

image

In graphical terms, an image is the computerized representation of a picture or graphic. In data representation terms, an image is a collection of files and folders (sometimes compressed into one file) that represent an imitation of the original file and folder structure -- an exact duplicate.

image resolution

The fineness or coarseness of an image as it is digitized, measured in dots per inch (DPI), typically ranging from 200 to 400 DPI.

independent hardware vendor (IHV)

A company that manufactures hardware devices and the associated device drivers.

independent software vendor (ISV)

A third-party software developer; an individual or an organization that independently creates computer software.

input language

The specification of the language you want to type in. Some programs that are designed for Windows recognize this setting. When you add a new input language, a keyboard layout for that language is also added.

input locale

A pairing of the input language (LangID) and the method of input that determines which language is currently being used and how it is being entered.

Input Method Editor (IME)

Programs used to enter the thousands of different characters in written Asian languages with a standard 101-key keyboard. An IME consists of both an engine that converts keystrokes into phonetic and ideographic characters and a dictionary of commonly used ideographic words. As the user enters keystrokes, the IME engine attempts to identify which character or characters the keystrokes should be converted into.

input/output (I/O) port

A channel through which data is transferred between a device and the microprocessor. The port appears to the microprocessor as one or more memory addresses that it can use to send or receive data.

See also: device; memory address; port

install

When referring to software, to add program files and folders to your hard disk and related data to your registry so that the software runs properly. Installing contrasts with upgrading, where existing program files, folders, and registry entries are updated to a more recent version.

When referring to hardware, to physically connect the device to your computer, to load device drivers onto your computer, and to configure device properties and settings.

See also: device driver; registry

integrated device electronics (IDE)

A type of disk-drive interface in which the controller electronics reside on the drive itself, eliminating the need for a separate adapter card. IDE offers advantages such as look-ahead caching to increase overall performance.

internet

internet. Two or more network segments connected by routers. Another term for internetwork.

Internet. A worldwide network of computers. If you have access to the Internet, you can retrieve information from millions of sources, including schools, governments, businesses, and individuals.

See also: World Wide Web

Internet address

An address for a resource on the Internet that is used by Web browsers to locate Internet resources. An Internet address typically starts with a protocol name, followed by the name of the organization that maintains the site; the suffix identifies the kind of organization it is. For example, the address http://www.yale.edu/ provides the following information:

  • http: This Web server uses the Hypertext Transfer Protocol.
  • www: This site is on the World Wide Web.
  • edu: This is an educational institution.
Internet address is also called Uniform Resource Locator (URL).

See also: protocol; Web server

Internet Information Services (IIS)

Software services that support Web site creation, configuration, and management, along with other Internet functions. Internet Information Services include Network News Transfer Protocol (NNTP), File Transfer Protocol (FTP), and Simple Mail Transfer Protocol (SMTP).

See also: Simple Mail Transfer Protocol (SMTP); File Transfer Protocol (FTP); Network News Transfer Protocol (NNTP)

Internet Protocol (IP)

A routable protocol in the TCP/IP protocol suite that is responsible for IP addressing, routing, and the fragmentation and reassembly of IP packets.

See also: Transmission Control Protocol/Internet Protocol (TCP/IP)

Internet service provider (ISP)

A company that provides individuals or companies access to the Internet and the World Wide Web. An ISP provides a telephone number, a user name, a password, and other connection information so users can connect their computers to the ISP's computers. An ISP typically charges a monthly or hourly connection fee.

See also: Web server

Internetwork Packet Exchange (IPX)

A network protocol native to NetWare that controls addressing and routing of packets within and between LANs. IPX does not guarantee that a message will be complete (no lost packets).

See also: IPX/SPX; local area network (LAN)

interrupt request (IRQ)

A signal sent by a device to get the attention of the processor when the device is ready to accept or send information. Each device sends its interrupt requests over a specific hardware line. Each device must be assigned a unique IRQ number.

interrupt request (IRQ) lines

Hardware lines over which devices can send signals to get the attention of the processor when the device is ready to accept or send information. Each device must have a unique IRQ line.

See also: device

IP address

A 32-bit address used to identify a node on an IP internetwork. Each node on the IP internetwork must be assigned a unique IP address, which is made up of the network ID, plus a unique host ID. This address is typically represented with the decimal value of each octet separated by a period (for example, 192.168.7.27). In this version of Windows, you can configure the IP address statically or dynamically through DHCP.

See also: Dynamic Host Configuration Protocol (DHCP)

IPX/SPX

Transport protocols used in Novell NetWare networks, which together correspond to the combination of TCP and IP in the TCP/IP protocol suite. Windows implements IPX through NWLink.

See also: Transmission Control Protocol/Internet Protocol (TCP/IP); Internetwork Packet Exchange (IPX); NWLink

IRP

See definition for: I/O request packet (IRP)

IRQ

See definition for: interrupt request (IRQ)

isochronous

Time dependent. Refers to processes where data must be delivered within certain time constraints. Multimedia streams require an isochronous transport mechanism to ensure that data is delivered as fast as it is displayed, and to ensure that the audio is synchronized with the video.

isolation

The Plug and Play process by which cards on an ISA bus are distinguished from each other after system startup.

ISP

See definition for: Internet service provider (ISP)

ISP sign-up server

An HTTP server that automates the task of adding new customers to an ISP's customer database. The Internet sign-up server collects information from each customer, adds the information to the ISP's customer database, and then passes a configuration packet back to the customer's desktop computer. The configuration packet contains information that is used to configure the customer's Internet browser for subsequent connection to the ISP's services.

ISP signup offer

A set of HTML pages in Windows Welcome that allows end users to sign up for Internet access from a particular Internet service provider.

ISV

See definition for: independent software vendor (ISV)

Itanium

An Intel microprocessor that uses explicitly parallel instruction set computing and 64-bit memory addressing.

J

There are no glossary terms that begin with this letter.

K

kernel

The core of layered architecture that manages the most basic operations of the operating system and the computer's processor. The kernel schedules different blocks of executing code, called threads, for the processor to keep it as busy as possible and coordinates multiple processors to optimize performance. The kernel also synchronizes activities among Executive-level subcomponents, such as I/O Manager and Process Manager, and handles hardware exceptions and other hardware-dependent functions. The kernel works closely with the hardware abstraction layer.

kernel mode

A highly privileged mode of operation where program code has direct access to all memory, including the address spaces of all user-mode processes and applications, and to hardware. Kernel mode is also known as supervisor mode, protected mode, or Ring 0.

kernel-mode driver

Driver for a logical, virtual, or physical device.

key

In Registry Editor, a folder that appears in the left pane of the Registry Editor window. A key can contain subkeys and value entries. For example, Environment is a key of HKEY_CURRENT_USER.

In IP security (IPSec), a value used in combination with an algorithm to encrypt or decrypt data. Key settings for IP security are configurable to provide greater security.

See also: registry; subkey

L

L2TP (Layer 2 Tunneling Protocol)

An industry-standard Internet tunneling protocol. Unlike Point-to-Point Tunneling Protocol (PPTP), L2TP does not require IP connectivity between the client workstation and the server. L2TP requires only that the tunnel medium provide packet-oriented point-to-point connectivity. The protocol can be used over media such as ATM, Frame Relay, and X.25. L2TP provides the same functionality as PPTP. Based on Layer 2 Forwarding (L2F) and PPTP specifications, L2TP allows clients to set up tunnels across intervening networks.

See also: Internet Protocol (IP); Point-to-Point Tunneling Protocol (PPTP)

label

Each part of a full DNS domain name that represents a node in the domain namespace tree. Domain names are made up of a sequence of labels, such as the three labels (example, microsoft, and com) that make up the DNS domain name example.microsoft.com. Each label used in a DNS name must be 63 bytes or less in character length.

See also: domain name; node

LAN

See definition for: local area network (LAN)

language group

A term used to describe the supported script families in Microsoft Windows.

Language ID

A 16-bit value which consists of a primary and a secondary language ID. Bits 0-9 make up the primary language ID and bits 10-15 comprise the sub-language ID.

layered driver

One of a collection of drivers that responds to the same IRPs. Layered driver describes the highest-level and lowest-level drivers in a chain of layered drivers that process the same IRPs, along with all intermediate drivers in the chain.

LBA

Logical block addressing. A method used with SCSI and IDE disk drives to translate the cylinder, head, and sector specifications of the drive into addresses that can be used by an enhanced BIOS. LBA is used with drives that are larger than 528MB.

lease

The length of time for which a DHCP client can use a dynamically assigned IP address configuration. Before the lease time expires, the client must either renew or obtain a new lease with DHCP.

See also: Dynamic Host Configuration Protocol (DHCP); IP address

legacy

Any feature in the computer system based on older technology for which compatibility continues to be maintained in other system components.

license

The right of a person or company to use software in a particular way, as described in the terms of the license agreement. Copyright law also limits how a person may use the software. A person needs a license agreement for each software program they use.

Lightweight Directory Access Protocol (LDAP)

The primary access protocol for Active Directory. Lightweight Directory Access Protocol (LDAP) version 3 is defined by a set of Proposed Standard documents in Internet Engineering Task Force (IETF) RFC 2251.

See also: protocol; Active Directory

local area network (LAN)

A communications network connecting a group of computers, printers, and other devices located within a relatively limited area (for example, a building). A LAN allows any connected device to interact with any other on the network.

See also: NetBIOS Extended User Interface (NetBEUI); network basic input/output system (NetBIOS); workgroup

local bus

Usually refers to a system bus directly connected to the microprocessor on a system board. Local bus is used colloquially to refer to system board buses located closer to the microprocessor than ordinary expansion buses (thus requiring less buffering), which make them capable of greater throughput.

Locale

A group of user preference information, such as date/time formatting, represented as a list of values related to the user's language and sub-language,

Locale ID

A 32-bit value which consists of the language ID in the low word (bits 0-15) and the sorting ID (bits 16-19) and a reserved value (bits 20-31) in the high word.

logical drive

A volume that you create within an extended partition on a basic master boot record (MBR) disk. Logical drives are similar to primary partitions, except that you are limited to four primary partitions per disk, whereas you can create an unlimited number of logical drives per disk. A logical drive can be formatted and assigned a drive letter.

See also: basic disk; basic volume; extended partition; master boot record (MBR); primary partition

long file name

A folder name or file name longer than the 8.3 file name standard (up to eight characters followed by a period and an extension of up to three characters). Most versions of Windows, including Windows XP, Windows 2000, Window NT, and Windows 9x, support long file names up to 255 characters.

LPT device

See definition for: parallel device

M

mass-storage device

A generic term for disk, optical disk, or other device that provides persistent storage for computer data.

master boot record (MBR)

The first sector on a hard disk, which starts the process of booting the computer. The MBR contains the partition table for the disk and a small amount of executable code called the master boot code.

See also: Recovery Console; partition boot sector

master computer

A fully-assembled computer containing a master installation.

See also: master installation

Master File Table (MFT)

An NTFS system file on NTFS-formatted volumes that contains information about each file and folder on the volume. The MFT is the first file on an NTFS volume.

See also: NTFS file system; file allocation table (FAT)

master installation

A customized installation of Windows that an OEM plans to duplicate onto one or more destination computers.

memory address

A portion of computer memory that can be allocated to a device or used by a program or the operating system. Devices are usually allocated a range of memory addresses.

See also: device

Message Queuing

A message queuing and routing system for Windows that enables distributed applications running at different times to communicate across heterogeneous networks and with computers that may be offline. Message Queuing provides guaranteed message delivery, efficient routing, security, and priority-based messaging. Message Queuing was formerly known as MSMQ.

See also: MSMQ

MFU list

Most-frequently used list. A list of applications that the end user has recently used.

Microsoft Management Console (MMC)

A framework for hosting administrative tools, called consoles. A console may contain tools, folders or other containers, World Wide Web pages, and other administrative items. These items are displayed in the left pane of the console, called a console tree. A console has one or more windows that can provide views of the console tree.

The main MMC window provides commands and tools for authoring consoles. The authoring features of MMC and the console tree itself may be hidden when a console is in User Mode.

See also: console tree; snap-in

Microsoft Reserved (MSR) partition

A required partition on every GUID partition table (GPT) disk. System components can allocate portions of the MSR partition into new partitions for their own use. For example, when you convert a basic GPT disk to dynamic, the system allocates a portion of the MSR partition to be used as the Logical Disk Manager (LDM) metadata partition. The MSR partition varies in size based on the size of the GPT disk. For disks smaller than 16 GB, the MSR partition is 32 MB. For disks larger than 16 GB, the MSR partition is 128 MB. The MSR partition is not visible in Disk Management, and you cannot store data on the MSR partition or delete it.

See also: GUID partition table (GPT); partition

MIDI

Musical Instrument Digital Interface. An industry-standard connection for computer control of musical instruments and devices. A hardware and data standard for communication between hardware. Most references involve only the data standard, which is a byte stream used for controlling musical instruments and storing the output of such instruments.

Mini-Setup

A subset of GUI-mode Setup, Mini-Setup is the first-run experience on the Windows Server family of products. Mini-Setup prompts for user-specific information, detects new hardware, and regenerates system IDs.

MIPS

Millions of instructions per second. A common measure of processor speed.

mirrored volume

A fault-tolerant volume that duplicates data on two physical disks. A mirrored volume provides data redundancy by using two identical volumes, which are called mirrors, to duplicate the information contained on the volume. A mirror is always located on a different disk. If one of the physical disks fails, the data on the failed disk becomes unavailable, but the system continues to operate in the mirror on the remaining disk. You can create mirrored volumes only on dynamic disks.

See also: fault tolerance; RAID-5 volume; dynamic disk; dynamic volume

mixed mode

The default domain mode setting on Windows 2000 or Windows XP domain controllers. Mixed mode allows backup domain controllers to co-exist in a Windows 2000 or Windows XP domain. Mixed mode does not support the universal and nested group enhancements of Windows 2000 or Windows XP. You can change the domain mode setting to native mode when all domain controllers are removed from a domain.

modem (modulator/demodulator)

A device that allows computer information to be transmitted and received over a telephone line. The transmitting modem translates digital computer data into analog signals that can be carried over a phone line. The receiving modem translates the analog signals back to digital form.

See also: port; Telephony API (TAPI)

monolithic driver

A driver that contains many different classes of functionality.

motherboard

The main circuit board of a microcomputer. The motherboard contains the connectors for attaching additional boards.

MSDN

Microsoft Developer Network.

MSMQ

The message queuing and routing system for Windows NT 4.0, Windows 95, and Windows 98. For Windows 2000 and Windows XP, this feature is called Message Queuing.

See also: Message Queuing

Multi-Language User Interface (MUI)

A separate, standalone release of Windows XP Professional that includes user interface resources for each supported language. MUI allows users to set the user-interface language according to their preferences, provided the required language files are present on the computer. It is designed to allow large corporations to deploy a single version of Windows worldwide, while allowing their local users or groups to select the user interface language.. Local users can then select the user interface language, or the language setting can be manage using Group Policy. MUI also allows users of different languages to share the same workstation: one user might choose to see system menus, dialog boxes, and other text in Japanese, while another user might choose to see the corresponding text in French. The following items are not localized in MUI versions: all 16-bit code, bitmaps, registry keys and values, folders and file names, and .inf files.

MultiByte Character Set (MBCS)

A mixed-width character set, in which some characters consist of more than 1 byte. A double byte character set (DBCS), which is a specific type of multibyte character set, includes some characters that consist of 1 byte and some characters that consist of 2 bytes.

multimedia

Refers to the delivery of information that combines different content formats, such as video, audio, still images, graphics, animation, and text.

multiprocessor

Two or more connected and roughly equal processors that can each carry out one or more processes (programs or sets of instructions) in tandem.

N

name resolution

The process of having software translate between names that are easy for users to work with and numerical IP addresses, which are difficult for users but necessary for TCP/IP communications. Name resolution can be provided by software components such as DNS or WINS.

See also: Transmission Control Protocol/Internet Protocol (TCP/IP); Windows Internet Name Service (WINS)

namespace

A set of unique names for resources or items used in a shared computing environment.

For Microsoft Management Console (MMC), the namespace is represented by the console tree, which displays all of the snap-ins and resources that are accessible to a console.

For Domain Name System (DNS), namespace is the vertical or hierarchical structure of the domain name tree. For example, each domain label, such as host1 or example, used in a fully qualified domain name, such as host1.example.microsoft.com, indicates a branch in the domain namespace tree.

See also: console tree; label; resource; snap-in

native mode

The condition in which all domain controllers in the domain have been upgraded to Windows 2000 and an administrator has enabled native mode operation (through Active Directory Users and Computers).

See also: Active Directory Users and Computers

NCW

See definition for: New Connection Wizard (NCW)

NetBIOS Extended User Interface (NetBEUI)

A network protocol native to Microsoft Networking. It is usually used in small, department-size local area networks (LANs) of 1 to 200 clients. It can use Token Ring source routing as its only method of routing. It is the Microsoft implementation of the NetBIOS standard.

See also: local area network (LAN); network basic input/output system (NetBIOS); protocol

network adapter

See definition for: network interface card (NIC)

network basic input/output system (NetBIOS)

An application programming interface (API) that can be used by programs on a local area network (LAN). NetBIOS provides programs with a uniform set of commands for requesting the lower-level services required to manage names, conduct sessions, and send datagrams between nodes on a network.

See also: application programming interface (API); basic input/output system (BIOS); local area network (LAN); node; service

network card

See definition for: network interface card (NIC)

network card driver

A device driver that works directly with the network card, acting as an intermediary between the card and the protocol driver.

network interface card (NIC)

An expansion card or other device used to provide network access to a computer or other device, such as a printer. Network interface cards mediate between the computer and physical media, such as cabling, over which transmissions travel. Also called network adapter or network card.

Network News Transfer Protocol (NNTP)

A member of the TCP/IP suite of protocols used to distribute network news messages to NNTP servers and clients (newsreaders) on the Internet. NNTP is designed so that news articles are stored on a server in a central database, thus enabling a user to select specific items to read.

See also: Transmission Control Protocol/Internet Protocol (TCP/IP)

New Connection Wizard (NCW)

A tool that helps users sign up for Internet service and automatically handles the software configuration steps necessary for gaining access to the Internet.

NIC

See definition for: network interface card (NIC)

node

For tree structures, a location on the tree that can have links to one or more items below it.

For local area networks (LANs), a device that is connected to the network and is capable of communicating with other network devices.

For server clusters, a computer system running Windows 2000 Advanced Server or Windows 2000 Datacenter Server or later versions of these operating systems that is an active or inactive member of a cluster.

See also: local area network (LAN); server cluster

non-spacing character

A character, such as diacritic, that has no meaning by itself, but overlaps a base character to modify it, sometimes referred to as a "combining character".

NTFS file system

An advanced file system that provides performance, security, reliability, and advanced features that are not found in any version of FAT. For example, NTFS guarantees volume consistency by using standard transaction logging and recovery techniques. If a system fails, NTFS uses its log file and checkpoint information to restore the consistency of the file system. In Windows 2000 and Windows XP, NTFS also provides advanced features such as file and folder permissions, encryption, disk quotas, and compression.

See also: FAT32; file allocation table (FAT); file system

NWLink

An implementation of the Internetwork Packet Exchange (IPX), Sequenced Packet Exchange (SPX), and NetBIOS protocols used in Novell networks. NWLink is a standard network protocol that supports routing and can support NetWare client-server applications, where NetWare-aware Sockets-based applications communicate with IPX/SPX Sockets-based applications.

See also: IPX/SPX; network basic input/output system (NetBIOS)

O

object

An entity, such as a file, folder, shared folder, printer, or Active Directory object, described by a distinct, named set of attributes. For example, the attributes of a File object include its name, location, and size; the attributes of an Active Directory User object might include the user's first name, last name, and e-mail address.

For OLE and ActiveX, an object can also be any piece of information that can be linked to, or embedded into, another object.

See also: attribute; child object; parent object

OEM

See definition for: original equipment manufacturer (OEM)

OEM branding

To incorporate a company name, logo, support information, and Help files into the Microsoft Windows installation.

OEM ISP sign-up offer

A set of HTML pages created by either the OEM or a third-party company that lets end users sign up for Internet access from a particular Internet service provider (ISP). You can incorporate these pages into Windows Welcome, or include a shortcut to the first page of the OEM link on the Start menu.

See also: OEM link; Windows Welcome

OEM License Agreement

A legal agreement between Microsoft Licensing, Inc., and OEMs regarding the terms of preinstalling, customizing, and distributing Microsoft Windows XP. For System Builders, the corresponding agreement is affixed to the side of every OEM Distribution Pack. By opening the package you agree to all the terms of the Break-The-Seal (BTS) agreement. For royalty OEMs, the license agreement is a signed contract. The specific requirements and customization options that apply to either or both license agreements is documented in the OPK User's Guide.

See also: Break-the-Seal Microsoft Distribution and Preinstallation Agreement (BTS); royalty OEM; system builder

OEM link

A link on the Start menu where OEMs can place any desired links or shortcuts.

OEM Preinstallation Kit (OPK)

A set of tools, documentation, and samples that enable OEMs to efficiently preinstall Windows on new computers according to the terms of the OEM Licensing Agreement.

Oem.chm

The HTML Help file that you customize to provide OEM-specific support information in Windows Help.

Oeminfo.ini

A file used to provide required OEM information, such as company name, computer model, company telephone number, and customer support information.

OnNow

See definition for: Advanced Configuration and Power Interface (ACPI)

OOBE

See definition for: Windows Welcome

OpenType fonts

Outline fonts that are rendered from line and curve commands, and can be scaled and rotated. OpenType fonts are clear and readable in all sizes and on all output devices supported by Windows. OpenType is an extension of TrueType font technology.

See also: font

OPK

See definition for: OEM Preinstallation Kit (OPK)

original equipment manufacturer (OEM)

A company that typically purchases computer components from other manufacturers, uses the components to build a personal computer, preinstalls Windows onto that computer, and then sells the computer to the public.

Out-Of-Box Experience (OOBE)

See definition for: Windows Welcome

P

paging file

A hidden file on the hard disk that Windows uses to hold parts of programs and data files that do not fit in memory. The paging file and physical memory, or RAM, comprise virtual memory. Windows moves data from the paging file to memory as needed and moves data from memory to the paging file to make room for new data. Paging file is also called a swap file.

parallel device

A device that uses a parallel connection.

parent object

The object in which another object resides. A parent object implies relation. For example, a folder is a parent object in which a file, or child object, resides. An object can be both a parent and a child object. For example, a subfolder that contains files is both the child of the parent folder and the parent folder of the files.

See also: child object; object

partition

A portion of a physical disk that functions as though it were a physically separate disk. After you create a partition, you must format it and assign it a drive letter before you can store data on it.

On basic disks, partitions are known as basic volumes, which include primary partitions and logical drives. On dynamic disks, partitions are known as dynamic volumes, which include simple, striped, spanned, mirrored, and RAID-5 volumes.

See also: basic disk; basic volume; dynamic volume; extended partition; primary partition; system partition

partition boot sector

A portion of a hard disk partition that contains information about the disk's file system and a short machine language program that loads the Windows operating system.

See also: partition

passport

A single sign-in service that lets you use a single name and password on multiple participating Web sites.

password

A security measure used to restrict logon names to user accounts and access to computer systems and resources. A password is a string of characters that must be provided before a logon name or an access is authorized. A password can be made up of letters, numbers, and symbols, and it is case sensitive.

See also: user account

PC Card

A removable device, approximately the size of a credit card, that can be plugged into a Personal Computer Memory Card International Association (PCMCIA) slot in a portable computer. PCMCIA devices can include modems, network cards, and hard disk drives.

See also: modem (modulator/demodulator)

PC Health

A suite of technologies and features focused on providing end users with improved technical support by enabling web-based support solutions. PC Health also provides better operating system reliability, and an enhanced end-user experience, by providing easier access to help content and support services.

PCMCIA device

A removable device, approximately the size of a credit card, that can be plugged into a PCMCIA slot in a portable computer. PCMCIA devices can include modems, network adapters, and hard disk drives.

Some PCMCIA cards can be connected to and disconnected from your computer without restarting it. Before you remove the PCMCIA card, however, you should use the Add Hardware Wizard to notify Windows that you are doing so. Windows will then notify you when you can remove the device.

permission

A rule associated with an object to regulate which users can gain access to the object and in what manner. Permissions are granted or denied by the object's owner.

See also: object

PIC

Programmable Interrupt Controller. This type of hardware cannot be used in computers with multiple processes, and the processing speed is slower than similar APIC hardware.

piracy

Unauthorized copying, distribution, and use of computer software, or software theft.

pixels

An abbreviation for picture elements. The minimum raster display element, represented as a point, with a specified color or intensity level. One way to measure picture resolution is by the number of pixels used to create images.

Plug and Play

A set of specifications developed by Intel that allows a computer to automatically detect and configure a device and install the appropriate device drivers.

See also: universal serial bus (USB)

Plug and Play BIOS

A BIOS with responsibility for configuring Plug and Play cards and system-board devices during system power up. Provides runtime configuration services for system board devices after startup.

See also: BIOS; Advanced Configuration and Power Interface (ACPI); system board

Point-to-Point Protocol (PPP)

An industry standard suite of protocols for the use of point-to-point links to transport multiprotocol datagrams. PPP is documented in RFC 1661.

See also: remote access; Transmission Control Protocol/Internet Protocol (TCP/IP)

Point-to-Point Tunneling Protocol (PPTP)

Networking technology that supports multiprotocol virtual private networks (VPNs), enabling remote users to access corporate networks securely across the Internet or other networks by dialing into an Internet service provider (ISP) or by connecting directly to the Internet. The Point-to-Point Tunneling Protocol (PPTP) tunnels, or encapsulates, IP, IPX, or NetBEUI traffic inside of IP packets. This means that users can remotely run applications that are dependent upon particular network protocols.

See also: Internet Protocol (IP); Internetwork Packet Exchange (IPX); NetBIOS Extended User Interface (NetBEUI)

port

A connection point on your computer where you can connect devices that pass data into and out of a computer. For example, a printer is typically connected to a parallel port (also called an LPT port), and a modem is typically connected to a serial port (also called a COM port).

See also: universal serial bus (USB)

POST

See definition for: power-on self test (POST)

power management

Mechanisms in software and hardware to minimize system power consumption, manage system thermal limits, and maximize system battery life. Power management involves trade-offs among system speed, noise, battery life, processing speed, and power consumption.

power-on self test (POST)

A set of routines stored in read-only memory (ROM) that tests various system components such as RAM, the disk drives, and the keyboard, to see if they are properly connected and operating. If problems are found, these routines alert the user with a series of beeps or a message, often accompanied by a diagnostic numeric value. If the POST is successful, it passes control to the bootstrap loader.

precached ISP signup offer

See definition for: OEM ISP sign-up offer

precomposed character

A single character that represents a sequence of characters, usually a combination of a base character and one or more diacritics.

preconfigured ISP signup

Configuring the operating system during the manufacturing process to use a specific account for access to the Internet.

predefined key

A key that represents one of the main divisions of the registry. Each predefined key is displayed in a separate Registry Editor window, with the key's name appearing in the window's title bar. For example, HKEY_CLASSES_ROOT is a predefined key.

See also: registry; hive; key

preinstallation

To load Windows XP on new computers for distribution to end users.

Primary disk

The hard disk drive that contains the system and boot partitions used to start Windows.

See also: boot partition; system partition

primary partition

A type of partition that you can create on basic disks. A primary partition is a portion of a physical disk that functions as though it were a physically separate disk. On basic master boot record (MBR) disks, you can create up to four primary partitions on a basic disk, or three primary partitions and an extended partition with multiple logical drives. On basic GPT disks, you can create up to 128 primary partitions. Primary partitions are also known as volumes.

See also: basic disk; extended partition; GUID partition table (GPT); logical drive; master boot record (MBR); partition

private key

The secret half of a cryptographic key pair that is used with a public key algorithm. Private keys are typically used to decrypt a symmetric session key, digitally sign data, or decrypt data that has been encrypted with the corresponding public key.

See also: public key; public key encryption

product activation

See definition for: Windows Product Activation (WPA)

Product Key

A 25-character, alpha-numeric string. Customers must enter this string to activate their installation of Windows. The product key is located on the certificate of authenticity, which is attached to the computer chassis.

property set

A method defined to set and get properties on a driver. Each property set has a unique identifier, which represents types of related information and is used to access the property set.

Protective MBR

The first sector of a GUID partition table (GPT) disk that is structured like the first sector of a master boot record (MBR) disk to prevent x86-based disk utilities from destroying GPT partitions. The Protective MBR contains one partition that reserves the entire space used on the disk by GPT partitions.

See also: Extensible Firmware Interface (EFI); GUID partition table (GPT); master boot record (MBR); x86

protocol

A set of rules and conventions for sending information over a network. These rules govern the content, format, timing, sequencing, and error control of messages exchanged among network devices.

See also: Transmission Control Protocol/Internet Protocol (TCP/IP)

proxy

A firewall and content cache server that provides Internet security and improves network performance.

public key

The nonsecret half of a cryptographic key pair that is used with a public key algorithm. Public keys are typically used when encrypting a session key, verifying a digital signature, or encrypting data that can be decrypted with the corresponding private key.

See also: private key; public key encryption; key

public key encryption

A method of encryption that uses two encryption keys that are mathematically related. One key is called the private key and is kept confidential. The other is called the public key and is freely given out to all potential correspondents. In a typical scenario, a sender uses the receiver's public key to encrypt a message. Only the receiver has the related private key to decrypt the message. The complexity of the relationship between the public key and the private key means that, provided the keys are long enough, it is computationally infeasible to determine one from the other. Public key encryption is also called asymmetric encryption.

See also: encryption; private key; public key

public key infrastructure (PKI)

The term generally used to describe the laws, policies, standards, and software that regulate or manipulate certificates and public and private keys. In practice, it is a system of digital certificates, certification authorities, and other registration authorities that verify and authenticate the validity of each party involved in an electronic transaction. Standards for PKI are still evolving, even though they are being widely implemented as a necessary element of electronic commerce.

See also: certification authority (CA); public key; certificate

Q

QFE

Quick-Fix Engineering. This is usually referred to as a hotfix.

See also: hotfix

quiet mode

Running a command-line application so that it does not display confirmation messages or any other user interface items that normally appear on screen. The switch for quiet mode is typically /q.

R

RAID-5 volume

A fault-tolerant volume with data and parity striped intermittently across three or more physical disks. Parity is a calculated value that is used to reconstruct data after a failure. If a portion of a physical disk fails, Windows recreates the data that was on the failed portion from the remaining data and parity. You can create RAID-5 volumes only on dynamic disks, and you cannot mirror or extend RAID-5 volumes.

See also: dynamic disk; dynamic volume; fault tolerance

RAM

See definition for: random access memory (RAM)

random access memory (RAM)

Memory that can be read from or written to by a computer or other devices. Information stored in RAM is lost when the computer is turned off.

ranking

Windows XP ranks drivers to determine which is the best for a device. The lower the rank, the better the match of the driver to the device.

read-only memory (ROM)

A semiconductor circuit that contains information that cannot be modified.

rebinding state

A state used by DHCP clients to extend and renew their address lease when the current lease is close to expiring. In this state, the client broadcasts to the network to locate any DHCP server that can either renew or replace its currently leased configuration. The rebinding state begins when 87.5 percent of the client's lease time has elapsed.

See also: Dynamic Host Configuration Protocol (DHCP); lease

reboot

To restart a computer by reloading the operating system. This can be done by performing either a cold boot, such as turning the computer off and then back on, or a warm boot, such as turning the computer off by typically pressing CTRL + ALT + DEL, clicking Shut Down, and then clicking Restart.

Recovery Console

A command-line interface that provides a limited set of administrative commands that are useful for repairing a computer.

See also: NTFS file system

recovery media

Media provided by the OEM to the customer that allows the customer to repair or reinstall their installation of Windows.

reduced instruction set computing

A type of microprocessor design that focuses on rapid and efficient processing of a relatively small set of instructions. RISC architecture limits the number of instructions that are built into the microprocessor, but optimizes each so it can be carried out very rapidly{bmct emdash.bmp}usually within a single clock cycle.

Redundant Array of Independent Disks (RAID)

A method used to standardize and categorize fault-tolerant disk systems. RAID levels provide various mixes of performance, reliability, and cost. Some servers provide three of the RAID levels: Level 0 (striping), Level 1 (mirroring), and Level 5 (RAID-5).

See also: fault tolerance; mirrored volume; RAID-5 volume; striped volume

reference computer

See definition for: technician computer

registration

Providing the user's name, address, and other demographic information to Microsoft or to both Microsoft and the OEM. Registration information is commonly used for marketing purposes. Registration is different from activation; a user may activate their installation of Windows without providing any identification or demographic information.

See also: Windows Product Activation (WPA)

registry

A database repository for information about a computer's configuration. The registry contains information that Windows continually references during operation, such as:

  • Profiles for each user.
  • The programs installed on the computer and the types of documents each can create.
  • Property settings for folders and program icons.
  • What hardware exists on the system.
  • Which ports are being used.

The registry is organized hierarchically as a tree and is made up of keys and their subkeys, hives, and value entries.

See also: hive; key; subtree; value entry

registry key

An identifier for a record or group of records in the registry.

remote access

Part of the integrated Routing and Remote Access service that provides remote networking for telecommuters, mobile workers, and system administrators who monitor and manage servers at multiple branch offices. Users with a computer running Windows and Network Connections can dial in to remotely access their networks for services such as file and printer sharing, electronic mail, scheduling, and SQL database access.

See also: remote access server; service

remote access server

A Windows-based computer running the Routing and Remote Access service and configured to provide remote access.

See also: remote access

Remote Installation Server (RIS)

An optional component that remotely installs Windows XP Professional. RIS installs the operating system on remote boot-enabled client computers by connecting the computer to the network, starting the client computer, logging on with a valid user account, and copying an operating system image to the client computer.

reseal

To prepare the operating system for delivery to the end user, after completing any additional processing or validation in the factory. Run Sysprep -reseal at the end of your Factory processing to seal the computer.

resource

Generally, any part of a computer system or network, such as a disk drive, printer, or memory, that can be allotted to a running program or a process.

For Device Manager, any of four system components that control how the devices on a computer work. These four system resources are interrupt request (IRQ) lines, direct memory access (DMA) channels, input/output (I/O) ports, and memory addresses.

For server clusters, a physical or logical entity that is capable of being managed by a cluster, brought online and taken offline, and moved between nodes. A resource can be owned only by a single node at any point in time.

See also: input/output (I/O) port; interrupt request (IRQ) lines; memory address; node; resource; server cluster

RIS

See definition for: Remote Installation Server (RIS)

RISC

See definition for: reduced instruction set computing

root

The highest or uppermost level in a hierarchically organized set of information. The root is the point from which further subsets are branched in a logical sequence that moves from a broad or general focus to narrower perspectives.

root authority

The certification authority (CA) at the top of a certification hierarchy. The root CA has a self-signed certificate. Also called the root certification authority.

See also: certification authority (CA); root

root certificate

A self-signed certification authority certificate. It is called a root certificate because it is the certificate for the root authority. The root authority must sign its own certificate because by definition there is no higher certifying authority in the certification hierarchy.

See also: certificate; certification authority (CA); root authority

routing

The process of forwarding a packet through an internetwork from a source host to a destination host.

royalty OEM

A computer original equipment manufacturer who has signed a license agreement directly with Microsoft Licensing, Inc. Royalty OEMs receive a "golden master" copy of Windows from Microsoft. The royalty OEM may customize Windows as described in the OPK, their license agreement, or a signed addendum.

RunOnce application

An application that is configured to run the next time the computer is restarted. The application does not run after any subsequent reboots of the system.

S

script

A type of program consisting of a set of instructions to an application or tool program. A script usually expresses instructions by using the application's or tool's rules and syntax, combined with simple control structures such as loops and if/then expressions. "Batch program" is often used interchangeably with "script" in the Windows environment.

SCSI

See definition for: small computer system interface (SCSI)

seal

See definition for: reseal

security ID (SID)

A data structure of variable length that identifies user, group, and computer accounts. Every account on a network is issued a unique SID when the account is first created. Internal processes in Windows refer to an account's SID rather than the account's user or group name.

See also: group account; user account; user name

serial (COM) device

A string of up to 256 characters with five mandatory fields and ten optional fields, as defined in Section 3 of the Plug and Play External COM Device Specification, v. 1.0.

server

In general, a computer that provides shared resources to network users.

See also: client

server cluster

A group of independent computer systems, known as nodes, working together as a single system to ensure that mission-critical applications and resources remain available to clients. A server cluster is the type of cluster that Cluster service implements.

See also: cluster; node

service

A program, routine, or process that performs a specific system function to support other programs, particularly at a low (close to the hardware) level. When services are provided over a network, they can be published in Active Directory, facilitating service-centric administration and usage. Some examples of services are the Security Accounts Manager service, File Replication service, and Routing and Remote Access service.

See also: Active Directory; Dynamic Host Configuration Protocol (DHCP)

service mark

A mark used in the sale or advertising of services to identify and distinguish them from services provided by another company.

Service Pack

A software upgrade to an existing software distribution that contains updated files consisting of patches and hot fixes.

Setup Manager

A utility for creating and modifying answer files and configuration sets.

See also: answer file; configuration set

Setupapi.log

A log file provides valuable information for troubleshooting and debugging Setup, device installation, and related issues. The information stored in the log file includes errors, warnings, and related information from Windows Setup, including time information.

Setupcl.exe

An executable program invoked by Sysprep.exe that recognizes security IDs (SIDs). It must reside in the same folder as Sysprep.exe.

See also: security ID (SID); Sysprep.exe

signature

See definition for: digital signature

signed driver

A driver that has passed testing by the Windows Hardware Quality Lab (WHQL) to ensure that the driver is compatible with Windows XP, and that the driver meets the criteria of the Windows Logo program. For performance and stability, Microsoft strongly recommends that you use only signed drivers for new or updated drivers.

Simple Mail Transfer Protocol (SMTP)

A member of the TCP/IP suite of protocols that governs the exchange of electronic mail between message transfer agents.

See also: protocol; Transmission Control Protocol/Internet Protocol (TCP/IP)

Simple TCP/IP Services

Four TCP/IP services: Character Generator, Daytime Discard, Echo, and Quote of the Day.

See also: service; Transmission Control Protocol/Internet Protocol (TCP/IP)

simple volume

A dynamic volume made up of disk space from a single dynamic disk. A simple volume can consist of a single region on a disk or multiple regions of the same disk that are linked together. You can extend a simple volume within the same disk or onto additional disks. If you extend a simple volume across multiple disks, it becomes a spanned volume. You can create simple volumes only on dynamic disks. Simple volumes are not fault tolerant, but you can mirror them to create mirrored volumes.

See also: dynamic disk; dynamic volume; fault tolerance; mirrored volume; spanned volume

single sign-on

A process that allows a user with a domain account to log on to a network once, using a password or smart card, and to gain access to any computer in the domain.

See also: domain; smart card

single-byte character set

A character encoding in which each character is represented by 1 byte. Single byte character sets are mathematically limited to 256 characters.

SKU

Shelf keeping unit. A particular product; in this case, a particular edition of Windows XP.

small computer system interface (SCSI)

A standard high-speed parallel interface defined by the American National Standards Institute (ANSI). A SCSI interface is used for connecting microcomputers to peripheral devices such as hard disks and printers, and to other computers and local area networks (LANs).

See also: local area network (LAN); device

smart card

A credit card-sized device that is used with an access code to enable certificate-based authentication and single sign-on to the enterprise. Smart cards securely store certificates, public and private keys, passwords, and other types of personal information. A smart card reader attached to the computer reads the smart card.

See also: authentication; single sign-on; smart card reader

smart card reader

A device that is installed in computers to enable the use of smart cards for enhanced security features.

See also: smart card

snap-in

A type of tool you can add to a console supported by Microsoft Management Console (MMC). A stand-alone snap-in can be added by itself; an extension snap-in can only be added to extend the function of another snap-in.

See also: Microsoft Management Console (MMC)

spacing character

A character with a non-zero width.

spanned volume

A dynamic volume consisting of disk space on more than one physical disk. You can increase the size of a spanned volume by extending it onto additional dynamic disks. You can create spanned volumes only on dynamic disks. Spanned volumes are not fault tolerant and cannot be mirrored.

See also: dynamic disk; dynamic volume; fault tolerance; mirrored volume; simple volume

stage

Copy the directories and files to be installed to a destination computer, but do not configure any registry settings.

See also: attach; destination computer; detach

standalone server

A computer that runs Windows 2000 Server but does not participate in a domain. A standalone server has only its own database of end users, and it processes logon requests by itself. It does not share account information with any other computer and cannot provide access to domain accounts.

See also: domain

striped volume

A dynamic volume that stores data in stripes on two or more physical disks. Data in a striped volume is allocated alternately and evenly (in stripes) across the disks. Striped volumes offer the best performance of all the volumes that are available in Windows, but they do not provide fault tolerance. If a disk in a striped volume fails, the data in the entire volume is lost. You can create striped volumes only on dynamic disks. Striped volumes cannot be mirrored or extended.

See also: dynamic disk; dynamic volume; fault tolerance

subkey

A key within a key. In the registry structure, subkeys are subordinate to subtrees and keys. Keys and subkeys are similar to the section header in .ini files; however, subkeys can carry out functions.

See also: registry; key; subkey

subtree

Any node within a tree, along with any selection of connected descendant nodes. In the registry structure, subtrees are the primary nodes that contain keys, subkeys, and value entries.

See also: node; registry; key; subkey; value entry

SVGA

Super VGA. A video standard established by BESA to provide high-resolution color display on IBM-compatible computers.The most commonly implemented SVGA standard is 1024x768 pixels resolution.

synchronous

Each application or command runs in the order listed, and each item must finish before the next command is run.

Syspart

A process that executes through an optional parameter of Winnt32.exe. Used for clean installations to computers that have dissimilar hardware. This automated installation method reduces deployment time by eliminating the file-copy phase of Setup.

Sysprep

A tool designed for corporate system administrators, OEMs, and others who need to deploy Windows XP on multiple computers. Sysprep must be run again as the last step in your production process, to reset the first-run experience (either Windows Welcome or Mini-Setup) to run the next time the computer is started. By modifying the local computer security identifier (SID) so that it is unique for each destination computer, Sysprep prepares a master installation to be copied to a destination computer that uses similar hardware. Sysprep can be run multiple times on an installation.

See also: security ID (SID); destination computer; first-run experience

Sysprep.exe

The System Preparation utility that uses the Sysprep.inf answer file to prepare a system disk image for duplication.

Sysprep.inf

An optional answer file used by Sysprep that automates Mini-Setup and further customizes the installed operating system.

See also: answer file

system board

Also called a motherboard or planar. The primary circuit board in a PC that contains most of the basic components of the system.

system builder

Anyone who purchases an OEM Distribution Pack of Windows (available from distributors) and preinstalls Windows onto new computers. System Builders are subject to the terms of the Break-the-Seal (BTS) agreement attached to the outside of the OEM Distribution Pack.

See also: Break-the-Seal Microsoft Distribution and Preinstallation Agreement (BTS)

system context

The state of Windows after it first starts when some system services are loaded but no user is logged in and per-user settings are not available.

system devices

Devices on a system board, such as interrupt controllers, keyboard controller, real-time clock, DMA page registers, DMA controllers, memory controllers, FDC, IDE ports, serial and parallel ports, PCI bridges, and so on. In today's PCs, these devices are typically integrated in the supporting chip set.

system drive

The drive letter of the mass-storage device (usually a hard disk) where Windows is installed.

system engineer

A Microsoft employee who assists one or more specific royalty OEMs as they prepare to manufacture computers that will use the version of Microsoft Windows that is currently under development.

System File Protection

See definition for: Windows File Protection (WFP)

system locale

Determines which script non-Unicode applications will support. Thus it is the locale emulated by the system, as seen by applications. For example, if the system locale for US is set to Hebrew, then ANSI applications will see it as Hebrew localized, although the user interface of the system will still be in English. The system locale is system wide, in that it applies to all users. Changing the system locale requires a reboot.

system partition

The partition that contains the hardware-specific files needed to load Windows (for example, Ntldr, Osloader, Boot.ini, Ntdetect.com). The system partition can be, but does not have to be, the same as the boot partition.

See also: boot partition; partition

System Restore

A tool that reverses harmful changes to your computer and restore its settings and performance. System Restore returns your computer to an earlier time (called a restore point) without causing you to lose recent work, such as saved documents, e-mails, or history and favorites. Any changes that System Restore makes to your computer are completely reversible. Your computer automatically creates restore points, but you can also use System Restore to create your own restore points. This is useful if you are about to make a major change to your system such as installing a new program or changing your registry.

systemroot

The path and folder name where the Windows system files are located. Typically, this is C:\Windows, although you can designate a different drive or folder when you install Windows. You can use the value %systemroot% to replace the actual location of the folder that contains the Window system files. To identify your systemroot folder, click Start, click Run, type %systemroot%, and then click OK.

T

TAM

See definition for: technical account manager (TAM)

TAPI

See definition for: Telephony API (TAPI)

target computer

See definition for: destination computer

taxonomy

In the Windows XP Help and Support Center, the classification system that organizes Help topics into specific categories.

TCP/IP

See definition for: Transmission Control Protocol/Internet Protocol (TCP/IP)

technical account manager (TAM)

A Microsoft employee who provides technical assistance to one or more specific royalty OEMs as they manufacture computers installed with a released version of Microsoft Windows.

technician computer

The computer that you install Setup Manager on. Normally, the configuration sets and the distribution share are also located on this computer.

See also: configuration set; distribution share; Setup Manager

Telephony API (TAPI)

An application programming interface (API) used by communications programs to work with telephony and network services. Communications programs like HyperTerminal and Phone Dialer use TAPI to dial, answer, and route telephone calls on conventional telephony devices, including PBXs, modems, and fax machines. TAPI 3.0 also provides Internet Protocol (IP) telephony support, which Phone Dialer and other programs use to transmit, route, and control real-time audio and video signals over IP-based networks such as the Internet.

See also: application programming interface (API); Internet Protocol (IP); modem (modulator/demodulator); service

text-mode Setup

The second of the three stages of Setup, where the basic hardware of the computer (CPU, motherboard, hard disk controllers, file systems, and memory) is determined, the base operating system necessary to continue is installed, and specified folders are created.

third-party drivers

Device drivers that are not included in Driver.cab.

See also: Driver.cab

time stamp

A certification by a trusted third party specifying that a particular message existed at a specific time and date. In a digital context, trusted third parties generate a trusted time stamp for a given message by having a time stamping service append a time value to a message and then digitally signing the result.

See also: digital signature; service

topology

In Windows, the relationships among a set of network components. In the context of Active Directory replication, topology refers to the set of connections that domain controllers use to replicate information among themselves.

See also: Active Directory; domain controller

trail byte

The byte value that is the second half of a double-byte character.

Transmission Control Protocol/Internet Protocol (TCP/IP)

A set of networking protocols widely used on the Internet that provides communications across interconnected networks of computers with diverse hardware architectures and various operating systems. TCP/IP includes standards for how computers communicate and conventions for connecting networks and routing traffic.

See also: Internet Protocol (IP); protocol

Txtsetup.oem

A text file identifying supported hardware components, the files to copy from the distribution disk for the hardware component, and listing the registry keys and values to create for the hardware component. This is used only during text-mode Setup.

U

unallocated space

Available disk space that is not allocated to any volume. The type of volume that you can create on unallocated space depends on the disk type. On basic disks, you can use unallocated space to create primary or extended partitions. On dynamic disks, you can use unallocated space to create dynamic volumes.

See also: basic disk; dynamic disk; extended partition; logical drive; object; partition; primary partition

Unattend.txt

The generic name for the Windows Setup answer file. In the CD boot preinstallation method, Unattend.txt must be named Winnt.sif.

See also: answer file; CD boot; Windows Setup; Winnt.exe

unattended Setup

An automated, hands-free method of installing Windows. During installation, unattended Setup uses an answer file to supply data to Setup instead of requiring that an administrator interactively provide the answers.

UNC

See definition for: Universal Naming Convention (UNC)

uni-processor

A computer with a single processor.

See also: multiprocessor

Unicode

A character encoding standard developed by the Unicode Consortium that represents almost all of the written languages of the world. The Unicode character repertoire has multiple representation forms, including UTF-8, UTF-16, and UTF-32. Most Windows interfaces use the UTF-16 form.

See also: American Standard Code for Information Interchange (ASCII)

Universal Naming Convention (UNC)

A convention for naming files and other resources beginning with two backslashes (\), indicating that the resource exists on a network computer. UNC names conform to the \\SERVERNAME\SHARENAME syntax, where SERVERNAME is the server's name and SHARENAME is the name of the shared resource. The UNC name of a directory or file can also include the directory path after the share name, with the following syntax: \\SERVERNAME\SHARENAME\DIRECTORY\FILENAME.

universal serial bus (USB)

An external bus that supports Plug and Play installation. Using USB, you can connect and disconnect devices without shutting down or restarting your computer. You can use a single USB port to connect up to 127 peripheral devices, including speakers, telephones, CD-ROM drives, joysticks, tape drives, keyboards, scanners, and cameras. A USB port is usually located on the back of your computer near the serial port or parallel port.

See also: bus; Plug and Play; port

USB

See definition for: universal serial bus (USB)

user account

A record that consists of all the information that defines a user to Windows. This includes the user name and password required for the user to log on, the groups in which the user account has membership, and the rights and permissions the user has for using the computer and network, and accessing their resources. For Windows XP Professional and member servers, user accounts are managed with Local Users and Groups. For Windows Server domain controllers, user accounts are managed with Microsoft Active Directory Users and Computers.

See also: permission; Active Directory Users and Computers; password; resource; user name

user interface language

The language in which the operating system displays its menus, help files, and dialog boxes.

user locale

The user preferences for formatting of dates, currencies, numbers, and so on. The user locale is a per-user setting, and does not require restarting the computer.

user mode

The processing mode in which applications run.

user name

A unique name identifying a user account to Windows. An account's user name must be unique among the other group names and user names within its own domain or workgroup.

See also: domain; user account; workgroup

user password

The password stored in each user's account. Each user generally has a unique user password and must type that password when logging on or accessing a server.

See also: password; user account

user principal name

A user account name (sometimes referred to as the user logon name) and a domain name identifying the domain in which the user account is located. This is the standard usage for logging on to a Windows domain. The format is: user@domain.com (as for an e-mail address).

See also: user account; domain; domain name

user rights

Tasks that a user is permitted to perform on a computer system or domain. There are two types of user rights: privileges and logon rights. An example of a privilege is the right to shut down the system. An example of a logon right is the right to log on to a computer locally. Both types are assigned by administrators to individual users or groups as part of the security settings for the computer.

See also: administrator; domain

V

value added reseller (VAR)

A company that resells hardware and software packages to developers and/or end users.

value entry

The string of data that appears in the right pane of a registry window and that defines the value of the currently selected key. A value entry has three parts: name, data type, and the value itself.

See also: registry; key

VAR

See definition for: value added reseller (VAR)

VGA

Video graphics array. A video adapter that supports 640 x 480 pixels color resolution. VGA is the video display standard for boot devices under Windows operating systems and provides medium-resolution text and graphics.

volume set

A partition consisting of disk space on one or more physical disks that was created with Windows NT 4.0 or earlier. You can delete volume sets only with Windows&nsbsp;2000 or Windows XP. To create new volumes that span multiple disks, use spanned volumes on dynamic disks.

See also: basic disk; dynamic disk; partition; spanned volume

W

WDL

See definition for: Windows Driver Library (WDL)

Web server

A computer that is maintained by a system administrator or Internet service provider (ISP) and that responds to requests from a user's browser.

See also: Internet service provider (ISP)

WHQL

See definition for: Windows Hardware Quality Labs (WHQL)

wide area network (WAN)

A communications network connecting geographically separated computers, printers, and other devices. A WAN allows any connected device to interact with any other on the network.

See also: device; local area network (LAN)

Windows Driver Library (WDL)

A distribution point on www.microsoft.com for third-party drivers that meet the Windows Logo requirements.

Windows File Protection (WFP)

A Windows 2000 feature that runs in the background and protects your system files from being overwritten. When a file in a protected folder is modified, WFP determines if the new file is the correct Microsoft version or if the file is digitally signed. If not, the modified file is replaced with a valid version.

Windows Hardware Quality Labs (WHQL)

Provides compatibility testing services to test hardware and drivers for Windows operating systems.

Windows Installer

An operating system service that allows the operating system to manage the installation process. Windows Installer technologies are divided into two parts that work in combination: a clientside installer service (Msiexec.exe) and a package file (.msi file). Windows Installer uses the information contained within a package file to install the application.

Windows Internet Name Service (WINS)

A software service that dynamically maps IP addresses to computer names (NetBIOS names). This allows users to access resources by name instead of requiring them to use IP addresses that are difficult to recognize and remember. WINS servers support clients running Windows NT 4.0 and earlier versions of Microsoft operating systems.

See also: network basic input/output system (NetBIOS); resource; service; IP address

Windows Logo Program

A certification program to help customers identify systems, hardware, and software that meet a baseline definition of platform features and quality goals and ensure a good user experience of Windows.

Windows Management Instrumentation (WMI)

A management infrastructure in Windows that supports monitoring and controlling system resources through a common set of interfaces and provides a logically organized, consistent model of Windows operation, configuration, and status.

See also: resource

Windows Preinstallation Environment (WinPE)

A minimal Win32 operating system with limited services, built on the Windows XP Professional kernel running in protected mode. WinPE is only available to OEMs.

Windows Product Activation (WPA)

A technology that reduces software piracy by requiring that each installation of a Windows product be activated with Microsoft, either through the Internet or by telephone. A unique product key is required for each installation of Windows, but Microsoft does not request or collect any information other than the Product Key during the installation. The end user may reinstall Windows using the same Product Key on the same computer as many times as necessary, but it cannot be used to install Windows on another computer. The end user can make incremental hardware upgrades to the computer. However, if the hardware is significantly altered, the end user will be required to reactivate the installation of Windows.

Windows Setup

The program that installs the Windows operating system.

Windows Welcome

The end user's first experience of Microsoft Windows in Windows XP Home Edition and Windows XP Professional. Through a series of full-screen, HTML-based pages, Windows Welcome quickly and easily takes end users through the final steps of setting up their personal computer. End users are then prompted for any additional information that is needed to personalize their settings, which can include regional settings, network configuration (where applicable), and Internet connection settings. Windows Welcome is formerly known as Out-Of-Box Experience (OOBE).

Winnt.exe

A command line utility used to start an unattended Windows XP Setup from computers running MS-DOS, Windows 3.1, or Windows for Workgroups.

Winnt.sif

The answer file that contains information used by Setup when you install Windows using the CD boot method.

See also: answer file; CD boot

Winnt32.exe

A command line utility used to start an unattended Windows XP Setup from computers running Windows 95, Windows 98, Windows NT, Windows 2000, or Windows XP.

WinPE

See definition for: Windows Preinstallation Environment (WinPE)

WINS

See definition for: Windows Internet Name Service (WINS)

Winsock

Windows Sockets. An application programming interface (API) standard for software that provides a TCP/IP interface under Windows.

See also: Transmission Control Protocol/Internet Protocol (TCP/IP); application programming interface (API)

WMI

See definition for: Windows Management Instrumentation (WMI)

workgroup

A simple grouping of computers, intended only to help users find such things as printers and shared folders within that group. Workgroups in Windows do not offer the centralized user accounts and authentication offered by domains.

See also: user account; authentication; domain

World Wide Web

A system for exploring the Internet by using hyperlinks. When you use a Web browser, the Web appears as a collection of text, pictures, sounds, and digital movies.

See also: internet

X

x86

Refers to microprocessors that have or emulate the 32-bit Intel processor architecture.

Y

There are no glossary terms that begin with this letter.

Z

There are no glossary terms that begin with this letter.


Microsoft Windows Corporate Deployment Tools User's Guide

banner1 banner2

These tools help you customize and deploy these products in the Windows family of operating systems:

Windows XP Home Edition
Windows XP Professional
Windows XP 64-Bit Edition

© Copyright 1985-2001 Microsoft Corporation. All rights reserved.


Microsoft Windows Logo Programs

Microsoft Corporation developed the Designed for Microsoft Windows Logo Program for hardware (http://www.microsoft.com/hwdev/winlogo/) and the Certified for Windows Program for software (http://msdn.microsoft.com/certification/) to help end users easily identify hardware and software products designed specifically for the Windows operating systems. The goal of the program is to ensure that end users have an optimal experience using the software and hardware products that carry the Designed for Microsoft Windows logo.

Users can mix-and-match hardware and software products that carry these logos. They can be assured that the products take advantage of the new technologies available in the Microsoft Windows XP and Windows 2002 families of operating systems.

A separate license is required for you to use the Designed for Microsoft Windows and Certified for Microsoft Windows logos. Licensing these logos enables vendors to use the logo on Web sites, product packaging, advertising, collateral, and other marketing materials in connection with products that have passed logo testing and are licensed for the logo. Only use the Windows logo as explicitly specified in the logo license.

Hardware

The hardware-testing organization for the logo program is the Windows Hardware Quality Labs (WHQL), which provides compatibility testing services for Windows 2000 and Windows XP hardware and drivers. Both hardware and software are tested before rights to use the logo are granted.

Hardware developers whose products pass the WHQL testing program also receive a detailed test report, inclusion of tested hardware on the Windows Hardware Compatibility List (HCL), and free distribution of drivers in the Windows Driver Library (WDL).

For the most current list of supported hardware, see the Hardware Compatibility List (HCL) at the Microsoft Web site (http://www.microsoft.com/hcl/).

You are encouraged to submit your hardware systems for logo testing and to use components that carry the logo in your systems. For more information, contact:

Windows Hardware Quality Labs
Microsoft Corporation
One Microsoft Way
Redmond, WA 98053-6399 USA
http://www.microsoft.com/hwtest/
Fax: (425) 703-3872

For more information about hardware, see the following locations:

  • Windows Driver and Hardware Development Web site http://www.microsoft.com/hwdev/

Software

Software certification requires that the software vendors follow the guidelines listed in the Application Specifications for Windows (http://msdn.microsoft.com/certification/appspec.asp). These applications offer the following benefits:

  • Provide a robust, self-repairing installation that helps minimize conflicts among shared components ("DLL Hell") to enable better co-existence of applications.
  • Facilitate easier software deployment and management for organizations.
  • Correctly maintain user preferences and computer settings to ensure a good “roaming user” experience, support for multiple users per machine, and regeneration of application settings in machine replacement scenarios.
  • Run in a tightly controlled network environment, to enable network administrators to secure and control corporate desktops.
  • Provide a consistent user experience and supports accessibility standards to reduce support and training costs.
  • Provide a smooth transition of the application for users that upgrade from Windows 95 or later operating systems.
  • Support OnNow power management for a better mobile computing experience.

Applications that comply with the server specification offer the following benefits:

  • Support for a globally available infrastructure for easier access for the user and easier management for the administrator.
  • Facilitates secure access to resources and security for client-server interactions.
  • Reduced service downtime caused by system failures or planned server maintenance and upgrades, by exploiting Cluster services (for applications that comply with Windows 2002 Advanced Server requirements).

For the most up-to-date list of tested software, see the Certified for Windows Program Web site (http://msdn.microsoft.com/certification/).


Legal Notices

Information in this document, including URL and other Internet Web site references, is subject to change without notice. Unless otherwise noted, the example companies, organizations, products, domain names, e-mail addresses, logos, people, places and events depicted herein are fictitious, and no association with any real company, organization, product, domain name, e-mail address, logo, person, place or event is intended or should be inferred. Complying with all applicable copyright laws is the responsibility of the user. Without limiting the rights under copyright, no part of this document may be reproduced, stored in or introduced into a retrieval system, or transmitted in any form or by any means (electronic, mechanical, photocopying, recording, or otherwise), or for any purpose, without the express written permission of Microsoft Corporation.

Microsoft may have patents, patent applications, trademarks, copyrights, or other intellectual property rights covering subject matter in this document. Except as expressly provided in any written license agreement from Microsoft, the furnishing of this document does not give you any license to these patents, trademarks, copyrights, or other intellectual property.

© 2001 Microsoft Corporation. All rights reserved.

Active Desktop, ActiveX, Authenticode, BackOffice, ClearType, DirectX, FrontPage, Hotmail, JScript, Microsoft, Microsoft Press, MS-DOS, MSDN, MSN, Visual Basic, Win32, Win64, Windows, Windows logo, Windows Media, Windows NT, and Windows Start logo are either registered trademarks or trademarks of Microsoft Corporation in the U.S.A. and/or other countries.

The codename "Windows 2002 [___] Server" may change before the final release of these products. References in this document to these products or family of products are codename placeholders only.

TrueType is a registered trademark of Apple, Inc.

The names of actual companies and products mentioned herein may be the trademarks of their respective owners.